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Preface
Welcome to Toon Studies

This preface presents a brief history of animation revealing the 
philosophy behind Toon Boom Studio™ and suggesting how to use 
the application to its full potential. Also covered are the new 
features you’ll enjoy in V2.

This preface contains the following topics:

• The Next Step in Toonvolution on page 12 

• Harnessing the Boom in Your Toon on page 16 

• Installing Toon Boom Studio on page 18 

• New and Improved Features in V2 on page 19 

• About the Documentation on page 23 



The Next Step in Toonvolution
The Next Step in Toonvolution
From the earliest beginnings, mankind realized the potential of drawing. Some of the 
earliest cave dwellers record events by decorating the walls of caves with pictographs 
representing scenes from daily life, while others paint majestic scenes of migrating 
herds of animals. 

As time passed and the artists evolved, they became aware that something was missing 
in their work: the ability to show movement realistically, the ability to show movement 
over time... the ability to animate.

See Also
Harnessing the Boom in Your Toon on page 16 
New and Improved Features in V2 on page 19 
About the Documentation on page 23 
From the Past to the Present on page 13 
Bridging the Traditional and Computer Eras on page 15 

Using a flipbook, you can see the persistence of vision effect in 
action. If you have a different sequential drawing on 

each page of the flipbook and you flip through the 
pages rapidly, the drawings appear to move. 

In the 19th century, the phenomenon known as persistence of 
vision gave us the first glimpse into the modern 
animation world. 

Persistence of vision refers to the way our brain 
retains images for a split second longer than 
they actually appear, making a series of quick 
flashes appear as one continuous picture. 
12 
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From the Past to the Present
The first animated cartoon was created by a young magazine artist named John 
Randolph Bray (1879-1978) and was called The Dachsund and the Sausage (1910). To 
animate his drawings, Bray used a Zoetrope, which was a cylinder which contained 
each sequential drawing. 

The Zoetrope had long vertical slits cut into its side in between each of the images. 
When you spun the Zoetrope, the slits passed in front of the eye, presenting a sequence 
of images, and creating the illusion of motion. 

Excited over the success of his cartoon, John Bray teamed up with fellow cartoonist, 
Earl Hurd, who was independently developing a similar process using clear celluloid 
sheets. Hurd's approach used a static painting as a background with the characters 
inked onto the celluloid sheets. 

Bray took the idea further by introducing multiple layers of celluloid, each layer 
carrying a separate element of the scene. The advantage of this cel-based process was 
to greatly reduce animation production cycles and it was quickly adopted by every 
major animation studio in the world. 

By the early 1920’s, a basic assembly line process was already in use. Tasks like Inking 
and Painting were separated into distinct departments. A number of sophisticated 
cartooning methods such as; the use of gray tones, between scene camera dissolves, iris 
close-ups, title cards, and live-action integration were being developed. However, the 
major innovation of this era was the introduction of the cel process.

The cel process and it’s basic concepts are used in many of the computer software 
programs, producing special effects, independent movement of objects, and 
overlapping levels of action. 

If you place your eye next to one of the 
slits and spin the cylinder, you will see the 
man juggling.

As each image passes in front of your eye 
your brain retains the previous image just 
long enough to fool you into thinking that 
the new image replacing it actually 
moves. 
13
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As the animation technology evolved, the overlay idea was enhanced to include 
multiple translucent pieces of cels, a peg system for dead accurate registration, and the 
innovative use of long sheets of paper for drawing the background images. 

These early studios produced some of the animators 
who are now considered the pioneers of animation 
such as:

• Max Fleischer: patented rotoscoping in 
1915 (drawing images on cells by tracing 
over previously recorded live action), 
and later created Betty Boop

• Walt Disney: destined to become the 
animation superpower, not only does his 
studio introduce the use of a storyboard, 
pencil sketches, and the multi-plane 
camera stand, but Disney also pioneered 
the use of sound and color in animation.

See Also
The Next Step in Toonvolution on page 12 
Bridging the Traditional and Computer Eras on page 15 
Harnessing the Boom in Your Toon on page 16 
New and Improved Features in V2 on page 19 
About the Documentation on page 23 
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Bridging the Traditional and Computer Eras
Computer animation usually refers to systems that digitalize hand-drawn animation 
cels. Computer animation production borrows most of the ideas from conventional 
animation production including the use of a story board, test shots, pencil testing, key 
frames, and tweening. 

Computer-assisted animation has been around 
longer than you may realize. In the 1960’s, the 
University of Utah became a digital 2D animation 
pioneer when they produced the first animated line 
drawings. By the mid-1970s, North Carolina State 
University was using real-time video playback 
from digital disk to produce animation.

If you define traditional animation as the 
process of creating the illusion of motion 
by viewing a series of individual 
drawings successively, then you could 
define computer animation as a process 
of digitally recording drawn cels, 
sorting them on an electronic 
storyboard, and displaying them 
electronically in succession, creating a digital scene.

See Also
The Next Step in Toonvolution on page 12 
From the Past to the Present on page 13 
Harnessing the Boom in Your Toon on page 16 
New and Improved Features in V2 on page 19 
About the Documentation on page 23 
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Harnessing the Boom in Your Toon

Toon Boom Studio™ is the state-of-the art tool of choice for today’s Web animators. 
What once took multiple software packages to produce a single piece of animation is 
now all contained within one system.

We designed Toon Boom Studio™ to suit the many different types of animators out 
there. So here’s what you can expect to find in Toon Boom Studio™ from the following 
perspectives: 

• Traditional Animator: you’ll feel right at home animating with our electronic 
exposure sheets, virtual animation disk, rotary light table, the ink & paint 
utilities, and storyboarding tools.

• Digital Animator: we used the USAnimation® system, the industry-standard 
for the high-end studios, as a blueprint when designing Toon Boom Studio™.
At the heart of the Toon Boom Studio™ system, you’ll find the best parts of 
the USAnimation® system at your command to produce heart-stopping Web 
animation!

• Flasher: you’ll enjoy the flexibility to work in both Macromedia® Flash™ and 
Toon Boom Studio™ and love how you’ll be able to take your animations to 
the third dimension with the ground-breaking 3D stage in Toon Boom 
Studio™.

• Illustrator: combine the power 
drawing capabilities that you 
love in Illustrator with the 
exciting new animation 
possibilities you’ll 
discover in Toon Boom 
Studio™.

See Also
The Next Step in Toonvolution on page 12 
New and Improved Features in V2 on page 19 
About the Documentation on page 23 
Sceneplanning and Tweening on page 17 
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Sceneplanning and Tweening
You create motion, scaling, and rotation effects in Toon Boom Studio™ by attaching 
content layers to elements called Pegs. You set the start value and end value for an 
entire element in the Peg and Toon Boom Studio™ interpolates all of the images in the 
attached elements to create animated effects that unfold gradually. 

Toon Boom Studio™ does not tween images. Tweening creates mechanistic changes 
that look unnatural for objects that squash and stretch as they change in the real world. 
Some of the limitations with tweening are as follows:             

• Tweening an element layer to move and rotate or scale is very time-
consuming.

• To make even the slightest adjustment to a motion path, you must rebuild the 
tweened images.

• Tweened images can sometime lead to unpredictable and messy results that 
you must correct manually.

See Also
Harnessing the Boom in Your Toon on page 16 

Each element layer contains a set of drawings that 
you can repeat as often as necessary to complete 
your motion effect.

Plot the start and end frames of 
a motion path on a peg. 

Add a control point on the motion path 
and drag it to change the motion 
path’s shape. 

The element follows 
the motion path.
17
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Installing Toon Boom Studio
System Requirements

• 233 MHz Intel® Pentium® II or higher processor
• Microsoft® Windows® 2000, Windows 98, Windows ME or Windows XP

If you are using Windows 2000 or XP, you must have administrator rights 
to install software. Installation error messages may appear if you don’t 
have these rights. See your system administrator if you have installation 
problems.
If you are using Windows 98, you must have installed Internet Explorer 
V 5.01 service pack 2, or better.

• 64 MB of RAM
• 100 MB of available hard disk space
• 24-bit color display capable of 1024x768 resolution
• Wacom® Tablet is recommended
• Apple QuickTime® Version 5

To install Toon Boom Studio, follow these steps:

1. Start the installation program: setup.exe.
• If you received Toon Boom Studio™ on a CD, insert the CD in your CD-ROM 

drive. Click Start > Run. Click Browse and choose the setup.exe file from 
the Toon Boom Studio™ CD.

• If you downloaded Toon Boom Studio™ from our website, uncompress the 
file you downloaded, locate setup.exe from the uncompressed files and 
double-click the file to start the installation process.

2. Follow the onscreen instructions to complete the installation.
18 
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New and Improved Features in V2

Toon Boom Studio™ V2 provides you with many new features that will improve your 
animation experience and help you tool better toons!

Effects!

• Color tweening: change the color of elements over time with color tweening. 
• Clip masks: create masks to reveal only certain portions of your animation. 

You can even have the mask change over time with the use of pegs. 
Drawing

• Polyline tool: connect points to draw objects. Control the shape of the object 
with Bezier editing tools.

• Cutter tool: use a selection to cut pieces from your drawings.
• Grouping of drawing objects: combine drawing objects into one to improve 

drawing object management.
• Vector optimization: smooth your vector drawings and merge layers to 

reduce the complexity of your drawings and the files size of your 
Macromedia® Flash™ movies.

• Reposition all drawings: when you import scanned images, they can appear 
offset from the center. Now you can move all of the contents of an element to 
a new position so that you can see and work on them with ease.

• Flip and rotate your drawings.
• Improved navigation of Drawing Mode windows and nudging of drawing 

objects.
• Paste in place: cut and paste drawing objects in new cells or elements, in the 

original position.
• Draw from center: use the [ALT] key to draw round and rectangular shapes 

from the center of your mouse.
• Improved stroke identification: when you turn on show strokes, unconnected 

points appear in a different color than points that intersect so that you can 
modify those points easier.

• Change rotation pivot point: you can now change the position of the pivot 
point when you rotate drawings with the Select tool in Drawing Mode.
19
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Importing

• Considerable improvements to Adobe® Illustrator® import, including support 
for V5 through V10 and the PDF format.

• Improved support for media clips in Macromedia® Flash™ movies.
• Improved support for color tweening: import Macromedia® Flash™ movies 

with color tweens and they will be preserved in Toon Boom Studio™.
• Support for streamed sounds imported from Macromedia® Flash™ movies.
• Texture as image element: import Macromedia® Flash™ movies with bitmap 

fills and Toon Boom Studio™ will transform the bitmaps into image 
elements.

• Import and vectorize all bitmap file formats.
• Centered SWF Import: when you import Macromedia® Flash™ movies, they 

are now centered on the stage.
Inking and Painting

• Auto gap closing: close gaps as you paint and set your tolerance level.
• Painting with textures: use bitmap images as paint fills for your drawing 

objects.
• Editing texture: edit the center, rotation, and distribution of gradient and 

texture fills.
Sound

• Sound scrubbing: control playback of dialog tracks so that you can determine 
how you want to lip sync a track.

• Lip sync template: automatically map your character’s mouth positions to the 
lip chart generated from a sound element.

• QuickTime® audio support: export sound with your QuickTime® movies.
• Stream audio: export your Macromedia® Flash™ movies with streamed audio, 

which improves synchronization between images and sound.
• Improved support for different sound qualities.

Timeline and Exposure Sheet

• Create cycles: now you can repeat a sequence of drawings with ease by 
creating a cycle. You can even create more complicated cycles, such as those 
that go forward and back, using the Advanced Create Cycles feature.

• New ways to change exposure time: extend the exposure of a drawing by 
selecting the last cell you want it to appear in.
20 
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• Shortcuts for add/remove exposure: change the exposure of selected 
drawings using shortcut keys.

• Drag & Drop reordering or drawings in the Timeline window.
• Copy & Paste drawings from Timeline window.
• Swap drawings from Sceneplanning Mode. You don’t have to switch to 

Drawing Mode anymore to change the drawing that appears at a frame, or its 
exposure.

• Option to display “Feet and Frames” in Timeline window.
3D Sceneplanning

• Live update of 1D Editor functions: make changes using the 1D Editor, and 
your changes display automatically in the View windows.

• Copy & Paste the qualities of a control point or key frame to another point.
• Navigate to and nudge motion points with keyboard keys.
• Different first and last frames on pegs makes it easier for you to identify and 

select these key frames on the motion path of a peg.
Templates

• Preview templates using thumbnails or in the preview pane of the newly 
designed Library window (was the Template Browser).

• Seamless editing: edit templates, save your changes, and Toon Boom 
Studio™ automatically updates all animations that link to the template.

• Improved template color, file and catalog management features.
Exporting

• Exporting media elements as movie clips in Macromedia® Flash™ movies.
• Export to the Plazmic™ SVG format for mobile devices.
• Support for alpha channel information in the export to QuickTime®.
21
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General

• Save As: save your animation set in a new location, with a new name. 
• Close: close the current animation set without exiting the program.
• Scene background color: set the background color of each scene.
• Keep all settings when switching mode: switch between Sceneplanning Mode 

and Drawing Mode and maintain your toolbar and window layout.
• Improved menu organization and tool access.
• Support for localization for international users.

See Also
Harnessing the Boom in Your Toon on page 16 
The Next Step in Toonvolution on page 12 
About the Documentation on page 23 
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About the Documentation

We know that you’re anxious to get started with Toon Boom Studio™ and knock the 
socks off the Web animation community with your latest creation. That’s why we’ve 
structured this user guide to be task-based. After you understand how to perform a 
basic task (like creating a color palette), you can start getting creative with it, unlocking 
the true power of Toon Boom Studio™.   

Here are some suggestions on how to use the User’s Guide efficiently:

• If you want to find information on how to perform a task, use the Table of 
Contents at the front of the book.

• If you want to find reference-type information on a specific item, use the 
Index at the back of the book.
You can also use the context-sensitive online help that you can access from the 
Help menu in Toon Boom Studio™.

See Also
Harnessing the Boom in Your Toon on page 16 
The Next Step in Toonvolution on page 12 
New and Improved Features in V2 on page 19 
Document Conventions on page 24 
Using the Online Help on page 26 

Stay up-to-date with the latest information on Toon Boom Studio™! As the software 
and the community evolve, we’ll be posting updates to the documentation on the 
website which can include release notes, updated online help topics, advanced 
tutorials, and tips and tricks.

Log onto www.toonboomstudio.com and check out the latest updates to the 
documentation!
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About the Documentation
Document Conventions
The manuals provided with Toon Boom Studio™ use the following conventions. 

• Selecting Menu Commands
When you need to select a command from a menu, the documentation lists 
what you need to select in the following order: Menu name > Command.
For example, if you want to select the Open command from the File menu, 
the instruction would read as File > Open.
If there is a series of sub-menus, they will appear in the order in which you 
would need to open them. For example, if you needed to select Macromedia 
Flash Movie from the Export sub-menu in the File menu, the instruction 
would read as File > Export > Macromedia Flash Movie.

• Pointer vs. Cursor
When you want to enter text or numbers into a dialog box, the mouse pointer 
changes to an I-beam cursor as you move it over the dialog box, indicating 
that you can now type information into that location.

Pointer refers to the shape on your screen (usually an arrow) that 
represents the position of your mouse. 
Cursor refers to the I-beam where you enter text. 

• A blinking I-beam indicates that the cursor is active. 

• If the I-beam is not blinking, the cursor is not active and typing is 
ineffective. 

See Also
Harnessing the Boom in Your Toon on page 16 
The Next Step in Toonvolution on page 12 
New and Improved Features in V2 on page 19 
Using the Online Help on page 26 
Mouse Actions on page 25 

Pointer

I-beam cursor
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Preface: Welcome to Toon Studies
Mouse Actions
Throughout the Toon Boom Studio™ documentation, the following terms describe 
which mouse button to use to perform an action:. 

See Also
Harnessing the Boom in Your Toon on page 16 
The Next Step in Toonvolution on page 12 
New and Improved Features in V2 on page 19 
Using the Online Help on page 26 
Document Conventions on page 24 

Term Action

Click or 
Left-click

Click the left mouse button

Right-click Click the right mouse button

Double-click Click the specified mouse button twice rapidly without moving the mouse.

Shift-click Hold down the [Shift] key and simultaneously click the specified mouse 
button.

Ctrl-click Hold down the [Ctrl] key and simultaneously click the specified mouse 
button.

Click-hold Click the specified mouse button and hold without releasing while 
performing the function.

Drag Click-hold the object and move the mouse while keeping the mouse button 
pressed down. 
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About the Documentation
Using the Online Help
Toon Boom Studio™ comes with online help that you can use to find descriptions of 
application features or tasks that you want to perform. With the online help, you do not 
have to leave your computer to find the answers you need. 

There are two parts of the Toon Boom Studio™ online help:

• Microsoft® HTML Help: provides descriptions of all the tasks you may want 
to perform, as well as descriptions of Toon Boom Studio™ concepts and 
interface features.
To open the comprehensive Microsoft® HTML Help, click the Help button on 
the Main toolbar, select Help > Online Help, or press F1. 
In the left navigation frame, the Contents tab displays the help topics, which 
are organized into task and reference sections. You can also use the Index tab 
or full-text Search tab to find answers to your questions.

• Context-Sensitive Help: provides short definitions of various interface 
features. 
To get a description of a menu command or toolbar button, select Help > 
What’s This and click the item you want a description of. A pop-up window 
opens with a description of the item you clicked. You can click anywhere to 
close the pop-up window. You can also right-click an item and select What’s 
This from the pop-up menu.

See Also
Harnessing the Boom in Your Toon on page 16 
The Next Step in Toonvolution on page 12 
New and Improved Features in V2 on page 19 
Document Conventions on page 24 
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Chapter 1
Studio Basics

This chapter provides you with a quick overview of how you can 
use Toon Boom Studio™ to create Web-ready animations. 

It also explains how to use this User’s Guide so that you can learn 
how to use Toon Boom Studio™ quickly and to it fullest potential.

This chapter contains the following topics: 

• The Toon Boom Studio Workflow on page 28 

• Creating and Saving Animation Sets on page 38 

• Setting up Your Studio Session on page 47 



The Toon Boom Studio Workflow
The Toon Boom Studio Workflow

Toon Boom Studio™uses the power and logic of traditional animation production, yet 
has a workflow flexible enough to support the creative processes involved in the Web 
animation.   Below are the high-level steps in the Toon Boom Studio™ animation 
workflow. The details of these steps are explained in the sections and chapters that 
follow.

2. Draw line art and gather 
multimedia.

3. Add the sound track and 
draw lip synced drawings.

4. Ink and paint 
your drawings.

7. Export the final 
animated 
scene.

6. Choreograph the elements in your scene.

1. Create an animation set. 5. Change the sequence 
and timing of 
images.
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Chapter 1: Studio Basics
Just like any project, your animation set will evolve and change over time. As you work 
on your animation project, you‘ll find yourself jumping forwards and backwards in 
this process. 

• Maybe you’ll adjust the timing in the exposure sheet from your original 
calculations. 

• Just when you finish a scene, you’ll be hit with a sudden inspiration and 
realize you’ll need to draw a new character in the scene. 

• Then you might need to paint the new drawings and create a new motion 
path to match the existing action in the scene.

Toon Boom Studio™ makes it easy to make adjustments with the minimum amount of 
disruption.

See Also
Step 1: Create an Animation Set on page 29 
Setting up Your Studio Session on page 47 
Creating and Saving Animation Sets on page 38 
Setting the Frame Rate and Size of Your Movie on page 39 

Step 1: Create an Animation Set
When you are ready to build your animated production, you must create an animation 
set.    

An animation set is a project folder that contains all of the drawings, bitmaps, sounds, 
and effects in your animation, as well as all of the timing, lay out and motion changes 
you build.

See Also
Creating and Saving Animation Sets on page 38 
Step 2: Draw Line Art and Gather Multimedia on page 30 

All of the content in your animation is 
accessible from the animation set folder.
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The Toon Boom Studio Workflow
Step 2: Draw Line Art and Gather Multimedia
You take your first steps in the animation process in the Drawing Mode. This mode 
provides you with a workspace and a set of tools for you to develop the visual content 
of your animation. 

In Drawing Mode, you perform the following tasks:

• Add element layers to your Exposure Sheet.
• Draw the contents of your animation layers. Drawing tools, help you create 

vector images that are key to producing high-quality, small size, animation.
• Import background images into your element layers.
• Import multimedia, such as complete Macromedia® Flash™ movies and audio 

files. Toon Boom Studio™ studio provides a unique system of content 
management that can help you re-use animation elements.     

See Also
Step 3: Add the Sound Track on page 31 
Drawing Line Art on page 114 

Drawing tools help you 
create vector images.

Use the Exposure Sheet like a storyboard, 
so that you can see all of the action in your 
scene at a specific frame number.

Use the Drawing View window to create your 
vector drawings. 
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Step 3: Add the Sound Track
You can use Toon Boom Studio™ voice track analyzer to identify the lip positions that 
you must draw to match the voice track in each frame. 

Combine this with the Sound Element Editor to fine tune the sound synchronization. 

See Also
Step 4: Ink and Paint Your Drawings on page 32 

The lip positions of this character match 
the sound of the voice track. You can 
use these images as a reference while 
you draw your own character’s lips to 
match the voice track.

The sound editor gives 
you precise sound 
synchronization.
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The Toon Boom Studio Workflow
Step 4: Ink and Paint Your Drawings
After you complete the line art, you are ready to fill your drawings with color. Toon 
Boom Studio™ provides a color palette management system that simplifies the 
creation and organization of your project colors. 

With Toon Boom Studio™ you can:

• Create color palettes for each character.
• Create palettes for different versions of a character’s color palette (for 

example, a day and night palette).
• Change all of the color swatches in a palette style.
• After you mix your project colors, you can easily ink and paint the line art and 

zones with the painting tools. If you change the properties of a zone or a line 
after you paint them, Toon Boom Studio™ updates all of the painted zones 
and lines with the new properties of the color swatch. This saves you from 
having to repaint your drawings when your palette changes.

 

See Also
Step 5: Change the Sequence/Timing of Images on page 33 
Coloring Your Toon Boom Studio World on page 178 

Fill your drawings with color 
using the color swatches. 
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Step 5: Change the Sequence/Timing of Images
The Exposure Sheet allows you to keep track of all the drawings and element layers in 
your scene (characters, objects, backgrounds). Each row represents one frame in your 
animation. If you look across a frame in your exposure sheet, you will see what 
drawing or image appears together in one frame of your animation. 

The Exposure Sheet also identifies how long a drawing or image appears in your scene; 
this is known as “exposure”. As you work out the motion of your characters, you may 
have to adjust the exposure of drawings, or their order. You may also need to add 
drawings to make a motion more fluid and convincing. The Exposure Sheet manages 
your elements and their contents for you.    

 

Each image in your scene has it’s own element 
column, which is made up of a series of individual 
drawings.
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The Toon Boom Studio Workflow
As your scene evolves, you may need to add, remove, rename or use drawings, as well 
as elements. Your exposure sheet acts as a link to your database of drawings, images, 
sound and media, keeping track of their layering order and timing.

See Also
Step 6: Choreograph the Elements in the Scene on page 35 
Exposure Sheet and Timeline Windows on page 354 
Layering Elements on page 371 
Sequencing Element Contents on page 386 
Timing/Exposing Drawings and Images on page 401 
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Step 6: Choreograph the Elements in the Scene
After you ink and paint your drawings and work out their exposure, you are ready to 
use the 3D Sceneplanning space to lay out your elements and make them change over 
time. With the Timeline window, you can see when elements start and end. You can 
use the Timeline window to add and manage peg and camera elements.

In Sceneplanning Mode, you can view your element layers from three different 
perspectives. This allows you to see how elements work together through the scene. 

Three different 
perspectives for 
viewing element 
layers.
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The Toon Boom Studio Workflow
With 3D Sceneplanning, you can:

• Change the north/south and east/west position of element layers. You can 
also change the front/back position of elements to create a sense of depth in 
your scene.

• Change the rotation or size of element.
• Use pegs to create multi-plane effects. With 3D Sceneplanning, you can move 

elements through a scene.
• Create camera effects, such as pans, trucks and zooms. 

In the 3D Sceneplanning space, you can also map out the motion path of elements 
through three dimensions. 

With all transformations you make to an element layer in Sceneplanning Mode, Toon 
Boom Studio™ automatically interpolates all of the drawings in the element layer so 
that you do not have to do any tweening! The quality of your images is preserved 
through all transformations thanks to vector technology.

At anytime during the process, you can perform quick tests to check your animation or 
see it in real-time. You may find during these checks that you have to make corrections. 
You can move back and forth in the workflow to make additions and corrections to 
perfect your animation.

See Also
Step 7: Export on page 37 
Basic Sceneplanning Concepts on page 238 
Changing Elements Over Time with Pegs on page 260 

The element follows 
the motion path
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Step 7: Export 
Now it’s time to export your scenes and produce a final movie. 

You can export the final movie clip in one of the following formats:

• Macromedia® Flash™ format (SWF) 
If you are working with Macromedia® Flash MX to add interactivity to your 
animations, you don’t even have to export to SWF. You can use the Toon 
Boom Studio™ Importer (TBSi) for Macromedia® Flash MX to import your 
animations directly so that you can add ActionScript programming.

• QuickTime® format (MOV) 
• Plazmic™ Mobile SVG Movie

Toon Boom Studio™ follows the order of the scenes in your Scene Manager window 
and exports each scene in sequence to create one seamless movie complete with 
animation, movement effects, and sound. 

See Also 
Exporting to Flash on page 433 
Exporting to QuickTime on page 438 
Exporting to Plazmic SVG on page 442 

Launch the player and view 
your exported movie as soon as 
it is ready.
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Creating and Saving Animation Sets
When you are ready to build your animated production, you must create an animation 
set. An animation set is a project folder that contains all of the drawings, bitmaps, 
sounds, and effects in your animation, as well as all of the timing, lay out and motion 
changes you build.     

When you create your animation set, the name you select becomes the name of your 
project folder and the Toon Boom Studio™ project file. Inside your animation set 
folder are folders for:

• Sound files
• Local templates
• Scene

Each scene folder contains folders for:
Vector drawings
Bitmap graphics

To create an animation set, follow these steps:

1. Click on File > New. The New Animation Set dialog box opens.

2. Type the name of the animation set into the Animation Set field. You are limited 
to a maximum of 20 characters including spaces.

3. Type the location and name of the Project Folder. Or use the Browse feature to 
locate the correct Project folder.

4. Click OK to create the Animation set.
After you build your animation set and the Toon Boom Studio™system 
creates the necessary folders, you can start working on the creative elements 
of your animation. 
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To save your changes to the animation set:

• Select File > Save.
When you activate the Save command, Toon Boom Studio™ saves the open 
animation set using the name and location you gave the project when you created the 
animation set.

To save the animation set using the Save As command, follow these steps:

1. Select File > Save As. The Save As dialog box opens.

2. Type the new name of the animation set into the Animation Set field. You are 
limited to a maximum of 20 characters including spaces.

3. Type the location of the animation set in the Project Folder field or click the 
Browse button to locate a folder.

4. Click OK to save the animation set to the new name and location. 

See Also
Step 1: Create an Animation Set on page 29 
Adding Scenes to a Movie on page 41 
Setting the Frame Rate and Size of Your Movie on page 39 
Changing the Background Color of a Scene on page 42 

Setting the Frame Rate and Size of Your Movie
The frame rate and camera size you set for your animation determines how your 
animation is rendered during export and playback.   

• The frame rate sets the speed at which the movie will playback. The higher 
you set the frame rate, the faster your animation will play. 
By default, the frame rate is set to 12 frames per second. 

• The camera size defines the resolution of your final animation. Toon Boom 
Studio™ uses that camera to render the final movie. The larger the camera 
resolution, the larger the scene space you have.
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Creating and Saving Animation Sets
Although you can change the size of your movie at any time, you must set the frame 
rate before you import any sound. 

To define the frame rate and size of your movie, follow these steps:

1. Select File > Properties. The Animation Properties dialog box opens 

2. Type the frame rate at which you want to play the rendered movie in the Frame 
Rate field. The following frame rates are commonly used:
•  1, 2, 12, 24, and 30 frames per second.

3. Type the size of the final movie in the Camera Size fields.
• Left field: the width of the movie.
• Right field: the height of the movie.

The following resolutions are commonly used:
160 x 120
320 x 240
640 x 480
720 x 540 (NTSC)

4. Click OK when done.

See Also
Real-Time Playback on page 431 
Exporting to Flash on page 433 
Exporting to QuickTime on page 438 
Exporting to Plazmic SVG on page 442 

If you change the frame rate after you add your sound elements, you run the risk of 
de-synchronizing the sound effects with the animation. 
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Adding Scenes to a Movie
You can add scenes to your animation set to organize and manage the contents of your 
movie. 

The Scene Manager window provides you access to all of the scenes in your animation. 
You can use this window to show/hide the scenes you want to render, as well as 
change the order of the scenes in your movie.

When you add scenes to your movie, Toon Boom Studio™adds a scene folder to the 
animation set folder on your system.

All scenes in an animation set share the following:

• Palettes, palette styles, and swatches
• Pen styles
• Templates
• Sounds
• Exposure Sheet/Timeline window colors
• Default UI colors

If you make changes to any of these traits, Toon Boom Studio™ updates them in all the 
scenes in your animation set. This allows you to maintain a consistent look throughout 
your movie.

The arrows next to the scene’s 
name in the scene list 
indicates that this scene is the 
active scene.
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Creating and Saving Animation Sets
To add scenes to your movie, follow these steps:

1. Select Window > Scene Manager to display the Scene Manager window.

2. Click Add Scene  to create a new scene. By default, Toon Boom Studio™ 
assigns a name to each new scene that you can change later 

A new scene appears in the Scene Manager window and an empty exposure sheet 
or timeline (depending on the mode you are in) appears in the Toon Boom 
Studio™ window.

See Also
Reordering Scenes on page 44 
Renaming Scenes on page 44 
Deleting Scenes on page 46 
Changing the Background Color of a Scene on page 42 
Showing/Hiding Scenes on page 45 

Changing the Background Color of a Scene
The background color of all scenes is white by default. You can change the background 
color of each scene in your movie to suit the context of the action.   

To change the background color of a scene, follow these steps:

1. Select the scene in the Scene Manager window.

2. Click the Contextual Menu  button and select Properties. The Scene 
Properties dialog box opens.
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3. Double-click the Background Color square. The Color dialog box opens.

4. Select a color for the scene background or create your own by clicking Define 
Custom Colors.

5. Click OK when you are done and Toon Boom Studio™ will update the scene with 
the new background color.

You can show/hide the scene background color in the Drawing View window in 
Drawing Mode or in the Camera View window in Sceneplanning Mode.

To show/hide the scene background color in the Drawing View or Camera View 
windows:

• Select View > Show scene background color. 
When this option is activated, the scene background color will appear in 
the Camera View and Drawing View windows.
When this option is not activated, the background color of these windows 
is determined by the Drawing/Camera setting on the Interface tab of 
the Preferences dialog box.

See Also
Changing the Background Color of the Drawing and Camera View Windows on page 51 
Changing the Color of an Element on page 383 
Changing the Track Color in the Timeline on page 370 
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Reordering Scenes
When you playback or export an entire animation set with multiple scenes, Toon 
Boom Studio™ exports the scenes in the order in which they appear in the Scene 
Manager window. If you want to change the playback order of the scenes, you must 
resort them in the Scene Manager window. 

To change the order of scenes in the Scene Manager window, follow these steps:

1. Select the scene you want to move in the Scene Manager window. 

2. Drag it to its new position in the Scene Manager window. 

A grey bar appears between the scenes to indicate where you can drop the 
selected scene.

The new order of the scene will also appear in the Scene Manager pop-up menu. 

See Also
Renaming Scenes on page 44 
Deleting Scenes on page 46 

Renaming Scenes
When you start a new project, you always begin with one scene. By default, this 
exposure sheet is called Scene-1, and every scene you create after that gets a 
sequentially numbered default name (Scene-2, Scene-3, and so on). 

At any time, you can rename scenes with more descriptive names that more fully 
reflect the content. 

To rename a scene, follow these steps:

1. Right-click the scene name and select Properties from the pop-up menu. The 
Scene Properties dialog box opens.

2. Type the new name for the scene in the Scene Name field and click OK. You 
cannot name two scenes with the same name.
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The new scene’s name appears in the Scene Manager window. When you select a 
scene from the Scene  button in the Exposure Sheet window, the customized 
names of your scenes also appear.

See Also
Reordering Scenes on page 44 
Deleting Scenes on page 46 
Changing the Background Color of a Scene on page 42 
Showing/Hiding Scenes on page 45 

Showing/Hiding Scenes
When you are working on a production that has many scenes, you may not want to 
include them all in the rendered playback or in the export. Perhaps some of those 
scenes were just “working scenes” in which you were saving some rough animation.

You can use the Show/Hide buttons next to scene names in the Scene Manager 
window to hide scenes during the rendering process. This has the advantage over 
deleting scenes because the material remains with the animation set.

To show/hide scenes in your animation:

1. Click the Show/Hide button next to the scene name in the Scene Manager 
window.

See Also
Playback and Rendering on page 427 
Deleting Scenes on page 46 

When the Show/Hide button next to a scene 
name is empty, the scene will not appear in 
rendered animation.
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Deleting Scenes
As you work on your animation project, you may want to remove old scenes from your 
project before you produce your final output. 

For example, you could have a few test scenes where you wanted to try certain effects, 
but when you are ready to record your final movie, you’ll want to remove these scenes 
from the animation set.

To delete a scene:

• Click Delete  in the Scene Manager window. Toon Boom Studio™ 
deletes the scene folder and all its related animation files from your system.

See Also
Renaming Scenes on page 44 
Adding Scenes to a Movie on page 41 
Showing/Hiding Scenes on page 45 
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Setting up Your Studio Session

Toon Boom Studio™ is designed to be flexible enough to adapt to your computer 
setup as well as your personal flair, allowing you to customize your workspace. 

You can customize the following aspects of your Toon Boom Studio™ system: 

• Toolbars
• Keyboard shortcuts
• Units of measure and default values in Sceneplanning Mode
• Display settings
• Default element colors
• Author and copyright owner of templates
• Background color of Drawing View and Camera View windows

See Also
Displaying Toolbars on page 47 
Assigning Keyboard Shortcuts on page 48 
Selecting the Units of Measure on page 50 
Configuring Video Card Display Options on page 52 
Defining the Default Tension, Continuity and Bias Values on page 283 
Changing the Default Colors of Elements on page 384 
Defining the Template Author and Copyright on page 426 
Changing the Background Color of the Drawing and Camera View Windows on page 51 

Displaying Toolbars
By default, Toon Boom Studio™ displays specific toolbars in the main window, but 
you can select the toolbars to display in your Toon Boom Studio™ session. You can 
then drag these toolbars to any position in your Toon Boom Studio™ window.   

To select the toolbars you want to display:

• Select the menus you want to display from the View > Toolbars menu. A 
check appears next to the toolbars that will display.
Depending on the mode you are in, you have the following choices:
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Setting up Your Studio Session
Main: In Drawing Mode and Sceneplanning Mode, this toolbar allows 
you to start, open, or save animation sets, cut, copy, and paste content, 
and access the online help.
Mode: allows you to shift between Drawing Mode and Sceneplanning 
Mode.
Interactive Playback: In Drawing Mode and Sceneplanning Mode, this 
toolbar allows you to control the playback of your scene.
Grid Control: In Drawing Mode, this toolbar allows you to display grids 
in the Drawing View window.
Onion Skin: In Drawing Mode, this toolbars allows you to view the 
previous or next drawings in a sequence.
Peg: In Sceneplanning Mode this toolbar allows you to display/hide 
details about the peg path.
Scene Operation: In Sceneplanning Mode, this toolbar allows you to 
modify an elements’ position, motion path, size, and angle.
Scene View: In Sceneplanning Mode, this toolbar allows you to change 
what you see in the View windows.

See Also
Assigning Keyboard Shortcuts on page 48 
Setting up Your Studio Session on page 47 

Assigning Keyboard Shortcuts
When you are working on your Toon Boom Studio™animation, there are many 
commands that you can access using either toolbar buttons or menu commands. 

You can also access many of these commands using keyboard shortcuts. Many of these 
shortcuts appear next to the command in the menus. 

You can create customized keyboard shortcuts for commands that do not have default 
shortcuts, such as those that are only accessible from right-click (contextual) menus. 

When you assign a keyboard shortcut to 
a command, it’s keyboard combination 
appears next to the command in the 
menu.
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You can also edit the default keyboard shortcuts assigned to commands to suit your 
particular working style.

To assign a command to a keyboard combination, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Shortcuts tab. 

3. Select the area that the command is located by clicking the button next to Global, 
Drawing or Sceneplanning.

4. Select the type of command you want to assign from the Category drop-list. 

The contents of the Commands list changes depending on what you select from 
the Category drop-list.

5. Select the command you want to assign from the Commands list. 

A description of the selected command appears in the Description panel. If the 
command you select already has a keyboard shortcut, the keyboard combination 
appears in the Current key and Press new shortcut key fields.

6. Click in the Press New Shortcut Key field and press the keys you want to assign 
to the currently selected command. The keys you press appear in the field.

7. Click Assign to assign the current key combination to the selected command. 
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If you want to remove the current keyboard combination, click Remove. The two 
fields revert to None to indicate that there are no keyboard shortcuts for the 
current command.

8. To reset all the keyboard shortcuts to their original shipped settings, click Reset 
All. 

See Also
Displaying Toolbars on page 47 
Setting up Your Studio Session on page 47 

Selecting the Units of Measure
As you work on your scene objects in either Drawing Mode or Sceneplanning Mode, 
you can change their position or how they appear in your scene. To be able to measure 
the changes in size, rotation, or position, you need to use a system of measurement to 
make accurate modifications.        

To select the measurement unit you want to use in your Toon Boom Studio™ 
session, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Select the Sceneplanning tab.     

3. Select the unit of measure from the Coordinates drop-list. You have the 
following choices:
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• centimeters: measures distance using the Metric system.
• inches: measures distance using the Imperial system.
• fields: measures distance using the traditional animation industry standard 

for the size of a film camera (0.5" X 0.375" at a ratio of 4:3).
By default,Toon Boom Studio™ uses the traditional field system (measured by North/
South/East/West) to measure the distance, position, and size your elements.

4. Click OK when done or select another tab.

See Also
Basic Sceneplanning Concepts on page 238 
Setting up Your Studio Session on page 47 

Changing the Background Color of the Drawing 
and Camera View Windows

You can set the background color for the Drawing View and Camera View windows to 
improve your ability to work on the drawing objects and lay out of your scene. The 
color you choose for the background is not exported as the background color of the 
scene.

To change the background color of the Drawing View and Camera View windows, 
follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Interface tab.

3. In the Window background colors panel, double-click the Drawing/Camera 
color square. The Color dialog box opens.
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4.  Select a color for the window color or create your own by clicking Define 
Custom Colors.

5. Click OK when you are done and Toon Boom Studio™ will update the default 
background color of the windows.

6. To see the color you select in those windows, you must disable the View > Show 
scene background color option.

See Also
Changing the Background Color of a Scene on page 42 
Setting up Your Studio Session on page 47 

Configuring Video Card Display Options
If you are having problems with the display of Toon Boom Studio™ windows or tools, 
you can use the options on the Display tab of the Preferences dialog box to set 
rendering options that will work with your video card.  

To configure your display settings, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Display tab, select your options, and click OK to close the dialog box. 

• Renderer: By default Toon Boom Studio™ is set to use Direct3D for 
rendering images in the View windows. 

Disable Hardware Accelerator: select this option if you are having 
problems with your display that you suspect might be related to features 
of your video card.
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Disable Overlay: select this option if the drawing tools are responding 
very slowly.

• Rendering Options
Smooth Textures and Bitmaps: select this option to anti-alias bitmap 
images and improve their appearance in the View windows.
Use Small Tiles for Rendering Textures and Bitmaps: select this 
option if you are having problems displaying bitmaps and you suspect it 
might be due to the limitations of your video card.
Textures & Images: use this slider to configure the quality and speed of 
the display of bitmap images in the View windows.
Memory Usage: use this slider to control the amount of temporary 
memory used for storing drawings. Increasing the amount of memory 
allocated to the display of drawings will improve your performance 
because your processor will not have to reprocess the same images. 
However, this memory is taken from your RAM, so if you do not have a 
lot of RAM you may experience other performance reductions.
Smooth pegs: select this option to anti-alias motion paths in the View 
windows in Sceneplanning Mode.
Smooth tools: select this option to anti-alias the visual guides of the tools 
in the View windows. If you select this the circle guide will appear as a 
smoother circle instead of being jagged.

See Also
Displaying Toolbars on page 47 
Selecting the Units of Measure on page 50 
Setting up Your Studio Session on page 47 
Changing Elements Over Time with Pegs on page 260 
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Chapter 2 
Tutorial

The lessons in this tutorial give you the chance to learn Toon 
Boom Studio™ using realistic examples. 

You can do these lessons in any order. Each are self-contained so 
that you can learn about the features that interest you most.

The material for these lessons is included with the full installation 
of  Toon Boom Studio™ in the Tutorial folder.

This chapter includes the following lessons:

• Lesson 1: Drawing on page 56 

• Lesson 2: Painting on page 65 

• Lesson 3: Lip Syncing on page 76 

• Lesson 4: Building a Multiplane Scene on page 86 

• Lesson 5: Creating Cross-Dissolves with Color Transform 
Elements on page 96 

• Lesson 6: Creating Clipping Mask Effects on page 107 



Lesson 1: Drawing
Lesson 1: Drawing

In this lesson, you’ll work in Drawing Mode with the Toon Boom Studio™ drawing 
tools to create frame-by-frame animation. 

There are two animation sets for this lesson:

• Drawing_Rough
• Drawing_Final

You’ll use the Drawing_Rough animation set to complete a walk-cycle. You’ll use the 
onion skin, rotary light table, and the Toon Boom Studio™ centerline drawing tools 
and pressure-sensitive Brush tool to draw Mike Ant.

To start the Drawing Mike Ant lesson, follow these steps:

1. Open the Drawing_Rough animation set in the Lesson1_Drawing folder.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation set to a new location will ensure that you always have the original to 
return to and use should you want to.

You’ll draw this ant so it fits 
between the previous and 
next frames.

Previous frame. Next frame.

Current frame.
56 



Chapter 2: Tutorial
Step 1: Draw Mike Ant’s Body
In this step, you will draw the body of Mike Ant using the Ellipse tool. Because this 
drawing must fit with the other drawings in the element to create a complete cycle, you 
will use the onion skin to show previous and next drawings as a reference while you 
draw.

To draw Mike Ant’s body, follow these steps:

1. In the Exposure Sheet window, click the first cell in the rough-mike element 
and press the down arrow key on your keyboard. As you cycle through all of the 
drawings in the rough-mike element, you’ll notice that there is no drawing in the 
rough-mike-2 cell. That’s because you are going to draw it!

2. Select the rough-mike-2 cell. 

 

3. Set up the Drawing View window so that you have a clear view of Mike Ant.
• To turn off the grid, press [G], the default keyboard shortcut.
• To zoom-in, press [X], and to zoom-out press [Z].
• To pan the Drawing View window, press and hold [Spacebar] and use the 

Grabber tool to change the part of the window you are seeing.
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4. Click the Previous Drawing  button and the Next Drawing  button in the 
Onion Skin toolbar.

5. Select the Ellipse  tool from the Tools Palette. 

6. If the Properties window is not open, select Window > Properties. The 
Properties window appears. 

In the Drawing View window, the previous 
and next drawings in the onion skin appear 
in a different color to distinguish them from 
the drawing you are working on.
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7. In the Pen tab, type 20 for the Maximum Size value. When you draw with the 
centerline tools (including the Pencil, Rectangle, Ellipse, Polyline and Line) Toon 
Boom Studio™ uses the Maximum Size value for the width of the line.

8. In the Drawing View window, draw an ellipse roughly the shape of Mike Ant’s 
body. Don’t worry about the actual shape not being the same as the one in the 
animation. You will reshape it using the Contour Edit tool.

9. Save your animation using the Save command.
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Step 2: Reshape Mike Ant’s Body
In this step, you will use the Contour Editor tool to move the points that make up the 
ellipse you drew in step 1 and reshape Mike Ant’s body.

To reshape Mike Ant’s body, follow these steps:

1. From the Tools Palette, select the Contour Editor.

2. Click the ellipse you drew in step 1. You’ll notice that a line appears down the 
center of the shape (a centerline) and that there are points on this line.

3. Use the Contour Editor to reshape the ellipse by moving the points and dragging 
the Bezier handles. (To get the Bezier handles to appear, click a point on the 
centerline.) 

The final shape should be approximately the same shape as the ant’s body shown 
in the previous drawing.

4. Save your work using the save command. Select File > Save.

After you reshape the 
ellipse, it should look 
something like this
60 



Chapter 2: Tutorial
Step 3: Draw Mike Ant with the Brush Tool

In this step, you use the Brush  tool to draw the head and then the rest of Mike Ant.

Unlike the Ellipse tool and other centerline tools (Rectangle, Polyline, Line and Pencil), 
the Brush tool creates variable-width strokes that respond to the pressure you apply 
with a digital pen and graphic tablet. 

When you draw with the Brush tool, Toon Boom Studio™ creates shapes that are 
formed by points that surround a zone, which is filled with color. We call the shapes 
created by the Brush tool “contour shapes”. 

Drawing with the Brush tool allows you to create distinctive lines that are more natural 
than the mechanical looking centerline shapes. However, brush strokes require more 
memory to store because they use more points to create. If you are concerned about the 
file size of your animation, consider carefully when choosing your drawing tools.

To draw Mike Ant with the Brush tool, follow these steps:

1. Select the Brush tool from the Tools Palette. 

2. In the Pen tab, type 5 for the Minimum Size value. When you draw with a graphic 
tablet and pen, Toon Boom Studio™ uses the Minimum Size and Maximum Size 
values to determine the width of the variable-width line.

3. In the Drawing View window, use the Brush tool draw a circle approximately the 
same shape as the Mike Ant’s head as shown in the previous drawing in the onion 
skin.

4. Using the Contour Editor tool, [Shift]+click the ant’s head drawing and the ant’s 
body. Notice the number of points in Mike Ant’s head, drawn using the Brush 
tool, and Mike Ant’s body, drawn using the Ellipse tool.
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When you have finished comparing the drawings deselect them by clicking anywhere 
in the Drawing View window. 

5. Using the Contour Editor tool and the curve handles, reshape the ant’s head you 
drew so that it is approximately the same shape as the ant’s head shown in the 
previous drawing in the onion skin.

6. Draw the rest of the ant. The completed drawing must fit in run cycle, so you 
must draw Mike’s legs so that his left leg is touching the ground and his right leg 
is bent at the knee. His body should also be slightly elevated, so you might want 
to move the body up slightly. 

A brush stroke is surrounded by a 
collection of points. The outline of the 
brush stroke or painted fill is called a 
Contour. 

A line drawn with the 
Ellipse tool is defined by a 
series of centerline points.

After you reshape the head drawing it 
should look something like this.
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When you finish drawing, your ant should look something like this.

You can look at the final drawing in the Drawing_Final animation set to see how we 
did it.

7. To help you with your drawing, you can use the Rotary Light Table so that you 
can get a better angle on the part of the drawing you are working on.
• To display the Rotary Light Table, press [Ctrl]+[Alt] and use your mouse to 

freely rotate your drawing space.

• To return your drawing space to the original angle, select View > Reset 
Rotation or press [Shift] + [C].
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Step 4: Preview the Mike Ant Cycle
In this step, you use the Interactive Playback and the buttons on the Interactive 
Playback toolbar to preview your drawing of Mike Ant and see how it fits into the run 
cycle.

To preview the Mike Ant cycle using Interactive Playback, follow these steps:

1. In the Exposure Sheet window, press [Shift] and select drawings 1 through 8.

2. Press Play  in the Interactive Playback toolbar.

All of the selected content plays in sequential order in the View window until the 
frame marker reaches the last frame of the scene or until you click the Stop  
button.

3. If you want the playback to repeat, select the Loop  button in the Interactive 
Playback toolbar before you click the Play  button.

4. Make corrections to your Mike Ant drawing so that the transition between the 
drawings in the cycle is logical and smooth.

5. Save your animation set and you are done!
Congratulations on passing the first lesson in the Quick Start Tutorial.

Rewind to first 
frame

Play

Forward by 
one frame

Forward to last 
frame

Loop playback

Stop

Rewind by one 
frame
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Lesson 2: Painting
In this lesson, you will paint the infamous Mike Ant, and give him some color!

There are two animation sets for this lesson:

• Painting_Rough
• Painting_Final

In the Painting_Rough animation set, you’ll build a color palette for Mike Ant and 
create a gradient color swatch. Then you’ll paint Mike Ant using Toon Boom Studio™ 
power-paint features that will speed the painting process.

To start the Painting Mike Ant lesson, follow these steps:

1. Open the Painting_Rough animation set in the Lesson2_Painting folder.

2. Save the animation in a location of your choice using File > Save As. 

3. Click the Play  button in the Interactive Playback toolbar, and watch Mike Ant 
run! 

You’re going to give Mike some color, as well as give him a real reason to run - 
red hot flames licking his back!
65



Lesson 2: Painting
Step 1: Add a Color Swatch
In this step, you’ll add a color swatch to Mike Ant’s color palette.

To add a color swatch, follow these steps:

1. If the Properties window is not open, select Window > Properties. The 
Properties window appears. 

2. Click the Color Palette tab. The Color Palette tab appears with the default set of 
colors. 

3. From the Name drop-list, select mike. This is the Mike Ant color palette, which 
you can use to organize all of the color swatches for this buggy character.

4. Click the Show Color Name button on the right side of the dialog box, just above 
the swatch scroll bar. This changes the display to a list of swatches and their 
names.

5. Select the belt color swatch and click the Add a Color  button. A copy of the belt 
swatch appears in the palette style and it is called New 1 by default. You will edit 
the properties of this color swatch in the next step.

This color palette gives you all 
the color swatches you need to 
paint your ant

Show Color Names button, 
displays the swatch names.
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Step 2: Create a Gradient “Flame” Swatch
In this step, you will create a gradient for the flame that is licking Mike Ant’s back. 
You’ll use the swatch you created in the previous step as the basis for the gradient.

To create a gradient, follow these steps: 

1. Double-click the color swatch you added in the last step. You’ll use this swatch as 
a basis for the gradient because the orange color in the swatch is similar to one of 
the gradient colors.

The Color Picker opens.

2. Select Gradient by clicking the button to the left of the Gradient label.

3. In the Gradient panel, select Radial. The colors in a radial gradient blend in a 
circular pattern.

4. Click the first marker. A square appears in the marker to indicate that it is 
editable.

Gradient Color
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Lesson 2: Painting
5. Change the color of the first marker to yellow by dragging your mouse in the 
color square to the left of the gradient panel. We used these colors, which you can 
type in the R, G, B fields: 248, 251, 17

6. Click below the Gradient bar to add a gradient marker. The color of the marker is 
the same as the marker you had selected. Gradient markers represent the start or 
end of a transition between different colors.

7. In the Alpha value field, type 153. An alpha value of 255 is completely opaque 
and an alpha value of 0 is completely transparent. At 153, this value is partly 
transparent. 

8. Change the value of the last color to red. You can use these specific values: 236, 0, 
0

9. Close the Color Picker and that’s it! You have created a gradient swatch!

First color Last color

Transition color
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Step 3: Paint the Flame on Mike Ant’s Back
Now that you have created a gradient for the flame, you are ready to paint.

To paint the flame on Mike Ant’s back, follow these steps:

1. In the Exposure Sheet window, select the first drawing in the colorMe element. 
Mike Ant appears in the Drawing View window.

2. Set up the Drawing View window so that you have a clear view of Mike Ant.
• To turn off the grid, press [G], the default keyboard shortcut.
• To zoom-in, press [X], and to zoom-out press [Z].
• To pan the Drawing View window, press and hold [Spacebar] and use the 

Grabber tool to change the part of the window you are seeing.

3. Select the Paint  tool from the Tools Palette.
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4. From the Color Palette tab, select the gradient swatch you created for the flame.

5. Click the areas of the flame with the Paint  tool.

6. Scroll through the Mike Ant drawings in the Exposure Sheet window and paint 
all of the flaming areas. If you select the Exposure Sheet window, press [S] to 
advance to the next frame and press [A] to return to the previous frame.

You’ll notice that after you paint drawing 8, you will come to drawings that have 
already been painted. That’s because we repeated drawings 1 through 8 in the 
element to create a cycle. Because each cell in the Exposure Sheet window refers to 
a drawing in the animation set folder, when you update a drawing that is 
repeated in other frames, Toon Boom Studio™ updates all frames that reference 
that drawing.
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Step 4: Edit the Direction of the Flame
So you’ve painted all the flames that are scorching Mike Ant on his run cycle. But do 
they look convincing? Do they look natural? Not really, if you ask me. Usually a flame 
will change color at the edges, not just in a straight line from the source.

In this step, you will use the Edit Texture  tool to change the position and length of 
the flame gradient.

To edit the color gradient swatch, follow these steps:

1. Select the Edit Texture tool from the Tools Palette. 

2. With the Edit Texture tool, click the flame gradient in one of the Mike Ant 
drawings. The Edit Gradient frame appears.
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3. Grab the handles to rotate the gradient or change its length. You want to create an 
effect that looks more natural, so experiment with the Edit Texture tool.

For ideas about how to create a flame effect that changes as Mike runs, check out the 
Painting_Final animation set to see how the gradient looks in each frame.

Use the handles to reshape the 
gradient.

Drag the center of the Edit Gradient 
frame and you dramatically change the 
look of the flame gradient color.
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Step 5: Paint Mike Ant
In this step, you are going to get to try out the powerful auto paint features.

With auto paint, you click a zone in one drawing and Toon Boom Studio™ 
automatically scrolls through the rest of the drawings in the elements to check if there 
is a closed zone beneath where you clicked. If there is a closed zone, Toon Boom 
Studio™ paints the zone with the same color.

Another feature you need to be aware of is auto gap closing. To fill a zone with color, 
it has to be completely closed. Sometimes, when you draw with the Brush tool, you 
may not always close zones completely. When you are painting, you can set a threshold 
for line gaps so that Toon Boom Studio™ will paint zones regardless of the size of the 
gap that keeps them open.

To paint Mike Ant, follow these steps:

1. From the Tools > Auto Gap menu, select Close Large Gap. 

2. In the Exposure Sheet window, select the colorMe-1 drawing.

3. Press [X] to zoom-in on the drawing so that you can see the zones clearly.

4. Select the Paint tool from the Tools Palette.

5. In the Color Palette tab, click the skin color swatch in the mike color palette. 

6. Press [Shift]+[Alt] and click Mike Ant’s body. Your pointer changes to indicate 
that the Paint All tool is active. It may take a couple of minutes for Toon Boom 
Studio™ to paint all of the zones. 
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After it is done, scroll through the drawings to see that the body on all of the drawings 
are painted with the skin color swatch. You may have to manually correct some 
drawings because of where you clicked on the drawing (it might overlap other zones, 
for example).

7. Continue to use the Paint All tool until all the static areas of your drawing are 
colored.

8. When you are finished painting the big zones, you are going to have to paint the 
smaller zones one at a time. Use the names of the color swatches to identify what 
zone they belong to on Mike Ant and just click those zones with the Paint tool.

Click here with the Paint All tool and it paints the 
same spot in all of the drawings in the element.
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Step 7: Export
That’s it! You’ve made Mike Ant colorful and given him real inspiration to run, a hot 
fire! Now you are ready to export your creation and share it with your friends and 
family.

To export your animation, follow these steps:

1. Zoom-in and pan the Drawing View window so that Mike Ant fills the window. 
(When you export a Drawing Mode scene, Toon Boom Studio™ uses the zoom 
level and position of the Drawing View window.

2. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

3. Type the name of the movie in the File Name field, select a location, and click 
Save. 

The Export as Macromedia Flash Movie dialog box opens.

4. Select Drawing Mode Current Scene from the Export type panel and leave the 
rest of the settings as default.

5. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

Your Macromedia® Flash™ movie opens automatically in a Flash player when the 
export has finished.
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Lesson 3: Lip Syncing
Lip syncing can be the most tedious task in the animation process. Before you can even 
begin drawing the lip positions, you have to analyze the voice track to determine what 
lip position best matches the sound at each frame. 

Toon Boom Studio™ features a lip sync tool that assess the sounds in a voice track and 
generates a lip chart based on the eight animation phonemes. In addition to that, in V2 
we added a tool that will automatically map drawings in an element based on the 
sounds they are meant to reflect. These two tools together will save you tons of time so 
that you can focus on more interesting and creative tasks.

There are two animation sets for this lesson:

• Lip_Sync_Rough
• Lip_Sync_Final

To start the Painting Mike Ant lesson, follow these steps:

1. Open the Lip_Sync_Rough animation set in the Lesson3_LipSync folder.

2. Save the animation in a location of your choice using File > Save As. 

Just look at Deb Ant! So nervous? 

Looks like she’s got something to say?
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Step 1: Import Deb Ant’s Voice Track
In this step, you will import a speech made by Deb while she’s at the Survivor Ant 
tribal counsel meeting. 

In Toon Boom Studio™, you must import sounds into Sound elements so you must 
add a sound element first.

To import Deb Ant’s voice track, follow these steps:

1. Click the Add Sound Element  button at the top of the Exposure Sheet win-
dow. An empty sound element appears in the exposure sheet. 

2. Select Element > Rename Element and use the Rename Sound Element dialog 
box to name the element debSpeaks.

3. Right-click the first cell in the element and select Import Sound > From file from 
the pop-up menu. The Open dialog box opens.

4. Browse the Lip_Sync_Rough animation set folder and select please_dont.MP3 
and click Open. The sound file now appears in the cell you selected. 

If you saved your animation set folder in a new location like we told you to with 
the Save As command, you are going have to locate the original folder to get the 
sound file.

5. Turn-up your headphones or speakers, right-click the first cell in the debSpeaks 
element and select Play from the pop-up menu. Listen as Deb Ant begs not to be 
kicked out of the tribe.
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Step 2: Generate a Lip Chart for Deb Ant
In this step, you will use Toon Boom Studio™ to generate a lip chart that matches Deb 
Ant’s speech to a set of animation phonemes. You can use the lip chart as a reference 
as you draw the lip sync images for your characters. 

To generate a lip chart for a Deb Ant’s voice track, follow these steps:

1. Select the debSpeaks element and select Element > Edit Sound. The Sound 
Element Editor appears.

2. In the Sound Element panel, click the wave form of the sound track and click the 
Stream button to set up this sound for streaming. 

Voice tracks are best set as streamed sounds because they will maintain 
synchronization with images in Macromedia® Flash™ movies better. However, there 
can be only one streamed sound playing at a time, so you must pick the sound files that 
you want to stream, or Toon Boom Studio™ will do it for you.

 

3. Right-click the waveform in the Sound Element panel and select Compute Lip 
Sync. A progress bar appears as Toon Boom Studio™ analyzes the selected 
sound clips and assigns a lip sync letter to each frame.

Here’s the Stream 
check-box.
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Chapter 2: Tutorial
The lip sync images on the right side of the window become active. Drag the frame 
slider in the Sound Element panel to see the lip position for each frame of sound.

4. Select the Enable Scrubbing option at the bottom of the Sound Element Editor.

5. Drag the frame slider at the top of the Current Sound panel to “scrub” the sound 
track and hear for yourself the sound the Deb is making at each frame. The speed 
of the scrubbing is relative to the distance you drag with the mouse. The further 
you drag the mouse, the faster the sound “scrubs”.

6. Click OK to close the Sound Element Editor and then save your animation set.
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Step 3: Draw Deb Ant’s Missing Lips
In the sample Lip Sync lesson, we drew six out of seven of the lip positions for Deb Ant. 
It is up to you to draw Deb’s lip for the “D” position using the lip sync preview images.

To draw Deb Ant’s missing lips, follow these steps:

1. In the Exposure Sheet window, drag the debSpeaks element so that it is next to 
the mouth column. This will make it easier for you to see the lip chart while you 
are working on Deb’s lips.

2. Right-click the debSpeaks element and select Show lip-sync from the pop-up 
menu. Toon Boom Studio™ displays the phoneme assigned to each frame in the 
sound.

3. Click the Toggle Thumbnails button to show the lip chart.

This is the Toggle Thumbnails button. 
Click it and you will see preview images 
for the lip chart you computed.
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Chapter 2: Tutorial
4. Scroll down the Exposure Sheet window. At the frame in the debSpeaks element 
that is labelled D, you must double-click the equivalent cell in the mouth element 
and rename the cell D.

5. Now, with the lip sync preview image as a reference, draw Deb Ant’s lips in the D 
position. After you have finished drawing her lips, paint them using the swatches 
in the Deb Ant color palette on the Color Palette tab.

This is how Deb Ant’s lips look in the D position we drew.

Here are some tips that will help you out:

• Use the Add Stroke tool to create a closed zone without visible line art.
• Use the Close Gap tool to close the zone in the neck so that you can paint it.
• You can copy and paste drawings from previous cells (try the F cell) and 

modify them to suit the lip position.
• The lips must fit on Deb Ant’s head. 

Cell labels link the contents of the cell 
to a file in your animation set folder.
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You can use the onion skin to display the previous and next drawings and 
use those drawings as a reference.
You can use the Auto Light Table to display other drawings in the frame, 
including Deb. You will need to hide other elements (using the Element 
List) to display only selected elements.
You can add a drawing (like the F drawing) to the Static Light Table so 
that you can use it as a reference.

• Set up the Drawing View window so that you have a clear view of Deb Ant.
To turn off the grid, press [G], the default keyboard shortcut.
To zoom-in, press [X], and to zoom-out press [Z].
To pan the Drawing View window, press and hold [Spacebar] and use the 
Grabber tool to change the part of the window you are seeing.

Step 4: Auto-Map Deb Ant’s Lips to Her Voice 
Track

In V2, we have added another super time-saving feature to speed the lip sync process. 

In Lip Sync Mapping dialog box, you identify each phoneme drawing for a character 
and then Toon Boom Studio™ automatically labels all of the cells in the character’s 
element with the appropriate label for each phoneme drawing.

To make this feature really work for you, it is best if you name your drawings with the 
seven phonemes and the closed mouth position: A, B, C, D, E, F, G, and X.

In the mouth element, we have already named all the elements with the letters of the 
seven plus one phonemes. All you have to do is map the drawings to the phonemes in 
this element, and Toon Boom Studio™ will do the rest of the work for you.
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To auto-map Deb Ant’s, follow these steps:

1. Select the first drawing in the mouth element and press the arrow keys and scroll 
down the drawings in this element. You’ll see that the mouth positions do not 
reflect the lip chart that you generated.

2. Right-click the title of the debSpeaks element and select Modify Lip Sync 
Mapping from the pop-up menu. The Lip Sync Mapping dialog box opens. 

3. From the Destination element pull-down list, select mouth. This is the element 
that you are going apply the auto-map to.
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4. In the X field, type A. For Deb’s lips, you are going to use the same drawing for 
the A position and the X position.

5. Click OK. The dialog box closes. If you scroll through the mouth element now, 
you’ll see that all of the lip drawings have been mapped to the phonemes in the 
Deb’s voice track.
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Step 5: Export
Time to export your lip sync scene.

To export your animation, follow these steps:

1. Zoom-in and pan the Drawing View window so that Deb Ant fills the window. 
(When you export a Drawing Mode scene, Toon Boom Studio™ uses the zoom 
level of the Drawing View window.

2. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

3. Type the name of your lip sync movie in the File Name field, select a location, 
and click Save. 

The Export as Macromedia Flash Movie dialog box opens.

4. Select Drawing Mode Current Scene from the Export Type panel and leave the 
rest of the settings as default.

5. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. 

Your Macromedia® Flash™ movie opens automatically in a Flash player when the 
export has finished.
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Lesson 4: Building a Multiplane Scene

One of the great powers of Toon Boom Studio™ is the 3D scene space and the camera, 
which allows you to design multiplane moves and cinematic camera effects. 

In this lesson, you’ll create a multiplane camera move that trucks-in on the action, as 
well as make that hot ant run across the stage. In the process of all this, you will also 
get to work a bit with templates.

There are two animation sets for this lesson:

• Sceneplanning_Rough
• Sceneplanning_Final

To start the Building a Multiplane Scene lesson, follow these steps:

1. Open the Sceneplanning_Rough animation set in the Lesson4_Sceneplanning 
folder.

2. Save the animation in a location of your choice using File > Save As. 

3. Select View > Sceneplanning Mode to switch to Sceneplanning Mode. 

4. Playback the rough animation by selecting the Play command from the Play > 
Interactive Playback menu. Not really much to see, eh? Nothing moves, nothing 
happens. Go to step one to create some more interesting visual effects in this 
scene.
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Step 1: Attach the Camera to the Peg
The first step in this lesson is to create a camera move using a peg.

The idea of Toon Boom Studio™’s digital peg system was inspired by traditional 2D 
cel animation. In traditional animation, cycles of animation are typically drawn in-
place. To make characters move through the cycle, animators would use peg bars, 
which would ensure that the drawings changed position gradually and precisely.

In Toon Boom Studio™, you use pegs to create all sorts of changes over time. In 
addition to motion, you can also create scaling and rotation effects using pegs. 

Toon Boom Studio™ also features “cameras”, which are like traditional cameras that 
“film” the action in a scene. In Toon Boom Studio™, you can combine these two 
features - cameras and pegs - to create camera moves like trucks and pans.

For this step, we’ve already created the motion path that the camera will follow. All 
you have to do is attach the camera to the peg.

To attach the camera to the peg, follow these steps:

1. In the Timeline window, drag the Camera element on top of the Peg-camera 
element.

In the View windows, you can see the elements in your 
scene from the front, side and top:

• Here’s the camera

• Here’s a a motion path we 
created with a peg
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Lesson 4: Building a Multiplane Scene
The Camera element appears indented below the Peg-camera element to indicate that 
it is attached.

2. Select the Play command from the Play > Interactive Playback menu to 
playback the scene. Watch the camera as it follows the motion path of the peg.

Step 2: Add Mike Ant Template to the Scene
Templates are re-usable pieces of animation that you can share with different scenes in 
the same animation set or with many animation projects. Templates can help you 
reduce your workload through re-use, keep the file size of your animations small, as 
well as facilitate working in a group on the same project. 

For example, you can create a template of a walk cycle and send the template file (with 
the extension .TBT) to your buddy so that she can incorporate into her animation.

You can create templates out of anything you create or import into Toon Boom 
Studio™ - vector drawings, bitmaps, entire elements, groups of elements, sound or 
SWF files. With a template, you have a neat package of all the objects, which makes it 
easy to transport and manage. If you create templates from multiple elements, Toon 
Boom Studio™ even maintains timing (exposure) and layout information with the 
templates.

So why all this talk about templates? We created a template of the walk-cycle of the 
painted ant, Mike. All you have to do is to drag it into the Timeline window and you 
will have added it to your scene.

To add the Mike Ant template to the scene, follow these steps:

1. Make sure you are in Sceneplanning Mode.
88 



Chapter 2: Tutorial
2. Select Window > Library to open the Library window. The Library window is 
your center for Toon Boom Studio™ content management.

3. Open the Local folder, double-click the mikeAnt.tbt file and press the Play  
button in the preview panel. Watch as the Mike Ant runs in-place, flames 
scorching his back (poor Mike!).

4. Drag the Mike Ant template file, mikeAnt.tbt, from the Library window to the 
Timeline window. Drop it just above the first element at the top of the list. 

 

5. Save your animation set and move on to the next step, where you will make Mike 
Ant move as he runs.

From the Library window, you can use:

• The Animation folder to access all of 
the vector drawings in your animation.

• The Local folder to manage all of the 
templates in your current animation 
set. Local templates are available to 
the current animation set only.

• The Global folder to manage all of the 
templates on your system. Global 
templates are available to all 
animation sets on your system.

This is the preview panel of 
the Library.
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Step 3: Add a Peg and Attach Mike Ant to It
This is the first step to creating a motion path for Mike Ant. 

To add a peg and attach Mike Ant to it, follow these steps:

1. Click the Add Peg  button at the top of the Timeline window to add a Peg 
element to your animation.

2. Drag the trackbar of the peg so that it starts on frame 35. 

3. Drag the right edge of the trackbar so that it lasts for 24 frames.

4. With the Peg selected, select Element > Rename and change the name of the peg 
to Peg-mikeant.

5. Drag and drop the mike-color element on top of the Peg-mikeant element. The 
Peg-mikeant element turns orange when your pointer is positioned so that you 
can attach the two elements.
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Step 4: Create Motion Path for Mike Ant
This is the biggest step in this lesson. In this step you will get to do something a bit 
more challenging - you’re going to make a motion path with the peg you just added. 
This motion path will move Mike Ant from the east to the west side of the stage as he 
moves from back to front.

You will use the three View windows to design and playback your motion effect.

To create a motion path, follow these steps:

1. Advance the red frame slider at the top of the Timeline window to frame 35, 
where the Mike Ant peg will start.

2. In the Timeline window, select the Peg element you just added and click twice on 
the Show/Hide All  button at the top of the window so that only the Peg-
mikeant element is showing. Then click the Show buttons next to the Peg-mikeant 
and Camera elements so that only they are displayed. The Show/Hide All 
command helps you quickly isolate the elements you want to work on.

At this point, your peg is just a red circle at the center of the Top View and Side 
View windows.

Your Top and Side View windows will look something like these.

You may have to zoom and pan your windows to get the same views 
of these windows.

• To pan a window, press [Spacebar] and use the Grabber tool 
to move your view of the window.

• To zoom-in, press [X].

• To zoom-out, press [Z].

• To reset the view, press 
[Shift]+[V].

Use the Show/Hide buttons 
to display the elements
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Lesson 4: Building a Multiplane Scene
3. With the Select  tool, move the red circle of the peg in the Top View and Side 
View windows.
• In the Side View window, move the peg so that it is just above the line that 

marks the division between north/south and place it further back in the 
scene.

• In the Top View window, place the peg against the east side of the camera 
angle.
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4. Make sure you have the Peg element selected in the Timeline window and select 
Tools > Motion to activate the Motion  tool.

5. With the Motion  tool in the Top View window, drag the last key frame on the 
motion (which is on the left) path towards the west side of the camera frame and 
towards the front.

When you activate the Motion tool, two key frames 
appear on the peg.

• The first key frame is on the left.

• The last key frame is on the right.

This is the last key frame (frame 58).
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Lesson 4: Building a Multiplane Scene
These are the values for the first keyframe (frame 35) and the last keyframe (58). You 
can copy these values directly into the Offset fields in the Motion Point tab.

• Frame 35: 3.70 N, 41.79 E, 49.1 B
• Frame 58: 2.66 N, 25.68 W, 40.32 B

6. Click the Show/Hide All  button to show all elements in your animation and 
then select Play > Quick SWF Playback. This command renders your final 
animation so that you can play it back in real-time.

The Frame field identifies the frame 
number of the selected motion point.

In the Offset fields, you can type the 
value for the selected motion point.

To advance to the next motion point, you 
can click this button.
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7. Use the controls in the playback window to watch your ant run across the stage. 
Be sure to turn-up the volume on your headphones so that you can hear the sound 
track that plays.

Step 5: Export
Well, you have successfully created a multiplane camera move and motion path. Now 
it’s time to package your creation so that you can share it with friends and family!

To export your animation, follow these steps:

1. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

2. Select a name and location for your animation and click Save. The Export as 
Macromedia Flash Movie dialog box opens.

3. In the Export Type panel, select Full Movie is selected.

4. Accept the rest of the default settings and click OK. After the animation is 
rendered, a playback window will open and playback your animation.

If you had any trouble with this lesson, check out the Sceneplanning_Final animation 
set to see how we did it.
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Lesson 5: Creating Cross-Dissolves 
with Color Transform Elements

One of the new additions to V2 is the Color Transform element, which you can use to 
change the color properties of an element over time. 

In the lesson scene, a skater does some fancy tricks on a half-pipe. To accentuate his 
daring boardwork, you will use a Color Transform element to create a series of cross-
dissolves that change the transparency of the skater at different frames.

There are two animation sets for this lesson:

• ColorFX_Rough
• ColorFX_Final

You will use the ColorFX_Rough animation set to follow the steps in the lesson. When 
you have questions that you are not sure about, you can refer to ColorFX_Final to see 
how we did it. 

You will work mostly in the Timeline 
window to add and modify Color 
Transform elements to create cross-
dissolves.
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To start the Creating Color Effects lesson, follow these steps:

1. Open the ColorFX_Rough animation set in the Lesson5_ColorFX folder.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation set to a new location will ensure that you always have the original to 
return to and use should you want to.

3. Select View > Sceneplanning Mode to switch to Sceneplanning Mode. 

4. Playback the rough animation by selecting the Play command from the Play > 
Interactive Playback menu. 

Notice how two images of the skater appear to overlap for several frames? Well, 
in this lesson, you are going to make the overlapping images fade-in/out to create 
a series of cross-dissolves (chain mix).

Step 1: Add the First Color Transform Element
To change the color of a drawing or image element over time, you attach it to a Color 
Transform element and then use the Color Transform element to specify how the 
colors in the elements attached to it will change.

During the cross-dissolve you will create, two drawings will appear at the same time, 
one fades-in while the other fade-out. To achieve this effect, we placed each drawing 
in a separate element layer so that you can control them independently. You’ll see as 
we progress through the lesson how this enables you to create cross-dissolves.

We have put the drawings 
for the skater in different 
elements so that we can 
create the cross-dissolve 
effect.
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To add the first color transform element, follow these steps:

1. Click the Add  button at the top of the Timeline window. The New Elements dia-
log box opens.

2. Enter information about the element in the New Elements dialog box:
• From the Type menu, select Color Transform Effect.
• In the Name field, type skateColor and click OK. A new element layer appears 

in the Timeline window.

3. In the element list on the left-side of the Timeline window, attach the Color 
Transform-skateColor element to the SkatePeg2 element by dragging and 
dropping it just below the peg.

 

4. Attach the sk_2 element to the Transform-skateColor element by dragging and 
dropping it on top of the effects element. 
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5. Change the start and duration of the Transform-skateColor element so that it 
matches the start and duration of the sk_2 element.
• Drag the trackbar of the Transform-skateColor element to frame 11.

 
• Drag the end of the trackbar so that it ends on the same frame as the sk_2 

element (frame 20).

 

6. Select File > Save to save your animation set.
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Step 2: Add Key Frames and Set their Values
In the first Color Transform effect, the drawing should fade-out from frame 16 to frame 
20. 

To achieve this, you must add a key frame at frame 16. Then, at the key frame on frame 
20, you must make the attached elements completely transparent.

With color transforms, you can chose to do an additive or a multiplicative color 
transform. 

• In additive color transformations, you select a color value that is added to all 
of the color values in an element.

• In multiplicative color transformations, you select a value (usually between 0 
and 1) and multiply this value with all of the color values in an element to 
arrive at a final value.

Because the effect you want to create in this lesson is an even transformation of the 
alpha value (transparency) of element colors, you will create multiplicative color 
transformations. 

To make an element change from transparent to opaque to transparent, you must 
multiply the alpha values by 0, 1, and 0. When you multiply an opaque color (255 
alpha) by 0, the result is 0 which makes the color transparent.

To add a key frame and set its value, follow these steps:

1. Advance the red frame at the top of the Timeline window to frame 16.
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2. From the element list on the left-side of the Timeline window, select the 
Transform-skateColor element. Notice in the Properties window (Window > 
Properties) that the Color Transform tab opens.

3. In the Color Transform tab, click the Add  button to add a key frame to the 
selected frame on the Transform-skateColor element. 

4. Advance the red frame slider at the top of the Timeline window to frame 20. 

5. On the Color Transform tab, drag the Alpha slider in the Multiplicative section of 
the tab all the way to the left. The value should appear as 0 in the Alpha field.

6. Drag the red frame slider at the top of the window from frame 11 to 20 and watch 
as the element fades-out.

7. Select File > Save to save your animation set.

An “X” appears to identify the 
key frame on the trackbar.
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Step 3: Create the Next Color Transform Effect
In this step, you are going to create another color transform effect, for the next element 
in the series, that will go from transparent to opaque to transparent.

To achieve this effect, you will add a Color Transform element, set three key frames, 
and multiply the alpha value at each key frame by 0, 1, and 0.

To create the next color transform effect, follow these steps:

1. Add a Color Transform element and name it skateColor2.

2. Drag and drop the Color Transform-skateColor2 element just before the sk_3 
element in the element list. This will also attach it to the SkatePeg 2 element.

3. Attach the sk_3 element to the Color Transform-skateColor2 element.

4. Change the start frame of the Color Transform-skateColor2 element so that it 
matches the sk_3 element. Start frame: 16; End frame: 24.

5. Add a key frame to the Color Transform-skateColor2 element at frame 20. Your 
Timeline window should now look something like this:

6. In the Color Transform tab, set the key frames to the following multiplicative 
alpha values:
• Frame 16: 0
• Frame 20: 1
• Frame 24: 0
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7. Drag the red frame slider from frame 16 to 24 and watch how the first element 
fades-out as the second one fades-in and then out again. 

You’ll notice how the drawing in the next element appears for the last five frames. 
In the next step you’ll use the exact same color transform element to fix all of the 
other elements so that they undergo the same color transform effect.

8. Select File > Save to save your animation set.

Step 4: Clone the Color Transform Effect
All of the remaining elements, except for the last, must undergo the same color 
transform effect as you created in Step 3. Rather than duplicating your efforts, you can 
just clone the Color Transform element and attach the other elements to it. 

When you clone a Color Transform element, all of the information stored in the effect 
are duplicated so that you do not have to re-create key frames or their values. If you 
update any one clone with new values, Toon Boom Studio™ will update all the other 
clones with the new values.

To clone the color transform effect follow these steps:

1. In the Timeline window, select the Color Transform-skateColor2 element.

2. Select Element > Clone Element. Toon Boom Studio™ creates a new element 
and names it Color Transform-skateColor2(1) and renames the original 
element Color Transform-skateColor2(0). The new element appears at the top 
of the element list in the Timeline window.

3. Attach the new element to the SkatePeg2 element and attach the sk_4 element to 
the Color Transform-skateColor2(1) element.

4. Drag the trackbar of the color transform element so its start/end frame matches 
the element you want it to transform.

5. Repeat the previous steps for the remaining sk_# elements. Make sure that as you 
attach the skater elements to the Color Transform elements that you maintain 
their layer order in the element list.
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When you are done, your Timeline window should look like this.

6. Playback the rough animation by selecting the Play command from the Play > 
Interactive Playback menu.

You just have to create the effect for the last element in the series and the effect 
will be complete!

7. Select File > Save to save your animation set.
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Step 5: Create the Last Color Transform
Now, all that is left is the color transform for the last element that makes up the skater.

For the last color transform effect, the skater will start out transparent, become fully 
opaque and remain opaque for the rest of the scene.

To create this effect, you will add one key frame to a Color Transform element, give the 
first key frame a multiplicative alpha value of 0 and give the second key frame a 
multiplicative alpha value of 1.

This step is basically the reverse of step 2, in which you made the character start opaque 
and then end transparent.

To create the last color transform, follow these steps:

1. Add a Color Transform element and name it skateColor3.

2. Attach the Color Transform-skateColor3 element to the SkatePeg2 element 
and attach the sk_8 element to the Color Transform-skateColor3 element. 

3. Change the duration of the Color Transform-skateColor3 element to 9 frames 
and make the element start on frame 36.

4. Add a key frame to frame 40 of the Color Transform-skateColor3 element.Your 
Timeline window will look something like this:

5. In the Color Transform tab, set the key frames on the color transform element to 
the following multiplicative alpha values:
• Frame 36: 0
• Frame 40: 1

6. Select File > Save to save your animation set.
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Step 6: Export
That’s it! You’ve created a pretty nifty color transform effect with the latest effects in 
Toon Boom Studio™ V2.

All that is left to do is to export your animation and watch it play!

To export your animation, follow these steps:

1. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

2. Select a name and location for your animation and click Save. The Export as 
Macromedia Flash Movie dialog box opens.

3. In the Export Type panel, select Full Movie is selected.

4. Accept the rest of the default settings and click OK. After the animation is 
rendered, a playback window will open and playback your animation.

That’s it! If you had any trouble with this lesson, check out the Color_FX_final 
animation set to see how we did it.
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Lesson 6: Creating Clipping Mask 
Effects

The Clipping Effect element is another new addition to V2, which you can use to 
mask-out parts of an image to reveal only those portions you want to. 

In the lesson scene, you will merge two extreme sports scenes (mountain bike guy and 
surfer guy) using a mask to reveal the second scene. While you work on this effect, we 
hope you learn some other things too!

There are two animation sets for this lesson:

• MaskFX_Rough
• MaskFX_Final

You will use the MaskFX_Rough animation set to follow the steps in the lesson. When 
you have questions that you are not sure about, you can refer to MaskFX_Final to see 
how we did it. 

See the wave hot on the trail of the 
biker? 

That is created by a mask element 
in the shape of the wave, which 
reveals an image of a wave below 
it.
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To start the Creating Clipping Mask Effects lesson, follow these steps:

1. Open the MaskFX_Rough animation set in the Lesson6_MaskFX folder.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation set to a new location will ensure that you always have the original to 
return to and use should you want to.

3. Select View > Sceneplanning Mode to switch to Sceneplanning Mode. 

4. Playback the rough animation by selecting the Play command from the Play > 
Interactive Playback menu. 

Notice how the two scenes - the one of the biker and the other of the surfer - just 
run smack into each other? In this lesson, we’ll create a transition between these 
two scenes out of a clip in the shape of a wave, which will reveal the surf scene. 
Take a look at the final animation set, MaskFX_Final, if you want to see what you 
will do.

Step 1: Drawing the Mask
Like the masks worn by partiers at a halloween ball, a Toon Boom Studio™ mask 
reveals certain visual elements while hiding others (like a halloween mask reveals the 
eyes of the wearer, while covering most of the face).

For the first step in the creation of the mask effect, you must draw the mask that will 
reveal image(s) below it. You can only create masks from vector drawings.

We have already drawn a mask for you. The mask consists of a cycle of vector drawings 
of a wave, which will cut out an image of rolling waves beneath it. 

Take a look at the mask we drew so that you know what you can do when you create 
your next clip effect solo. 

With the onion skin on, you can see the 
cycle of drawings that fit together to 
make the mask.
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To review the mask we created, follow these steps:

1. Select View > Drawing Mode to switch to Drawing Mode. 

2. In the wave_mask element column in the Exposure Sheet window, press [Shift] 
and select frames 15 through 36.

3. Playback the selection of drawings by selecting the Play command from the Play 
> Interactive Playback menu.

Notice the wave cycle is a collection of painted vector drawings. The painted 
areas of these drawings will be like the wholes in the halloween mask that will let 
the images below it show through, assuming the shape of the mask drawings.

Step 2: Building the Clipping Element
After you have created the vector drawings that will act as your mask, or in this case, 
have seen the vector drawings that will act as the mask, you are ready to switch to 
Sceneplanning Mode, where you will add the Clipping Effect element.

Clipping Effect elements consist of two parts: the clip element and the mask parameter. 

• To the clip layer, you attach the elements that you want to show through the 
mask.

• To the mask parameter, you attach the vector drawing element that you want 
to use as a mask.

You will notice in our setup, that we have attached the wave_mask vector element to a 
peg, that moves the wave in the scene.

To build the mask element, follow these steps:

1. Select View > Sceneplanning Mode to switch to Sceneplanning Mode. 

2. Click the Show/Hide buttons next to the wave_mask element so that you can see 
it.

• Here’s the clip layer.

• Here’s the mask parameter.

• Here’s the vector element that is attached to the peg.

• Here’s the clip that will “show through” the mask.
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3. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

4. From the Type drop-list, select Clipping Effect, type waveEffect in the name field 
and click OK.

The Timeline window will look like this:

5. Drag and drop the Peg element on top of the Mask parameter. When you drag 
the Peg element, the vector element attached to it will move with it as well. You 
have now created the mask!

 

• Here’s the Clipping layer.

• Here’s the Mask parameter.
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6. Drag the wave.swf Media element on top of the Clipping-waveEffect layer. The 
clip layers appear below the mask layers, but are indented out from the mask 
layers.

 

Step 3: Export
Well now that you have created your clip mask effect, you are ready to export and 
show the world the fruits of your labor!

To export your animation to SWF, follow these steps:

1. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

2. Select a name and location for your animation and click Save. The Export as 
Macromedia Flash Movie dialog box opens.

3. In the Export Type panel, select Full Movie is selected.

4. Accept the rest of the default settings and click OK. After the animation is 
rendered, a playback window will open and playback your animation.

There is an element with some text in it, which we imported from an Adobe® 

Illustrator® file. To experiment more with the Mask effect, you can replace the existing 
mask with this element. Remember you will have to change the start time and exposure 
of this drawing so that it matches the duration of the transition.

Enjoy!
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Chapter 3
Drawing

This chapter explains how to use the tools in Toon Boom Studio™ 
to create your own animated drawings.

This chapter includes the following topics:

• Drawing Line Art on page 114 

• Working with Selections on page 121 

• Optimizing Drawing Objects for the Web on page 131 

• Cutting and Erasing Parts of Drawing Objects on page 139 

• Modifying the Shape of Vector Lines on page 142 

• Setting Up Your Pens on page 150 

• Setting Up Your Drawing Space on page 153 



Drawing Line Art
Drawing Line Art
Lines (also called “line art”) are the basis for all shapes that you draw with Toon Boom 
Studio™ vector drawing tools. As lines are the basis of all shapes, points are the basis 
of all lines.  

Points can run down the center of a line, creating what we call a centerline. Or, points 
can run around the outside of a shape, creating a line called a contour. 

• The Line , Polyline , Pencil , Rectangle  and Ellipse  tools create 
centerline shapes of a set width.

• The Brush  tool creates variable-width strokes that respond to the pressure 
you apply with a digital pen and graphic tablet. The points that compose a 
brush stroke surround a zone that is filled with color, creating a contour. 

All lines are composed of points. It 
takes at least two points to define a 
line.

A straight line drawn with the Line tool 
has a point at either end. 

A line drawn with the 
Pencil tool is defined by a series of 
centerline points.

A brush stroke or a painted shape is surrounded 
by a collection of points. The outline of the brush 
stroke or painted fill is called a Contour. 
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The tool you select depends on the type of effect you want to create as well as 
considerations for the file size of your final animation.

To draw your line art, you must be in Drawing Mode. 

To switch to Drawing Mode: 

• Click the Drawing Mode  button or select View > Drawing Mode. 
If you are already in Drawing Mode, the command in the View menu reads 
as Sceneplanning Mode.

   

See Also
Drawing Straight Lines, Ellipses and Rectangles on page 116 
Drawing Brush Strokes on page 118 
Drawing Pencil Lines on page 120 
Drawing with the Polyline Tool on page 117 
Creating Lip Charts Automatically on page 230 
Modifying the Shape of Vector Lines on page 142 
Optimizing Drawing Objects for the Web on page 131 
Exposure Sheet and Timeline Windows on page 354 
Protecting Drawings on page 398 

• When you draw your characters, you may want to wait to draw the lip 
positions until after you import the sound track.

Toon Boom Studio™ features a powerful lip sync generator. With this tool, 
you can generate a lip chart that identifies the animation phoneme that 
matches each frame. You can use the lip chart as a reference while you draw 
the lip positions of your characters.

• The features of Sceneplanning Mode may change how you approach 
drawing in Drawing Mode.

In Sceneplanning Mode, you can create motion, scale and rotation changes 
over time. Therefore, you do not have to animate these changes in your 
drawing objects in Drawing Mode.
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Drawing Straight Lines, Ellipses and Rectangles
The drawing tools in Toon Boom Studio™resemble standard drawing tools used in 
many graphic programs, including a few extras made special for animators. You can 
use your mouse or graphic tablet to draw your shapes.                

  

To draw straight lines, ellipses and rectangles, follow these steps:

1. Select the tool you want to use from the Tools > Drawing menu or the Tools 
Palette. You have the following choices:
• Line  tool: draws straight lines. To draw at 15 degree angles, press [Shift].

• Rectangle  tool: draws rectangular or square shapes. To draw a square, 
press [Shift] as you drag the Rectangle tool.

• Ellipse  tool: draws round shapes. To draw a circle, press [Shift] as you 
drag the Ellipse tool. 

2. Select a pen style from the Pen tab. The width of your line is based on the 
Maximum Size value of the pen you select.

3. Select a solid color swatch from the Color Palette tab. You cannot use a gradient 
or texture color swatch.

4. Drag the tool in the Drawing View window until you have the shape you want. 
• With the Rectangle and Ellipse tool, press [Alt] to draw from the center.
• With the Line tool, press [Alt] to draw from the previous point.
• Press [Ctrl] to select the object you just drew and move, resize, or rotate it.

See Also
Drawing with the Polyline Tool on page 117 
Working with Selections on page 121 
Setting Up Your Pens on page 150 

When you click and hold the drawing tool button on the Tools 
Palette, you can select the drawing tool you want to use from 
the pop-up menu.

The active drawing tool appears in the second button of the 
Tools Palette. You can press [2] to cycle through the tools in the 
drawing pop-up menu.
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Drawing with the Polyline Tool

The Polyline  tool is great for drawing vector shapes that consist of many continuous 
points that form different angles. As you draw with the Polyline tool, you can be sure 
to close your line art so that you can fill it with color without having to worry about 
gap closing. 

To draw a shape with the Polyline tool, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Polyline  tool. 

2. Select a pen style from the Pen tab. The width of your line is based on the 
Maximum Size value of the pen you select.

3. Select a solid color swatch from the Color Palette tab. You cannot use a gradient 
or texture color swatch to draw with the Polyline tool.

4. Click to add points to the line you draw. 

5. After you add a point, keep the pointer button pressed, and shape the line using 
the handles.
• Press [Shift] to move the handles at 15 degree increments.
• Press [Alt] to detach the motion of one handle from the other.

6. To close a shape so that there are no gaps:
• Place your pointer over a point and click. A plus [+] sign appears when you 

are adding a point that will close a shape.
• Place your pointer over any location on the shape you are drawing and click. 

An “o” [o] appears when your pointer is over a spot that Toon Boom 
Studio™ can use to create a closed shape.

With the Polyline tool, you can draw 
shapes one point at a time, forming the 
shape as you go.
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7. To remove a point on the line, press [Shift] and click the point. Toon Boom 
Studio™ recalculates the shape with the point removed.

See Also
Setting Up Your Pens on page 150 
Drawing Straight Lines, Ellipses and Rectangles on page 116 
Working with Selections on page 121 
Modifying the Shape of Vector Lines on page 142 
Sequencing Element Contents on page 386 
Protecting Drawings on page 398 

Drawing Brush Strokes

When you draw with the Brush  tool and a graphic tablet and pen, you can enjoy the 
effect of drawing as if you are working with pen and paper and the width of your 
stroke can change depending on the amount of pressure you apply.

Although strokes created by the Brush tool are more natural looking, they require more 
memory to store than shapes drawn with the centerline tools Ellipse, Rectangle, Pencil 
and Polyline.

See how the line in the drawing varies just 
slightly throughout this drawing? 

The variable-width brush stroke creates 
a neat look in your drawings.
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To draw a brush stroke, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Brush tool. 

2. Select a pen style from the Pen tab. 

If you are using a graphic tablet and pen, the width of the line you draw depends 
on the pressure you apply and the Minimum and Maximum size settings on the 
Pen tab.

3. Select a color for your line art from the swatches in Color Palette tab. You can 
select either a solid, gradient or texture swatch when you use the Brush tool.

4. Draw your line using your mouse or pen and graphic tablet.

See Also
Setting Up Your Pens on page 150 
Drawing Straight Lines, Ellipses and Rectangles on page 116 
Working with Selections on page 121 
Optimizing Drawing Objects for the Web on page 131 
Modifying the Shape of Vector Lines on page 142 
Exposure Sheet and Timeline Windows on page 354 

You can force Toon Boom Studio™ to connect all overlapping shapes that you draw.

• Select Tools > Draw Top Layer. When this command is active, Toon Boom 
Studio™ creates one object out of overlapping lines.

As you draw with the Brush tool, the Draw Top Layer command will create one 
shape out of numerous lines you may create as you draw with a graphic tablet and 
pen.
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Drawing Pencil Lines

You can use the Pencil  tool to draw as you would with an ordinary pencil. The 

Pencil tool creates a single-width centerline shape, unlike the Brush  tool.

To draw pencil lines, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Pencil tool. 

2. Select a pen style from the Pen tab. The width of your line is based on the 
Maximum Size value of the pen you select. 

3. Select a solid color swatch from the Color Palette tab. You cannot use a gradient 
color swatch to draw a pencil line.

4. Draw your line using your mouse or pen and graphic tablet.

See Also
Setting Up Your Pens on page 150 
Drawing Straight Lines, Ellipses and Rectangles on page 116 
Drawing Brush Strokes on page 118 
Drawing Brush Strokes on page 118 
Working with Selections on page 121 
Optimizing Drawing Objects for the Web on page 131 
Modifying the Shape of Vector Lines on page 142 
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Working with Selections
 You can select and modify any drawing object. When you select a drawing object, a 
bounding box appears around it and you can then change its properties (color, shape, 
angle) or it’s location in the drawing space.

  
You can change an object’s properties interactively by either moving the object in the 
Drawing View window or by changing its properties in the Properties window.

There are several ways to select the objects in your Drawing View window:

• To select all the objects, select Edit > Select All. 

• To select one or more objects, click the Select  tool and use one of these 
methods:

Click the object you want to select. To select more than one object, press 
[Shift] and click the objects you want to select. 
Drag the Select tool over each object (drawing a selection square across 
each object).
Press [Alt] and drag the lasso around or through each object you want to 
select.

    
When you select drawing objects, you can copy them by pressing [Ctrl] and 
dragging the selection away from its original position.

If you press the [Shift] key, you can 
select more segments and add them to 
what you’ve already selected.s
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Working with Selections
To deselect the objects in the Drawing View window, you have two choices: 

• To deselect an object without deselecting the others, press [Shift] and click on 
the objects you don’t want. 

• To deselect them all, you can select Edit > Deselect All, click the Select  
tool in an empty space in the Drawing View window, or press [Esc].

See Also
Ordering Drawing Objects on page 123 
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Cutting, Copying, and Pasting Drawing Objects on page 127 
Deforming a Drawing Object on page 128 
Exposure Sheet and Timeline Windows on page 354 

Grouping Drawing Objects
Grouping drawing objects will help you transform and deform multiple objects as one.

To group drawing objects, follow these steps:

1. Select the drawing objects you want to group.

2. Select Tools > Group > Group.

To ungroup drawing objects, follow these steps:

1. Select the grouped drawing object.

2. Select Tools > Ungroup.

See Also
Ordering Drawing Objects on page 123 
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Cutting, Copying, and Pasting Drawing Objects on page 127 
Deforming a Drawing Object on page 128 
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Ordering Drawing Objects
The order that you draw objects determines their stacking order in the Drawing View 
window. Drawing objects that are drawn last appear on top of drawing objects drawn 
earlier.

To change the layering order of drawing objects, follow these steps:

1. Select the drawing object that you want to reorder.

2. From the Tools > Arrange menu, select one of the following commands:
• Bring to Front: moves the currently selected drawing objects on top of all 

other objects in the drawing.
• Bring Forward: moves the currently selected drawing objects forward in the 

layering order.
• Send to Back: moves the currently selected drawing objects behind all other 

objects in the drawing. 
• Send Backward: moves the currently selected drawing objects back one in 

the layering order of the drawing.   
   

See Also
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Cutting, Copying, and Pasting Drawing Objects on page 127 
Deforming a Drawing Object on page 128 
Merging Layers Using Draw Top Layer on page 138 

If you are drawing with the Brush tool with the Tools > Draw Top Layer option 
enabled, drawing objects are merged to one layer.

The splotch on the top (3) was drawn last, and 
the splotch on the bottom (1) was drawn first.

These drawing objects will always appear in 
this layering order unless you change them.

1 2

3
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Working with Selections
Resizing, Flipping, Rotating and Moving 
Drawing Objects

When you select one or more objects in the Drawing View window, a bounding box 
appears around the selected objects. If you take a close look at the bounding box, you’ll 
notice that there are small boxes in each corner, in the center of each side, and on the 
right side of the bounding box. These boxes are called handles.

Depending on the handle you select, you can make different types of changes to the 
selected object. When you pass your pointer over a handle or over the object, the 
pointer changes to indicate the type of change you can make. 

• Move : changes the current position of the selected lines/shapes. To nudge 
selected objects, you can also use the arrow keys. Press [Shift] if you want to 
move the object in larger increments.  

• Resize Sides : changes the width of the selected lines/shapes.
• Resize Top/Bottom : changes the height of the selected lines/shapes.

• Resize Height/Width : changes the height and width of the selected lines/
shapes. Press [Shift], and the shape will resize proportionally.

• Rotate : changes the angle of the selected lines/shapes.

If you drag a handle beyond it’s opposing handle on the bounding box, you will flip 
the drawing object either horizontally, vertically, or diagonally.

You can also use the following commands in the Tools > Transform menu to flip and 
rotate your drawing objects:

• Flip Horizontal: swaps the left and right side of the image.
• Flip Vertical: swaps the top and bottom of the image.

One drawing can be made up of many individual 
lines, but when you select more than one, one 
bounding box appears for all the selected lines.

Handles
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Chapter 3: Drawing
• Rotate 90° CW: turns the drawing 90 degrees to the right (clockwise).
• Rotate 90° CCW: turns the drawing 90 degrees to the left (counter-

clockwise).
• Rotate 180°: rotates the image 180 degrees.

See Also
Grouping Drawing Objects on page 122 
Ordering Drawing Objects on page 123 
Cutting, Copying, and Pasting Drawing Objects on page 127 
Deforming a Drawing Object on page 128 
Protecting Drawings on page 398 

Changing the Center of Transformation
You can change the center of the rotation and scaling effects. This might come in handy 
if you want to rotate or scale a drawing from a corner, rather than from the center. 

We moved the transformation point to the 
corner and then rotated the drawing object 
to achieve different results.

We rotated this drawing on the original 
point in the center of the bounding box.
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To change the center of the transformation, follow these steps:

1. With the Select  tool, select the drawing object you want to transform.

2. In the bounding box, drag the point that is in the center to the new position. 

3. Scale or rotate the drawing object. 
• To use the new position of the pivot point as you scale, press [Alt] as you 

drag. If you don’t press [Alt], Toon Boom Studio™ scales the drawing object 
from the opposite corner that you drag from. 

• To rotate from the center, press [Alt] as you rotate. If you don’t press [Alt], 
Toon Boom Studio™ rotates from the pivot point.

• Press [Shift] if you want to maintain the relative proportions of the drawing.

See Also
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Deforming a Drawing Object on page 128 
Protecting Drawings on page 398 

The point starts off in the center of the drawing object.

You can move the 
transformation point 
to any location.
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Cutting, Copying, and Pasting Drawing Objects
You can cut, copy, and paste drawing objects in different areas of the current drawing 
or place them in a completely different drawing. 

To cut, copy, and paste drawing objects, follow these steps:

1. Click the Select  tool and select the object you want to cut or copy in the 
Drawing View window.

2. Decide if you want to create copy of the selected object or if you want to remove 
it.
• Select Edit > Copy Drawing Object to copy the selected object. 
• Select Edit > Cut Drawing Object to cut the selected object. The original 

object disappears from the Drawing View window.

3. Select Edit > Paste Drawing Object to place the copied object in the Drawing 
View window. The pasted object appears slightly offset from the original.

4. If you want to create a new drawing from the selected object, select another cell in 
the Exposure Sheet window and reselect the Drawing View window before you 
paste the object.

See Also
Grouping Drawing Objects on page 122 
Ordering Drawing Objects on page 123 
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Deforming a Drawing Object on page 128 
Creating Cycles on page 395 
Exposure Sheet and Timeline Windows on page 354 

If you just want to make a copy of the selected objects, press [Ctrl] and drag the 
select objects.

Toon Boom Studio™ automatically creates a copy of the selected objects every time 
you [Ctrl]+click a selected object.
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Deforming a Drawing Object

You can use the Perspective  tool to skew and distort (also known as “deforming”) 
the selected drawing object in the Drawing View window. 

For example, if you had an image you wanted to appear as viewed from an angle, you 
could draw the image as it looks from the front and then use the Perspective tool to 
distort it so that it would appear like you were looking at it from an angle. 

To deform a drawing object, follow these steps:

1. From the Tools > Select menu or from the Tools Palette, select the Perspective 
tool.

2. Select the drawn objects you want to deform. Press [Shift] to select multiple 
objects.

3. Drag the selection handles to deform the selected object.

Toon Boom Studio™ redraws the shape with its new perspective.

See Also
Grouping Drawing Objects on page 122 
Ordering Drawing Objects on page 123 
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Cutting, Copying, and Pasting Drawing Objects on page 127 

If you drag the center handles, you can add a 
slant to the selected drawing.

If you drag the corner handles, you 
can stretch and distort the selected 
drawing.
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Changing the Color of Brush Strokes, Fills and 
Centerline Objects

After you draw brush strokes and centerline objects and fill them with color, you can 
modify their color properties using the Color Palette tab in the Properties window.  

To change the color of a brush stroke or color fill:

1. Use the Select  tool to select the brush stroke, centerline object or color fill 
whose color you want to change.

2. In the Color Palette tab, click the new color swatch you want to assign to the 
brush stroke or color fill. Toon Boom Studio™ changes the color of the selection 
to match the properties of the new swatch.

See Also
Changing the Thickness of Centerline Objects on page 130 
Working with Selections on page 121 
Protecting Drawings on page 398 
Inking Line Art on page 204 

In this example, we changed the color of the lower body segment 
to the same green that we used on the top.
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Changing the Thickness of Centerline Objects
To change the properties of the line art, select the line art you want to affect and adjust 
the line size in the Pen tab or change the line color using the swatches in the Color 
Palette tab.

You can use the Pen and Color Palette tabs to make the following types of changes:

• To change the color of a line or color region, click the Select  tool, select the 
line or region, and select a swatch from the Color Palette tab. 

• To change the width of lines, use the Select tool to select the object and adjust 
the sliders on the Pen tab. 

See Also
Changing the Color of Brush Strokes, Fills and Centerline Objects on page 129 
Working with Selections on page 121 
Drawing Line Art on page 114 
Drawing Straight Lines, Ellipses and Rectangles on page 116 
Drawing with the Polyline Tool on page 117 
Drawing Pencil Lines on page 120 
Protecting Drawings on page 398 

We drew this simple circle with the Ellipse tool, which creates centerline 
objects.

You can change the maximum size of centerline objects by dragging the 
Maximum size slider on the Pen tab.
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Optimizing Drawing Objects for the 
Web

When you design your animation for the Web, you should consider taking steps to 
reduce the file size of your final animation. The smaller the file, the faster it downloads 
over the Internet, and the faster it will play on the machines of your audience.

Key to the production of small-sized animation is reducing the amount of points in 
your drawings. The fewer points you have in a line or a shape, the smaller the file size 
will be because each point requires memory to store it. 

Shapes you draw with the Pencil , Line , Polyline , Rectangle  and Ellipse  
tools create a minimum amount of points that run down the center of the shape. 

Strokes you draw with the Brush  tool require more memory to store because the 
points that compose it run along the outside of the shape to create the variable-width 
effect.

There are only two points in this line, 
which we drew with the Line 

tool. 
There are only seven 
points in this line, which we drew 
with the Pencil tool.

This brush stroke is surrounded by a number of 
points. It requires more memory to store, but the 
extra points are necessary to achieve the variable-

width of the line. 
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Toon Boom Studio™ has a number of tools that you can use to reduce the number of 
points in your drawings, making them simpler and less heavy. You can use any of 
these commands to simplify your drawings and reduce the complexity and file size of 
your animation: 

• Converting Brush Strokes to Pencil Lines on page 132 
• Reducing Drawing Layers with the Optimize Command on page 133 
• Reducing Drawing Layers with the Flatten Command on page 135 
• Removing Points with the Smooth Command on page 137 
• Merging Layers Using Draw Top Layer on page 138 

See Also
Drawing Line Art on page 114 
Cloning Elements on page 381 
Creating Cycles on page 395 

Converting Brush Strokes to Pencil Lines

After you draw variable-width strokes with the Brush  tool, you can convert the 
brush stroke to a pencil line to reduce the number of points in the line with the Extract 
Center Line command.

Toon Boom Studio™ calculates the average of exterior points in a brush stroke to 
create a center line of points. You should convert your brush strokes to pencil lines 
before you ink them (changing their color).  

If you have brush strokes with two different widths, Toon Boom Studio™ calculates 
the average of both widths to create a smooth pencil line with one width size.

Because each point in a stroke requires memory 
to store, converting your brush strokes to pencil 
lines reduces the file size of your final movie.
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To convert selected brush strokes to pencil lines, follow these steps:

1. Select View > Show Strokes to display the lines that compose your drawing 
objects.

2. Click the Select  tool and click the brush strokes you want to convert. To select 
multiple brush strokes, press [Shift] and click the brush strokes.

3. Select Tools > Optimize > Extract Center Line.

As soon as you activate the command, Toon Boom Studio™ converts the selected 
brush strokes to pencil lines. If the Show Stroke command is active, you can see 
the exterior contour line of the brush stroke move to the center to become a pencil 
line.

See Also
Deleting Points from Vector Shapes on page 148 
Reducing Drawing Layers with the Optimize Command on page 133 
Reducing Drawing Layers with the Flatten Command on page 135 
Removing Points with the Smooth Command on page 137 
Merging Layers Using Draw Top Layer on page 138 
Protecting Drawings on page 398 

Reducing Drawing Layers with the Optimize 
Command

When you have two overlapping shapes with the same color characteristics (color 
value and transparency), you can use the Optimize command to reduce the number of 
layers in the drawing, which reduces the number of redundant points and the file size. 
Toon Boom Studio™ automatically performs this function when you export a 
Macromedia® Flash™ movie.

Optimize will change the drawing objects only if merging the selected objects will not 
change the appearance of the final image. 

Do not use Extract Center Line on painted zones. Painted zones are surrounded by 
points and then filled with color. When you Extract Center Line on a painted zone, 
you may get unexpected results.
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For example, if you have selected a number of partially transparent objects, which you 
layered to create an additive color effect, the selected transparent drawing objects will 
not be merged. This is because merging the transparent drawing objects will cause 
them to loose the effect of the layered transparent colors.   

To reduce drawing layers with the Optimize command, follow these steps:

1. Select View > Show Strokes to display the lines that compose your drawing 
objects.

2. Click the Select  tool and click the brush strokes you want to convert. To select 
multiple brush strokes, press [Shift] and click the brush strokes.

3. Select Tools > Optimize > Optimize.

As soon as you activate the command, Toon Boom Studio™ merges all of the 
selected objects that it can, while preserving the look of the drawing.

See Also
Converting Brush Strokes to Pencil Lines on page 132 
Reducing Drawing Layers with the Flatten Command on page 135 
Removing Points with the Smooth Command on page 137 
Merging Layers Using Draw Top Layer on page 138 
Protecting Drawings on page 398 

This face is made up of two round shapes painted with 
the same color swatch. When you optimize the 
shapes, they are merged to one layer, eliminating 
extra points and reducing the file size of the drawing. 
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Reducing Drawing Layers with the Flatten 
Command

The Flatten command merges drawing layers into one, reducing the number of points 
in your drawings and reducing the file size of your animation.    

The Flatten command is different from the Optimize command in that it does not verify 
first to make sure that the merge will not affect the final appearance of the image. If the 
layered objects have transparencies, the cumulative effect of the transparency is not 
preserved when you flatten the layers. Also, the Flatten command may not preserve 
the layer order of overlapping centerline shapes.

These two circles will appear on top of each other as in the final 
image, so there is no reason to have them on two separate layers. 

When they are flattened, the top layer takes a bite out of 
the bottom layer because they have different color 
properties.

These circles are transparent, but when they are layered the 
overlapping area is less transparent because of the additive effect 
of the layering.

This overlapping effect is not preserved when you merge the 
circles into one layer. All overlapping areas will assume 

the color properties of the bottom shape in the 
selection.

In this case, one shape is created out of the two 
because they have the same color properties.
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To reduce drawing layers with the Flatten command, follow these steps:

1. Select View > Show Strokes to display the lines that compose your drawing 
objects.

2. Click the Select  tool and click the brush strokes you want to convert. To select 
multiple brush strokes, press [Shift] and click the brush strokes.

3. Select Tools > Optimize > Flatten.

As soon as you activate the command, Toon Boom Studio™ merges all of the 
selected objects.

See Also
Converting Brush Strokes to Pencil Lines on page 132 
Reducing Drawing Layers with the Optimize Command on page 133 
Removing Points with the Smooth Command on page 137 
Merging Layers Using Draw Top Layer on page 138 
Protecting Drawings on page 398 
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Removing Points with the Smooth Command
Excessive numbers of points in your drawings can increase the size of your web 
animations unnecessarily. Often you can reduce the number of points in a drawing, 
adjust the curve, and still maintain the same shape. This can be quite time consuming 
if you have a lot of brush strokes to adjust.

Toon Boom Studio™ can automate this process for you with the Smooth command. 
The Smooth command removes unnecessary points from a brush stroke and adjusts 
the brush stroke so that the curves are maintained. 

You can apply the Smooth command repeatedly; however the more times you apply 
the command the less definition your shape will have.   

To remove points with the Smooth command, follow these steps:

1. Select View > Show Strokes to display the lines that compose your drawing 
objects.

2. Click the Select  tool and click the brush strokes you want to remove points 
from. To select multiple brush strokes, press [Shift] and click the brush strokes.

3. Select Tools > Optimize > Smooth.

As soon as you activate the command, Toon Boom Studio™ removes points and 
recalculates the curves of the drawing objects you select.

See Also
Converting Brush Strokes to Pencil Lines on page 132 
Reducing Drawing Layers with the Optimize Command on page 133 
Reducing Drawing Layers with the Flatten Command on page 135 
Merging Layers Using Draw Top Layer on page 138 
Protecting Drawings on page 398 

This shape was drawn with the Brush tool and created a lot of 
points.

After applying the Smooth command a 
couple of times, Toon Boom Studio™ reduced 
the number of points and preserved the shape of the object.
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Merging Layers Using Draw Top Layer 
You can have Toon Boom Studio™ optimize layers automatically as you draw using 
the Draw Top Layer command. When you activate this command, Toon Boom 
Studio™ merges drawing layers as you draw.     

To enable or disable the Draw Top Layer command:

• Select Tools > Draw Top Layer. A check appears next to the command when 
it is enabled. 

See Also
Converting Brush Strokes to Pencil Lines on page 132 
Reducing Drawing Layers with the Optimize Command on page 133 
Reducing Drawing Layers with the Flatten Command on page 135 
Removing Points with the Smooth Command on page 137 
Protecting Drawings on page 398 

With the Draw Top Layer command disabled, you can 
see in the second picture how the two clouds kept their 
original form as they are moved apart.

With the Draw Top Layer command enabled, you 
can see that when we drag these two objects 
apart, the top layer took a bite out of the bottom 
layer Toon Boom Studio™ merged the layers.
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Cutting and Erasing Parts of Drawing 
Objects

As you use the drawing tools to create the objects and characters in your scene, you 
may need to cut or erase sections of drawing objects to refine your artwork. For 
example, if you need only the top left quarter of a ellipse, you can draw a full ellipse 
and cut away the section that you need.  

Toon Boom Studio™ provides you with two tools that allow you to cut or erase parts 
of your artwork. You can select these tools from the floating Tools Palette.

The Cutter  tool and Eraser  tool both allow you to remove parts from drawing 
objects, but function differently. The Cutter tool allows you to create cut selections. The 
Eraser tool allows you to draw the shape of the section you want to erase. 

See Also
Cutting Parts from Drawing Objects on page 140 
Erasing Parts from Drawing Objects on page 141 
Protecting Drawings on page 398 

Eraser tool: erases parts of 
your lines and shapes.

Cutter tool: makes square 
selections, which you can 
move or delete, in the drawing 
object. Pressing [Alt] turns the 
cutter into a lasso that use can 
use to cut various shapes.
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Cutting Parts from Drawing Objects

Toon Boom Studio™ has the Cutter  tool that you can use to cut sections from 
shapes in your Drawing View window. You can then move and modify these cut pieces 
in any way you please.     

The Cutter tool makes a rectangular selection that you can use to select the area you 
want to cut. By pressing [Alt], you can use a lasso to cut the shape you want.

To cut parts from drawing objects, follow these steps:

1. From the Tools > Erase menu or from the Tools Palette, select the Cutter  
tool.

2. Drag the Cutter tool across the section of the drawing object you want to cut. The 
Cutter tool creates a rectangular selection over the area. You can press [Alt] to 
create a lasso selection mark of the shape you want.

3. Use the Cutter tool to move the cut selection away from the original drawing 
object. If you deselect the cut object or the Cutter tool, the cut will disappear and 
the object will remain uncut.

After you cut your shapes, you can use the Contour Editor  tool to reshape them into 
whatever shape you like. 

See Also
Reshaping Brush Strokes on page 145 
Erasing Parts from Drawing Objects on page 141 
Protecting Drawings on page 398 

The rectangle and ellipse are centerline shapes. When 
you cut a centerline object, Toon Boom Studio™ 
rounds the ends of the cut lines. Notice how the painted 
area is cut straight.

The cyclist was drawn with the Brush tool. The Cutter 
tool makes clean cuts of the brush strokes
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Erasing Parts from Drawing Objects

The Eraser  tool in Toon Boom Studio™ works as a traditional eraser works on ink 
and paper, it allows you to remove a section of a drawing object. 

With the Erase tool, you can create new shapes or erase sections completely from 
existing shapes. You can even adjust the size of the erasure line using the controls in 
the Pen tab.  

To erase a section of a shape or brush stroke, follow these steps:

1. From the Tools > Erase menu or from the Tools Palette, select the Eraser  
tool. 

2. Select the Pen tab in the Properties window and select a pen style to set the size 
of the Eraser tool. 

3. Drag your pointer through the parts of the drawing you want to erase.

Toon Boom Studio™ creates new vectors lines to define the erased zones. If you 
create a closed zone with the Eraser tool, you can:
• Fill the zone with a different color. 
• Reshape the zone to create an even different form. 

See Also
Painting Zones in Your Drawings on page 189 
Modifying the Shape of Vector Lines on page 142 
Setting Up Your Pens on page 150 
Protecting Drawings on page 398 

In this example, we drew an 
eraser line through the 
circle.
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Modifying the Shape of Vector Lines

When you draw a line or a shape in Toon Boom Studio™, you can use the Contour 
Editor  tool to modify and reshape it.  

The Contour Editor is an important tool in the optimization of drawings for the Web. 

• With the Contour Editor, you can delete points from lines and shapes you 
draw. When you reduce the number of points in a drawing, you reduce the 
amount of memory required to store the file.

• After you delete unnecessary points, you can use the Contour Editor to 
reshape your drawing objects.

Using the Contour Editor tool, you can transform a simple square into more complex 
and sleek forms that would have taken longer to draw by hand. 

The Contour Editor tool allows you to create smoother curves because you are 
changing the curve of an existing line instead of drawing it manually.

See Also
Reshaping Centerline Shapes
Reshaping Brush Strokes
Adding Points to Vector Shapes
Deleting Points from Vector Shapes

You can select the Contour Editor tool from the 
pop-up menu on the Tools Palette.
142 



Chapter 3: Drawing
Reshaping Centerline Shapes
Toon Boom Studio™ adds points down the center of centerline shapes drawn with the 
following tools: Pencil, Line, Polyline, Ellipse, and Rectangle. You can use the Contour 
Editor to move these points and change the shape of centerline shapes.  

To reshape centerline shapes, follow these steps: 

1. From the Tools > Drawing menu or Tools Palette, select the Contour Editor  
and click the shape you want to modify.

If you want to create closed zones as you reshape your drawing objects, use the Snap 
to Contour option.

• Select Tools > Snap to Contour to enable this option.

You can now see the center line of the 
shape along with the points 

that make up the 
centerline. 
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2. To change the shape of the centerline shape, drag one of the center points to a new 
position.

 

3. Drag one of the curve handles to adjust the curve of the line.

See Also
Drawing Line Art on page 114 
Reshaping Brush Strokes on page 145 
Optimizing Drawing Objects for the Web on page 131 
Cutting and Erasing Parts of Drawing Objects on page 139 
Protecting Drawings on page 398 

As you drag the end of the line, one of the curve handles may appear.

You can drag the line in any direction. stretching or curving it.

To move each curve handle 
independently, press [Alt] before you 
click the centerline point. You can 
then change the shape of the curve 
on either side of the point.

If you drag one curve handle, 
the curve of the line that passes 
through the point changes on 
both sides.

If you can’t see the curve 
handle, press [Alt], click a point, 
and drag away from the line. 
The curve handle will appear.
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Reshaping Brush Strokes
When you use the Brush, Toon Boom Studio™ creates a shape that is surrounded by 
points, creating what we call a contour line. Toon Boom Studio™ also creates contour 
lines when you paint an enclosed shape. You can reshape either Brush lines or painted 
zones with the Contour Editor. 

To change the shape of a brush stroke, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Contour Editor  
and click the shape you want to modify.

2. To change the shape of the brush stroke, click one of the points drag it to a new 
position.

3. Drag one of the curve handles to adjust the curve of the line. You can use these 
curve handles to change the amount of curve in the line between the current point 
and two point on either side.

If you want to create closed zones as you reshape your drawing objects, use the Snap 
to Contour option.

• Select Tools > Snap to Contour to enable this option.

Notice the set of points around the shape. You 
can use these control points to change the 

shape and thickness of the brush stroke.

When you release the mouse, you‘ll notice that 
there are two curve handles around the point you 

just selected. Every point on the line has 
two of these curve handles. 
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See Also
Drawing Line Art on page 114 
Reshaping Centerline Shapes on page 143 
Optimizing Drawing Objects for the Web on page 131 
Cutting and Erasing Parts of Drawing Objects on page 139 
Painting a Zone with a Solid Swatch on page 190 
Protecting Drawings on page 398 

Adding Points to Vector Shapes
All vector shapes in Toon Boom Studio™ are composed of points. These points mark 
an edge or a position where the center line or contour line changes direction. You can 
add more points to a center line or contour to add a more pronounced edge to a shape 
or a line.  

For example, if you wanted a straight line to flow upwards from the start point and 
then turn back down sharply to the end point, you could add a point to the center of 
the line and drag it upwards to the new position. 

If you simply drag one curve handle, the curve of 
the line that passes through that control 

point changes on both sides of the 
point.

To move each curve handle independently, 
press [Alt] before you select a point. You can 
then change the shape of the curve on 
either side of the control point 
individually.
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You can add as many points as you like. However, the more points you add, the greater 
the file size will be in the final animation. 

To add points to vector artwork, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Contour Editor  
and click the shape you want to modify.

2. Press [Ctrl] and click on the centerline or contour of the shape you want to 
modify. A new control point now appears on the line.

3. You can drag this new control point to a new position or use the curve handles to 
adjust the curve of the line as it passes through the new control point.

See Also
Reshaping Centerline Shapes on page 143 
Drawing Line Art on page 114 
Optimizing Drawing Objects for the Web on page 131 
Cutting and Erasing Parts of Drawing Objects on page 139 
Protecting Drawings on page 398 

The line’s shape changes to 
follow the new point.

In this example, we add two control points on the left 
and right sides of the square and dragged them 

both to the right.

Notice how the curve handles appear 
on the top corners now that the sides 

of the square have changed.
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Deleting Points from Vector Shapes
All vector shapes in Toon Boom Studio™ are composed of points. These points mark 
an edge or a position where the center line or contour line changes direction. 

You can delete points from a center/contour line to remove pronounced edges from a 
shape or a line. Deleting points from vector artwork also reduces the file size of your 
final Macromedia® Flash™ movie file.

 

To delete control points from vector artwork, follow these steps:

1. From the Tools > Drawing menu or Tools Palette, select the Contour Editor  
and click the shape you want to modify.

2. Click a point on the shape. 

3. Press [Del] to delete the selected control point(s). The line that flowed through the 
selected deleted control point adjusts itself based on the remaining controls 
points.

To transform a square into a 
triangle, delete one of the four 
corner points.

The lines in the square 
change direction to follow the 
remaining points.

The selected control point appears white.

You can select multiple control points by 
pressing [Shift] and clicking the control points 
you want.
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See Also
Adding Points to Vector Shapes on page 146 
Drawing Line Art on page 114 
Reshaping Brush Strokes on page 145 
Painting Zones in Your Drawings on page 189 
Protecting Drawings on page 398 

With the center point gone, the line straightens itself out, 
taking the shortest distance between two points, forming a 

triangle.

Be careful not to delete too many control points! 
For example, if you delete three of the four 

control points on this square, the shape will 
disappear.
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Setting Up Your Pens
As you design the elements of your scene, you can select different types of pens to draw 
lines with different qualities. The lines can be thin or thick, and be smooth or rough. 
You can configure all this in the Pen tab of the Properties window. 

When you select a pen style, all lines you draw will have the properties of that pen style 
until you select another. You can create customized pen styles for each project you are 
working on. 

For example, if you are working on a project whose drawings use a thick outside line 
but use thinner lines for the detailed areas, you could create two pen styles for each 
type of line.

See Also
Creating and Removing Pen Styles on page 151 
Modifying a Pen Style on page 152 
Drawing Line Art on page 114 

If you don’t see the Properties window, select Window > 
Properties.

Each pen style displays: 

• the name of the pen style

• the amount of correction that Toon Boom Studio™ 
will apply when you draw with it

• the minimum/maximum size of its line

• a preview of the pen style
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Creating and Removing Pen Styles
Toon Boom Studio™ provides you with five default pen styles, but you can add your 
own custom-built pen styles to the Pen tab. All pen styles you create are available in 
every scene in the current animation set. 

To create your own pen style, follow these steps:

1. Click the Add Pen Style  button. A copy of the currently selected pen style 
appears at the bottom of the pen styles list.

2. Select the minimum and maximum size of the drawing line with the Minimum 
size/Maximum size sliders.

The minimum value only applies when you use a pressure-sensitive pen and 
tablet. If you draw your lines with your mouse, the line thickness always uses the 
maximum value.

3. Adjust the smoothness of the line with the Smoothness slider.
• 0: makes a slight adjustment, allowing more sharp edges
• 10: makes a greater adjustment, reducing the number of sharp edges and the 

number of points in the line (smaller file size in your exported animation).

When you draw a line with the Brush  tool or the Pencil  tool, Toon Boom 
Studio™ makes an adjustment to the line based on the value in this panel. It 
smooths out any sharp edges or jagged peaks in the line. 

4. Right-click the new pen style and select Rename Pen from the pop-up menu. The 
name field for the pen style becomes editable.

5. Type the pen style’s name in the Name field and press [Enter].

As you draw your objects, 
you can continue to make 
adjustments to your pen 
styles. 
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6. To remove a pen style, simply select the pen style and click Remove Pen Style 
 button.

See Also
Modifying a Pen Style on page 152 
Setting Up Your Pens on page 150 
Drawing Line Art on page 114 

Modifying a Pen Style
You can modify the size, smoothness, and name of any pen style in the animation set. 
When you make changes to a pen style, Toon Boom Studio™ updates the pen styles in 
every scene in the animation set. Only drawings you make after the pen changes are 
affected.  

To modify a pen style, follow these steps:

1. Select the pen style you want to modify.

2. Modify the characteristics of that pen style by adjusting the following:
• Select the minimum and maximum size of the drawing line with the 

Minimum size/Maximum size sliders.
• Adjust the smoothness of the line from the Smoothness slider.
• Rename the pen style by right-clicking on it and selecting Rename Pen from 

the pop-up menu.

See Also
Modifying the Shape of Vector Lines on page 142 
Resizing, Flipping, Rotating and Moving Drawing Objects on page 124 
Modifying a Pen Style on page 152 
Setting Up Your Pens on page 150 
Drawing Line Art on page 114 
Creating and Removing Pen Styles on page 151 

Any changes you make to pen styles only affect the lines you draw afterwards.

If you remove a pen style, any lines you drew with that pen style do not change; the 
line art remains unchanged even if you delete the pen style that created it.
152 



Chapter 3: Drawing
Setting Up Your Drawing Space
You can customize your drawing space to suit your needs. You can:  

• Display a grid that you can use as a reference while you draw.

• Rotate the drawing space so that you can get a better angle on your drawings.
153



Setting Up Your Drawing Space
• Use the onion skin to view previous and next drawings in an element layer.

See Also
Displaying the Drawing Grid on page 154 
Rotating the Drawing Space on page 156 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
Zooming and Panning the View Window on page 164 

Displaying the Drawing Grid
When you are drawing your objects, it may be difficult to draw them on a plain white 
surface that does not have any reference points. You can choose to display a grid that 
appears either behind or in front of your objects.  

When you have the size of your animation set to 500 x 375, the 12 Field Grid is 
equivalent to the camera frame in Sceneplanning Mode.
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To display the grid in the Drawing View window, follow these steps:

1. Select View > Grid > Show Grid or click the Grid  button in the Grid Control 
toolbar. A grid appears in the Drawing View window.

2. Select the type of grid you want to use from either the View > Grid menu or the 
Grid Control toolbar. You can choose from the following types: 
• Normal : the grid is divided into a standard set of squares of equal size.

• 12 Field : the grid measures 12 fields in each compass direction from the 
grid center.

• 16 Field : the grid measures 16 fields in each compass direction from the 
grid center.

3. Select where you want the drawings to appear in relation to the grid from either 
the View menu or the Grid Control toolbar. You have two choices: 

• Underlay : the grid appears below the drawing.

• Overlay : the grid appears on top of the drawing.

See Also
Rotating the Drawing Space on page 156 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
Zooming and Panning the View Window on page 164 

You can use the grid to judge the 
distance and size of objects in your 
scene.

In this example, the grid measures 12 
fields in size and the drawing appears 
above it.
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Rotating the Drawing Space
Short of flipping the monitor on its side, drawing on your computer presents new 
challenges that the traditional artists didn’t have to deal with. However, Toon Boom 
Studio™ solves that problem with the Rotate commands. 

It’s only natural to want to rotate your drawing space while you are working. Getting 
the best drawing angle, while seeing all of the relevant parts of your drawing, is 
important for you to be able to finely craft your drawings.

With the rotary light table, you 
can change your view of your 

drawing space so that you get 
the best angle.

You can rotate your drawing 
space so that you get a better 
angle on a part of the drawing you 
are working on.

In this example, the artist is using 
the Onion Skinning feature to see 
the previous position of the arm 
and is rotating the drawing space 
to draw the current drawing from 
a different angle.
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To rotate the drawing space, do one of the following:

• To turn your drawing space to the right, select View > Rotate Clockwise or 
press [V]. 

• To turn your drawing space to the left, select View > Rotate Counter 
Clockwise or press [C].

• To display the Rotary Light Table in the Drawing View window, press 
[Ctrl]+[Alt] and use your mouse to freely rotate your drawing space.

To return your drawing space to the original angle, select View > Reset Rotation or 
press [Shift] + [C].  

See Also
Displaying the Drawing Grid on page 154 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
Zooming and Panning the View Window on page 164 

Onion Skin: Displaying the Next and Previous 
Drawings

As you develop your scene elements, it can be very helpful to see drawings that will 
appear before or after the current drawing. You can use these drawings as a reference 
to figure out the size, angle, or position of the drawing you are working on. 

In Toon Boom Studio™, the onion skin allows you to display the other drawings in the 
same element that appear either before or after the current cell. You can display up to 
three previous and three next drawings in the onion skin.  
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Toon Boom Studio™ displays previous and next drawings in the onion skin in a 
different color so that you can distinguish them. 

To set the Previous Onion Skin depth, click one of the buttons on the left side of 
the Onion Skin toolbar: 

• No previous Drawings visible : displays only the drawing in the 
currently selected cell.

• Previous Drawing Visible : displays the drawing before the current 
selection.

• Previous Two Drawings Visible : displays the two drawings before the 
current selection.

• Previous Three Drawings Visible : displays the three drawings before 
the current selection

To set the Next Onion Skin depth, click one of the buttons on the right side of the 
Onion Skin toolbar:

• No next Drawings visible : displays only the drawing in the currently 
selected cell.

• Next Drawing Visible : displays the drawing after the current selection.

• Next Two Drawings Visible : displays the two drawings after the current 
selection.

You can use the buttons in 
the Onionskin toolbar to set 
your display options.

In this example, we can see two 
previous drawings and the two next 
drawings. The current drawing is on 
top of all the other drawings in the 
display.
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• Next Three Drawings Visible : displays the three drawings after the 
current selection.

You can also select the onion skin depth by selecting it from the View > Onion Skin 
sub-menu.

See Also
Displaying the Drawing Grid on page 154 
Rotating the Drawing Space on page 156 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
Zooming and Panning the View Window on page 164 
Setting Onion Skin Options on page 159 

Setting Onion Skin Options
You can change how drawing objects appear in the onion skin to suit your working 
style.  

To set onion skin options, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Light Table tab.

3. Select your color shading option.
• If you want previous and next drawings to appear in their original color and 

faded, de-select the Enable Color Shading option.
• If you want previous and next drawings to appear as different colors, select 

the Enable Color Shading option.

4. If the Enable Color Shading option is selected, you can choose colors for 
previous and next drawings.
• Double-click the Previous Drawing Color or Next Drawing Color square 

and select a new color from the Color dialog box. 

5. Click OK when you are done.

See Also
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Setting Up Your Drawing Space on page 153 
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Static Light Table: Displaying Selected 
Drawings

As you create your drawings, you may need to see drawings from other elements in 
your scene so you can figure out how to draw the new drawing. While you can use the 
Onion Skin toolbar to see next and previous drawings in the same element, you can’t 
use them to see drawings in other element columns. 

To display specific drawings from other elements, you can place them in the Static 
Light Table. The Static Light Table displays a paler version of the selected drawing in 
the Drawing View window while you work on other drawings.

If you change the drawings that appear in the Static Light Table panel, the Static Light 
Table panel updates its contents immediately. 

To add a drawing to the Static Light Table, follow these steps:

1. Click the Static Light Table  button in the Exposure Sheet window.

The Static Light Table panel appears at the bottom of the Exposure Sheet 
window.  

2. Drag the cell that contains the drawing or image you want to display into the 
Static Light Table panel.

A thumbnail of the selected drawing appears in the Static Light Table and the 
drawing appears slightly dimmed in the Drawing View window (unless you 
have it currently selected, in which case it appears in full color). 

3. To remove drawings in the Static Light Table, you have two options:  
• To remove selected drawings, right-click the selected drawing and select 

Delete from the pop-up menu.

The Static Light Table appears just 
below the exposure sheet when you 
click the Toggle Static Light table button.
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• To remove all the drawings, right-click anywhere in the Static Light Table 
and select Delete All from the pop-up menu.

See Also
Displaying the Drawing Grid on page 154 
Rotating the Drawing Space on page 156 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Auto Light Table: Displaying All Images in a Frame on page 163 
Zooming and Panning the View Window on page 164 
Changing the Display of Objects in the Static Light Table on page 161 

Changing the Display of Objects in the Static Light Table
When you load drawings into the Static Light Table, you can modify their display 
properties so that they appear differently in the Drawing View window. These 
properties only affect how the drawings appear while they are in the Static Light Table; 
they do not affect the original drawings. 

For example, if you had a drawing in the Static Light Table panel and it was hiding 
another drawing you wanted to work on, you have two choices:

• You can hide it from view (while keeping it in the Static Light Table).
• You can change it layering order so that it no longer hides the drawing you 

want to see.

To change the display properties of the objects in the Static Light Table, do any 
of the following: 

• To show/hide a drawing, click the Display radio button above the thumbnail.
When you select the Display radio button, the drawing appears in the 
Drawing View window.
When you deselect the Display radio button, the drawing disappears 
from the Drawing View window, although it still appears in the Static 
Light Table.

Click this button to change the front/back position of 
the drawing in the Static Light Table.

Click this button to show/hide the drawing in the 
Static Light Table.
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• To show/hide all the drawings in the Static Light Table, right-click in the 
Static Light Table panel and select one of the following commands from the 
pop-up menu:

Show All: displays all the drawings in the Static Light Table.
Hide All: hides all the drawings in the Static Light Table.

• To change the layering order of a drawing, click the layering icons above the 
drawing’s thumbnail. 

Overlay : places the currently selected Static Light Table image above 
the currently selected drawing in the Exposure Sheet window.

Underlay : places the currently selected Static Light Table image 
below the currently selected drawing in the Exposure Sheet window.

• To change the layering order for all the drawings in the Static Light Table 
panel, right-click in the Static Light Table panel and select one of the 
following options from the pop-up menu:

Overlay All: places all the drawings in the Static Light Table above the 
currently selected drawing.
Underlay All: places all the drawings in the Static Light Table below the 
currently selected drawing.

To enable/disable the shading of objects that appear in the Static Light Table, 
follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.  

2. Click the Light Table tab.

3. In the Static Light Table panel, select Enable Shade.
• When this option is selected, the color of objects in the Static Light Table is 

paler than the original.
• When this option is de-selected, objects in the Static Light Table have the same 

color shading as the original.

See Also
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
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Auto Light Table: Displaying All Images in a 
Frame

You can use the Auto Light Table when you want to see all of the images in a frame. 
Only the elements that are selected to show in the Element List will appear in the Auto 
Light Table.

The Auto Light Table can help you draw objects in relation to each other. For example, 
if one character is grabbing something from another, you will need to see all of the 
drawings together to get a sense of how to position the characters’ hands. 

In the Auto Light Table, the selected element appears on top of all other elements, and 
the rest of the elements are displayed based on their layer order in the Exposure Sheet 
window.  

To activate the Auto Light Table:

• Click the Auto Light Table  button or select View > Onion Skin > Auto 
Light Table. All the drawings from the elements in the exposure in the 
current frame appear in the Drawing View window.

See Also
Displaying the Drawing Grid on page 154 
Rotating the Drawing Space on page 156 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Zooming and Panning the View Window on page 164 

With the Auto Light Table 
activated, you can see all 
of the drawings at the 
selected frame.
163



Setting Up Your Drawing Space
Zooming and Panning the View Window
As you work on your scene in the View windows, you can change the zoom factor so 
that you can zoom in closer to see some parts of your drawings in more detail or zoom 
out to see the entire frame.

There are two ways to change the zoom factor on your drawing:

• You can use the Zoom In and Zoom Out commands in the View menu.

• You can use the Zoom  tool to zoom in and out of a specific point or a 
selected zone.

To zoom in on a specific part of your drawing, follow these steps: 

1. Click the Zoom tool in the Tools Palette toolbar or select Tools > View ? Zoom. 
The pointer becomes a magnifying glass.

2. Decide which part of the drawing you want to see in greater detail. You have two 
choices:
• If you want to see a general area, click once on that area. If you want to zoom 

in closer, click the area again.
• If you want to see a specific region in greater detail, drag the Zoom tool to 

create a selection region. The Drawing View window zooms-in on the region 
you selected.

3. To zoom-out, press [Alt] and click the Zoom tool on the Drawing View window. 
The zoom factor decreases, displaying more of the drawing. 

4. To reset the zoom level, select View > Reset Zoom. 
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To zoom-in/out using the commands in the View menu:

• Select View > Zoom In to increase the zoom factor. You can also press the [X] 
key.

• Select View > Zoom Out to decrease the zoom factor. You can also press the 
[Z] key.

• Select View > Reset Zoom to reset the zoom level. You can also press 
[Shift]+[Z]. 

To pan the Drawing View window:

• Use the Grabber  button or press [Spacebar] and move the view of the 
Drawing View window.

• To return to the center of the Drawing View window, select View > Recenter 
or press [Shift]+[Spacebar].    

See Also
Displaying the Drawing Grid on page 154 
Rotating the Drawing Space on page 156 
Onion Skin: Displaying the Next and Previous Drawings on page 157 
Static Light Table: Displaying Selected Drawings on page 160 
Auto Light Table: Displaying All Images in a Frame on page 163 
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Chapter 4
Importing Artwork

This chapter explains how to import visual content, such as 
bitmaps and movies, created outside in another application.

This chapter includes the following topics:

• Importing Static Images (Bitmaps) on page 168 

• Vectorizing Bitmaps on page 171 

• Importing Illustrator and PDF Files on page 173 

• Importing Flash Movies on page 174 

• Repositioning All Drawings on page 175 



Importing Static Images (Bitmaps)
Importing Static Images (Bitmaps)
Bitmaps might be larger in file size than vector drawings, but they do create a different 
visual effect that is often desirable in animated movies.

As you are setting up your scene, you may want to use a background image for your 
characters to act against. You can import any bitmap supported by the version of 
QuickTime® installed on your computer, including BMP, JPEG, PNG, GIF, PSD and 
PICT, as well as others.

You must import bitmap images into Image elements. When you place a background 
image in your scene, make sure you place the element column at the extreme left (the 
bottom layer) of the exposure sheet. If you activate the Auto Light Table in Drawing 
Mode and you place a background element to the right of an other element, you may 
only see the background element in your Drawing View window.

To import a bitmap image into your scene, follow these steps:

1. Select Element > New > Image Element to add an image element to your anima-
tion. 

Graphic formats like TIFF and TGA support an alpha channel, which allows you to 
make certain parts of an imported image transparent.

In this scene, we used an 
image from a city alley as the 
backdrop for our characters.
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You can also click the Add Image Element  button in the Exposure Sheet 
window. 

2. Right-click the cell where you want to place the bitmap image and select Import 
Images from the pop-up menu. The Open dialog box opens.

3. Select the bitmap you want to import and click OK.
The bitmap you selected appears in the selected cell. You’ll probably want to extend 
this image’s exposure time so that it appears for the necessary length of your scene. 

See Also
Importing Flash Movies on page 174 
Timing/Exposing Drawings and Images on page 401 
Linking Templates to Media Elements on page 420 
Creating Transparent Bitmaps on page 169 
Adding Many Elements to a Scene on page 373 
Repositioning All Drawings on page 175 

Creating Transparent Bitmaps
Bitmap graphics are shaped like rectangles, regardless of the shape of the image within 
them.

For example, if you have an image of a dog that you want to place on top of some other 
elements, the area around the dog must be transparent so that the background image 
appears behind the dog, and the dog appears in the scene.

We made the area around the dog transparent so that 
the background shows through and the dog blends into 
the scene.
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If you have a bitmap you want to use within the layering order of your elements, you 
must make the non-image portion of your graphic transparent so that you can see 
elements behind the bitmap and that other elements can appear to pass by the bitmap 
in the action of your scene.

To create an image that has transparent areas, follow these steps:

1. Open the graphic in a third-party graphics application

2. Add an alpha channel to the image and create a transparent shape that will reveal 
the rest of the channels in the image.

3. Save the graphic in a file format that preserves the alpha channel.

4. Import the transparent graphic into Toon Boom Studio™. Toon Boom Studio™ 
assumes that the alpha channel is “straight” (not pre-multiplied).

If you can see “around” the object in the image, then you have successfully 
created a transparent graphic.

Refer to your graphic application’s documentation for instructions on how to define 
transparent areas.

See Also
Importing Flash Movies on page 174 
Timing/Exposing Drawings and Images on page 401 
Linking Templates to Media Elements on page 420 
Adding Many Elements to a Scene on page 373 

There are a couple of bitmap file formats that save transparency in an alpha (matte) 
channel, including the 32-bit TARGA format (TGA), TIFF, SGI and PSD.
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Vectorizing Bitmaps
As you develop your animation, you may want to integrate hand-drawn pictures. You 
can scan these pictures and import them as bitmaps into image elements. However, 
you cannot edit bitmap images in Toon Boom Studio™. In addition, bitmap images are 
not as flexible as vector drawings when it comes to resolution and file size.

Rather than importing your scanned drawings as bitmaps, you can transform the 
scanned images into vector drawings so that you can benefit from Toon Boom 
Studio™ vector technology. 

When you import and vectorize bitmap images, you must select an appropriate image 
filter and threshold. You may have to experiment with different settings to achieve the 
best results for your drawings.

All color bitmaps are transformed into grayscale during the vectorization process. Any 
pure color (with an RGB value of 255) will be converted to white and ignored during 
the vectorization process. If you are vectorizing color bitmaps, you should recolor pure 
color regions that you want to be vectorized, with another color.

To vectorize bitmap images, follow these steps:

1. In the Exposure Sheet window, select a cell in a drawing element where you want 
the vector drawing to appear. 

2. Right-click the cell and select Import and Vectorize from the pop-up window. 
The Open dialog box opens.

3. Select the bitmap image you want to import and vectorize, and click Open. You 
can select multiple files.
• Press [Ctrl] to select image files in any order.
• Press [Shift] to select image files in a series.

The Import and Vectorize Settings dialog box opens.

4. Select a bitmap filter. You may have to experiment with these settings based on 
the qualities of the images you are vectorizing.
• If the lines in your bitmap are thin, select Smoothing + Loss of Sharpness. 

This filter blurs the lines in the bitmap slightly so that thin lines are picked up 
in the vectorization process.
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Vectorizing Bitmaps
• If the lines in your bitmap are very fine, select Smoothing + Greater Loss of 
Sharpness. This filter blurs the lines in your bitmap more so that more lines 
are transformed in the vectorization process.

• If the lines in your bitmap are thick, select Edge Enhancement. This filter 
merges fine lines (noise) into larger lines to create cleaner objects.

• If the lines in your bitmaps are thick and include a lot of fine detail, select 
Sharpening With Clearness. This filter sharpens edges to enhance details in 
your images.

5. Select a Threshold percentage.

The Threshold value filters out noise in your bitmaps. Noise can be dirt or faint 
smudges on your scanned images.

For example, if your value is set to 70%, all color values below 70% are converted 
to white and ignored in the final image.

6. Click OK when you are done.
A progress dialog box opens while Toon Boom Studio™ imports and vectorizes your 
images. You can modify these vector drawings like you would any other vector 
drawing.

See Also
Importing Flash Movies on page 174 
Timing/Exposing Drawings and Images on page 401 
Linking Templates to Media Elements on page 420 
Creating Transparent Bitmaps on page 169 
Adding Many Elements to a Scene on page 373 
Drawing Line Art on page 114 
Modifying the Shape of Vector Lines on page 142 
Repositioning All Drawings on page 175 
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Importing Illustrator and PDF Files

You can import Adobe® Illustrator® vector drawing files or PDF files into a Toon Boom 
Studio™ drawing element. Toon Boom Studio™ supports Adobe® Illustrator® files 
from version 5 to 10.    

When you import Adobe® Illustrator® or PDF files, Toon Boom Studio™:

• Converts CMYK colors to RGB.
You can convert the color space of your Adobe® Illustrator® or PDF files when 
you save them. See Adobe® Illustrator® documentation for instructions. 
However, to ensure the color results you want, you should develop your Web 
colors in the Web-safe RGB palette.

• Displays objects that were hidden in the Adobe® Illustrator® file.
• Does not import text. You must convert text to outlines to import it.
• Does not import global color swatches from V8 and under. 
• Does not convert transparent objects drawn with the brush tool.

If your Adobe® Illustrator® file contains bitmaps, be sure those bitmaps are copied into 
the file. If they are linked, Toon Boom Studio™ can not import them.

To import Adobe® Illustrator® files into your scene, follow these steps:

1. Select a cell in a drawing element column in the Exposure Sheet window.

2. Right-click the selected cell and select Import Illustrator. The Open dialog box 
opens.

3. Select the file you want to import and click OK.

The vector image appears in the Drawing View window. 

You can modify this drawing just like you would modify vector drawings you 
created in Toon Boom Studio™.

See Also
Importing Flash Movies on page 174 
Adding Many Elements to a Scene on page 373 
Drawing Line Art on page 114 
Modifying the Shape of Vector Lines on page 142 
Repositioning All Drawings on page 175 
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Importing Flash Movies

If you import a Macromedia® Flash™ file into your scene, Toon Boom Studio™ 
expands the contents of it and lays it out as a collection of elements. If there is any 
motion, rotation or scaling changes to the objects in the Macromedia® Flash™, Toon 
Boom Studio™ creates pegs in the Timeline window to manage those changes. 

To import a Macromedia® Flash™ movie, follow these steps:

1. Select File > Import > Macromedia Flash movie.The Open dialog box opens.

2. Browse to the path that contains the SWF file you want, select it, and click Open.
Toon Boom Studio™ expands the artwork within the SWF file and creates a series of 
element columns in the Exposure Sheet window and Timeline window, preserving the 
original animation layout.

See Also
Timing/Exposing Drawings and Images on page 401 
Adding Many Elements to a Scene on page 373 
Drawing Line Art on page 114 
Modifying the Shape of Vector Lines on page 142 
Using Templates on page 417 

If you have an SWF file saved as a template in your Template Browser window, you 
can also add an expanded copy of it in your exposure sheet. You can also import SWF 
files as a linked media element.
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Repositioning All Drawings
When you hand-draw animation, you don’t always draw in the center of your paper. 
Sometimes you might draw more to the right so that you can see images better as you 
are flipping through them. Or, if you are preparing work for a traditional process, you 
may draw your images relative to their final placement in the composited film.

When you import and vectorize bitmap images you may find that they are too far from 
the center for you to work on them with ease in Toon Boom Studio™. Especially when 
you can work in Sceneplanning Mode to layout entire elements, it makes more sense 
to draw images in the center of the Drawing View window.

You can reposition all drawings in a vector element in one move to correct drawings 
that might be too far from the center to work with easily.

To reposition all drawings in an element, follow these steps:

1. Select a drawing element.

2. Select Tools > Select > Reposition All Drawings. The vector drawings in the 
drawing element become selected in the Drawing View window.

3. Use your mouse to reposition the drawing. Toon Boom Studio™ moves all 
drawings in the element in the same way you moved the drawing in the cell.

See Also
Importing Flash Movies on page 174 
Timing/Exposing Drawings and Images on page 401 
Linking Templates to Media Elements on page 420 
Creating Transparent Bitmaps on page 169 
Adding Many Elements to a Scene on page 373 
Repositioning All Drawings on page 175 
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Chapter 5
Inking and Painting 

Learn how to produce a vibrant colorful animation using Toon 
Boom Studio™ powerful inking and painting tools. 

This chapter contains the following topics:

• Coloring Your Toon Boom Studio World on page 178 

• Swatches on page 179 

• Painting Zones in Your Drawings on page 189 

• Closing Gaps in Your Drawings on page 200 

• Inking Line Art on page 204 

• Managing Your Colors with Palettes on page 205 



Coloring Your Toon Boom Studio World
Coloring Your Toon Boom Studio World
After you create the line art for your drawing elements, you need to complete your 
artwork by adding color. Toon Boom Studio™ features a full inking and painting suite 
that allows you to add spectacular and vibrant colors to your drawings. 

Toon Boom Studio™ makes the inking and painting process lightning fast by featuring 
simple, yet powerful painting tools designed specifically to create high-quality 
animation. Toon Boom Studio™ also provides a number of color palette management 
tools that can help you track, organize and update color swatches.

To ink and paint your drawings, you must be in Drawing Mode.

To switch to Drawing Mode, follow these steps:

• Click the Drawing Mode  button or select View > Drawing Mode. 
If you are already in Drawing Mode, the command in the View menu reads 
as Sceneplanning Mode.   

See Also
Swatches on page 179 
Painting Zones in Your Drawings on page 189 
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Swatches
A swatch lets you define specific colors and textures that you can use to paint zones or 
line art in your drawings. You can use swatches to store solid and gradient colors, as 
well as textures, which allow you to paint with bitmap images. 

You can add your own set of swatches to a color palette to define the colors in your 
animation. If you use swatches to color zones consistently throughout your movie, you 
can easily update the colors of your drawings when the color model changes.

The Toon Boom Studio™ color management system updates all zones and line art you 
paint when you make changes to the color properties of the swatch. For example, if you 
have a light green stripe on a pair of pants and you want to make the stripe appear 
darker on all of the pant drawings, all you have to do is change the properties of the 
swatch and Toon Boom Studio™ updates all zones that use that swatch with the new 
color properties. 

See Also
Coloring Your Toon Boom Studio World on page 178 
Painting Zones in Your Drawings on page 189 
Closing Gaps in Your Drawings on page 200 
Inking Line Art on page 204 
Managing Your Colors with Palettes on page 205 

Shirt zone

Pants zone

Skintone 
zone

Frame zone

Pantstripe
zone

Shirtsleeve zone

Use the swatches in the 
Color Palette tab to paint 
the corresponding zones.
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Swatches
Adding a Swatch 
When you add a swatch to your palette, the properties of the new color swatch are 
based on the values of the selected swatch. If you select an existing swatch with 
properties close to the new color, it will reduce the time you spend defining the new 
properties. 

A color swatch consists of the following: 

• RGB and HSV values: define the color of the swatch.
• Alpha value: defines the amount of transparency in the swatch.
• Name: labels the swatch and can indicate where to apply the swatch.

To add a swatch to your scene’s palette, follow these steps:

1. Select the Windows > Properties and click the Color Palette tab.

2. Click the New Color  button. A copy of the selected swatch appears in the 
palette style called New. If there is already a swatch named New the latest swatch 
will appear as New 2 and so on.

You can change the name of the swatch in the Color Picker dialog box. 

See Also
Painting Zones in Your Drawings on page 189 
Changing RGB or HSV Values in a Swatch on page 181 
Creating a Gradient Swatch on page 183 
Creating a Bitmap Swatch on page 187 
180 



Chapter 5: Inking and Painting
Changing RGB or HSV Values in a Swatch 
You can choose between RGB or HSV color models. The RGB and HSV panels 
represent different color models from which you can select your colors.    

• RGB panel: a color model based on a Red, Green, or Blue value. 
• HSV panel: a color model based on Hue, Saturation, Value (brightness). 

You can edit the RGB or HSV values of an existing swatch in one of two ways:

• By entering specific values
• Visually, using the color panel

To enter specific RGB or HSV values, follow these steps:

1. Double-click the color swatch you want to change. The Color Picker dialog box 
opens displaying the values for the currently selected swatch. 

2. Type the exact RGB or HSV values in the appropriate fields.

3. After you configure your color swatch, you can close the Color Picker by clicking 
the X button in the top right corner of the dialog box or you can select another 
swatch that you want to edit.

To visually determine the RGB or HSV values, follow these steps:

1. Double-click the color swatch you want to change. The Color Picker dialog box 
opens displaying the values for the currently selected swatch.

2. Select the type of color model you want to use from the RGB and HSV panels. 

3. Use the Color Slider and the Color panel to select the color you want to use.

As you drag the pointer around the Color panel, notice how all the other values 
in the RGB and HSV fields change.
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Swatches
For example, to pick a color based on its hue, select the Hue radio button. The range of 
colors in the Color Slider would change to display all the hues available. You can then 
select the remaining S and V values from the area at the top of the Color panel.

After you configure your color swatch, you can close the Color Picker by clicking the 
X button in the top right corner of the dialog box or you can select another swatch that 
you want to edit.

See Also
Painting Zones in Your Drawings on page 189 
Creating a Gradient Swatch on page 183 
Creating a Bitmap Swatch on page 187 

Hue active Saturation active Value active

Color panel

Color Slider
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Creating a Gradient Swatch
You can add a color swatch to your palette that paints a zone with more than one color. 
The painted zone displays multiple colors that blend smoothly from one to another. 
This is called a gradient swatch. 

You can create some spectacular effects using a gradient. For example, you can use a 
gradient swatch to create a setting Sun.

You can define up to eight different transition points within one swatch. You can then 
adjust where the transitions take place by dragging transition markers to the 
appropriate place. In the setting sun example, we used a Linear gradient (the colors 
change in a straight line), but you can also use a Radial gradient (the colors change in 
a circular motion).

In this example, the gradient 
swatch has four transition 
colors: 

• yellow

• red

• purple

• fuscia

You can see the transition colors 
at these points.
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Swatches
To create a gradient, follow these steps: 

1. Double-click a color swatch on the color palette tab. The Color Picker dialog box 
opens.

2. Select the type of gradient you want from the Direction panel. You have two 
choices: 
• Radial: the colors blend in a circular pattern
• Linear: the color blend along a straight line

3. Define the transition color for each marker by clicking a marker and selecting a 
color from the Color panel. A small square appears on the selected marker. 

When you choose a color for a transition marker, Toon Boom Studio™ adjusts the 
colors on either side of it based on the colors of the nearest transition markers.

4. Drag the transition markers to where you want the color to be completely 
changed.

5. To add more color transitions, click directly below the gradient bar. A transition 
marker appears (you can add a maximum of eight markers). 

Transition markers
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Chapter 5: Inking and Painting
To remove a transition marker, drag it down until it disappears. The gradient 
colors re-adjust to the remaining transition markers. You must always have at 
least two transition markers.

Close the Color Picker window by clicking the X button in the top right corner of the 
dialog box.

See Also
Adding a Swatch on page 180 
Painting Zones with Gradients and Bitmap Textures on page 191 

Changing the Transparency of a Swatch
The Alpha value of a color changes it’s transparency. You can use this technique to 
produce a foggy scene on a waterfront. 

For example, if you have two circles: a blue circle with a yellow circle on top. Changing 
the Alpha value of the yellow circle lets you control how much of the blue circle you 
see or hide.   

Start color

End color

Transition color

No transparency, the yellow circle 
blocks out the blue beneath it.

Partial transparency, the yellow circle 
lets some of the blue show through.
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Swatches
To change the Alpha value of an existing color swatch in your palette:

1. Double-click the color swatch you want to alter, on the color palette tab. The 
Color Picker dialog box opens.

2. Change the transparency by doing one of the following:
• Grab the Alpha slider and move it to alter the transparency value of the color. 
• Type the exact transparency value for the color swatch in the Alpha field. 

The amount of transparency applied appears in the color swatch in the Edit panel. 

See Also
Adding a Swatch on page 180 
Offsetting Colors in a Palette Style on page 212 

Naming a Swatch
Although Toon Boom Studio™ gives the current swatch a default name you can 
change it to one that describes where you intend to use the color. The swatch name is 
more than just a label: it’s a way of defining a color zone in your drawing. 

For example, let’s say you use a swatch called Skintone and you use this swatch in all 
of your character’s skin zones. If you decide you want to darken a character’s skin 
color, you only need to adjust the Skintone swatch. If you applied the Skintone swatch 
on only the character’s skin zones, Toon Boom Studio™ updates all the drawings 
accurately. 

To change the Name of an existing color swatch in your palette, follow these 
steps:

1. On the Color Palette tab, double-click the color swatch you want to rename. The 
Color Picker dialog box opens.

2. Type the name of the color swatch in the Name field.

3. When you’ve finished editing the swatch, close the Color Picker. The name is 
automatically changed in Swatch list of the color palette. By using names 
consistently you can make global adjustments quickly and easily.
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Creating a Bitmap Swatch
You can paint vector shapes with bitmap images. Toon Boom Studio™ fills the vector 
shape with the image, which allows you to achieve some sophisticated painting effects 
that are difficult with vector painting tools. 

For example, you can create a bitmap image of scales. Then you can paint your 
dinosaur with the scale image. Your bitmap textures can even have transparency.

The smaller the file size of the bitmap texture, the faster your movie will render, and 
the smaller the file size of your Macromedia® Flash™ movie. 

To create a bitmap swatch, follow these steps:

1. Click the Contextual Menu  button on the Color Palette tab and select Color > 
Add Texture. The Open dialog box appears.

2. Choose the texture file you want to add to the swatch. 

3. Click OK and the texture is added to the swatch.

Set a Bitmap Swatch to Tile or Stretch
By default, all bitmap swatches are set to tile. If you click and drag in the vector shape 
you want to fill, the bitmaps will repeat and the length of one tile is based on the length 
of the drag area you create.    

You can change the properties of a bitmap swatch so that it stretches to fill an area. 

To change the properties of a bitmap swatch, follow these steps:

1. In the Color Palette tab, double-click the swatch. The Texture Properties dialog 
box opens.

2. Click the Tile option to select your option.
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Swatches
• When you select the Tile option, all vectors you fill with the bitmap will tile.
• When you de-select the Tile option, you turn on the Stretch option and all 

paint areas will stretch to fill the area of the vector zones.

3. If you want to change the name of the swatch, type the new name in the Name 
field.

4. If you want to change the image in the swatch, click the Browse button and use 
the Open dialog box to find the image you want to use.

5. Click OK when you are done.

See Also
Creating a Bitmap Swatch on page 187 
Painting a Zone with a Solid Swatch on page 190 
Painting Zones with Gradients and Bitmap Textures on page 191 
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Painting Zones in Your Drawings 

To paint or unpaint the zones in your drawings, you use the Toon Boom Studio™ 
painting tools. These tools let you fill closed zones with a solid or gradient color, or a 
bitmap texture. You can choose colors from the color palette, or an existing line or zone.   

When you paint a zone in your drawing, you add color to that zone, and assign a color 
swatch to it. This lets you make color changes to your drawings without repainting 
each time.

You have two choices when painting zones with color.

Change the properties of the swatch and you 
automatically change the color zones. 
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Painting Zones in Your Drawings
• You can use the Paint  tool to fill zones with color or to change the color of 
a zone that is already painted.

• You can use the Paint Unpainted  tool to paint only zones that have no 
color. This tool allows you to quickly paint many zones with the same color 
while not changing the color of zones that have already been painted.

See Also
Coloring Your Toon Boom Studio World on page 178 
Swatches on page 179 
Closing Gaps in Your Drawings on page 200 
Inking Line Art on page 204 
Managing Your Colors with Palettes on page 205 
Painting Zones with Gradients and Bitmap Textures on page 191 
Drawing Line Art on page 114 

Painting a Zone with a Solid Swatch
When you have enclosed zones in your drawings, you can start painting them with the 
color swatches in your palette style. If you change the properties of a swatch, the color 
properties of the associated zones change as well.  

You can move any painted shape 
independently of the line art.

When you unpaint a color zone, 
you are deleting the color shape.
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To paint a zone with a solid color, follow these steps:

1. From the Color Palette tab, select the swatch you want to use to paint the zone.

2. Select the Paint or Paint Unpaint tool from the Tools > Paint menu or from the 
Tools Palette. 

3. Click in the enclosed zone in your drawing. If you are using the Paint Unpainted 
tool, you can drag your pointer through many zones to paint the unpainted zones 
with the selected color.

See Also
Painting Zones in Your Drawings on page 189 
Unpainting Zones/Line Art on page 198 
Closing Gaps in Your Drawings on page 200 
Auto Gap Close Options on page 203 
Painting Zones with Gradients and Bitmap Textures on page 191 
Power Painting Drawings in an Element on page 195 

Painting Zones with Gradients and Bitmap 
Textures

You can fill closed vector shapes with gradients or bitmap texture. Toon Boom 
Studio™ fills the entire zone with the gradient or bitmap texture.

To paint a zone with a gradient or bitmap, you can just click inside the vector shape, 
which fills the zone with the gradient or bitmap. Or you can drag your pointer to 
control the angle of the fill or the length of the transition.   

• When you paint with a gradient, the first click sets the position of the start 
color and where you drag the pointer sets the position of the end color; the 
zone between the start and end points is the gradient.

• When you paint with a texture, the direction you drag your pointer indicates 
the direction of the bitmap fill. If your bitmap swatch is set to tile, the distance 
between the first and last click indicates the length of one image in the tile.
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Painting Zones in Your Drawings
To paint zones with gradients and bitmap textures, follow these steps:

1. From the Color Palette tab, select the swatch you want to use to paint the zone.

2. Select the Paint  or Paint Unpaint  tool from the Tools > Paint menu or 
from the Tools Palette. 

3. Click in the enclosed zone in your drawing or click and drag to control the 
properties of the fill. 

If you are using the Paint Unpainted tool, you can drag your pointer through 
many zones to fill the unpainted zones with the selected gradient or bitmap. 
However, you don’t get to control the properties of the fill when you paint 
multiple zones.

See Also
Painting Zones in Your Drawings on page 189 
Unpainting Zones/Line Art on page 198 
Auto Gap Close Options on page 203 
Power Painting Drawings in an Element on page 195 
Closing Gaps in Your Drawings on page 200 

We started this linear 
gradient at the top right 
and ended it at the 
bottom left

We started this 
radial gradient at 
the centre and 
ended it near the 
edge of the circle.

We started this radial 
gradient at the top right 
and ended it near the 
bottom left of the circle.
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Editing Gradient and Bitmap Texture Fills
After you fill a zone with a gradient or texture bitmap, you can change its using the 

Edit Texture  tool.   

To edit a texture bitmap swatch, follow these steps:

1. Select Edit Texture tool from the Tools > Paint menu or from the Tools Palette.

2. Click the texture you want to edit. An edit selection frame appears around the 
textured drawing.

3. Rotate or change the direction of the gradient or bitmap fill by grabbing and 
moving the handles.

The Edit Texture tool

The Edit Texture 
selection frame

Edit Selection handles 

Pivot point 

Rotate handle 
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Painting Zones in Your Drawings
See Also
Swatches on page 179 
Painting Zones with Gradients and Bitmap Textures on page 191 
Creating a Bitmap Swatch on page 187 
Set a Bitmap Swatch to Tile or Stretch on page 187 

Grab and drag the rotation 
handle. and the bitmap texture 
rotates within the line art

Rotated bitmap texture. Notice the 
Selection frame’s new position.

Use this handle to compress 
or expand the bitmap 
texture horizontally.

Use this handle to compress 
or expand the bitmap 
texture diagonally
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Power Painting Drawings in an Element
You can use Toon Boom Studio™ Paint All tool to automatically paint closed zones in 
the same location in an element.

When you use the Paint All tool, you click the Drawing View window in a zone. Toon 
Boom Studio™ then flips through all of the drawings in the element to see if there is a 
closed zone in the location you clicked. If there is, Toon Boom Studio™ fills the zone 
with the same color. This can save you a lot of time when you are painting an element 
with a lot of drawings that are very similar. 

You can use the onion skin to select a location to click.

The ant’s head stays in the 
same position throughout the 
cycle of drawings.
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Painting Zones in Your Drawings
To power paint drawings in an element, follow these steps:

1. Use the View > Onion Skin menu to turn on the onion skin so that you see as 
many drawings in your element as possible.

2. From the Color Palette tab, select the swatch you want to use to paint the zone.

3. Select the Paint tool from the Tools > Paint menu or from the Tools Palette. 

4. Press [Shift]+[Alt] and click a zone that many drawings in the element share.

Toon Boom Studio™ evaluates all of the drawings in the element to determine if 
there is a closed zone beneath where you clicked.

You may have to review the drawings and make sure that the zones you wanted 
painted were.

See Also
Painting Zones in Your Drawings on page 189 
Unpainting Zones/Line Art on page 198 
Auto Gap Close Options on page 203 
Painting Zones with Gradients and Bitmap Textures on page 191 
Closing Gaps in Your Drawings on page 200 
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Picking a Swatch from a Line/Zone
To select the swatch you want to draw, ink or paint with, you can click a color swatch 
on the Color Palette tab. However, if you have a number of color palettes, palette styles 
and color swatches, it can be time-consuming to select the right color swatch.   

You can use the Dropper tool to select a swatch from a drawing. When you click a zone 
or line with the Dropper tool, Toon Boom Studio™ selects the color palette, palette 
style and color swatch that from the line or zone. You can then switch to the Paint tool 
and color a line or zone with the active color swatch.

To pick a color from a line/zone, follow these steps:

1. Select the Dropper  tool from the Tools > Paint menu or the Tools Palette. If 
either the Pencil, the Paint tool, or Brush tools are active, you can press [Alt] to 
activate the Dropper tool.

2. Click the line or zone that has the color you want to use. Toon Boom Studio™ 
selects the color palette, palette style and color swatch that was used in the line or 
zone. You can now switch to the Paint tool and fill a line or zone with the active 
swatch.

See Also
Swatches on page 179 
Unpainting Zones/Line Art on page 198 
Creating Multiple Palette Styles on page 209 
Blending a Color into a Palette Style on page 215 

Toon Boom Studio™ selects the color 
palette, palette style and color swatch of 

the color you click with the Dropper 
tool.
197



Painting Zones in Your Drawings
Unpainting Zones/Line Art
You can remove a color entirely from a selected zone using the Unpaint tool. This 
deletes the color shape you created when you filled the closed zone with a color. You 
can leave it empty or color it with another color swatch. 

This is not the same as just painting it white; when you delete the color shape from a 
painted zone, whatever is behind the zone shows through.

When we unpainted this zone, we 
effectively deleted the color shape 
assigned to it.

Unpainted zones allow the grid in 
the Drawing Mode window to show 
through.
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To remove the color from a zone or the line art, follow these steps:

1. Select the Unpaint  tool from the Tools > Paint menu or the Tools Palette. 

2. Click the painted zone or the line art from where you want to remove the color.

See Also
Swatches on page 179 
Painting Zones with Gradients and Bitmap Textures on page 191 
Creating a Bitmap Swatch on page 187 

If you unpaint a color zone that has line art around it, you’ll be able to repaint that 
zone. But if you unpaint a line, a brush stroke, or a color shape that doesn’t have line 
art, Toon Boom Studio™ erases that object. You will not be able to repaint that shape.
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Closing Gaps in Your Drawings
When you draw your line art, you may not always close the zones completely. 
Sometimes, intentionally or not, you might end a line too soon, creating a gap. To fill 
zones with color, they must be closed. You must use the gap closing features in Toon 
Boom Studio™ if you want to fill unclosed zones with color. 

 You can use the following tools to close gaps manually:

• The Close Gap  tool closes zones so that you can fill them with a solid color 
or gradient swatch.

• The Add Stroke  tool allows you to draw shapes that have no visible line 
art. 

While you are painting, you can also use the Toon Boom Studio™ auto-gap close 
options to automatically close gaps as you paint.

See Also
Painting Zones in Your Drawings on page 189 
Manually Closing Gaps on page 201 
Auto Gap Close Options on page 203 

Use these Paint tools 
to close the gaps in 
your drawings 
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Manually Closing Gaps
To manually close gaps in your artwork so that you can paint the zones, use one of 
these two tools:

• You can use the Add Stroke  tool to close zones manually, without adding 
line art. 
The Add Stroke tool adds contours, which you can use to close zones that you 
can fill with color.    

• You can use the Close Gap  tool to create closed zones you can fill with 
color.   
The Close Gap tool automates gap closing. It finds the end points closest to 
the line you draw with the Close Gap tool and draws straight lines to connect 
the points. You can use this tool to close small gaps that are difficult to see.

To close a gap using the Add Stroke tool, follow these steps:

1. Select View > Show/Hide Strokes so that you can see the contours that make up 
the zones you want to close. Every line and shape should display a thin blue line 
with occasional contour points.

2. To activate the Add Stroke tool, select the Tools > Paint > Stroke or select the 
Add Stroke tool from the Tools Palette.

3. Drag the Add Stroke tool across the open gaps to close any open zones. After you 
close all of the gaps in a zone, you can fill the zone with color. 

Activating the Show/Hide Strokes 
command lets you see the contours.

Connect contours to create closed zones 
that you can fill with color.
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Closing Gaps in Your Drawings
To close a gap using the Close Gap tool, follow these steps:

1. Select View > Show/Hide Strokes so that you can see the contours that make up 
the zones you want to close. 

Every line and shape should display a thin blue line with occasional contour 
points.

2. Select the Close Gap tool from Tools Palette. Your pointer becomes a crosspoint 
when the Close Gap tool is active. 

3. Drag the Close Gap tool near the areas on your drawing where there are gaps. 

Toon Boom Studio™ finds the closest end-points and draws a straight contour 
line to connect them. After you close all of the gaps in a zone, you can fill the zone 
with color. 

See Also
Painting Zones in Your Drawings on page 189 
Closing Gaps in Your Drawings on page 200 
Auto Gap Close Options on page 203 
Drawing Line Art on page 114 

Drag the Close Gap tool near the gap in the zone. 
Toon Boom Studio™ finds the closest end-points and 
draws straight contour 
lines to connect 
them.

Activating the Show/Hide Strokes 
command lets you see the contours.
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Auto Gap Close Options
By using the Auto Gap Close option you eliminate gaps in your line art as you paint. 
This lets you paint your zones without having to be concerned about having gaps in 
your artwork, which may prevent you from filling zones with color. 

You have three tolerance levels to choose from:

• Close Small Gap
• Close Medium Gap
• Close Large Gap

You can also disable this feature.

To use auto gap closing to close zones, follow these steps:

1. Select Tools > Auto Gap.

2. From the Auto Gap menu, select the tolerance level you want to use:
• Disable
• Close Small Gap
• Close Medium Gap
• Close Large Gap

The selected option is automatically applied when you paint your zones.

See Also
Painting Zones in Your Drawings on page 189 
Manually Closing Gaps on page 201 
Drawing Line Art on page 114 
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Inking Line Art

When you draw line art, Toon Boom Studio™ uses the currently selected color swatch 
to color the line. If you change the properties of the swatch, the color properties of the 
associated line art change as well.

You can also change the color properties of a line by inking the line art with the Paint 
tool. When you ink line art, you assign a new swatch to the line and change its color 
properties. 

To change the line art color, follow these steps:

1. From the Color Palette tab, select the swatch you want to use to paint the zone.
• You can ink brush strokes with solid, gradient or texture swatches.
• You can only ink centerline shapes with solid swatches.

2. Select the Paint  tool from the Tools > Paint menu or from the Tools Palette. 

3. Click the line art you want to ink. 

See Also
Swatches on page 179 
Painting Zones in Your Drawings on page 189 
Managing Your Colors with Palettes on page 205 
Changing the Color of Brush Strokes, Fills and Centerline Objects on page 129 
Drawing Line Art on page 114 

This line art 
uses a solid 
swatch.

This line art uses a 
linear swatch, 
starting at the top 
centre and ended it 
at the bottom centre

This line art uses 
a radial swatch, 
starting at the 
centre and ending 
at the bottom.
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Managing Your Colors with Palettes
You can organize color swatches into palettes and palette styles. You use these to create 
sets of color swatches, custom built to suit different character moods or light settings. 

You can create one palette for each character/object and customize the palette styles 
for each situation that character/object may be in.

For example, let’s say you had a character that appeared in two different lighting 
settings. You could create a palette for that character with two palette styles (one for 
each lighting setting). 

See Also
Coloring Your Toon Boom Studio World on page 178 
Swatches on page 179 
Painting Zones in Your Drawings on page 189 
Closing Gaps in Your Drawings on page 200 
Inking Line Art on page 204 

One Palette 

Two Styles 

 Different situations
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Creating a Palette
For each character and object in your movie, you can have a different palette that 
contains the customized color swatches organized by palette style. Having individual 
palettes allows you to control the unique color properties of each part of your scene.   

For example, let’s say you have a movie with two characters and takes place in two 
different lighting sets. You would create two palettes (one for each character) that 
would each have two palette styles (one for each light change).

To create a new palette, follow these steps:

• In the Color Palette tab, click the Contextual Menu  button and select 
Palette > New from the pop-up menu. A new palette appears in the Palette 
Name drop-list with a default name. 

See Also
Swatches on page 179 
Managing Your Colors with Palettes on page 205 
Renaming a Palette on page 208 
Creating Multiple Palette Styles on page 209 

Copying a Palette
Because many characters have the same types of features that need painting (hair, face, 
eyes, mouth, and so on), creating copies of a palette can save you time and effort. You 
can create one palette and use it as a template for other palettes. 

When you have this template palette, you can then create a copy of it and change its 
name, the names of the palette styles, and customize all of it’s associated color swatches 
to suit each character and object in your scene. 

When you create a new 
palette, Toon Boom Studio™ 
creates a new palette with one 
default color swatch.
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For example, in this scene we created a palette style that contains most of the necessary 
color swatches for the Bikerdude character. Then we made two copies of that palette, 
one for each character, because they all share similar color zones (Skintone, Frame, 
shirt, pants and so on). 

When you copy a palette, you are also copying all the palette styles contained in that 
palette. Each palette style contains the color swatches you can use to add color to a 
specific character. 

To create a copy of your palette, follow these steps:

1. Select the palette you want to copy from the Name drop list in the Color Palette 
tab.

2. Click the Contextual Menu  button and select Palette > Duplicate from the 
pop-up menu. 

A new palette appears in the Palette Name drop-list. This copied palette contains 
all of the palette styles (and their associated color swatches) that the original 
palette had.

See Also
Swatches on page 179 
Managing Your Colors with Palettes on page 205 
Creating a Palette on page 206 
Renaming a Palette on page 208 
Creating Multiple Palette Styles on page 209 

In this example, colors common to each scene remain the 
same in each Palette. 
The colors of the clothing elements are different in each 
scene so these colors are different in each palette
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Renaming a Palette
When you create a new palette or you copy an existing palette, Toon Boom Studio™ 
assigns a default name to it. You can rename the palette to give it a more descriptive 
name. 

For example, if you had four characters in a scene, you could create four palettes that 
each contain the customized color swatches for each character. 

To rename a palette, follow these steps:

1. Select the palette you want to rename from the Name drop list in the Color 
Palette tab.

2. Click the Contextual Menu  button and select Palette > Rename to give the 
new palette a customized name. The Rename dialog box opens.

3. Type a new name for the palette in the Palette Name field and click OK. The new 
name for the selected palette appears in the Name drop-list.

See Also
Swatches on page 179 
Managing Your Colors with Palettes on page 205 
Creating a Palette on page 206 
Copying a Palette on page 206 
Creating Multiple Palette Styles on page 209 

Deleting a Palette
When you no longer need a palette, or any of its styles, you can delete it. When you 
delete a palette, any zones or lines you painted with the colors in the palette turn bright 
red. You can repaint the lines and zones using either a new palette or an existing 
palette. 

To delete a palette, follow these steps:

1. Select the palette you want to delete from the Name drop list in the Color Palette 
tab.

2. Click the Contextual Menu  button and select Palette > Delete from the pop-
up menu. A confirmation dialog box opens.

3. Decide if you really want to delete the selected palette.
• Click Yes to delete the selected palette and all of its palette styles.
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• Click No to cancel the delete palette command.
Toon Boom Studio™ removes the selected palette from the current animation set. The 
other palettes in the animation set are not affected.

See Also
Swatches on page 179 
Managing Your Colors with Palettes on page 205 
Creating a Palette on page 206 
Copying a Palette on page 206 
Renaming a Palette on page 208 
Creating Multiple Palette Styles on page 209 

Creating Multiple Palette Styles
A palette includes one or more palette styles. After you create the swatches in a palette 
style, you can make multiple copies of this palette style and customize them to suit 
different light and color settings.

Multiple palette styles allow you to adjust a character’s colors instantly instead of 
recoloring each swatch. 

When you switch palette styles Toon Boom Studio™ automatically repaints those 
zones with the same properties of the active palette style. When you export your 
animation, the active palette style is used. 

When you add a color swatch to one palette style, Toon Boom Studio™ automatically 
adds it to all the palette styles in the current palette. This allows you to create different 
color styles for a single drawing, while keeping the same swatches in each style. 

Two styles - one brightly colored 
for a daytime scene, the other has 
dull colors for the same scene in 
the rain.
209



Managing Your Colors with Palettes
To create a new palette style in a set, follow these steps: 

1. In the Color Palette tab, select the palette and palette style you want to use to 
create the new style.

2. Click the Contextual Menu  button and select Style > Duplicate from the pop-
up menu.

A new palette style appears in the Palette style drop-list with a default name 
(Style#). The copied style contains all of swatches in the original palette style.

3. Customize the color swatches as necessary. 

See Also
Swatches on page 179 
Managing Your Colors with Palettes on page 205 
Creating a Palette on page 206 
Renaming a Palette Style on page 210 
Deleting a Palette Style on page 211 

Renaming a Palette Style
When you create a palette style, Toon Boom Studio™ assigns a default name to it. You 
can rename the palette style to give it a more descriptive name. 

For example, if you had a character that had scenes in three different light settings, you 
could create three palette styles that each contain the same number of color swatches 
with the same names, but with different color properties based on each type of light 
setting. 

To rename a palette style, follow these steps:

1. Select the palette style you want to rename from the Style drop list in the Color 
Palette tab.

2. Click the Contextual Menu  button and select Style > Rename to give the 
palette style a new name. The Rename dialog box opens.

Remember that you can change the color properties of a swatch in a palette style 
without changing the properties of the same swatch in the other palette styles.

If you attempt to change the name of a swatch, or add a new swatch, all the styles in 
the palette reflect this change as well.
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You can also select this command by right-clicking the top section of the Color 
Palette tab and selecting Style > Rename from pop-up menu.

3. Type a new name for the palette style in the Style Name field and click OK. The 
new name for the selected palette style appears in the Palette style drop-list.

See Also
Swatches on page 179 
Creating Multiple Palette Styles on page 209 

Deleting a Palette Style
When you no longer need a palette style, you can delete it. However, you cannot delete 
the last style in a palette. Your only option is to delete the entire palette, deleting all the 
styles in it. 

For example, let’s say you had a scene called Dusk that required the color swatches to 
have more red in them. You would have created a palette style for each of your 
characters called Dusk that had slightly redder colors. As your project evolves, you 
decide to drop the Dusk scene completely. Because you don’t really need the Dusk 
palette style anymore, you can delete it from the palette.

Deleting a palette style from a palette does not affect any of the other styles in the set. 
However, the zones and line art in your drawing will now use the colors in the next 
available palette style.

To delete a palette style, follow these steps:

1. Select the palette style you want to delete from the Style drop list in the Color 
Palette tab.

2. Click the Contextual Menu  button and select Style > Delete. 

Toon Boom Studio™ removes the selected style and its associated color swatches 
from the current palette and applies the swatch properties of the active style to the 
drawings that use them.

See Also
Swatches on page 179 
Creating Multiple Palette Styles on page 209 
Renaming a Palette Style on page 210 
211



Managing Your Colors with Palettes
Offsetting Colors in a Palette Style
Toon Boom Studio™provides you with a powerful feature for tinting the color 
properties of all swatches in a palette style simultaneously. 

Using the Tint Offset dialog box you can add or subtract RGB/ HSV and Alpha 
(transparency) values from all of the swatches in a selected palette style to suit a 
specific situation. This eliminates the need to make time consuming individual 
adjustments to each swatch, removes the possibility of inconsistent results, and 
provides uniform color adjustment. 

Changing the offset properties adjusts the color properties of the swatches in the 
current palette style. 

Normal settings before adjusting 
RGB/ HSV and Alpha (transparency) 
values.
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For example, you can increase the amount of red in a palette, which makes reds redder 
and blues more purple.

If you want to mix a new color into a palette style, you must use the Tint Blend dialog 
box. 

To tint all of the colors in a palette style, follow these steps:

1. Select the palette and the palette style you want to modify from the Color Palette 
tab.

2. Click the Contextual Menu  button and select Style > Tint Offset. The Tint 
Offset dialog box opens.

3. Select the type of adjustment you want to make to the palette style. You have two 
choices:
• RGB: adjusts the Red, Green, and Blue values in the current palette.
• HSV: adjusts the Hue, Saturation, and Value values in the current palette.

4. Using the sliders/fields, adjust the RGB or HSV values in the current palette. 

As you make adjustments in this dialog box, the swatches in the current palette 
style change as well as the drawings that use those swatches, but the changes only 
become permanent when you click OK.

Results of setting the Red 
values to minimum or 
maximum.
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Managing Your Colors with Palettes
You can also use the Alpha slider/field to adjust the amount of transparency in the 
current palette style colors.

5. Use the Blending slider to change the intensity of the current RGB/HSV and 
Alpha values by a selected percentage.

6. Click OK when done.

See Also
Swatches on page 179 
Creating Multiple Palette Styles on page 209 
Blending a Color into a Palette Style on page 215 

Reducing the Alpha value alters the 
transparency. 
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Blending a Color into a Palette Style
You can use the Tint Blend dialog box to blend a specific amount of a selected color into 
the swatches in a palette style. 

For example, if a character is standing close to a fire, blend orange into the character’s 
palette style to show the firelight reflecting off the character’s body and clothing. 

The difference between tint blend and tint offset is that when you use the Tint Offset 
command, you are increasing or decreasing the existing RGB/HSV/Alpha values of 
the swatches in a palette style. The Blend command add a new color into all the 
swatches in the palette style.

To blend a selected color into the selected palette style, follow these steps:

1. Select the palette and palette style you want to modify from the Color Palette 
tab.

2. Click the Contextual Menu  button and select Style > Tint Blend. The Tint 
Blend dialog box opens. 

3. Select the type of adjustment you want to make to the palette style. You have two 
choices:
• RGB: adjusts the Red, Green, and Blue values in the current palette.
• HSV: adjusts the Hue, Saturation, and Value values in the current palette.

4. Use the RGB/HSV sliders and the Alpha slider/field, select the type of color you 
want to mix with the current palette style.

As you make adjustments in this dialog box, the swatches in the current palette 
style change as well as the drawings that use those swatches, but the changes only 
become permanent when you click OK.
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5. Use the Blend slider/field to select the percentage of the blend color you want to 
add to the current palette style.

6. Click OK to permanently blend the selected color into the swatches in the current 
palette style.

See Also
Swatches on page 179 
Creating Multiple Palette Styles on page 209 
Offsetting Colors in a Palette Style on page 212 

Adds 50% of the selected 
color to the swatches.

Adds 100% of the selected 
color to the swatches.

Zero blend used.
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Chapter 6
Adding Sound 

This chapter explains how to add sound tracks to your movie. It 
also explains how to automatically generate a lip assignment 
chart.

This chapter contains the following topics:

• Importing Sounds on page 218 

• Editing Sounds on page 222 

• Creating Lip Charts Automatically on page 230 



Importing Sounds
Importing Sounds
When you decide that you want to add sound to your movie, you must first prepare 
this sound outside Toon Boom Studio™. Then in Toon Boom Studio™, you must add 
a Sound element, which organize sound files in your animation. 

A sound will play in the movie until it reaches the end of the file or a stop frame you 
create in the Sound Element Editor. If the sound extends into multiple scenes it will 
keep playing.

You can import as many sound files as you like, just be sure to consider the constraints 
of your audience if you will be delivering your movies over the Internet - the more 
sounds you add, the larger the file size of your final movie.

Toon Boom Studio™ import, exports and plays sounds using QuickTime®. Toon 
Boom Studio™ only supports the sound formats recognized by QuickTime®, with one 
exception: Flash ADPCM format, which we support natively.

To import sound to your scene, follow these steps:

1. Select Element > New > Sound. An empty sound element appears in the Expo-
sure Sheet window and Timeline window.

2. In the Exposure Sheet window, right-click the cell at the frame number where you 
want the sound to start playing and select Import Sound > From file from the 
pop-up menu. The Open dialog box opens.
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3. Select the sound file you want to use in your scene and click Open. 

If the sound file doesn’t already exist in your animation, Toon Boom Studio™ 
copies the file from its present location to the Sound folder in your animation set 
folder. 

The sound file now appears in the cell you selected. The entire name of the file appears 
in the cell, so you should try to keep the file name short so you can see it easily in the 
cell.

See Also
Editing Sounds on page 222 
Renaming Elements on page 379 
Creating Lip Charts Automatically on page 230 

Event and Stream Sounds
You can set up your sounds to be either stream or event sounds when they are exported 
to the Macromedia® Flash™ format. 

There are two major distinctions between event and stream sounds in the 
Macromedia® Flash™ file:

• Downloading
Event sounds are downloaded by the Macromedia® Flash™ player before 
they play.
Event sounds are reusable. Once downloaded, the Macromedia® Flash™ 
player can play the sound repeatedly without downloading it again. This 
is not possible with streamed sound.
Streamed sound plays as it arrives. 

You can also import sounds in the Sound Element Editor.

1. Select the sound element and select Element > Edit Sound. The Sound 
Element Editor opens.

2. Right-click an empty spot in the Sound Element panel and select Import 
Sound from the pop-up menu. The Open dialog box appears.

3. Select the sound you want to import and click OK.
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Streamed sound samples are broken into small bits and inserted between 
the video frame. This allows the Macromedia® Flash™ player to start to 
play before receiving the full sound track which is helpful for a long 
sound track (like background music).

• Synchronization
Stream sounds are kept synchronized with the video by the Macromedia® 

Flash™ player. The player drops frames if necessary, for example, if the 
video renderer is too slow and falls behind the sound track. 
Event sounds are not synchronized with video. After a while, an event 
sound may fall out of sync with the video.

Because streamed sounds are more likely to be synchronized with the images in your 
animation, lip sync sounds should be set to stream. However, only one sound can be 
streamed at a time, if there are multiple sounds set to be streamed, Toon Boom 
Studio™ chooses the one that will be streamed and the rest will be event sounds. 

To stream the sounds in an element, follow these steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor opens.

2. Select the Stream checkbox. This toggles on and off the streaming sound option. 
If the option is not selected, the sound is set as an event sound.

 

See Also
Editing Sounds on page 222 

Here’s the Stream 
check-box.
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Playing the Sound in Your Animation
After you’ve added sounds to your scene, you can preview the scene with all the 
sounds in sync. This helps you make any adjustments necessary to keep your sound 
synchronized with the action in your scene. 

To play sound only, follow these steps:

1. In the Exposure Sheet window, right-click on the cell containing the sound. 

2. Select Play from the pop-up menu. 

3. To stop the sound playback, right-click the same cell and select Stop from the 
pop-up menu.

See Also
Creating Lip Charts Automatically on page 230 
Editing Sounds on page 222 
Real-Time Playback on page 431 
Exporting to Flash on page 433 

You can’t use the Interactive Playback to playback the sound in a scene. Because the 
scene does not playback in real time, the sound would be out-of-sync with the action.
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Editing Sounds
The Sound Element Editor makes it possible for you to edit sounds created outside of 
Toon Boom Studio™and imported into the movie.   

The Sound Element Editor consists of three main elements.

• The Sound Element panel displays the waveform of all sound files in the 
element.

• The Current Sound panel displays the waveform of the selected sound so that 
you can edit its properties.

• The Lip sync preview images appear when you lip sync a sound.
In the Sound Element Editor, you can:

• Adjust the start frame/time of a sound.
• Cut sections from the start and end of the sound.
• Adjust the volume of a sound clip and create fade envelopes.
• Generate lip charts.
• Set the sound element to Stream or Event sound.

See Also
Creating Lip Charts Automatically on page 230 
Changing the Lip Assignment of a Sound on page 231 
Trimming the Start and End of a Sound File on page 224 
Fading the Sound In and Out on page 227 

Lip sync 
preview 
images

Sound Element 
panel

Current Sound 
panel
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Changing the Start or End Frame of a Sound
To synchronize your sound with specific images in your animation, you must set a start 
frame. If you want to make sure the sound ends by a certain frame, you must set an end 
frame. 

To change start or end frame of a sound, follow these steps:

1. Select Element >Edit Sound. The Sound Element Editor dialog box opens.

2. Select the sound you want from the Sound Element panel. To distinguish one 
sound file from another, check the frame numbers that appear above the sound 
waves or select a sound wave and click the Play button in the Current Sound 
panel (only the selected sound plays).

3. Using the Sound Element panel, drag the selected clip to the frame position 
where you want it to start playing. 

The start and end 
frames appear in 
the green and 
yellow tabs.
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You can only move the clip to a section that does not already contain a clip; you 
cannot overlap two clips in the same element.

4. To change the end frame, drag the yellow marker at the end of the waveform to 
the frame position.

5. To hear how all of the clips fit together in the element, click the Play  button in 
the Sound Element panel.

If you only want to hear the selected clip, click the Play  button in the Current 
Sound panel.

6. Click OK when done. The exposure sheet/timeline should now display the sound 
clip at the start frame you selected.

See Also
Importing Sounds on page 218 
Creating Lip Charts Automatically on page 230 
Fading the Sound In and Out on page 227 
Changing the Lip Assignment of a Sound on page 231 

Trimming the Start and End of a Sound File
If you want to play only a section of a sound file, you can use the Sound Element Editor 
dialog box to select the exact part you want to use.   

For example, let’s say there is a bit of noise at the start of the sound. You can use the 
Sound Element Editor to cut the noise at the start of the sound file. 

The Sound Element Editor does not change the original sound file; it only plays a 
section of it, ignoring the rest. This allows you to reuse the full sound in other scenes 
in the movie. However, this means that the entire sound file is included on export. So 
if must be considerate of file size, it is better to edit sound files completely in a sound 
editor before you bring them into Toon Boom Studio™.

Toon Boom Studio™ does not change the sound to fit into the number of frames you 
select. If the number of frames you select is longer than the played sound, no sound is 
heard from that point on.
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To select the section of a sound file to play in your scene, follow these steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor dialog box opens.

2. Select the sound you want to work on from the Sound Element panel. 

To distinguish one sound file from another, check the frame numbers that appear 
above the sound waves or select a sound wave and click the Play  button in the 
Current Sound panel (only the select sound will play).

3. Using the Current Sound panel, you can decide which part of the file you want 
to play by dragging the left and right boundaries of the selection area.

See Also
Importing Sounds on page 218 
Creating Lip Charts Automatically on page 230 
Fading the Sound In and Out on page 227 
Changing the Lip Assignment of a Sound on page 231 
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Looping a Sound
To repeat a sound, you specify the number of times you want it to loop in the Sound 
Element Editor.   

To loop a sound, follow these steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor opens.

2. From the Sound Element panel, select the sound file you want to loop.

3. In the Current Sound panel, type the number of time you want the sound to play 
in the Number of Loops field.

4. Click OK to close the dialog box.

When you loop a sound, the looped sections fill the frames in the Sound element until 
they encounter the next sound in the column, at which point the sound cuts out.

See Also
Importing Sounds on page 218 
Creating Lip Charts Automatically on page 230 
Fading the Sound In and Out on page 227 
Trimming the Start and End of a Sound File on page 224 

Enter the number of loops 
here.

The looped sounds appear washed-out to 
distinguish them from the original.
226 



Chapter 6: Adding Sound
Fading the Sound In and Out
You can modify the volume throughout a sound clip by adjusting the fade-in and fade-
out times; these are also known as envelopes.    When you play the sound clip the 
volume adjusts over time to fade the sound. The fades only affect the playback; the 
original sound file is not affected.

To adjust the fade in/out effect on a sound clip, follow these steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor dialog box opens.

2. In the Sound Element panel, select the sound you want to work on. A more 
detailed version of the selected sound appears in the Current Sound panel.

3. In the Current Sound panel, click the waveform to add an envelope marker.

4. Drag the envelope markers to adjust the volume at each frame and the time of the 
transition.The line from the edge of the clip to the envelope marker identifies how 
the volume either increases (fades-in) or decreases (fades-out) over time.

See Also
Editing Sounds on page 222 
Trimming the Start and End of a Sound File on page 224 
Sound Scrubbing on page 235 

You can also adjust the volume (mix) sound in the Sound Element Editor.

1. In the Sound Element panel, select the sound whose volume you want to 
adjust.

2. In the Current Sound panel, drag the volume slider to the new level.

Envelope marker
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Editing Sounds
Viewing the Waveform in the Exposure Sheet
When you insert a sound file in your sound element and activate the Thumbnail view, 
the sound element displays a waveform to represent the sound file. The waveform 
represents the sound as it rises and falls in volume. If there is no sound in the file, the 
waveform appears as a straight line.  

You can use the waveform as a guide to determine when a certain sound effect occurs. 
For example, if you have a sound effect of a rooster crowing, you can analyze the 
sound’s waveform to determine the initial “cock-a-doodle-doo” sound and sync it to 
the drawings of the rooster crowing.

If you look at the waveform of the sound effect, you’ll notice the volume increases as 
the size of the waveform increases. You can use the size of the waveform as a guide to 
sync the sound effect with the action in your scene.

To view or hide the waveform of the sound element:

• Click the Toggle Thumbnails  button in the Exposure Sheet window.
There are two viewing modes that apply to sound columns when you activate the 
element thumbnails, depending on if you apply a Lip Sync function. 

• Lip Sync active: the sound cells display the lip sync letter or a graphic.
• Lip Sync inactive: the sound cells display the file name or a waveform.

See Also
Creating Lip Charts Automatically on page 230 
Editing Sounds on page 222 

When a lip sync is applied to the cells in a sound element, you can no longer view the 
waveform or the file name. If you want to view its waveform again, right-click the 
sound cell and deselect the Show Lip Sync option in the pop-up menu.
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Customizing the Playback Range
If you want to hear a specific section of the sound element, you can adjust the playback 
range in the Sound Element Editor to start or stop at specific frames. This customized 
playback range does not affect the actual sound in the Sound element.    

To change the playback range in the Sound Element Editor dialog box:

• Drag the start or end range markers in the Sound Element panel to the 
boundary frames you want.

When you press Play  to playback your sound in the Sound Element Editor, it only 
plays the sound that exists between the two markers. 

See Also
Editing Sounds on page 222 

The playback start/end 
range markers
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Creating Lip Charts Automatically
It can be a difficult task to shape a characters mouth so that it matches the sound at the 
right frame.  

To solve this problem Toon Boom Studio™ provides you with the Lip Sync feature 
which analyses the contents of a sound element and generates a lip chart based on the 
eight animation phonemes (A, B, C, D, E, F, G, and X, which represents silence). You 
can refer to the lip chart positions as you draw the shape of you character’s mouth. 

To generate a lip chart for a sound, from the Exposure Sheet, follow these steps:

1. In the Exposure Sheet, right-click the sound cell you want to affect and select 
Show Lip Sync from the pop-up menu. A checkmark appears next to the com-
mand to show that it is active. 

Toon Boom Studio™ analyzes the selected sound clips and assigns a lip sync 
letter to each sound cell. All the cells that have a sound file in them display a 
cartoon face that mimic the sound at that specific frame.

2. To show/hide the Lip Sync images that represent the lip position at each frame, 
click the Contextual Menu  button and select View > Thumbnails. 

All the possible lip position 
graphics appear below the lip sync 
preview image in the Sound 
Element Editor dialog box.
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To generate a lip chart for a sound, using the Sound Element Editor, follow these 
steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor opens.

2. In Sound Element panel, right-click the waveform you want to generate the lip 
chart for.

3. Select Compute lip sync. A progress bar appears as Toon Boom Studio™ 
analyzes the selected sound clips and assigns a lip sync letter to each sound cell.

Each lip chart image displays a letter which corresponds to the sound cell shown in the 
exposure sheet. 

See Also
Viewing the Waveform in the Exposure Sheet on page 228 
Changing the Lip Assignment of a Sound on page 231 

Changing the Lip Assignment of a Sound
You can change the lip position assigned to a frame if you think another lip position 
would be more appropriate.   

For example, let’s say you have a character who says nothing for 10 frames inbetween 
two speeches. Toon Boom Studio™ would normally assign an X image for the silence 
period. 

If you want your character to let his mouth hang open in astonishment for these 10 
frames, you could change the lip assignment for these 10 frames from an X to an F.

To change the lip assignment of a sound, follow these steps:

1. Right-click the cell that contains the lip position you want to change.

2. From the Lip Sync menu, select the letter that reflects the lip position you want to 
use for that sound. 

Toon Boom Studio™ changes the lip chart to reflect the new lip assignment.

You can also change the lip assignment of a sound in the Sound Element Editor.
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Creating Lip Charts Automatically
To change the lip assignment of a sound from the Sound Element Editor, follow 
these steps:

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor opens.

2. In the Sound Element panel, drag the frame slider to the frame you want to 
change the lip assignment on.

In the Lip Sync image area, the image on top represents the lip position assigned 
to the current frame. 

3. To change the image assigned to the frame, click image of the lip position you 
want from below the preview image.

The preview image changes to the lip image you select.

See Also
Adding Lip Sync Notes on page 233 
Sound Scrubbing on page 235 
Automatically Mapping Lip Sync Drawings on page 236 

All the possible lip position graphics appear 
below the lip sync preview image in the 
Sound Element Editor dialog box.
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Adding Lip Sync Notes
To identify the different sections of your sound element, you can add lip sync notes to 
the lip chart. 

Lip sync notes are not the same as cell or element notes. Lip sync notes appear directly 
in the sound element cell in the Exposure Sheet window. 

Adding lip sync notes does not change the lip assignment at the frame.

To add lip sync notes to your sound element, follow these steps:

1. In the Sound element, double-click the sound cell you want to affect. The cell 
becomes editable.

2. Type the note text you want to appear with the lip sync image and press [Enter]. 
The next cell becomes editable.

If you don’t want to edit the next cell, click outside of the cell. If you want to 
cancel the note change, press [Esc].

The lip sync note appears in the sound element in the Exposure Sheet window and 
appears in the Sound Element Editor. 

See Also
Editing Sounds on page 222 
Adding Element/Cell Notes on page 360 
Automatically Mapping Lip Sync Drawings on page 236 
Changing the Lip Assignment of a Sound on page 231 
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Recomputing the Lip Chart
When you generate the lip chart for a sound in a sound element, you can either accept 
the lip positions assigned by Toon Boom Studio™ or assign your own lip sync images. 

However, if you change the sound’s start frame or reassign its lip position, you can use 
the Recompute lip sync command to reanalyze the sound and regenerate the lip chart 
for it. The command remains dimmed until you change the start frame or the assigned 
lip position.

To recompute the lip chart for a selected sound, follow these steps:

1. Right-click the sound in the Sound element 

2. Select Recompute lip sync from the pop-up menu.

See Also
Creating Lip Charts Automatically on page 230 
Adding Lip Sync Notes on page 233 
Automatically Mapping Lip Sync Drawings on page 236 

 Regenerating the lip chart erases any customized assignments you make.
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Sound Scrubbing
Toon Boom Studio™ uses a process known as Sound Scrubbing to let you hear sound 
in real-time while you move the playback pointer forward or backwards. This is very 
useful for fine tuning the lip sync process.   

To scrub a sound, follow these steps: 

1. Select the Sound element and select Element > Edit Sound. The Sound Element 
Editor opens.

2. In the Sound Element panel, select the waveform you want to scrub.

3. Below the Current Sound panel, select the Enable Scrubbing option. This 
option sets the red markers in scrub mode.

4. Drag the red playback marker and hold the left mouse button down. The sound 
plays back at a speed relative to the distance from the initial position of the slider 
and the mouse pointer.

You can play the sound forwards or backwards by moving the mouse pointer in 
the opposite direction.

5. To stop the playback, release the mouse button.

See Also
Creating Lip Charts Automatically on page 230 
Changing the Lip Assignment of a Sound on page 231 
Trimming the Start and End of a Sound File on page 224 
Fading the Sound In and Out on page 227 
235



Creating Lip Charts Automatically
Automatically Mapping Lip Sync Drawings
Toon Boom Studio™ can automatically map drawings in an element to the lip chart 
you generated on a sound. This can save you lots of time when you are lip syncing a 
voice track.   In Lip Sync Mapping dialog box, you identify each phoneme drawing for 
a character and then Toon Boom Studio™ automatically labels all of the cells in the 
character’s element with the appropriate label for each phoneme drawing.

To automatically map lip sync drawings to a lip chart, follow these steps:

1. In a lip-synced sound element, right-click the Sound element and select Modify 
Lip Sync Mapping. The Lip sync mapping dialog box opens. 

2. From the Destination element drop-list, select the element that contains the lip 
positions for the character’s voice track. 

3. In the Mapping panel, type the drawing name in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme 
letters, you don’t have to do anything.

4. Click OK. The dialog box closes. If you scroll through the element with the lip 
positions, you’ll see that all of the lip drawings have been mapped to the 
phonemes in the voice track.

See Also
Creating Lip Charts Automatically on page 230 
Changing the Lip Assignment of a Sound on page 231 

If you make any changes to the voice track, you must remap the drawings to the 
appropriate phonemes. The mapping is not updated automatically.

Type the drawing name in the field to the 
right of the mapping letter 

This feature will save you even more time 
if you name your drawings with letters of 
the eight phonemes A, B, C, D, E, F, G, 
and X (represents silence).
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Chapter 7
Laying Out Elements in 3D Space

This chapter explains some of the basic concepts of the 3D scene 
space and how you can use it to place and adjust your elements.

This chapter contains the following topics:

• Basic Sceneplanning Concepts on page 238 

• Repositioning Elements on page 245 

• Scaling Elements on page 250 

• Rotating Elements on page 255 



Basic Sceneplanning Concepts
Basic Sceneplanning Concepts
Sceneplanning Mode adds a new dimension to the lay out process by allowing you to 
plan your 2D scenes in a 3D space. 

 The 3D space is described in terms of three planes:  

• EW: maps the horizontal plane in terms of East and West, this is the X 
coordinate.

• NS: maps the vertical plane in terms of North and South, this is the Y 
coordinate.

• FB maps the depth of the plane in terms of Front and Back, this is the Z 
coordinate. 

When you move, rotate, or scale your 2D elements in the 3D space, Toon Boom 
Studio™ automatically applies the changes to all of the contents in the element.

To switch to Sceneplanning Mode:

• Select View > Sceneplanning Mode or click the Sceneplanning Mode  
button. 

See Also
Exposure Sheet and Timeline Windows on page 354 
Selecting Elements on page 243 
238 



Chapter 7: Laying Out Elements in 3D Space
Using the View Windows
As you choreograph the elements in your scene, you need to be able to see where your 
elements appear in each frame of the scene.   

Toon Boom Studio™ provides you with three windows that display your elements 
from three unique perspectives.

• Camera View: (default) displays the scene from the camera’s perspective.
Use this view to change an element’s north, south, east, west, front, and back 
position, as well as its scale size, and rotation angle.

• Top View: displays the scene from a top-down view. Elements appear as lines 
(imagine looking at an animation cel from the top) and the camera field of 
view appears as an angle. 
Use this view to change an element’s east, west, front, and back position.

• Side View: displays the scene from the side. Elements appear as lines 
(imagine looking at an animation cel from the side) and the camera field of 
view appears as an angle. 
Use this view to change an element’s north, south, front, and back position.

Camera View 

Top View 
Side View 
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Basic Sceneplanning Concepts
You can use these View windows to place your elements in the scene and to map their 
actions over time. You can also use these windows to determine the size and position 
of the camera that records the action in your scene. 

See Also
Zooming and Panning the View Window on page 164 
Selecting Elements on page 243 

Zooming and Panning View Windows
As you work with your elements in your View window, you may need to see other 
parts of the scene space not in the camera’s field of view. Although all the action is 
taking place within the confines of the active camera’s field of view, you can place other 
elements outside the camera to bring them in later when needed.  

Changing the section of the viewable scene space doesn’t actually change anything in 
the scene itself; it only changes what you are currently seeing in the View window.

Elements within the 
camera’s current field 
of view 

Elements outside the 
camera’s current field 
of view 

Camera’s current field 
of view frame
240 



Chapter 7: Laying Out Elements in 3D Space
 To pan to another section of the scene space, you have these options:

• Select Tools > Grabber and use the Grabber  tool to pan the window. You 
can also activate the Grabber tool from the Scene View toolbar.

• Place the pointer in the View window and press [Spacebar]. When the pointer 
changes to a Grabber, you can click and drag the scene space around, making 
other parts of it visible.

• Use the scroll bars in the View window to scroll the scene space.

 To zoom-in, you have these options:

• Place the pointer in the view window press the [X] key on your keyboard.
• Select View > Zoom In.
• Select Tools > Zoom and click the area you want to zoom-in by clicking the 

Zoom  tool.

 To zoom-out, you have these options:

• Place the pointer in the view window press the [Z] key.
• Select View > Zoom Out.
• Press [Alt] and then click the View window with the Zoom  tool.

See Also
Resetting the Scene View on page 242 
Switching the Active View in Sceneplanning Mode on page 241 
Repositioning Elements on page 245 

Switching the Active View in Sceneplanning Mode
If you zoom or pan across your View window, you can switch back and forth between 
the current view and a second view set up.   

To switch the active view in Sceneplanning Mode, you have these options:

• Select View > Switch Active View.
• Press the [B] key on your keyboard to toggle between the views.

See Also
Using the View Windows on page 239 
Zooming and Panning View Windows on page 240 
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Resetting the Scene View 
If you change the focus of the View window to view other parts of the scene space, you 
may want to return to the default view, which is based on the camera size and position.  

To reset the view focus, you have two choices:

• Select View > Reset Zoom to return to the default zoom value.

• Select View > Reset View or click the Reset View  button in the Scene 
View toolbar to reset your view to the position of the camera and the size of 
the window.
This option allows you to have a better idea of what the active camera is 
viewing in the scene.

• Click the Recenter View  button to reset your view to the center of the 
active camera.
The view in the current View window recenters itself based on the camera 
position, but it does not reset the zoom level     

The Top and Side View windows use a fixed viewpoint in the center marked by a 
cross. When you click the Reset View  button or the Recenter View  button, Toon 
Boom Studio™ resets the windows to that fixed position, no matter where the camera 
is located in the scene space.

See Also
Using the View Windows on page 239 
Zooming and Panning View Windows on page 240 
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Selecting Elements 
When you’re ready to start choreographing your scene, you need to be able to select 
the elements you want to change.  

You can select elements in the:

• Camera View, Top View and Side View windows 
• Timeline window

All the images at the current frame appear in full-color in the Camera View 
window. A selected element appears highlighted.

How you select your element depends on the type of change you want to make:

• Single element
• Multiple elements

To select a single element in the Camera View, Top View or Side View windows, 
follow these steps:

1. Select Tools > Select to activate the Select  tool. 

2. Click the element. The selected element appears highlighted in all the View 
windows and the Timeline window. 

Selected elements and their 
relative positions in the View 
windows
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To select multiple elements in the Timeline window, follow these steps:

• [Shift]+click the element names in the Timeline window. You can then 
change their scene timing, layer order, and attach/detach them from pegs.  

• To select all the elements, select the Timeline window and select Edit > 
Select All. 

• To deselect all the elements, select Edit > Deselect All or simply click the 
Select tool in an empty space in the Camera View, Top View, Side View, or 
Timeline windows.

See Also
Exposure Sheet and Timeline Windows on page 354 
Adding Pegs and Attaching Elements to Pegs on page 261 
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Repositioning Elements
When you first load a scene in the Sceneplanning Mode, all of your elements appear as 
they were drawn in the Drawing View window with the initial position of zero fields 
NS, zero fields EW, and zero fields FB within the 3D scene space. 

Using the EW (X), NS (Y), and FB (Z) coordinates you can place your elements at 
different distances in depth from the camera and from each other, adding a three 
dimensional effect to your two dimensional animation.  

This is what you see in the 
Camera field of view.
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Repositioning Elements
Camera View window displays the NS/EW/FB offset positions, but you can also use 
the Side View and Top View windows to reposition elements:

• Top View window: displays the EW and FB positions.
• Side View window: displays the NS and FB positions.

Changing an element’s position affects all the contents in that element. If you want to 
change an element’s properties over time, you need to attach it to a peg. 

See Also
Changing the NS/EW Position of an Element on page 246 
Changing the FB Position of an Element on page 248 
Defining an Element’s Layering Order on page 249 
Changing Elements Over Time with Pegs on page 260 

Changing the NS/EW Position of an Element
You can use the Camera View window or the Properties tab to change the NS/EW 
position of an element.  

As you change the position of 
an element, the values in the 
Offset fields change.
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To change the NS/EW position of an element, follow these steps:

1. Select the element you want to reposition using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. To change the NS/EW position, you have the following choices:
• To use the mouse to change the NS/EW position, move the pointer over the 

element so that it changes to  and drag the element to its new position. 
• To nudge selected elements, you can also use the arrow keys. Press [Shift] if 

you want to move the element in larger increments.  
• To use an exact NS/EW position, type the values in the first Offset fields in 

the Properties dialog box (select Window > Properties).
To change the NS position, type the offset value in the left field followed 
by its direction (N for north or S for south). 
To change the EW position, type the offset value in the right field 
followed by its direction (E for east or W for west). 

See Also
Selecting Elements on page 243 
Changing the FB Position of an Element on page 248 
Defining an Element’s Layering Order on page 249 
Showing/Hiding Elements on page 355 
Zooming and Panning View Windows on page 240 
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Changing the FB Position of an Element
You can change the FB position of an element visually in the Top View or Side View 
windows. You can also use a keyboard shortcut and change the FB position of elements 
in the Camera View window. All changes to the position of an element appear in the 
Properties window for the element.   

To offset the FB position of an element, follow these steps:

1. Select the element you want to reposition using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the View window. 

2. To offset the FB position, you have the following choices:
• In the Top View or Side View window, move the pointer over the element so 

that it changes to  and drag the element to its new position.
• In the Camera View window, you can use the mouse to change the FB 

position of the element. Move the pointer over the element and press [Alt] so 
that it changes to an up/down arrow . Drag the element to its new position. 

Dragging the mouse upwards moves the element backward in space.
Dragging the mouse downwards moves the element forward in space.

If you open the Properties dialog box (select Window > Properties), you 
can see the FB position value in the last Offset field.

The Top View and Side View windows 
show you the relative front/back 
position of all elements in your scene.
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• To use an exact FB position, make sure the Properties dialog box is active 
(select Window > Properties) and type the values in the last Offset field.
Type the Front/Back value in the last field followed by its direction (F for 
forward or B for backward). 

See Also
Zooming and Panning View Windows on page 240 
Selecting Elements on page 243 
Changing the NS/EW Position of an Element on page 246 
Defining an Element’s Layering Order on page 249 
Showing/Hiding Elements on page 355 

Defining an Element’s Layering Order
To make an element appear in front of or behind all the elements in your scene, you can 
tag that element as either a Foreground or Background element.      

For example, if you have a background image, you can tag the element as a 
Background element and Toon Boom Studio™ will always place it behind all the other 
elements, even if another element’s Front/Back position places it behind the 
background element.

To select the element type, follow these steps:

1. Select an element in either the View windows or the Timeline window.

2. Select the element type from the Type drop-list in the Properties window (select 
Window > Properties to display this window). You have the following choices:
• Normal (default): the layer order is determined by the order of the elements 

in the Timeline window and its Front/Back position.
• Foreground: this type of element will always appear in front of other 

elements no matter what their Front/Back position is. 
• Background: this type of element will always appear behind other elements 

no matter what their Front/Back position is. 
When you have two or more Foreground/Background elements, their order in the 
Timeline window determines their final layer order.

See Also
Selecting Elements on page 243 
Changing the NS/EW Position of an Element on page 246 
Changing the FB Position of an Element on page 248 
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Scaling Elements
Scaling Elements 
When you open your elements for the first time in Sceneplanning Mode, the images 
appear at their original size (as set in Drawing Mode). You can change an element’s 
height and width using the Scale  tool in Sceneplanning Mode, which resizes all of 
the contents in the selected element.

Scaling an element is not the same as moving it closer to the camera, although the effect 
is similar. When you move an element closer or farther away from the camera, it’s size 
seems to change, but it’s an illusion. 

You can scale an element by:

• dragging the scale handles
• entering specific values

To see a change in the element’s size, make sure the Camera View is active.      

Check this box to 
force proportional 
scaling

Drag the proportional 
scale handle to 
rescale 
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To scale an element using the scale handles, follow these steps:

1. Select the element you want to scale using one of the following methods:     
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the View window. 

2. Select Tools > Scale or click the Scale  tool in the Scene Operation 
toolbar.The scale selection frame appears around the element.

3. Place the mouse pointer over one of the scale handles.

4. Drag one of the scale handles in the direction you want to rescale. 

To scale without proportion, 
uncheck this box

Drag a scale handle to 
rescale in any 
direction

Scale handles.
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Dragging away from the element scales it up and dragging toward the element 
scales it down. If you drag the handles beyond the scale borders, the element’s 
drawings flip over. 

Top-right corner handle: changes the height and width values at the same 
time. If you press [Shift], you can rescale the element proportionally.
Top-center handle: changes the height value.
Side-center handle: changes the width value.

To change the size of an element over time, you must attach it to a peg.

To scale an element with specific values, follow these steps:

1. Select Window > Properties to open the Properties dialog box. You can see the 
size scale values change in the Scale fields.     

2. Type the size values in the Scale fields in the Properties dialog box.

To change the height of the element, type the height value in the left 
Scale field. 
To change the width of the element, type the width value in the right 
Scale field. 
To change the height and width of an element proportionally, select the 
Keep Proportions checkbox. When you type one value in the vertical 
Scale field, Toon Boom Studio™ adjusts the horizontal value 
automatically and the horizontal value field is greyed out.

See Also
Scaling Elements Over Time on page 297 
Changing Elements Over Time with Pegs on page 260 
Showing/Hiding Elements on page 355 

Proportional Scale Scale fields
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Changing the Scale Pivot Point Position
The scale pivot point allows you to change the center of the scaling.

For example, with the pivot point at the center of the scale grid (default), when you 
resize the element, all four sides can move in the direction you drag the resize handles. 
Only the centre of the drawing stays in place.

With the pivot point on the left middle-side, only the three opposite sides will move if 
you resize the object. 

This can be useful if you want to resize an element, but you don’t want to change it’s 
horizontal or vertical position in the scene.     

You can move the scale pivot point by:

• dragging the scale pivot point
• entering specific values

To change the scale pivot point using the Scale tool, follow these steps:

1. Select the element using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

Pivot point
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Scaling Elements
2. Select Tools > Scale or click the Scale  tool in the Scene Operation 
toolbar.The scale selection frame appears around the element.

3. Select the pivot point and drag the pivot point to the position where you want to 
focus the scaling.

4. Scale the element as you wish using the resize handles.

To change the scale pivot point by entering specific values, follow these steps:

1. Select the element using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. Select Window > Properties. The Properties dialog box opens and the pivot 
point position values are displayed in the Scale Pivot fields of the element’s tab. 

3. Type the values in the Scale Pivot fields.
To change the NS pivot point position, type the value in the left field, 
followed by its direction (N for north or S for south). 
To change the EW pivot point position, type the value in the right field, 
followed by its direction (E for east or W for west). 

See Also
Changing the Pivot Point Over Time on page 303 
Repositioning Elements on page 245 
Selecting Elements on page 243 
Repositioning Elements on page 245 
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Rotating Elements
When you open your elements for the first time in Sceneplanning Mode, the images 
appear in the Camera View window at the angle drew them at in Drawing Mode. 

You can rotate all of the contents in an element using the Rotate  tool in 
Sceneplanning Mode. The rotation can be as simple as changing the element’s angle so 
it appears to move up or downhill, or as complex as a skateboarder performing 
acrobatics as he rotates through the air. 

When you rotate an element, it rotates around the rotation pivot point. With the Rotate 
tool, you can even change the rotation pivot point, to create different rotation effects.   

To rotate an element over time, you must attach it to a peg.

To rotate an element using the Rotate tool, follow these steps:

1. Select the element you want to rotate using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. Select Tools > Rotate or click the Rotate  tool in the Scene Operation toolbar. 
The rotation range appears on the element as a circle. 

3. In the Camera View window, drag the rotation handle (on the outer ring) until 
the element is at the new angle.

Rotation Pivot point
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As you change the element’s angle of rotation, the value appears in the Rotation field 
of the Properties dialog box.

To rotate an element by entering specific values, follow these steps:

1. Select the element you want to rotate using one of the following methods: 
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. Select Window > Properties. The Properties dialog box opens and the pivot 
point position values are displayed in the Rotation Pivot fields of the element’s 
tab.

3. Type the angle value in the Rotation field in the Properties dialog box. 

You can enter a negative value (to rotate to the left) or a positive value (to rotate to 
the right).

See Also
Selecting Elements on page 243 
Repositioning Elements on page 245 
Changing the Rotation Pivot Point Position on page 257 
Rotating Elements Over Time on page 289 

Rotate the element using the rotation handle.

The element’s angle of 
rotation appears here.
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Changing the Rotation Pivot Point Position 
You can use the rotation pivot point to change the center of rotation.

After you change the pivot point of an element, you can move the element to another 
position and Toon Boom Studio™ maintains the relative position of the pivot point. 

You can change an element’s pivot point by:

• dragging the rotation pivot point 
• entering specific values

To change the rotation pivot point using the Rotate tool, follow these steps:

1. Select the element using one of the following methods:
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. Select Tools > Rotate or click the Rotate  tool in the Scene Operation toolbar. 
The rotation range appears on the element. 

3. In the Camera View window, drag the rotation pivot point in the center of the 
rotate range circle to it’s new position.

In these examples, you can see how the placement of the 
pivot point produces different rotation effects.
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To change rotation pivot point by entering values in the Properties dialog box, 
follow these steps:

1. Select the element using one of the following methods: 
• Select the element in the Timeline window. 

• Select Tools > Select or click the Select  tool on the Scene Operation 
toolbar and click the element in the Camera View window. 

2. Select Window > Properties. The Properties dialog box opens and the pivot 
point position values are displayed in the Rotation Pivot fields of the element’s 
tab.

3. Type the values in the Rotation Pivot fields in the Properties dialog box.
• To change the NS pivot point position, type the value in the left field, 

followed by its direction (N for north or S for south). 
• To change the EW pivot point position, type the value in the right field, 

followed by its direction (E for east or W for west). 

See Also
Changing the Pivot Point Over Time on page 303 
Selecting Elements on page 243 
Repositioning Elements on page 245 
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Chapter 8
Moving, Rotating, and Scaling Over 
Time

This chapter explains how to use pegs to add motion, rotation, 
and scaling effects to elements in your movie.

This chapter contains the following topics:

• Changing Elements Over Time with Pegs on page 260 

• Creating Motion Paths with Pegs on page 267 

• Rotating Elements Over Time on page 289 

• Scaling Elements Over Time on page 297 

• Changing the Pivot Point Over Time on page 303 

• Changing the Velocity of a Motion Path on page 287 

• Working with the 1D and Function Editors on page 311 
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Changing Elements Over Time with 
Pegs

Sceneplanning Mode puts many 3D computer animation tricks at your disposal so that 
you can select and move, rotate, or scale your 2D elements over time in a 3-dimensional 
space.    

You use a special element called a Peg to transform your elements over time. With 
Pegs, you can change the position, rotation or scaling of an element. Toon Boom 
Studio™ interpolates all changes to gradually transform your element over time.

You can attach Image or Drawing elements to a peg to change an object’s position, size, 
or rotation over time and you can attach Cameras to Pegs to creating trucking, panning 
and zooms. You can also attach Pegs to Pegs to combine motion effects.

To change entire elements over time, you must be in Sceneplanning Mode. 

To switch to Sceneplanning Mode:

• Click the Sceneplanning Mode  button or select View > Sceneplanning 
Mode. If you are already in Sceneplanning Mode, the command in the View 
menu reads as Drawing Mode. 

See Also
Basic Sceneplanning Concepts on page 238 
Camera Effects with Toon Boom Studio on page 320 
Adding Pegs and Attaching Elements to Pegs on page 261 
Building Peg Hierarchies on page 265 

In this shot, a peg is used to 
create a motion path that the 
camera follows through the 
multiple planes in the scene.
260 



Chapter 8: Moving, Rotating, and Scaling Over Time
Adding Pegs and Attaching Elements to Pegs
To change an element over time, you must attach the element to a peg. All elements 
attached to the peg inherit the effects you program in the peg.     

To add a peg and attach an element to it, follow these steps:

1. Click the Add Peg  button in the Timeline window. A 20 frame peg appears at 
the top of the element list.

2. Select the element you want to affect in the left-side of the Timeline window and 
drag it to the peg element.

3. When the peg element becomes highlighted, release the mouse button. The 
selected element is now attached to the peg.

In this example, we attached the 
Mikeant element to the Mikeant 
Motion Path peg. 

As you drag an element onto a 
peg, the peg element becomes 
highlighted.

In this example we have two pegs and two elements attached to 
pegs. Notice:

• Attached elements are indented below the peg.

• You can use the arrow next to the peg to show/hide all of 
the elements attached to it.
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4. To rename the peg, select the peg and select Element > Rename. 

You must give the peg a unique name. You can include the name of the element it 
affects. For example, you could call the peg Mikeant-walk.  

See Also
Showing/Hiding Elements on page 355 
Repositioning Elements on page 245 
Changing the Start Time and Duration of a Peg on page 262 
Looping a Peg on page 264 
Configuring Video Card Display Options on page 52 

Changing the Start Time and Duration of a Peg
The default duration for new pegs is 20 frames, starting at frame one. You can change 
the start time and duration of a peg to reflect the period that you want the peg to 
change attached elements.      

Let’s say that the exposure time for a walk-cycle of drawings is 24 frames. You drew 
the character walking in place, so you must create a motion path with a peg for your 
drawings to follow. 

The duration of the peg element your cycle is attached is 20 frames only. If you did not 
change this, your character would appear to walk in place from frame 20 to 24. For your 
character to continue moving as he walks from frame 20 to 24, you must extend the 
duration of the peg by four frames, from frame 20 to 24.

You can improve the display quality of pegs in the View windows by changing the 
Smoothness setting on the Peg tab. You must enable Smooth Pegs on the 
Sceneplanning tab of the Preferences dialog boxes to see changes to a peg’s 
smoothness.

This is the peg’s trackbar, which 
you can use to change the start 
time and duration of the peg.
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To change the start time of a peg:

• Click the peg’s trackbar in the right panel of the Timeline window and drag 
the trackbar to the start time. You may want to use the zoom slider at the 
bottom of the Timeline window to see more or less of the timeline. 
You can also right-click the peg, select Change Start Frame from the pop-up 
menu, type the frame number in the field, and click OK. 

To change the duration of the peg:

• Move the pointer to the edge of the peg in the right panel of the Timeline 
window and drag the boundary to the left or right to increase or decrease the 
length of the peg. A peg must always be at least two frames in length. 
You can also right-click the peg, select Change Duration from the pop-up 
menu, type the new length of the peg, and click OK. 

If you add content or change the exposure of content that you have already attached to 
a peg and designed effects for, you will have to extend to the duration of the peg. 
However, if you just drag the peg’s trackbar, frames will be added to the effect you 
created and the effect will just slow down, which might not be what you want. 

With the Extend Peg command, you can change the duration of the peg without 
changing the effect (rotation, scaling, or motion) that you created. When you extend the 
peg, the key frames you created remain and new frames are added after what was the 
last frame in the original effect. Toon Boom Studio™ adjusts the velocity of your effects 
based on the number of additional frames.

To extend a peg, follow these steps:

1. In the Timeline window, use the red frame slider to select the frame you want to 
extend the peg to.

2. Select the peg in the Timeline window, and select Element > Cell > Extend Peg. 
Toon Boom Studio™ changes the duration of the peg and adjust all effects so that 
you maintain the effect that you created before you extended the peg.

See Also
Exposure Sheet and Timeline Windows on page 354 
Timing/Exposing Drawings and Images on page 401 
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Looping a Peg 
If you want a peg to repeat an effect, you can loop the peg.  

For example, if you had a scene with a boy walking across the stage with a bird circling 
his head, you would create a peg with a motion path of a single orbit for the bird. You 
would then loop the orbit motion path so that the bird would continue to circle the boys 
head for the duration of his motion path.

Each time the loop restarts, it skips the first frame of the peg. Similar to a walk-cycle 
where the last step leads naturally to the first step in the cycle, this ensures the logical 
continuation of the looped action. Therefore, if you loop a 10-frame peg three times, the 
entire length of the peg will be 28 frames.

To loop a peg, follow these steps:

1. Right-click the peg bar in the right panel of the Timeline window and select 
Change Loops. The Change Loops dialog box opens.

2. Type the number of times you want to repeat the selected peg and click OK.
The peg now repeats itself for the number of loops you selected. After the first segment, 
the peg bar of the looped segments is grey.

See Also
Rotating Elements Over Time on page 289 
Scaling Elements Over Time on page 297 

If you want the bird to circle the boy’s 
head following the same path, you 
would loop its peg so that it lasts as 
long as the boy’s motion path.
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Building Peg Hierarchies
As you animate your characters and objects in Sceneplanning Mode, you will 
gradually create more complicated peg effects.  

In the following example, we created a scene of a boy walking across a lawn with a bird 
flying in circles over his head. The primary action is the motion of the two characters 
across the scene. The bird has another secondary action, that of circling the boy’s head. 

To achieve this effect, you must attach the bird and its peg to the boy’s peg, building 
what we call a peg hierarchy. In this example, the bird’s motion path is subordinate to 
the motion path of the boy.

Boy’s and Bird’s peg

To make sure the bird keeps pace 
with the boy, you would link the bird’s 
circular motion peg to the boy’s 
motion path.

Bird’s peg
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To build the peg hierarchy in this example, follow these steps:

1. Link the Boy element to a peg that defines a horizontal motion path.

2. Link the Bird element to a peg that makes the bird fly in circles around the boy.

3. Link the Bird’s peg to the Boy’s peg so that the bird moves across the scene as it 
flies in circles around the boy.

See Also
Exposure Sheet and Timeline Windows on page 354 
Adding Pegs and Attaching Elements to Pegs on page 261 

The following elements make up the peg hierarchy from 
this scene:

• The Boy element is attached to the Walking peg.

• The Bird element is attached to the Flying peg.

• The peg element is attached to the Walking peg.

Notice how the attached elements are indented below 
Walking, the primary peg.
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Creating Motion Paths with Pegs
When you add a peg to your animation, two key frames appear stacked on top of each 
other at the center point of the 3D scene space. The first key frame has an arrow that 
points right and the second key frame also has an arrow and it points left.  

You can grab a key frame with the Motion  tool and drag it in any direction to create 
a motion path that goes in a straight line. When you create a motion path, you’ll see 
that it is made up of a series of tick marks. Each tick mark represents a frame of time in 
the scene. 

To shape a motion path and change the direction elements attached to the peg will 
move, you add control points and key frames and change their position. Remember 
that creating a complex motion path does not affect the final file size of your output.

Because of the 3D stage in Sceneplanning Mode, you can create motion paths that go 
from east to west, north to south, or front to back. When your character moves front to 
back on a motion path, Toon Boom Studio™ automatically interpolates size changes 
as it moves closer to, or farther away from, the camera.   

The first and last key frame are 
identified with arrows that point in 
opposite directions

You can add control points 
and key frames to a peg at 
specific frames to change the 
direction of the motion path. 
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See Also
Creating a NS or EW Motion Path on page 269 
Creating a FB Motion Path on page 271 
Adding Motion Points to a Motion Path on page 273 
Changing the Velocity of a Motion Path on page 287 
Adding Pegs and Attaching Elements to Pegs on page 261 
Repositioning Elements on page 245 
Showing/Hiding Elements on page 355 

You can reposition pegs like you can change the position of most elements in the 3D 
space. When you reposition a peg, all elements attached to the peg also move. In 
addition, the values of points you add to your motion paths are based on the static 
position of the peg, plus the change in position to the motion point.  

The 3D stage windows were quite useful in designing 
the motion path of the skateboarder.

In the Camera View window, you can map out the 
east/west and north/south direction of the motion 
path.

In the Top View window, 
you can map out the 
front/back and east 
west direction of the 
motion path.

In the Side View window, 
you can map out the north/
south and front/back 
position of the motion 
path.
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Creating a NS or EW Motion Path
Motion is essential to transform your drawings and images from still life pictures to 
animated movies.  

In the Camera View window, you can stretch the peg to create a motion path that goes 
from north to south and east to west. All elements that are attached to the peg will 
follow the motion path of the peg.

To create NS and EW motion for a peg, follow these steps:

1. Click the peg's name in the Timeline window to select it. The peg appears in all 
View windows. You can hide other elements to make it easier to identify and 
modify pegs.

2. Select Tools > Motion. This activates the Motion  tool.

This motion path goes from south to 
north.

This motion path goes from west to east.

Drag the motion points at the start or end 
of the motion path to change the direction 
of the motion path.

N

S
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3. In the Camera View window, drag the motion points at the beginning or end of 
the motion path to give the motion path a direction. Your mouse pointer becomes 
a four-headed arrow when you position it over a motion point that you can move.
• Drag the motion points from left to right to create a path that goes from west 

to east.
• Drag the motion points from top to bottom to create a path that goes from 

north to south.

See Also
Showing/Hiding Elements on page 355 
Creating a FB Motion Path on page 271 
Adding Pegs and Attaching Elements to Pegs on page 261 
Changing the Start Time and Duration of a Peg on page 262 
Changing Elements Over Time with Pegs on page 260 

When you are creating motion paths, elements linked to a peg may be offset from the 
motion path. This can make it difficult to visualize how an element will change 
position as it follows the peg.

You can display peg ghosts in the Camera View window to see the path that an 
element linked to a peg will follow. To display peg ghosts:   

• Select View > Peg > Show Peg Ghosts.
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Creating a FB Motion Path
With the Toon Boom Studio™ 3D scene space, you can create multiplane effects for 
elements by creating motion paths that go from the front to the back of the scene.  

The Top View and Side View windows can help you visualize front/back (FB) motion. 
All elements appear as lines in the Top View and Side View.

To create FB motion, follow these steps:

1. Click the peg's name in the Timeline to select it. The peg appears in all View win-
dows. You can hide other elements to make it easier to identify and modify pegs.

2. Select Tools > Motion. This activates the Motion  tool.

3. Drag the motion points at the beginning or end of the motion path to give the 
motion path a direction. The mouse pointer becomes a four-headed arrow when 
you position it over a motion point that you can move.

Here’s a front to back motion 
path that goes from left to right in 
the Side View window.

F B

B

F

Here’s a front to back motion path that goes 
from bottom to top in the Top View window.
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The direction you drag the spline points depends on the window you are using.
• In Top View, you drag a motion point from top to bottom to change its FB 

position.
• In Side View, you drag a motion point from left to right to change its FB 

position.

See Also
Showing/Hiding Elements on page 355 
Creating a NS or EW Motion Path on page 269 
Adding Pegs and Attaching Elements to Pegs on page 261 
Changing the Start Time and Duration of a Peg on page 262 
Changing Elements Over Time with Pegs on page 260 
Basic Sceneplanning Concepts on page 238 

You can also change the FB motion of motion points in the Camera View window by 
pressing [Alt] as you move the motion points. 

• Press [Alt] and drag up to move the motion point backward.

• Press [Alt] and drag down to move the motion point forward.
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Adding Motion Points to a Motion Path
If you want to create a motion path that is not straight, you must add motion points to 
your motion path.   

Motion points can be either key frames or control points. Key frames are locked to a 
specific frame number and control points are not locked. 

• Add key frames when you want to lock the position of the motion path to a 
specific image in an element. 

• Add control points when you want your element to reach a specific position, 
but you don’t care when.

Then you can use the Motion  tool to move the motion points and change the shape 
of the motion path.

To add a motion point to a motion path, follow these steps:

1. Select a peg element in the Timeline window. The peg appears in all View win-
dows. You can hide other elements to make it easier to identify and modify pegs. 

2. Select Tools > Motion. This activates the Motion  tool.

3. Place the pointer over the motion path of the peg and decide which type of 
motion point you want to add.

The start/end control points don’t appear 
until you click the Motion  button. 

You can then drag the start/end motion 
points to change the shape of the motion 
path.
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• Press [Shift] and click the motion path to add a control point. The mouse 
pointer becomes a diamond when it is over a spot where you can add a 
control point. A green point appears on the motion path after you click. 

• Press [Alt] and click the motion path to add a key frame. The mouse pointer 
becomes a square when it is over a spot where you can add a key frame. A red 
point appears on the motion path after you click.

4. Drag the new point to a position where you want the motion path to be at that 
point. To nudge a motion point, you can also use the arrow keys. Press [Shift] if 
you want to move the motion point in larger increments. 

• If you added a control point, notice how it changes position on the motion 
path. This is because the control point is not locked to a specific time frame. 

• If you added a key frame, notice how it remains at the frame you added it to. 
This is because the key frame is locked at a specific time frame. 

See Also
Adding Motion Points with the Motion Point Tab on page 275 
Deleting Motion Points from a Motion Path on page 278 
Locking/Unlocking Control Points on page 279 
Changing Elements Over Time with Pegs on page 260 
Adding Pegs and Attaching Elements to Pegs on page 261 
Copying and Pasting the Values of Motion Points on page 280 

You can also add key frames to a motion path by using the Motion tool to drag the 
element that is attached to a peg. Toon Boom Studio™ adds a key frame at the frame 
selected with the frame slider in the Timeline window.

When you place the pointer over a motion point, the pointer 
changes to a move icon.

 The rest of the motion path changes 
to follow the motion point.
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Adding Motion Points with the Motion Point Tab
As you build your motion path, the easiest way is to add motion points is to use the 
Motion  tool. But if you want to place a control point on a specific frame, this method 
can be inaccurate.  

That’s when you can use the Motion Point tab to add control points to your motion 
path. Not only does this tab allow you to add a motion point at a specific frame, but 
you can also lock or unlock motion points or delete them from the peg.

To add motion points, follow these steps:

1. Select the peg you want to affect from the Timeline window. The peg appears in 
all View windows.

2. Select Tools > Motion. This activates the Motion  tool. The control points and 
key frames appears on the motion path. If there is no motion path in the peg, you 
will only see the first and last key frames stacked on top of each other in the View 
windows.

3. Click a motion point on the motion path. The Motion Point tab opens in the 
Properties window.

The Motion Point tab lists the properties of 
the motion point you have selected on the 
motion path.
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4. Click the New  button at the bottom of the Motion Point tab. The Add Motion 
Point dialog box opens.

5. Select the type of motion point you want to add from the Point type drop-list. 
You have the following choices:
• Key Frame: places a red key frame at the selected frame.
• Control Point: places a green control point at the selected key frame, but you 

can drag it to any other frame.

6. In the Frame field, type the frame number where you want to place the motion 
point and click OK. If you are adding a control point, you can enter a value with a 
decimal point.

See Also
Locking/Unlocking Control Points on page 279 
Deleting Motion Points from a Motion Path on page 278 
Adding Motion Points to a Motion Path on page 273 

Moving Motion Points with the Motion Point Tab
The Motion Point tab allows you to select individual motion points and change the 
size, angle, and offset position at that motion point. The Motion Point tab only appears 
when you select a key frame or control point with the Motion  tool.    

You may want to use the Motion Point tab if you have a peg with many motion points 
and they are too close together to select one accurately. Or, you might not be able to see 
the individual points because the motion path is not extended.

To change the properties of a motion point, follow these steps:

1. Select a peg in the Timeline window. The peg appears in all View windows.

2. Select Tools > Motion. This activates the Motion  tool. 

Use the Add Motion Point dialog 
box to add key frames or control 
points to your motion path.
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3. With the Motion tool, select a motion point on the motion path. The Motion Point 
tab opens in the Properties window.

4. Type the number of the frame that contains the control point or key frame you 
want to affect in the Frame field or select one using the < and > buttons (at the 
bottom of the Motion Point tab).

5. Type the position values in the Offset fields.
• To change the North/South position, type the position coordinates in the first 

Offset field followed by N for North or S for South. You can also use positive 
or negative numbers:

Positive values: places the element northward
Negative values: places the element southward

• To change the East/West position, type the position coordinates in the second 
Offset field followed by W for West or E for East. You can also use positive or 
negative numbers:

Positive values: places the element eastward
Negative values: places the element westward

• To change the Front/Back position, type the position coordinates in the third 
Offset field followed by F for Front or B for Back. You can also use positive or 
negative numbers:

Positive values: places the element to the front
Negative values: places the element to the back

See Also
Changing Elements Over Time with Pegs on page 260 
Creating Motion Paths with Pegs on page 267 
Adding Pegs and Attaching Elements to Pegs on page 261 

With the Motion Point tab, you can 
change the position of motion points to 
a precise value.
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Deleting Motion Points from a Motion Path
You can remove unnecessary motion points from your motion path. When you remove 
a control point or key frame, the path reshapes itself to follow the remaining points. 

You cannot remove the start and end key frames in any motion path.  

To delete a point with the pointer:

• Select the control point/key frame and press [Del]. 

To delete a point with the Motion Point tab, follow these steps:

1. Select any motion point. You can use the < and > buttons to select any point in 
order along the motion path.

If you know the exact frame number where the point is, you can type it in the 
Frame field and press [Enter].

When you select a point, it appears highlighted in the View windows.

2. Click Delete to remove the point.

See Also
Locking/Unlocking Control Points on page 279 
Moving Motion Points with the Motion Point Tab on page 276 
Adding Motion Points to a Motion Path on page 273 
Creating Motion Paths with Pegs on page 267 
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Locking/Unlocking Control Points
When you add a control point to a motion path, you can change its position to 
anywhere between the closest key frames. This not only changes the shape of the 
motion path, but can also slightly affect the velocity of the pegged element’s 
movement.  

However, if you need the element’s movement to change at a specific frame, you can 
lock the motion point at a specific frame number to create a key frame. 

Let’s say you had a character whose drawings changed drastically on specific key 
frames (for example, the character is pacing and he turns around at specific frames). If 
you wanted to plot a complex motion path for that character, you could lock the control 
points on the important frames and then change the shape of the motion path.

To lock/unlock your points, follow these steps:

1. Select a peg in the Timeline window. The peg appears in all View windows.

2. Select Tools > Motion. This activates the Motion  tool. 

3. With the Motion tool, select a motion point on the motion path. The Motion Point 
tab opens in the Properties window.

4. Use the Lock in time checkbox in the Motion Point tab to lock or unlock the 
point.

In this example, the clown 
drawings change at specific 
frames of 5, 24, and 30 and he 
suddenly turns around to walk 
in another direction.

Since these drawings occur at 
specific frames, we locked the 
control points to create key 
frames.
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• If you select the Lock in time checkbox, the control point locks itself to the 
current frame and turns red on the motion path. The control point now 
becomes a key frame.
If your control point is between frames, Toon Boom Studio™ selects the 
closest frame as the locked frame.

• If you deselect the Lock in time checkbox, the key frame becomes unlocked 
and turns green, indicating you can change its position. The key frame now 
becomes a control point.
The frame number may change as well since the spline adjusts its velocity on 
either side of the control point.

See Also
Changing the Velocity of a Motion Path on page 287 
Deleting Motion Points from a Motion Path on page 278 
Moving Motion Points with the Motion Point Tab on page 276 
Adding Motion Points to a Motion Path on page 273 
Creating Motion Paths with Pegs on page 267 

Copying and Pasting the Values of Motion Points
You can copy and paste the values of motion points to other motion points. This can 
save you lots of time, especially if you use the keyboard shortcuts to select motion 
points.        

There are two different ways to copy and paste the values of a motion point. 

• Basic Copy and Paste copies the position values of the copied point into the 
selected point.

• Paste Special allows you to copy additional values from the original point 
(including tension, continuity, bias, rotation, scale and pivot).
Because certain values can only be applied to key frames, the options in the 
Paste Special dialog box change based on the characteristic of the motion 
point that you select to receive the pasted values.

To copy and paste the position values of a motion point, follow these steps:

1. Select a peg in the Timeline window and select the motion point whose position 
values you want to copy. Use one of the following methods:

• Select Tools > Motion and click the motion point with the Motion  tool. 
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• Select Element > Motion Points > Previous Motion Point or Next Motion 
Point.

• Click the < and > buttons at the bottom of the Motion Point tab.

2. Select the motion point you want to copy the values to and select Edit > Paste 
Point. Toon Boom Studio™ copies the NS, EW, and FB values to the selected 
motion point.

To copy and paste selected values of a motion point, follow these steps:

1. Select a peg in the Timeline window and select the motion point whose position 
values you want to copy. Use one of the following methods:

• Select Tools > Motion and click the motion point with the Motion  tool. 
• Select Element > Motion Points > Previous Motion Point or Next Motion 

Point.
• Click the < and > buttons at the bottom of the Motion Point tab.

2. Select the motion point you want to copy the values to and select Edit > Paste 
Special. The Paste Special dialog box opens.

3. Select the values you want to paste into the selected motion point and click OK.

See Also
Creating Motion Paths with Pegs on page 267 
Rotating Elements Over Time on page 289 
Scaling Elements Over Time on page 297 
Changing the Pivot Point Over Time on page 303 
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Adjusting the Curve Between Motion Points
When you add a motion point and change its position, the motion path curves towards 
that point, reshaping the entire motion path. By default, the line has a gentle curve on 
either side of the control point.  

You can use the Tension, Bias, and Continuity sliders in the Motion Point tab to adjust 
the amount of curve on either side of a motion point, further customizing the segments 
of the motion path. 

You can adjust each point individually in your motion path, but if you press [Shift] 
while dragging the slider, the selected value applies to all the peg points. By default, 
each value starts at 0.0, but you can change the default value.

Tension: controls how sharply the path bends as it pass through a motion point. 

Continuity: controls the smoothness of a transition between the segments joined by a 
point. 

A Tension of -1 increases 
the curve on either side of 

the control point.

A Tension of +1 sharpens the 
curve on either side of the 

control point.

A Continuity of -1 sharpens 
the transition on either side 
of the control point.

A zero value creates 
a smooth transition.

A Continuity of +1 rounds out 
the transition, creating two 
gentle curves on either side 

of the control point.
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Bias: controls the slope of the path so that it flows towards one side of the motion point 
or the other. 

See Also
Defining the Default Tension, Continuity and Bias Values on page 283 
Adding Motion Points to a Motion Path on page 273 
Moving Motion Points with the Motion Point Tab on page 276 
Creating a FB Motion Path on page 271 
Creating a NS or EW Motion Path on page 269 
Copying and Pasting the Values of Motion Points on page 280 

Defining the Default Tension, Continuity and Bias Values
As you work on the shape of your motion path, you can change the default tension, 
bias, or continuity values using the Sceneplanning tab in the Preferences dialog box.  

Toon Boom Studio™ uses the values you select for all future motion points you add; 
existing motion points are not changed.

To define the default Tension, Continuity, and Bias values, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Sceneplanning tab.

A Bias of -1 favours the left 
side of the control point.

At zero, neither 
side of the point 
is favored.

A Bias of +1 favours the right 
side of the control point.
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3. Type the default values in any of the following fields. You can type any value 
between -1.0 and 1.0:
• Default Tension: controls how sharply the path bends as it pass through a 

motion point. 
• Default Continuity: controls the smoothness of a transition between the 

segments joined by a point. 
• Default Bias: controls the slope of the path so that it flows towards one side 

of the motion point or the other. 

4. Click OK when you are done. 

See Also
Adding Motion Points to a Motion Path on page 273 
Moving Motion Points with the Motion Point Tab on page 276 
Creating a FB Motion Path on page 271 
Creating a NS or EW Motion Path on page 269 
Adjusting the Curve Between Motion Points on page 282 
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Plotting the Motion Path in the 1D Editor
The 1D Editor window allows you to plot a motion path in each of the 3 dimensions, 
one dimension at a time. 

If you want to create a complex motion that is difficult to work out visually in the View 
windows, edit the motion path in the 1D Editor.

For example, let's say you want an element to move up and down, east and west, or 
back and forth along the same path. It would be difficult for you to map out this motion 
in the View windows because you cannot see the motion path through time. To make 
a motion that follows the same path repeatedly, you must use the 1D Editor. 

To plot the motion of a peg in the 1D Editor, follow these steps:

1. Select a peg in the Timeline window. The Properties window displays a series of 
tabs that allow you to edit different types of effects for the selected peg.

If the Properties window is not active, you can activate it by selecting Window > 
Properties.

2. Click the Motion tab in the Properties window. The Motion tab displays a 
preview of the plotline of the peg’s motion path.

In the Camera View window, you can see a motion 
path that appears to have only two key frames. In 
fact this motion path consists of multiple key 
frames, but you can’t see them because the 
motion path repeats over the same path.

In the 1D Editor (North/South Projection), you can 
see the north/south 
position of the motion 
point at each frame. 
The 1D Editor is ideal 
for modifying this type 
of motion path.
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3. Select the dimension you want to work in:

• Select the NS  button to map an element’s path from North to South.

• Click the EW  button to map an element’s path from East to West.

• Click the FB  button to map an element’s path from Front to Back.

4. Click Edit to edit the motion path in the selected dimension. The 1D Editor 
window opens.

5. Add control points to the plotline to plot the peg’s motion and click OK.

See Also
Positioning Pivot Points in the 1D Editor on page 309 
Creating Motion Paths with Pegs on page 267 
Working with the 1D and Function Editors on page 311 

If you haven’t made any changes to a 
peg’s NS/EW/FB position, the plotline in 
the Motion tab appears as a straight line 
at zero.

You can use these buttons 
to change dimensions.

The plotline represents the position of 
each motion point at each frame.

• The axis at the top of the plotline 
displays the frame number.

• The axis on the left of the plotline 
displays the position.
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Changing the Velocity of a Motion Path
The Function Editor window allows you to change the velocity of motion paths.    

The distribution of frame marks on a motion path in the Camera View window 
determines how fast a change is going to happen. 

• the closer together the frame marks, the slower the action
• the farther apart the frame marks, the faster the action

The Function Editor provides a number of preset acceleration changes that you can 
apply to your peg. In the Function Editor, velocity is represented by the curve of the 
plotline. 

To change the velocity of a peg, follow these steps:

1. In the Timeline window, select the peg whose velocity you want to modify. The 
Properties window displays a series of tabs that allow you to map different types 
of effects for the selected peg.

If the Properties window is not active, you can activate it by selecting Window > 
Properties.

The frame marks are concentrated at the end of the motion path, 
so the action will start fast and end really slow.

The frame marks on this motion path are concentrated at the 
start. This means that the action will start slow and end really 
fast.

The plotline to the left represents fast acceleration at the start 
of the motion and slow deceleration at the end.

The plotline to the right represents slow 
acceleration at the start of the motion and fast 
deceleration at the end.
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2. Click the Velocity tab in the Properties window. The Velocity tab displays a 
preview of the flowchart that maps out the selected peg’s speed.

3. Click Edit to modify the element’s velocity. The Function Editor window opens.

4. Change the velocity of the peg by adjusting the shape of the plotline in the 
Function Editor. You can select preset velocity settings from the Reshape menu 
or you can add and adjust key frames.

5. Click OK when done.

See Also
Working with the 1D and Function Editors on page 311 
Scaling a Peg with the Function Editor on page 301 
Creating Motion Paths with Pegs on page 267 
Changing Elements Over Time with Pegs on page 260 
Basic Sceneplanning Concepts on page 238 

The plotline in the Velocity tab represents 
the velocity of the selected peg. 

This plotline represents a velocity curve 
that eases-in and out.

You can use the Reshape options 
change the velocity of the peg with preset 
velocities.

The x-axis (horizontal axis) marks the frame 
number.

The y-axis (vertical axis) marks the percentage of 
distance covered.
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Rotating Elements Over Time
After you attach an element to a peg, you can create gradual changes to the rotation of 
the peg using the Rotate  tool. When the Rotate tool is active, the peg displays a 
rotation handle that you can use to rotate the peg and all attached elements. 

For example, let’s say you have an element that starts at frame 1 and ends at frame 30. 
If you wanted the element to rotate from 0 to 270 degrees by frame 20, and then rotate 
back to 90 degrees by frame 30, here’s what you would do:

• Attach the element to a peg and change the duration of the peg to 30.
• Select frame 1 and make sure there is no rotation on the peg (rotation angle of 

0 degrees).

• Select frame 20 and use the Rotate  tool to rotate the peg to 270 degrees.
• Select frame 30 and rotate the peg back to 90 degrees.

Frame 30: 90 degrees

Frame 1: 0 degrees Frame 20: 270 degrees
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When you play the scene back, the element rotates gradually from 0 degrees to 270 
degrees at frame 20 and then rotates back to 90 degrees by frame 30. In this example, 
the character is also moving from West to East over the 30 frames.

See Also
Rotating a Peg in the Camera View Window on page 291 
Rotating a Peg with the Motion Point Tab on page 293 
Rotating a Peg with the Function Editor on page 295 
Rotating Elements on page 255 

You can rotate pegs like you can most elements in the 3D space. When you rotate 
pegs, all elements attached to the pegs are also rotate. The rotation value of the peg 
appears on the Peg tab. Any rotation you add to key frames are based on the static 
rotation value of the peg plus the changes you make.
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Rotating a Peg in the Camera View Window
To change the angle of a pegged element, you can work in the Camera View window 
to rotate the element visually (you cannot change an element’s rotation in either the 
Top or Side View windows). You can select a frame, set the element’s angle, and Toon 
Boom Studio™ interpolates the element’s rotation between frames.  

To rotate a pegged element in the Camera View window, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows.

2. Select Tools > Rotate. This activates the Rotate  tool. The rotation handle 
appears on the selected peg at the current frame in the Camera View window.

If the motion path is visible in 
the Camera View window, it 
appears at the selected frame 
on the peg.

If there is a motion path for the peg, you 
will see the motion path.

If there is no motion path, the rotation 
handles will appear over the center of 
the peg.
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3. In the Timeline window, drag the red frame slider to the frame where you want 
the element to complete its rotation. 

4. In the Camera View window, use the rotation handle to change the rotation of the 
element. Toon Boom Studio™ interpolates the pegged element’s rotation for the 
other frames so that it ends on the selected angle.
• Press [Shift] to rotate the peg at 15 degree increments.
• If you drag the element attached to the peg, you will move the pivot point.

5. Repeat steps 3 and 4 for every rotation you want to apply to the peg.

Each time you set the rotation of a peg at a specific frame, Toon Boom Studio™ 
adds a rotation key frame that does not appear on the motion path. However, you 
can see these rotation points on the Rotate tab in the Properties window.

See Also
Rotating a Peg with the Function Editor on page 295 
Changing Elements Over Time with Pegs on page 260 
Rotating a Peg with the Motion Point Tab on page 293 
Copying and Pasting the Values of Motion Points on page 280 
Rotating Elements on page 255 

You can show element arms when you are rotating a peg that you have attached 
multiple elements to. When you show element arms, a rotation handle appears on 
each element attached to the peg. To display element arms:

• Select View > Peg > Show Element Arms.

This is the frame slider.

Use the rotation handle to change 
the angle of the peg.
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Rotating a Peg with the Motion Point Tab
You can use the Motion Point tab to change the rotation of a peg at specific key frames.   

You may want to use the Motion Point tab if you have a peg with many key frames that 
are too close together to select one accurately. Or, you might not be able to see the 
individual points because the motion path is not extended into a motion path.

The Motion Point tab only appears when you use the Motion  tool to select one of the 
motion points on the motion path. You can only change the rotation value for a key 
frame, not a control point.

To rotate a peg using the Motion Point tab, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows.

2. Select Tools > Motion. This activates the Motion  tool. All motion points appear 
on the motion path. 

3. Click one of the motion points on the peg to display the Motion Point tab.

4. In the Frame field, type the number of the frame that contains the key frame you 
want to rotate or select one using the < and > buttons (at the bottom of the Motion 
Point tab).
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5. In the Rotation field, type the angle of rotation.
• To rotate the element to the right, type a positive degree value.
• To rotate the element to the left, type a negative degree value.

If you want your peg to rotate multiple times, enter a value over 360 degrees. 
Just remember, one full rotation is 360 degrees.

The peg will rotate in the Camera View window as soon as you make the change to 
the rotation angle.

See Also
Rotating a Peg with the Function Editor on page 295 
Changing Elements Over Time with Pegs on page 260 
Rotating a Peg in the Camera View Window on page 291 

Key frames do not have a decimal 
value.

The Lock in Time field is also 
selected when you select a key 
frame.
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Rotating a Peg with the Function Editor
The Function Editor allows you to change the rotation of an element over the duration 
of the peg.  

The Function Editor allows you to plot a peg’s rotation over time and using a plotline 
that gives you greater control over the specific rotation values as well as the speed of 
the rotation.

Also, if you use the peg in the Camera View window to add rotation key frames, the 
only way to precisely remove or modify these key frames is by using the Function 
Editor because the key frames for rotation do not appear on the motion path.

To define the rotation motion of a pegged element, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows. 
The Properties window displays a series of tabs that allow you to set up different 
types of effects for the selected peg.

If the Properties window is not active, you can activate it by selecting Window > 
Properties.

2. Click the Rotation tab in the Properties window. The Rotation tab displays a 
preview of the flowchart that maps out the selected peg’s rotation path.

There are three key frames 
visible in this plotline for the 
selected peg.
295



Rotating Elements Over Time
3. Click Edit to modify the peg’s rotation angle. The Function Editor window 
appears.

4. Change the element’s angle of rotation by adjusting the plotline in the Function 
Editor. 

You can add key frames and change the shape of the plotline as it passes through 
these points. The Reshape options change the shape of the curve between two 
key frames and affects the speed of the rotation.

5. Click OK when done.

See Also
Rotating a Peg in the Camera View Window on page 291 
Working with the 1D and Function Editors on page 311 

The rotation angle

The number of frames 
in your scene 
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Scaling Elements Over Time
After you attach an element to a peg, you can create gradual changes to the size of the 
peg using the Scale  tool. When the Scale  tool is active, the peg displays square 
scaling handle that allows you to stretch or shrink the size of the peg and all attached 
elements.   

For example, let’s say you have an element that starts at full size at frame 1, shrinks to 
half-size at frame 10, and grows to twice its original size by frame 20. Here’s an 
example of what you would do:

• Attach the element to a peg and change the duration of the peg to 20.
• Select frame 1 and make sure there is no scale change to the peg.
• Select frame 10 and use the Scale  tool to reduce the peg to half its original 

size.
• Select frame 20 and stretch the peg to twice its original size.

When you play the scene back, the element changes size gradually from full size to 
reduced size at frame 10 and then to much larger by frame 20. In this example, the 
character is also moving from West to East over the 20 frames.

See Also
Scaling a Peg in the Camera View Window on page 298 
Scaling Elements on page 250 
Changing Elements Over Time with Pegs on page 260 

You can also scale pegs like you can most elements in Sceneplanning Mode. When 
you scale pegs, all elements attached to the pegs also resize. The scale value of the 
peg appears on the Peg tab. Any scale change you add to key frames are based on the 
static scale value of the peg plus the changes you make.

Frame 1: scale factor 1

Frame 10: scale factor 0.5

Frame 20: scale factor 2
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Scaling a Peg in the Camera View Window
You can change the size of a peg visually in the Camera View window (you cannot 
scale an element in either the Top or Side View windows). You can select a frame, set 
the element’s size, and Toon Boom Studio™ interpolates the element’s change in size 
between frames.     

To scale a peg in the Camera View window, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows. 

2. Select Tools > Scale. This activates the Scale  tool. The square scaling handle 
appears on the selected peg at the current frame.

If the motion path of the peg is visible in 
the Camera View window, it appears at 
the selected frame on the peg.

If there is a motion path for the peg, 
you will see the motion path.

If there is no motion path, the resize 
handles will appear over the center 
of the peg.
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3. Drag the frame slider to the frame where you want to resize the pegged element.

4. Use the scale handles to resize the peg’s height, width or both. Press [Shift] to 
maintain the proportions of the element as you scale it.

Toon Boom Studio™ interpolates the peg’s size for the other frames so that it 
ends on the scale you select.

Each time you set the size of a peg at a specific frame, Toon Boom Studio™ adds a 
scaling key frame that does not appear on the motion path. However, you can see 
these scale points using the HScale and VScale tabs in the Properties window.

5. Repeat steps 3 and 4 for every scale change you want to apply to the peg.

See Also
Scaling a Peg with the Function Editor on page 301 
Scaling a Peg in the Motion Point Tab on page 299 
Changing Elements Over Time with Pegs on page 260 
Creating Motion Paths with Pegs on page 267 
Rotating Elements Over Time on page 289 
Copying and Pasting the Values of Motion Points on page 280 

Scaling a Peg in the Motion Point Tab
You can use the Motion Point tab to scale a peg at specific key frames.    

You may want to use the Motion Point tab if you have a peg with many key frames that 
are too close together to select one accurately. Or, you might not be able to see the 
individual points because the motion path is not extended into a motion path.

The Motion Point tab only appears when you use the Motion  tool to select one of the 
control points/key frames on the motion path. You can only change the rotation value 
for a key frame, not a control point.

This is the frame slider.
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To scale a peg using the Motion Point tab, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows. 

2. Select Tools > Motion. This activates the Motion  tool. All motion points appear 
on the motion path. 

3. Click one of the motion points on the peg to display the Motion Point tab.

4. Select the key frame you want to modify using one of the following methods:
• In the Frame field, type the number of the frame that contains the key frame 

you want to scale or select one using the < and > buttons (at the bottom of the 
Motion Point tab).

• Select Element > Motion Points > Previous Motion Point or Next Motion 
Point.

5. Type the scale size in the Scale fields.
• To change the height of the element, type the height value in the left Scale 

field. 
• To change the width of the element, type the width value in the right Scale 

field. 

See Also
Scaling a Peg with the Function Editor on page 301 
Scaling a Peg in the Motion Point Tab on page 299 
Changing Elements Over Time with Pegs on page 260 
Rotating Elements Over Time on page 289 

The Scale fields are active only when you 
select a key frame:

• The height value is in the left field.

• The width value is in the right field.
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Scaling a Peg with the Function Editor
The Function Editor allows you to plot a change in angle of an element over time, using 
a plotline that gives you greater control over the specific scale values as well as the 
speed of the scale change.    

Also, if you use the peg in the Camera View window to add scaling key frames, the 
only way to precisely remove or modify these key frames is by using the Function 
Editor because the key frames for rotation do not appear on the peg.

To scale a peg using the Function Editor, follow these steps:

1. Select the peg in the Timeline window. The peg appears in the View windows. 
The Properties window displays a series of tabs that allow you to set up different 
types of effects for the selected peg.

If the Properties window is not active, you can activate it by selecting Window > 
Properties.

2. Select the type of scaling change you want to make from the following two tabs:
• Click the HScale tab to make changes to the element’s horizontal size (the 

width).
• Click the VScale tab to make changes to the element’s vertical size (the 

height).

3. Depending on the tab you select, the HScale/VScale tab displays a preview of 
the plotline that maps out the scale change of the peg.

There are three key 
frames visible in this 
plotline for the selected 
peg.
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4. Click Edit to modify the element’s scale. The Function Editor window appears.

5. Select the type of plotline you want to use to map the change in scale from the 
Curve Type drop-list. You can select one of two options:
• Spline: you can control the velocity of scaling changes by reshaping the 

plotline.  
• Velocity-based: you can link the velocity of scale changes to the element’s 

velocity.   
This option is useful when an element is moving at a specific speed and you 
want it to change its scale with the same speed.

6. Change the element’s scale factor by adjusting the plotline in the Function Editor 
and click OK when done.

You can add key frames and change the shape of the plotline as it passes through 
these points. If you select the Spline option, you can use the Reshape options to 
change the shape of the curve between two key frames and affect the speed of the 
scale change. 

See Also
Scaling a Peg in the Camera View Window on page 298 
Working with the 1D and Function Editors on page 311 
Scaling a Peg in the Motion Point Tab on page 299 
Changing Elements Over Time with Pegs on page 260 
Creating Motion Paths with Pegs on page 267 
Rotating Elements Over Time on page 289 

The axis on the top of the window 
displays the number of frames in your 
scene. 

The axis on the left of the window 
displays the scale factor.
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Changing the Pivot Point Over Time
The peg has it own rotational and scaling pivot point. If you don’t modify it, the pivot 
point remains at the center of the peg for its duration. You can choose to move the pivot 
point for a rotation or a scaling effect.  

Let’s say that you have a character that is rotating as it follows a motion path. However 
the center of the motion path is at the character’s feet and you want the character to 
spin on his hand. You would move the pivot point to the character’s hand at the first 
and last frame so that the pivot point remains on his hand for the duration of the peg.

As this skateboard zooms along, we want him to spin on his 
hand, not on the center of the peg. 

So we moved the pivot point at the first frame and the last 
frame so that it would stay in the same position as the skater 

rotates on it.

The line that runs parallel to the motion path is 
the path of the pivot point. You can see that it 
stays in the same spot on the skateboarder’s 
body as he moves to the right.
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You can apply the pivot point to either rotation or scaling, not both. You use the Apply 
Pivot To option in the Peg tab to apply the moving pivot to either the scale or rotation. 
The pivot point stays at the center of the peg for the effect you do not apply the pivot 
point change to.

You would move the pivot point for a scale change if you wanted the center of the scale 
change to be on a point other than the center of the peg.

See Also
Positioning Pivot Points in the Camera View on page 305 
Positioning Pivot Points in the Motion Point Tab on page 307 
Positioning Pivot Points in the 1D Editor on page 309 
Changing Elements Over Time with Pegs on page 260 
Working with the 1D and Function Editors on page 311 
Basic Sceneplanning Concepts on page 238 

You use the Apply Pivot To option to 
move the pivot point for either rotation or 
scaling.

You can see by the straight pivot path that 
the position of the pivot will stay on the shark’s 
tail from frame 1 to 20.

We moved the pivot point to the tail of 
the shark from the center of the peg.
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Positioning Pivot Points in the Camera View
If your peg has a motion path that you can see in the Camera View window, you can 
make changes to the pivot point directly in the Camera View window. However, if you 
can’t see the motion path clearly, then you should use the Pivot Point tab in the 
Properties window to position its pivot points. 

To edit the pivot path with the Camera View window, follow these steps:

1. In the Timeline window, select the peg that has the pivot point you want to move 
over time.

2. Select the Peg tab in the Properties window and decide which effect you want to 
apply the pivot point to:
• Select the Rotation radio button to change the rotation pivot point.
• Select the Scaling radio button to change the scaling pivot point.

The pivot point of the effect you do not select stays centered on the peg.

3. Based on your selection in the Peg tab, select the appropriate tool.
• To change the rotation pivot point, select Tools > Rotate. The Rotate  tool 

becomes active and the rotation handle appears on the selected peg at the 
current frame.

• To change the scaling pivot point, select Tools > Scale. The Scale  tool 
becomes active and the scale handle appears on the selected peg at the current 
frame.

4. Select View > Peg > Show Pivot Path so that you can see how the pivot will 
move over the duration of the peg.
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5. Use the active tool to drag the pivot point to the position you want. 
• By default, moving the pivot point moves the entire pivot path.
• To add key frames to the pivot path so that you can change the position of the 

pivot point dynamically, select the frame with the frame slider in the Timeline 
window and press [Shift] as you move the point.
The graph on the Pivot Path tab is updated as you move the pivot point.

6. Repeat steps 5 and 6 until you have created the pivot point path you want. You 
can use the 1D Editor to correct the motion path of the pivot point.

See Also
Positioning Pivot Points in the 1D Editor on page 309 
Positioning Pivot Points in the Motion Point Tab on page 307 
Changing Elements Over Time with Pegs on page 260 
Copying and Pasting the Values of Motion Points on page 280 

When you change the frame number and 
drag the pivot point, it adds a pivot key 
frame, reshaping the pivot path.

In this example, we gave the pivot point the same 
value at the first frame and the last frame so that it 
would stay in the same position on the character 
throughout the rotation.
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Positioning Pivot Points in the Motion Point Tab
If the key frames of a peg are too close together to select individually, or the motion 
path is not extended and you cannot see the individual points, use the Motion Point 
tab. 

The Motion Point tab lets you select key frames in a peg and modify the position of the 
peg’s pivot point. 

The Motion Point tab only appears when you select a motion point with the Motion  
tool. You can only change the pivot point position at key frames.

To change the position of a pivot point using the Motion Point tab, follow these 
steps:

1. In the Timeline window, select the peg that has the pivot point you want to move 
over time.

2. Select View > Peg > Show Pivot Path so that you can see in the Camera View 
window how the pivot will move over the duration of the peg.

3. Select Tools > Motion. This activates the Motion  tool. All motion points appear 
on the motion path. 

4. Click one of the motion points on the peg to display the Motion Point tab.

5. In the Frame field, type the number of the frame that contains the key frame you 
want to modify or select one using the < and > buttons (at the bottom of the 
Motion Point tab).
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6. Type the pivot point position in the Pivot Point fields.
• NS position: type the vertical position value in the left Pivot Point field. 
• EW position: type the horizontal position value in the right Pivot Point field. 

See Also
Positioning Pivot Points in the 1D Editor on page 309 
Positioning Pivot Points in the Camera View on page 305 
Changing Elements Over Time with Pegs on page 260 

The Pivot point fields display the 
north/south and east/west 
values for the pivot point.
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Positioning Pivot Points in the 1D Editor
Use the 1D Editor to map out the pivot point path if there is no motion path on the peg 
or the path is not visible in the Camera View window. 

For example, if you had a character that jumped up and down in place, the motion path 
would most likely stretch up and down in the same spot, making it difficult to 
distinguish one frame from another in the motion path. 

The 1D Editor allows you to edit the pivot point path along the North/South or East/
West axes. If you had a motion path shaped like the one in the example, you could see 
its path in the 1D Editor since it displays the change of position in relation to the frame 
time.

To edit the pivot path with the 1D Editor window, follow these steps:

1. In the Timeline window, select the peg that has the pivot point you want to move 
over time.

2. Select View > Peg > Show Pivot Path so that you can see in the Camera View 
window how the pivot will move over the duration of the peg.

3. Select the Peg tab in the Properties window and decide which effect you want to 
apply the pivot point to:
• Select the Rotation radio button to change the rotation pivot point.
• Select the Scaling radio button to change the scaling pivot point.

The pivot point of the effect you do not select stays centered on the peg.

4. Select the Pivot Point tab in the Properties window and click Edit. The 1D 
Editor window opens.

In the Pivot Point tab, you can see that the 
first and last key frames do not have exactly 
the same value.

You can use the 1D Editor to make those 
values the same.
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5. Select the dimension you want to edit.

• North/South : moves the pivot point up or down

• East/West : moves the pivot point left or right.

6. Change the path of the pivot point by changing the values of existing key frames 
or key frames that you add in the 1D Editor. 

See Also
Positioning Pivot Points in the Motion Point Tab on page 307 
Positioning Pivot Points in the Camera View on page 305 
Changing Elements Over Time with Pegs on page 260 
Working with the 1D and Function Editors on page 311 

The x-axis (horizontal axis) marks 
the frame number.

The y-axis (vertical axis) marks the 
position of the pivot point relative to 
the motion path.
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Working with the 1D and Function 
Editors

The Function Editor and the 1D Editor use plotlines to represent changes to properties 
over time.   

With the Function Editor, you can map the values of an effect over a set number of 
frames.

• Along the x-axis (horizontal axis) are the frame numbers.
• Along the y-axis (vertical axis) are the values for the effect you are editing 

(rotation, horizontal and vertical scale, velocity and field-of-view).

You can modify how quickly a change (such as rotation, scale or velocity) occurs by 
modifying the shape of the plotline.

The slope of the plotline in the Function Editor 
represents the velocity of an effect.

• A steep slope indicates that the value 
will change quickly.

• A gradual slope indicates that the value 
will change gradually.
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The 1D Editor allows you to map the movement of a peg in a 3-dimensional space or a 
pivot point in 2-dimensional space, one dimension at a time. The 1D Editor presents 
different views of the plotline so that you can isolate specific directions in the motion 
path to make precise changes at specific frames.  

For example, let's say that you want your character to jump up and down in place. It 
would be difficult to create a jumping motion path in the Sceneplanning View 
windows because the path would repeat on top of itself. To create a jumping motion, 
it would be easier to edit the motion path of the peg using the 1D Editor.

Like the Function Editor, you can use the 1D Editor to map the values of an effect over 
a set number of frames.

See Also
Adding Key Frames and Changing their Value on page 313 
Reshaping the Plotline in the Function Editor on page 315 
Changing Your View of the Editor Window on page 317 

Along the x-axis (horizontal axis) are the 
frame numbers.

Along the y-axis (vertical axis) are the 
values for the effect you are editing 
(motion path and pivot path).

The Projection panel allows 
you to choose the dimension 
you want to edit.
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Adding Key Frames and Changing their Value
You add key frames to a plotline in either the Function Editor or in the 1D Editor when 
you want to create an effect.     

Here are two examples of when you would add a key frame to a plotline.

Example 1: Function Editor

Let's say that you have an object that you want to rotate to 450 degrees to the right 
between frames 1 and 5. Then, rotate 200 degrees to the left and finally back to zero 
rotation. 

After you attach the element to a peg, you would access the Function Editor from the 
Rotation tab, add key frames at each frame, and then change the rotation value of the 
key frames to the desired rotation angle. 

This plotline represents 
the rotation of the element 
over 20 frames
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Example 2: 1D Editor

For this example, let's say that you want your character to jump up and down in place.

Open the 1D Editor from the Motion tab. In the north/south projection of the plotline, 
add key frames at each frame where you want the character's motion to be up or down. 
Then, move the key frames on the plotline to create the jumping effect.

To add key frames to a plotline and change their value, follow these steps:

1. Select the frame on the plotline where you want to add a key frame. You can use 
one of the following methods.

• Activate the Select  tool from the Tools panel and click the frame in the 
plotline.

• Type the value in the x-axis field of the Function Values panel.

2. Click the Add  button in the Tools panel.

The key frame appears at the frame number you selected. Now you can change 
the value of the key frame you added.

In this plotline, you can see how the peg 
changes north/south position. 

This path would be difficult to edit in the 
Camera View window because it repeats on 
itself. The 1D Editor is the perfect tool for 
editing this type of motion path because it 
isolates motion in a particular dimension.
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3. Click and drag the point to the new y-axis value. Notice that the y-axis value 
changes in the Function Values panel. To get a more precise value, you can type 
the value in this field.

The shape of the curve you create reflects the speed of the effect you are creating.
• In the Function Editor, you can change the shape of the plotline to create 

different velocity effects (like ease-in and ease-out). 
• When you are working with an effect in the 1D Editor, you can modify the 

speed of a change by accessing the Function Editor from the Velocity tab. 

See Also
Changing the Velocity of a Motion Path on page 287 
Reshaping the Plotline in the Function Editor on page 315 
Changing Your View of the Editor Window on page 317 

Reshaping the Plotline in the Function Editor
You can change the shape of the plotline in the Function Editor when you want to 
change how quickly an effect (such as rotation, scale or velocity) is applied to the peg 
and other elements attached to it.  

The Function Editor provides pre-set reshape functions that you can apply to your 
plotline to change its shape. For example, if you wanted an effect to ease-in and ease-
out, you could use one of the ease functions to change the plotline.

• Constant:  applies the value you have selected on the horizontal axis (y-
axis) to the segment or plotline.

• Ease in/out : applies a gradual acceleration to the beginning, and a gradual 
deceleration to the end, of the segment or plotline.

• Extreme ease in/out :applies a more gradual acceleration to the 
beginning, and a more gradual deceleration to the end, of the segment or 
plotline.

• Linear:  applies a constant change to the segment or plotline.

• Fast in/out : applies a fast acceleration to the beginning and end of the 
segment or plotline.

• Extreme fast in/out : applies an even faster acceleration to the beginning 
and end of the segment or plotline.

• Slow acceleration : applies a slow acceleration to the segment or plotline.
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• Slow deceleration : applies a fast acceleration to the segment or plotline.
You can also make changes to the shape of your plotline manually. However, when 
you use the pre-set functions in the Function Editor, Toon Boom Studio™ does the 
work for you!

To reshape the plotline in the Function Editor using the Reshape Functions, 
follow these steps:

1. Click the Select  button in the Tools panel. 

2. Select the segment of the plotline you want to reshape.
• If you want to reshape only one segment, click anywhere along the segment.
• If you want to reshape all segments on the plotline, click anywhere on the 

plotline.

3. To create segments on the plotline, you must add key frames.

4. Decide if you want to apply a change to a segment or the whole plotline.
• To reshape only the segment you selected, select any of the options in the 

Reshape menu.
• To reshape all segments in the plotline with the same function, press [Ctrl] 

and select one of the options in the Reshape menu.

To manually reshape the plotline in the Function Editor, follow these steps:

1. Click a key frame on the plotline. Handles appear on either side of the point you 
select.

2. Decide if you want to move both handles independently of each other or together.
• To move a handle independently of the other handle, drag the point at the 

end of the handle to its new position.
• To move both handles together, press [Alt] and drag the points to their new 

position.

The Left and Right Handle  and Angle  fields also display the position and the 
angle of the key frames. You can also use these fields to set precise position/angles.

See Also
Adding Key Frames and Changing their Value on page 313 
Changing Your View of the Editor Window on page 317 
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Changing Your View of the Editor Window
As you plot values for the selected peg, you can change how the Editor window 
displays the plotline and what it represents. You can change the scale of the vertical 
and horizontal axes, change the zoom detail on the plotline, or view a different section 
of the plotline itself.  

To change your view of the Editor window, use any of the following tools:

• Zoom  tool: you can increase the detail on the plotline by either clicking on 
a general area or drag-selecting an area to view. To zoom out, press [Alt] and 
click the plotline.

• Fit  button: resizes the view in the Editor window so that the plotline fills 
the viewable space. 

• Grabber  tool: you can view another part of the window by grabbing a part 
of the plot area and dragging to another place. 

• Grid  button: you can toggle a grid that appears behind the plotline to mark 
each notch on the horizontal and vertical axes.

• Horizontal/Vertical zoom sliders: you can change the detail level in the 
horizontal and vertical axes and see more or fewer values.

Dragging the zoom sliders 
changes the horizontal or vertical 
zoom factor.
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Chapter 9
Using the Multiplane Camera

This chapter explains how to use the scene camera. You’ll learn 
how to change the static properties of a camera as well as how to 
change its properties over time.

In this chapter, you will learn how to:

• Camera Effects with Toon Boom Studio on page 320 

• Adding Cameras to a Scene on page 322 

• Zooming the Camera In or Out on page 327 

• Zooming the Camera Over Time on page 329 

• Panning and Trucking the Camera on page 336 



Camera Effects with Toon Boom Studio
Camera Effects with Toon Boom Studio

Like traditional animation, cameras in Toon Boom Studio™ capture a view of your 
scene that will playback for your audience. You can use cameras to frame your scenes 
just as you do when you take a picture or film a movie. 

With Toon Boom Studio™, you can:   

• Reposition cameras
You can reposition a camera to get a specific view of a scene. For example, if 
you want your audience to view the action in the center of a large forest scene, 
you would reposition your camera to view only that area of the scene.

• Zoom cameras in or out
You can change the field-of-view (FOV) of the camera for the entire duration 
of the scene. If you wanted your whole scene to focus on the face of one 
character as she spoke, you could set the zoom level of the camera to exclude 
all other characters and action in your scene.

• Zoom cameras dynamically throughout your scene

In this scene, the camera pans 
across the scene to follow the 
snowboarder.

The Camera View window shows you how 
the scene looks to your camera. 

The red tint and frame identify the camera 
when you select it.
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You can also change the zoom level dynamically throughout your scene to 
create complex zooming effects. For example, you can start a scene with a 
close-up of a character and then zoom-out to see all of the action in your 
scene.

• Pan cameras across or up and down your scene, or truck cameras in and out
Creating pans and trucks with the camera is a breeze when you attach 
cameras to pegs and then create motion effects on the pegs. You can create the 
effect of moving through your scene by attaching a camera to a peg and then 
giving the peg front to back motion through your scene.

To add camera effects to your scene, you must be in Sceneplanning Mode. 

To switch to Sceneplanning Mode:

• Click the Sceneplanning Mode  button or select View > Sceneplanning 
Mode. 
If you are already in Sceneplanning Mode, the command in the View menu 
reads as Drawing Mode.     

See Also
Adding Cameras to a Scene on page 322 
Zooming the Camera In or Out on page 327 
Zooming the Camera Over Time on page 329 
Panning and Trucking the Camera on page 336 
Basic Sceneplanning Concepts on page 238 
Changing Elements Over Time with Pegs on page 260 
321



Adding Cameras to a Scene
Adding Cameras to a Scene

Toon Boom Studio™ adds a camera element, which you can zoom, pan and truck, to 
all of your scenes. 

You can create additional cameras in your scene to try different framing. After you add 
a camera, you use the Camera drop-list in the Scene View toolbar to select the camera 
you want to use to see your scene and to change the framing of that camera. When you 
export your scene, Toon Boom Studio™ films the scene from the perspective of the 
selected camera only.   

There is also a default scene camera, which does not appear in the Timeline window. 
You cannot change the properties of the default camera. If you want to create any 
camera effects, you must add camera elements.

In these windows, the active camera is 
represented by the black square surrounding 
the snowboarder

In the window on the left, the secondary camera 
is represented by the black dot in the corner of 
the window.

When a secondary camera is offset from the main camera and you 
select it in the Timeline window, Toon Boom Studio™ displays a 
cone, which represents the angle that the secondary camera has 
on the scene.

To see exactly what secondary cameras see of your scene, you 
must select the camera from the Camera drop-list on the Scene 
View toolbar.
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To add a camera to the scene, follow these steps:

1. Select Element > New > Camera Element. You can also click the Contextual 
Menu button in the top-right corner of the Timeline window and select New > 
Camera from the pop-up menu. 

A new camera element appears in the Timeline window and in the Camera 
drop-list in the Scene View toolbar. Toon Boom Studio™ gives the camera a 
default name.

The composition order of the camera in the Timeline window does not affect the 
output of your final movie. 

2. Select the new camera from the Camera drop-list on the Scene View toolbar. 
The contents of the Camera View window changes to show the view this camera 
has.

See Also
Adding Many Elements to a Scene on page 373 
Renaming Elements on page 379 
Deleting Elements on page 380 

You can place the camera 
at any layer in the Timeline 
window.

This is the view that the 
secondary camera has of the 
same scene. 
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Positioning a Camera
You can change the north/south, east/west and front/back position of cameras you 
add to a scene just like you can change the position of any other element in 
Sceneplanning Mode. 

If you wanted to see only the action that was taking place on the west side of your 
screen, you would add a new camera and move it so that it sees only that part of the 
scene.

You can change the position of a camera in any of the Sceneplanning View windows 
(Camera View window, Side View window and Top View window). The camera’s 
field of view appears as a cone in the Top and Side View windows.

In the Camera View window you can 
change the north/south position of a 
camera by dragging up and down.

You can also change the east/west 
position of a camera by dragging from 
the left to the right.
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• In the Side View window, you change the front/back position of the camera 
by dragging from left to right. You change the north/south position of the 
camera by dragging from the top to the bottom.

• In the Top View window, you change the front/back position of the camera 
by dragging from the top to the bottom. You change the east/west position by 
dragging from left to right.

To change the position of a camera, follow these steps:

1. Add a new camera element to your scene.

2. From the Window menu, select the window to display.
• Select Camera View to change the north/south and east/west position of the 

camera. You can also change the front/back position in this window by 
holding down [Alt] while you drag up (back) or down (front).

• Select Side View to change the north/south and front/back position of the 
camera. 

• Select Top View to change the east/west and front/back position of the 
camera.
The camera in both the Side View and Top View windows is represented by 
a cone, which reflects the field-of-view that the camera has on the scene. The 
camera “films” all elements that are within the field-of-view.

3. Select Tools > Select to activate the Select  tool.

You can view the same scene from two 
different perspectives.
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4. Select the camera. Use one of the following methods:
• Use the Select tool to click the camera frame in any of the View windows.
• Click the camera's name in the Timeline window. 
• If the camera is an inactive secondary camera, you can click the dot that 

represents the camera to select and move it.

The camera’s frame and field of view tints red when you select it.

5. Drag the camera frame to the position you want.
Notice that the Offset values in the Camera tab change as you move the camera. You 
can also manually type values into these fields to change the position of the camera.

See Also
Adding Cameras to a Scene on page 322 
Changing an Element’s Start Time in the Timeline on page 402 
Repositioning Elements on page 245 

The Offset fields record the north/south, 
east/west and front/back position of the 
camera.

You can type values in these fields to 
change the position of the camera.
326 



Chapter 9: Using the Multiplane Camera
Zooming the Camera In or Out
You change the field-of-view (FOV) of a camera when you want to zoom the camera in 
or out on a character or object in your scene. Use the Camera View window to make 
changes to the FOV of a camera and see how the change affects the framing of your 
scene.

When you want to give the camera one zoom level for the entire scene, your zoom level 
will be static. You can also create dynamic camera zooms throughout your scene.    

To zoom a camera in or out, follow these steps:

1. Add a new camera element to your scene.

2. Select the camera. Use one of the following methods:

• Select Tools > Select, and use the Select  tool to click the camera frame.
• Click the camera's name in the Timeline window. 

In the Camera View window, the camera frame and background is highlighted in 
red. A handle appears on the bottom of the camera frame.

3. Select the Static option in the FOV tab in the Properties window.

When you select this option, the FOV of the camera stays constant throughout the 
scene.

In this scene, we’ve changed the 
zoom level of the camera to 
focus on the surfer and the shark.
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4. With the Select tool, use the handle on the bottom of the camera frame to change 
the zoom level of the camera.
• Drag the handle to the left to zoom-in on the scene.
• Drag the handle to the right to zoom-out on the scene.

As you change the zoom level, the value in the Static field on the FOV tab (in the 
Properties window) changes. You can also type a value in the Static field for a more 
precise FOV value. 

When you change the FOV, you are actually changing the angle of view on your scene. 

• If you make the field of view smaller, the camera represents a smaller amount 
of the full scene in the same size camera, which creates the zoom effect.

• If you look in the Top View window or in the Side View window as you 
change the field of view, you can see how the angle of your camera changes.

See Also
Adding Cameras to a Scene on page 322 
Positioning a Camera on page 324 
Changing the Start Frame and Duration of a Dynamic Camera on page 332 
Creating Zoom Effects with the Function Editor on page 334 

Drag the handle below the camera frame 
to change the zoom level of the camera.
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Zooming the Camera Over Time
You can change the FOV of a camera at different frames throughout your scene to 
create dynamic camera zooms. 

You can use the Camera View window to make changes to the FOV of a camera and 
see how the changes affect the zoom level of your scene.

Toon Boom Studio™ smooths the transition 
between camera zoom levels to create high-
quality camera effects.

The camera zoom level in this animation 
changes from a close-up to a long shot.
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To zoom a camera in and out during a scene, follow these steps:

1. Add a new camera element to your scene.

2. In the Timeline window, select the camera you want to modify. The camera frame 
should appear in red in the Camera View window.

3. On the Camera tab, select the Dynamic option.

When you select this option, you can change the zoom level of the camera at 
different frames throughout your scene. 

4. Select the start and end frame, and the duration, of the zoom change.

When you activate the Dynamic option, a bar appears in the camera element in 
the Timeline window. This bar (set to 20 frames by default) represents the period 
(start and end frame, and duration) of the FOV change. 

• If you want your zoom changes to last longer than 20 frames, you must 
extend this bar. 

• If you want your zoom changes to have a different start and end frame, drag 
the bar to the position you want it to occupy.

You can drag the handle below the 
camera frame to change the zoom 
level at specific frames.

This bar reflects the start and 
end frame, as well as the 
duration, of the camera zoom 
changes.
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The camera uses the zoom level at the start and end of the zoom period for the 
camera zoom level before and after the zoom period.

5. Drag the red frame slider on top of the Timeline to select the frame at which you 
want the zoom to stop.

 

6. With the Select tool, use the handle beneath the camera frame to change the 
zoom level of the camera.
• Drag the handle to the left to zoom-in on the scene.
• Drag the handle to the right to zoom-out on the scene.

You can also use the Function Editor to make more precise changes to the FOV.

See Also
Adding Cameras to a Scene on page 322 
Creating Zoom Effects with the Function Editor on page 334  
Zooming the Camera In or Out on page 327 
Changing the Start Frame and Duration of a Dynamic Camera on page 332 
Camera Effects with Toon Boom Studio on page 320 
Basic Sceneplanning Concepts on page 238 
Changing Elements Over Time with Pegs on page 260 

If you want a zoom to reach a 
certain level by frame 10, then you 
would move the red frame slider to 
10.
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Changing the Start Frame and Duration of a 
Dynamic Camera

When you add a dynamic camera, it always appears at the first frame of the scene and 
covers a default length of 20 frames. If you need to make a dynamic camera effect last 
longer, you must modify the duration of the camera element in the Timeline window. 

For example, if you want to link a zoom effect to a pan that is controlled by a peg, you 
should make the zoom effect last as long as the peg.

To modify the start/end frame and duration of a dynamic camera zoom, follow one of 
these steps.

To change the start/end frame of the camera, follow these steps:

1. Click the camera’s bar in the right panel of the Timeline window. 

2. Drag the camera bar to the correct position in the Timeline window. You may 
want to use the zoom slider at the bottom of the Timeline window to see more or 
less of the Timeline.

The thin red bar that appears in the Timeline window for all cameras indicates the 
duration of the camera’s recording time in the scene. The red bar for the active scene 
camera increases or decreases based on the duration of all visible elements in the 
scene. 

Even if the camera is dynamic for only a few frames (the length of the trackbar), it 
continues to record until the last frame where there is a visual element.

Drag the camera’s bar to 
its new position.

Use the zoom slider to change the amount of detail you see 
in the Timeline window.
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To change the duration of a camera effect, follow these steps:

1. Move the pointer to the end or the beginning of the camera bar in the right panel 
of the Timeline window. 

2. Drag the boundary to the left or right to increase or decrease the length of the 
camera. A camera must always be at least two frames in length.

See Also
Adding Cameras to a Scene on page 322 
Changing the Timeline Zoom Level on page 366 
Splitting the Timeline Window into Two Sections on page 369 
Changing an Element’s Start Time in the Timeline on page 402 
Sequencing Element Contents on page 386 

You can drag the ends of the 
camera bar to change the 
duration of the camera effect.
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Creating Zoom Effects with the Function Editor
You can use the Function Editor to create zoom effects that change precisely over time. 
To create zoom effects, you change the field of view (FOV) of the camera. 

Let's say that you want your camera to repeat the same zoom changes over 60 frames. 
In the Camera View window, you can use the camera handle to change the zoom level, 
but you can not select exact FOV values with the handle. To do this, you must use the 
Function Editor.

To create precise camera zooms with the Function Editor, follow these steps:

1. Add a new camera element to your scene.

2. Select the camera element in the Timeline window.

3. In the Camera tab, select the Dynamic option for the FOV Type.

When you select the Dynamic option, you will be able to make the zoom level of 
the camera change throughout your scene.

4. Change the start frame and duration of the camera.

5. Select the FOV tab and click the Edit button. 

The graph on the FOV tab 
represents the change in the zoom 
level of the camera over time.
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The Function Editor appears.
• The Y-axis (vertical axis) marks the angle of view that the camera has of the 

scene. 
• The X-axis (horizontal axis) marks the frame number. 

6. To change the angle of view of the camera, select the frame on the plotline where 
you want the zoom effect to change and add a key frame.

You can then move this key point to the angle of view you want. The shape of the 
plotline identifies the speed of the change in zoom. 

7. To change the speed of the zoom, you can manipulate the shape of the plotline 
using options in the Reshape menu. 

See Also
Reshaping the Plotline in the Function Editor on page 315 
Adding Motion Points with the Motion Point Tab on page 275 
Adding Cameras to a Scene on page 322 
Changing the Start Frame and Duration of a Dynamic Camera on page 332 

Change the speed of the 
zoom effect by changing 
the shape of the plotline. 

You can select different 
plotline shapes from the 
Reshape panel.

Each point represents the 
angle the camera reaches 
at a specific frame number.

You can use the handles on 
each point to change the 
shape of the curve.
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Panning and Trucking the Camera
You can create camera moves common in animation, like pans and trucks, using 
cameras and pegs. For example, you can change the area of the scene you are looking 
at by panning the camera. Or, you can move the camera into the scene (trucking) to 
create a sense of motion through the scene.   

To create camera pans and trucks, you must attach the camera to a peg. Then, you must 
create east/west or north/south motion paths with the peg to create pans, or front/
back motion paths to create trucks.

From the first frame to the last the camera 
follows the snowboarder all the way down the 
mountain.
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To pan and truck a camera, follow these steps:

1. Add a new camera element to your scene.

2. Add a peg to the your scene. 

3. Change the start/end frame and duration of the peg to the values you want. 

4. To attach the camera to the peg, drag the camera element on top of the peg 
element in the Timeline window. 

5. Modify the peg to create north/south, east/west and front/back motion. 

The camera follows the path of the peg through your scene. Cameras are affected 
by a peg's motion and rotation, but not scale.

See Also
Adding Cameras to a Scene on page 322 
Adding Many Elements to a Scene on page 373 
Changing an Element’s Start Time in the Timeline on page 402 
Adding Pegs and Attaching Elements to Pegs on page 261 
Creating Motion Paths with Pegs on page 267 

You can click the 
peg button just 
above the left 
column in the 
Timeline window to 
add a peg to your 
scene. 

Drag the camera 
on top of the peg 
to attach it to a 
peg.
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Chapter 10
Creating Effects

This chapter describes how you can add cool effects to your 
elements, creating interesting visuals, which your audience will 
enjoy, with ease and speed.

This chapter contains these topics:

• Additive and Multiplicative Color Changes on page 340 

• Clipping Mask Effects on page 347 



Additive and Multiplicative Color Changes
Additive and Multiplicative Color 
Changes

Various scenes you create may require the gradual change in color of characters or 
scenery because of changes to the lighting of the scene. If the sun is setting on a beach, 
the colors of all of the scenery on the beach are going to darken or even redden before 
they absorb a dark purple or blue tint.

It would be quite time consuming to figure out the colors of each object in your scene 
at each frame, and then recolor each drawing at each frame (which traditional painters 
did have to do). With Toon Boom Studio™, you can automate colors changing over 
time by creating color changes in Color Transform elements and attaching all of the 
elements you want to transform to these effects elements.

In this scene, the sun starts to set on the surfer, 
darkening all of the objects in the scene.

Watch out for that shark!

Here’s the Color Transform element 
in the Timeline window.
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There are two types of color transformations you can create: additive and 
multiplicative.

• With additive color transformations, you can add or subtract color values 
from selected color channels (red, green, blue and alpha). 
You would select an additive color transformation if you wanted to add or 
remove a color from your drawings over time. 
For example, if a fire suddenly starts in front of a character, the character 
would reflect more and more red or orange as the fire starts and grows larger.

This ant is made up of the following RGB colors:

• Skin: 190, 140, 101

• Eye: 40, 97, 196

• “White” around the eye: 250 250, 229

• Belt: 245, 152, 31

If you create a Color Transform that adds 80 red to all of the colors, the red 
value in each color would increase by 80.

When you add 80 to the red channel in the colors of the ant, each red 
value increases while the values of the other channels remain the same.

• Skin: 190 + 80 = 270 Red (the other colors remain the same)

• Eye: 40 + 80 = 120 Red

• “White” around the eye: 250 + 80 = 330

• Belt: 245 + 80 = 325

This ant is on his way to becoming one crispy critter, getting hotter and 
redder the longer the fire burns. Stop! Drop and Roll, Anty!
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• With multiplicative color transformations, you multiply the current values in 
the color channels (red, blue, green and alpha) by selected values to create 
new color values. 
You would select a multiplicative color transformation if you wanted to 
create an effect that changes all color channels evenly. 
For example, if you wanted to increase the redness of an image by 20%, you 
would multiply the red value by 1.2.

You can combine additive and multiplicative color transformations. Toon Boom 
Studio™ calculates the final value by first applying the multiplicative value and then 
the additive value. The formula looks like this:

(Color * Multiplicative Values) + Additive Values = Final Color

You may notice that the values of your color go beyond the 256 colors that are actually 
displayed. Although you only see colors with values between 0 and 255, Toon Boom 
Studio™ saves the final value and uses it when you combine multiple Color 
Transforms. 

See Also
Changing Color Over Time on page 343 
Combining Multiple Color Transforms on page 346 

The red values in this image are 
now:

• Skin: 190 * 1.2 = 228

• Eye: 40 * 1.2 = 48

• “White” around the eye: 250 * 
1.2 = 300

• Belt: 245 * 1.2 = 294
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Changing Color Over Time
You attach elements whose colors you want to change over time to Color Transform 
elements. Then, you change the properties of the Color Transform elements at selected 
key frames. Toon Boom Studio™ calculates the color values of each image in an 
element at each frame for you. You can transform any visual element - drawing, image, 
or media. 

You can add/subtract values from the color channels or you can multiply the current 
color values by a value. 

To change colors in elements over time, follow these steps:

1. In Sceneplanning Mode, select Element > New > Color Transform Effect. A 
new element layer appears in the Timeline window.

2. Drag the elements you want to change on top of the Color Transform Effect 
element. The elements appear indented below the Color Transform element. 

3. If needed, change the start time and duration of the Color Transform element. 
• Drag the entire trackbar of the element to a new start frame. 
• Drag the end of the trackbar to a new end frame.

4. Select the Color Transform element and use the red frame slider at the top of the 
Timeline window to select the key frame at which you want the color change to 
end. Notice that the Color Transform tab opens in the Properties window. 

Notice how the bg elements are indented below 
the Color Transform element. This means that 
they are attached to the Color Transform element 
and will be effected by the color changes you 
program in it.

See the X’s on the Color Transform trackbar? 
They are the key frames for the color change.
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Additive and Multiplicative Color Changes
5. In the Properties tab, make your selections for the color transformation. Drag the 
slider or enter a value in a field. You can see the results of your changes 
immediately in the Camera View window. 

If you nest color transformations in multiple Color Transform elements, the real value 
is used to calculate the combined effect.  

See Also
Adding/Removing Key Frames from a Color Transform on page 345 
Additive and Multiplicative Color Changes on page 340 
Additive and Multiplicative Color Changes on page 340 
Combining Multiple Color Transforms on page 346 
Real-Time Playback on page 431 

When a color transform is applied on an image element or a vector element with a 
bitmap fill, what you see in the Camera View window will not be the same as the final 
rendered movie.  

To evaluate color transforms applied to bitmaps, you must playback the rendered 
animation.

• In the multiplicative fields, you would usually 
enter a value between 0 and 2. In fact the slider 
only allows you to go from 0 to 2. You can enter 
a value less than 0 and greater than 2 in the 
fields.

• In the additive fields, you would usually enter a 
value between -255 to + 255. You can enter 
greater values in the fields.

• You will only see resulting color values that range 
from 0 to 255. If the final value is outside this 
range, Toon Boom Studio™saves the value and 
uses it for other calculations. 
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Adding/Removing Key Frames from a Color Transform
Let’s say that your character is holding her breath. Her skin color might go from pink 
to blue. Then if she got mad, her skin might go from blue to red!

You can add key frames to Color Transform elements to change the color values of 
attached elements at different frames throughout your scene. 

To add or remove key frames from a Color Transform element, follow these steps:

1. In the Timeline window, select the Color Transform element.

2. Select the frame at which you want to add a key frame using the red frame slider 
at the top of the Timeline window to change the frame number.

3. In the Color Properties tab, Properties window, click the Add Key Frame  
button. A new X appears in the Color Transform element at the selected frame. 
You can now change the value of the color transformation. 

4. To remove a key frame, select the Color Transform element, use the frame slider 
to select the key frame you want to delete, and click the Remove Key Frame  
button on the Color Properties tab. 

See Also
Adding/Removing Key Frames from a Color Transform on page 345 
Additive and Multiplicative Color Changes on page 340 
Previewing a Scene Interactively on page 428 
Changing Color Over Time on page 343 

You can disable the display of color transform effects in the Camera View windows.

• Select View > Effects > Disable All Effects.

Effects will export regardless if you have this option selected.  

Move the red frame slider to the frame 
number where you want to add a key 
frame.

Xs appear in the trackbar for each key 
frame.
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Combining Multiple Color Transforms
You can combine multiple Color Transform effects to control different color changes in 
your scene.

For example, if your character was blushing as the sun was setting, you would create 
one Color Transform effect for the blushing, and another for the effect of the setting sun 
on the whole scene.

Multiple color transformations are combined starting with the top Color Transform 
elements, working down.

To combine multiple color transforms, follow these steps:

1. Create the secondary Color Transform effect. The secondary effect is the one that 
will be influenced by the primary effect.

2. Create the primary Color Transform effect. This is the effect that will have 
influence over elements as well as other Color Transform effects.

3. Attach the secondary Color Transform effect to the primary Color Transform 
effect.

See Also
Adding/Removing Key Frames from a Color Transform on page 345 
Previewing a Scene Interactively on page 428 
Clipping Mask Effects on page 347 
Changing Color Over Time on page 343 

In the Timeline, you can see how 
there are two Color Transforms 
that are secondary to a master 
Color Transform element.
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Clipping Mask Effects
Ever been to a costume party where the only thing you see beneath the masks of the 
other guests is their eyes and mouth? The costume mask hides all of the face, except 
those parts revealed by the holes for the eyes and the mouth.   

You can create a very similar effect with moving images by hiding parts of images (the 
clip) below a mask. This effect can create some interesting visual results because you 
are no longer constrained by the rectangular shape of your camera to frame for your 
images.

See Also
Creating Clipping Mask Effects on page 348 
Additive and Multiplicative Color Changes on page 340 
Modifying Masks on page 351 

The mask in the image to the left is 
shaped like a wave to reveal a clip of a 
wave washing over a beach.

Combining the clipping mask effect with 
other elements can create interesting 
transitions between material.
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Creating Clipping Mask Effects
With Toon Boom Studio™, you can create masks that allow part of an image to appear 
through a shape. To create this clipping mask effect, you must create a vector shape 
and attach it to the effect’s mask parameter. Then, you attach the images you want to 
see through the mask to the clipping element.      

Centerline strokes cannot be masks; only Brush strokes and painted areas can be 
masks.

When displaying the clipping mask, the composite elements are rendered into one 
layer. The top element inside the clip establishes the layering order with other elements 
in the scene and the mask layer establishes the foreground/background property of 
the entire rendered effect. To change the depth of the clipping effect, you must move 
the top element in the clip.

You can mask drawing or image element types. You can also resize, rotate or move 
your masks dynamically with pegs, like you do other element types.

In this clipping mask effect, the wave_mask element is 
attached to the mask layer. The images that will show 
through (wave.swf) is attached to the Clipping element.
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To create a clipping mask effect, follow these steps:

1. In Drawing Mode, create a drawing element and draw the shape you want to use 
for the mask, and fill the regions you want to use to show the layers below the 
mask. This is opposite the concept of the party mask because it is actually the 
areas that are filled with paint that will show through the bottom layers.

2. Switch to Sceneplanning Mode.

3. Select Element > New > Clipping Effect. Two element layers appear in the 
Timeline, the Clipping Effect layer and the Mask layer. The Mask layer is a 
parameter of the Clipping Effect layer and as a result you cannot move, rename or 
delete it.

4. Drag the drawing element you created to be the mask on top of the Mask layer. 
When it is attached, the drawing element is indented below the Mask layer. 

You can add multiple elements to the Mask layer. However, only the top visible 
drawing element will be used as the mask. Other drawing elements will be 
ignored in the calculation of the mask.  

If you only want the mask to hide a part of the clip for a segment of the clip’s 
duration, you must create a large drawing that will reveal the full clip for the 
duration of its exposure. If there is no drawing in the mask layer, then Toon 
Boom Studio™ assumes that all of the holes in the mask are filled, and that there 
is nothing that you want to see beneath it. 
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Clipping Mask Effects
5. Drag the elements you want to mask on top of the Clipping Effect layer. The 
masked elements are indented below the Clipping Effect layer.

See Also
Changing Elements Over Time with Pegs on page 260 
Previewing a Scene Interactively on page 428 
Additive and Multiplicative Color Changes on page 340 
Modifying Masks on page 351 

You can disable the display of mask effects in the Camera View windows.

• Select View > Effects > Disable All Effects. Effects will export regardless if 
you have this option selected.

In the Timeline window, you can also hide the mask layers beneath a Clipping Effect 
element to make it easier to work with elements.

• To hide the mask layers in all Clipping Effect elements, select View > Effects 
> Hide All Effects Parameters. 

• To show the mask layers in the selected Clipping Effect element, View > 
Effects > Show Effect Parameters. 

• To show the mask layers in all Clipping Effect elements, select View > 
Effects > Show All Effects Parameters.  

You must drag the mask you want to use 
(the vector drawing with painted zones 
identifying the areas you want to show 
through) on top of the Mask element. 

Then you drag all elements you want to be 
affected by the mask on top of the Clipping 
Effect element.
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Modifying Masks
You can change the rotation and size of masks just like you would any other element 
in Sceneplanning Mode. You can even use pegs to change masks dynamically 
throughout the scene. 

However, if you just want to reposition a mask, it can be a little bit tricky. In the 
following example, the clip image fills the mask. If you try to move the mask as it is set 
up now, Toon Boom Studio™ will move the clip. To move the mask, you must hide 
the clip.

This is a mask created from a drawing of a wave, 
which is revealing an image of a wave beneath it.

If you try to move the mask, you 
will end up moving the clip 
beneath it.
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To move a mask, follow these steps:

1. Use the Show/Hide buttons in the element list to hide the clip layer.

2. Use the Select  tool to move the mask.

3. Show the clip layer so that you can see the layers beneath the mask.

See Also
Repositioning Elements on page 245 
Scaling Elements on page 250 
Rotating Elements on page 255 
Changing Elements Over Time with Pegs on page 260 

Here’s a tip that also helps with the selection and modification of masks.

1. Add a peg and move it just outside of the mask’s area.

2. Attach the mask to the peg.

3. Use the circle that represents the peg as a handle for moving the mask.

We hid the wave.swf media element, 
which is the clip in this effect.
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Chapter 11
Organizing Elements

This chapter explains how to organize the element layers in your 
scene, as well as work out the sequence and timing of contents.

This chapter contains the following topics:

• Exposure Sheet and Timeline Windows on page 354 

• Layering Elements on page 371 

• Sequencing Element Contents on page 386 

• Timing/Exposing Drawings and Images on page 401 



Exposure Sheet and Timeline Windows
Exposure Sheet and Timeline Windows
The Exposure Sheet and Timeline windows are your worksheets for organizing, 
sequencing and timing the contents of your animation. Although both the Exposure 
Sheet and the Timeline serve similar purposes, they display layering, sequence and 
timing information differently because of the functions you perform in the different 
modes. 

• In Drawing Mode, you build the content of your animation by drawing and 
importing media. You use the Exposure Sheet to track the content of each 
element, as well as establish the order and timing of each item.

• In Sceneplanning Mode, you use the Timeline window to add effects to entire 
elements, as well as establish their final composition order. You can change 
the order and timing of element contents in the Timeline, but you cannot 
create new visual content in this mode that you will need to manage frame-
by-frame.

See Also
Showing/Hiding Elements on page 355 
Adding Element/Cell Notes on page 360 
Changing the Cell Display in the Exposure Sheet on page 363 
Changing the Timeline Zoom Level on page 366 

The Exposure Sheet is similar to 
the paper exposure sheets 
traditional animators use to 
organize layers, or elements, in 
2D cel animation. Drawing, 
image, sound and media 
elements are organized into 
columns.

In Sceneplanning Mode, 
the Timeline window 
organizes the elements of 
your scene into rows. 
354 



Chapter 11: Organizing Elements
Showing/Hiding Elements
Sometimes it helps to hide a couple of elements so that you can focus on the ones you 
are working on.  

• If you are in Drawing Mode, you may want to hide elements so that you see 
only specific layers in the Auto Light Table.

• If you are in Sceneplanning Mode, you may want to hide elements so that it is 
easier for you to lay out others in the 3D scene space.

When you hide elements, they will also not show in your animation when you render 
for playback or export.  

You can show/hide elements using the commands in the Element > Display menu. 
You can also use the Show/Hide buttons in the Exposure Sheet and Timeline 
windows.  

To show/hide elements in Drawing Mode, follow these steps:

1. In the Exposure Sheet, click the Toggle Element List  button to open the 
Element List panel. 

2. Click the radio button next to the element name in the Element List panel.
• When the button is selected, the element appears in the Drawing View and 

Exposure Sheet windows, and in your rendered animation.
• When the button is deselected, the element does not appear in the Drawing 

View and Exposure Sheet windows, or in your rendered animation. 

When you have hidden pegs, you can show them without changing their show/hide 
status in the element list in the Timeline window.

• Select View > Peg > Show Pegs. All pegs become visible in the View 
windows.
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Exposure Sheet and Timeline Windows
To show/hide elements in Sceneplanning Mode:

• Click the radio button next to the element name in the Element List panel.  
When the button is selected, the element appears in all of the View and in 
your rendered animation.
When the button is deselected, the element does not appear in the View 
windows or in your rendered animation. 

See Also
Changing Layering Order in the Exposure Sheet on page 375 
Changing Layering Order in the Timeline on page 377 
Exposure Sheet and Timeline Windows on page 354 
Organizing Elements on page 353 

Use the Show/Hide buttons in 
the Element List panel to select 
the elements you want to 
appear in Drawing Mode.

Use the Show/Hide buttons to select 
the elements you want to appear in 
Sceneplanning Mode.
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Displaying Selected Elements Only in Sceneplanning
In Sceneplanning Mode, all your elements that are visible at the selected frame 
(indicated by the frame marker) appear in the View windows. This is unlike the 
Drawing View window in Drawing Mode that only displays the selected cell in a single 
element at the current frame.  

If you want to work on a single element or set of elements, you would need to hide all 
the unrelated elements and then re-display them later. That doesn’t sound like a big 
deal, but if you have many elements, it can be time consuming.

Toon Boom Studio™ allows you to hide all other elements except the ones you select 
using Solo mode. When this mode is active, it temporarily hides all unselected 
elements from the View windows, allowing you to work on only the elements you 
want. 

When you just want to work on 
the motion path of a particular 
character, you don’t need to 
see all of the other elements in 
a scene.

Now that some of the 
elements are hidden, you 
can see the motion path of 
the character clearly.
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To hide elements in your View windows with Solo mode, follow these steps:

1. Select the element(s) you want to show. You can either select a single element or a 
range of elements (using [Shift] + click). 

2. Click the Solo mode  button located at the top-left of the Timeline window. 

When Solo mode is active, the Solo mode  button appears inverted and the 
hidden elements appear grayed-out in the Timeline window.

See Also
Exposure Sheet and Timeline Windows on page 354 
Deleting Elements on page 380 

When you are in Solo mode, you can still display or hide elements from the View 
windows:

• If you want to temporarily display an element that is not one of the selected 
elements, select it in the Timeline window. 

• You can use the Show/Hide buttons to hide or display elements currently in 
the Solo mode.

Only these highlighted elements will 
appear in the View windows.
358 



Chapter 11: Organizing Elements
Showing/Hiding Peg Attachments
When you are building your peg hierarchies in the Timeline window (which links 
related elements together), the peg hierarchies can get pretty deep and extensive, 
taking up quite a bit of space in your window.  

That’s why Toon Boom Studio™ allows you to expand or collapse the contents of your 
pegs in the Timeline window. By default, pegs are always expanded which displays all 
the elements attached to it. 

To make more room available in the Timeline window, you can collapse a peg which 
hides its attached elements from view. However, the contents of a collapsed peg still 
appears in your scene and View windows.

To collapse or expand a peg:

• click the arrow next to the peg element in the Timeline window. 

When the arrow points downward, the peg displays the attached elements. When the 
arrow points to the right, the peg hides the attached elements. This arrow doesn’t 
appear until you attach something to the peg.

See Also
Exposure Sheet and Timeline Windows on page 354 
Changing Elements Over Time with Pegs on page 260 

Expanded peg

Collapsed pegs hide 
attached elements in 
the Timeline window.
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Adding Element/Cell Notes
With a paper exposure sheet, animators can scribble notes on the paper about the 
elements in the scene and the action.    

Toon Boom Studio™ makes it possible to add electronic notes to your elements and 
cells so that you can record and save ideas about your animation.

If you clone an element, Toon Boom Studio™ also clones all of the element and cell 
notes. However, if you copy and paste an annotated cell, the note does not appear on 
the pasted cell.

To add a note to an element or a cell, follow these steps:

1. Select the element or cell you want to add a note to. 

You can select an element in either the Exposure Sheet window or in the 
Timeline window. However, you must use the Exposure Sheet to add cell notes.

2. Select one of the following commands.
• To add an element note, select Element > Insert Element Note.
• To add a cell note, select Element > Cell > Insert Cell Note.

The Note dialog box opens.

3. Type the note you want to add to the element/cell and click OK when you are 
done.

The element or cell displays a small note icon to identify the note. 

Cell and element note icons 
appear next to the names.

In the Timeline, only element 
notes are identified.
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To update an element or cell note, follow these steps:

1. Select one of the following commands. 
• To add an element note, select Element > Insert Element Note.
• To add a cell note, select Element > Cell > Insert Cell Note.

The Note dialog box opens.

2. Update the note and click OK. 

If you remove all of the text from the note, Toon Boom Studio™ will delete it.

See Also
Viewing Cell and Element Notes on page 362 
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Viewing Cell and Element Notes
You can view element and cell notes in Drawing Mode, but you can only view element 
notes in Sceneplanning Mode because you cannot see individual cells in this mode.  

To view a cell or element note:

• Pass your pointer over the note. The contents of the note will appear in a pop-
up.

See Also
Adding Element/Cell Notes on page 360 
Cloning Elements on page 381 

You can show/hide notes by clicking 
the Contextual Menu button and 
selecting View > Notes. 
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Changing the Cell Display in the Exposure Sheet
You can customize how the Exposure Sheet window displays the contents of elements 
by clicking the Contextual Menu  button and selecting the option you want from the 
View menu.   If the option is active, a checkmark appears next to it:

• Thumbnails: when active, a graphic representation of the contents appears. 
When deactivated, the cell displays only the cell name.

        
If the cell contains an image, drawing or media link, a thumbnail appears. If 
the cell contains a sound, the sound’s wave form or an example of the lip 
position that would make the sound at that frame is displayed. 

• Exposure: when active, a vertical line appears in the cells to indicate that the 
previous cell label applies to the current cell. When deactivated, the cell 
repeats the cell name for the length of the exposure.

   

Thumbnails active Thumbnails in-active

Exposure active Exposure in-active
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Exposure Sheet and Timeline Windows
• Named: when active, the cell displays the name of the element before the cell 
name, which is often a number.
When deactivated, only the cell name appears in the cell.

   
• Show Notes: when active, an element or cell annotation appears in a pop-up 

window when you place your pointer over the annotated cell.
When deactivated, the pop-up window does not appear. However, you can 
right-click on the element or cell and select Update Cell Note to view (or 
update) the note.

See Also
Creating Lip Charts Automatically on page 230 
Resizing Columns in the Exposure Sheet on page 365 
Adding Element/Cell Notes on page 360 

Named active Named inactive
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Resizing Columns in the Exposure Sheet
You can adjust the width of columns in the Exposure Sheet window to make it easier 
to see more element columns or more of the names of elements and cells.  

To resize columns in the Exposure Sheet window:

1. Drag the sides of the columns to their new size. You must drag the element title.

2. To reset the column width, click the Contextual Menu  button and select View 
> Reset Column Width.

See Also
Changing the Color of an Element on page 383 
Changing the Default Colors of Elements on page 384 

As you resize columns their titles, or 
the labels of their cells, might become 
hidden.

But, you can see more columns if the 
columns are narrow.
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Changing the Timeline Zoom Level
You can change the zoom level of the Timeline window so that you can see more of the 
timing of elements in the Timeline window or get a more global view of the scene. 

For example, if you wanted to see when drawings in an element change, you can 
increase the zoom level until you can clearly see the vertical lines that represent new 
cells in the Timeline window.

To change the detail level in the Timeline window:

• Drag the Zoom  slider either to the left (zoom out) or to the right (zoom in).
You’ll notice that as you change the zoom level, the amount of detail changes 
in stages. 

See Also
Changing the Current Frame in the Timeline on page 367 
Displaying Feet and Frames in the Timeline on page 368 
Splitting the Timeline Window into Two Sections on page 369 
Changing the Track Color in the Timeline on page 370 

Changing the zoom level of the Timeline 
reveals more about the timing of your 
scene, exposing details or giving you the 
“big picture”.
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Changing the Current Frame in the Timeline
The frame marker in the Timeline window identifies the frame you are viewing. When 
you play your scene, the frame marker moves across the Timeline window.

To view the images at a specific frame, you can change the frame marker’s position in 
the Timeline window. 

To change the current frame, do one of the following:

• Drag the frame marker to the frame you want to view.
• Click the frame marker at the top of the Timeline window. The red frame 

marker appears at the point you click and the elements at that frame appear in 
the View window.

• To advance one frame, press [S]. To rewind one frame, press [A].
• Right-click the frame bar and select Change current frame. 

In the Change Current Frame dialog box, type the frame number you want 
to see and click OK. The red frame marker now appears on the frame you 
selected and the elements at that frame appear in the View window.

See Also
Changing the Timeline Zoom Level on page 366 
Displaying Feet and Frames in the Timeline on page 368 
Splitting the Timeline Window into Two Sections on page 369 
Changing the Track Color in the Timeline on page 370 

The currently selected 
frame is indicated by the 
red frame marker and is 
in the title bar of the 
window.
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Displaying Feet and Frames in the Timeline
Traditional animation for TV and film is often measured in feet. The number of feet of 
film measurement is a handy way for animators to judge their output based.

There are 16 frames per foot of film. 

If you are accustomed to working in a traditional environment, animating for film and 
TV, the “feet and frames” measurement on the Timeline window might be a more 
familiar reference point for you to use. 

To display “feet and frames” in the Timeline window, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Click the Interface tab.

3. From the Time Measurement drop-list, select Feet and Frames and click OK.

See Also
Changing the Timeline Zoom Level on page 366 
Changing the Current Frame in the Timeline on page 367 

Select how you want 
the Timeline to mark 
time from the Time 
Measurement drop-list.

When you are displaying “feet 
and frames” in the Timeline 
window, the first number 
indicates the number of feet 
and the second number 
indicates the number of frames 
in the current foot.
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Splitting the Timeline Window into Two Sections

You can use the Zoom  slider to view more or less of the Timeline window, but if 
your scene is very long, you would still have to use the slider to display the beginning 
and end of the scene. 

That’s why the Timeline window features the Split Window  button. This button 
allows you to split the Timeline window into two sections, allowing you to view two 
sections of the scene independently. 

To split the Timeline window into two sections, follow these steps:

1. Click the Split Window  button in the top-right of the Timeline window. A 
border bar appears on the extreme right of the Timeline window.

2. Place your pointer over the bar that separates the two sections so that your 
pointer changes to a resize  pointer.

3. Drag the bar to its new position.

The new section of the Timeline window has its own scroll bars and Zoom  slider.

See Also
Showing/Hiding Elements on page 355 
Changing the Current Frame in the Timeline on page 367 
Changing the Timeline Zoom Level on page 366 

Change the size of each 
section by dragging the 
border bar inside the 
Timeline window.
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Changing the Track Color in the Timeline
By default, the background color of tracks in the Timeline window is white, allowing 
for the highest contrast with the elements that appear on top of it. 

You can change the background color of selected tracks in the Timeline window so that 
you can easily distinguish a specific element or a group of elements from others.  

To customize the color of a track in the Timeline window, follow these steps:

1. Select the element whose track color you want to change. 

2. Select Element > Display > Default Color. The Color dialog box opens.

3. Select the color you want to use for the selected track and click OK. 

4. To revert the track’s color, select Element > Display > Background Color.

See Also
Changing the Color of an Element on page 383 
Changing the Default Colors of Elements on page 384 

Track color

 Element color

If the color you want to assign 
doesn’t appear here, you can click 
the Define Custom Colors 
button to select from a wider 
range of colors.
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Layering Elements
The layering order of elements determines how they are stacked (the composition 
order) when you playback or export your animation from each mode.     

• In the Exposure Sheet, columns on the left are below columns on the right 
when you export a Drawing Mode scene.

• When you export a full movie or Sceneplanning Mode scene, elements in 
rows on top of the Timeline list appear layered on top of the elements below. 
Of course, when your elements change relative front/back position based on 
layout and pegged motion effects, that ultimately determines the composition 
order of the elements.

Any changes you make to your scene’s contents in the Exposure Sheet appears in the 
Timeline window, except for layer order and element show/hide status.

There are eight element types you can add to your animation. Some elements do not 
appear in both modes:  

• Drawing : vector drawing files you create or import.
Drawing elements appear in both the Exposure Sheet and the Timeline.

• Image : bitmap graphics that you import into your animation.
Image elements appear in both the Exposure Sheet and the Timeline.

• Sound : sound files you import into your animation.
Sound elements appear in both the Exposure Sheet and the Timeline.

• Media : multimedia files that you link into your animation.
You use the media element type to make a link from your animation to a 
multimedia file.
Media elements appear in both the Exposure Sheet and the Timeline.

• Peg : create motion, scaling, and rotation changes over time.
Peg elements appear only in the Timeline. You can modify peg elements in 
Sceneplanning Mode, but not in Drawing Mode.

• Camera : As in traditional animation and film production, you use 
cameras to “film” the action in a scene. You can use camera elements to zoom-
in and zoom-out on your scene by changing the field-of-view (FOV), create 
pans, move closer or farther (truck in and out) from the action in your scene.
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Layering Elements
Toon Boom Studio™ can film a scene with only one camera. You can add 
additional cameras as a reference, but Toon Boom Studio™ can only use the 
camera you select from the Camera drop-list on the Scene View toolbar to film 
your scene. You must create all of the camera effects you want to use for the 
final movie in one camera.
The default “scene camera” does not appear in the Timeline window, but any 
cameras you add will appear in the element list. You can modify camera 
elements in Sceneplanning Mode, but not in Drawing Mode.

• Color Transform Effects : change the color of element gradually from key 
frame to key frame.

• Clipping Effects : display only part of an image, using a mask to identify 
the areas on the image you want to “show through”. When you add this 
element, Toon Boom Studio™ adds a Mask parameter element to control the 
masking image.

See Also
Adding Many Elements to a Scene on page 373 
Changing Layering Order in the Exposure Sheet on page 375 
Changing Layering Order in the Timeline on page 377 
Renaming Elements on page 379 
Deleting Elements on page 380 
Cloning Elements on page 381 
Showing/Hiding Elements on page 355 
Changing the Default Colors of Elements on page 384 
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Adding Many Elements to a Scene
By default, there is one drawing element in new animation sets. When you want to add 
new content to your animation or add different types of content (such as bitmaps or 
sounds), you must add new elements. 

To add elements to your scene, follow these steps:

1. Select Element > New > Elements. The New Elements dialog box opens.
• You can also open this dialog box by clicking the Contextual Menu  button 

in the Exposure Sheet window and selecting New > Elements, or by 
clicking the Add  button in the Timeline window.

2. Select the type of element from the Type drop-menu. You have the following 
choices. 
• Drawing: stores vector drawings you create in Toon Boom Studio™, import 

from Adobe® Illustrator®, or create by vectorizing bitmaps.
• Image: contains static bitmap images you import in the element (usually a 

background image).
• Sound: contains audio files you import to the scene. 
• Media: contains multimedia files you link to the scene. 
• Peg: allows you to change an element’s position, size, or angle over time.
• Camera: adds another perspective to a scene.
• Color Transform Effect: allows you to change the colors in an element at key 

frames.
• Clipping Effect: allows you to hide certain parts of a clip with a mask. When 

you select this option, Toon Boom Studio™ adds a Mask parameter layer, 
which you use to control the mask parameter.

Use the New Elements dialog box to 
enter information about the elements 
you are adding.
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3. Type the name of the new element(s) in the Name field. 
• If you are adding one element, Toon Boom Studio™ labels the column with 

the selected element name.
• If you add more than one element, Toon Boom Studio™ labels each with the 

selected element name followed by a sequential number (starting at one).

4. Type the number of elements you want to add in the Number field. You can also 
use the arrow buttons to increase or decrease the number. 

5. Click OK when done.
Toon Boom Studio™ adds the selected number of columns to the Exposure Sheet 
window and the Timeline window with their default names, but you can rename them 
at any time. 

See Also
Renaming Elements on page 379 
Deleting Elements on page 380 
Changing the Color of an Element on page 383 
Changing Layering Order in the Exposure Sheet on page 375 
Changing Layering Order in the Timeline on page 377 
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Changing Layering Order in the Exposure Sheet
The order of the elements in the Exposure Sheet window determines:

• Their layering order in the Drawing View window, which can be helpful 
when drawing related objects in a scene. The Exposure Sheet window sorts 
the layers from left (bottom layer) to right (top layer). 

• Their layering order when rendering a Drawing Mode scene for export or 
playback.

• The initial layering order of elements in Sceneplanning Mode. However, once 
you switch to Sceneplanning Mode, the layering order of the Timeline and 
Exposure Sheet windows will be independent of each other. 

In this example, the walkGuy 
element is on top of the wall, the city 
scape and the sky.
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To change the layering order of elements in the Exposure Sheet window, do one 
of the following:

• Select the element in the Exposure Sheet and select one of the following 
commands from the Element > Arrange menu:

Bring to Front: move the element on top of all elements.
Bring Forward: move the element in front of the element currently on 
top of it.
Send to Back: move the element behind all elements.
Send Backward: move the element behind the element currently below 
it.

• Drag the element to its new layering position in the columns of the Exposure 
Sheet or in the Element List panel.

In the Exposure Sheet, element columns to the left appear below 
element columns to the right.
In the Element List panel, elements at the top of the list appear on top of 
elements on the bottom of the list.

See Also
Changing Layering Order in the Timeline on page 377 
Renaming Elements on page 379 
Deleting Elements on page 380 
Exporting to Flash on page 433 

A line appears between the 
existing elements 
to indicate where 
the element will 
appear.
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Changing Layering Order in the Timeline
When you first switch to Sceneplanning Mode, the initial layering order of elements is 
based on the order in which they were added to the Exposure Sheet window. After you 
switch modes, the layering order of the two modes are separate; Toon Boom Studio™ 
does not update the Exposure Sheet when you make changes to the layering order in 
the Timeline window or vice-versa.

You can force elements to appear behind or in-front of other elements in your 
animation using the options of the Type list in the Drawing tab, Image tab, and Media 
tab. 

• Foreground: Forces the element to appear in-front of other elements. When 
you have more than one element set to Foreground, the layering order in the 
Timeline determines the order of the Foreground elements.

• Normal: Allows the elements to follow the layering order of the Timeline 
order or the front/back position in the Offset field in the Properties window. 
If you select this option, then you must make sure that your foreground and 
background images are in the right layering order in the Timeline list.

• Background: Forces the element to appear behind other elements. When you 
have more than one element set to Background, then the layering order in the 
Timeline determines the order of the Background elements.

You can also use the Timeline window to change the layering order of elements. The 
top layers are composited on top of the lower layers.

We made the clouds a background 
element so that no matter how 
characters or camera move in the 
scene, the clouds will always appear in 
the back.
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To change the composition order of elements in the Timeline window, use one of 
the following methods:

• Select one of the following commands from the Element > Arrange menu:
Bring to Front: move the element on top of all elements. 
Bring Forward: move the element in front of the element currently on 
top of it.
Send to Back: move the element behind all elements.
Send Backward: move the element behind the element currently below 
it.
If the element is a child attached to a parent element, such as a peg or an 
effect, these commands change the element’s layering order within the 
group of child elements attached to the parent. They will not detach the 
element from its parent to change its layering order.

• Drag the element to its new layering position in the Timeline window.
In the Timeline list, click the name of the element you want to move.
Drag the element to its new position in the layering order. Your pointer 
changes to indicate if the element can be placed in the position you have 
selected.

See Also
Creating Motion Paths with Pegs on page 267 
Adding Pegs and Attaching Elements to Pegs on page 261 
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Renaming Elements
At any time, you can rename elements to more accurately reflect the contents they hold. 
The new element name appears in both Drawing and Sceneplanning Modes.

If you change the name of a drawing or image element, Toon Boom Studio™ changes 
the names of all drawings and images in the element and in your animation set folder. 

To rename an element, follow these steps:

1. Select the element you want to rename.

2. Select Element > Rename Element. The Rename Element dialog box opens.

The name of the dialog box actually changes depending on the type of element 
you are modifying. For example, if you select an Image element, the dialog box 
opens as Rename Image Element.

3. Type the name for the element in the Element Name field and click OK.
Toon Boom Studio™ renames the selected element and if the element contains 
drawings or images, their names change to reflect the new element name.

See Also
Exposure Sheet and Timeline Windows on page 354 
Layering Elements on page 371 
Sequencing Element Contents on page 386 
Naming and Renaming a Cell on page 393 
Renaming a Drawing or Image on page 393 
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Deleting Elements
As you develop your animation, you may need to delete unnecessary elements. 

For example, when you complete your final drawings of a character, you can delete the 
elements that contained the roughs.   

To delete an element from your animation, follow these steps:

1. Select the element you want to remove.

2. Select Element > Delete Element. Toon Boom Studio™ removes the element 
and its contents from your animation and from your animation set folder.

If you want to only hide an element in a scene, you do not need to delete it from the 
scene completely! You can temporarily toggle it on and off, which not only hides it 
from the Drawing View/Camera View window, but also from the rendering process 
too!

See Also
 Showing/Hiding Elements on page 355 
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Cloning Elements
You can clone elements when you want to reuse the contents of an element. When you 
clone elements, Toon Boom Studio™ refers to the same content file in the animation 
set folder. Cloning elements can help you keep your Macromedia® Flash™ movie small 
in file size. 

Let’s say you want to create the skyline of a city. Rather than drawing hundreds of 
buildings, you could draw a few, and then reposition them in space and flip them, to 
create a dense scene from few drawings. 

You can clone the following element types:

• Drawings
• Images
• Media
• Sounds
• Pegs
• Color Transform Effects

The contents of the cloned elements are shared, but you can change some of the 
properties of the clones without affecting the other clones.

• Drawing and Image Elements: the original and the cloned element both 
reference the same files. Cloning drawing and image elements does not 
increase the file size of your final animation.

If you change a drawing or image, all clones are updated with the new 
drawing or image.

In this example, we cloned some 
buildings three times, then 
positioned them throughout 
the 3D space to create a 
deep city scene with a 
minimal amount of drawings.
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If you add new drawings or images to the clones, they do not appear in 
the other clones. However, they are available to the other clones by 
renaming a cell with the name of the drawing or image.
You can change the exposure of drawings and images without affecting 
the clones.

• Media: cloned media share the same content. You can reposition and change 
the start frame of media elements without modifying other clones.

• Pegs: the cloned pegs share control points and key frames, and you can 
change the position of the peg in the 3D Sceneplanning space without 
affecting the clones. Cloning peg elements does not increase the file size of 
your final animation.

• Sounds: cloned sounds are exact copies. You can change any property in the 
sound clones without affecting other clones. Cloning sound elements does not 
increase the file size of your final animation.

• Color Transform Effects: clones are exact copies of the original, with the same 
key frame and values. Changes to the key frame values in any clone changes 
all other clones. You can change the start time of any clone without changing 
the others.

To clone an element, follow these steps:

1. Select the element you want to clone. You can only select one element at a time.

2. Select Element > Clone.

A copy of the selected element appears in the Exposure Sheet window and in 
the Timeline window.

See Also
Adding Many Elements to a Scene on page 373 
Renaming Elements on page 379 
Deleting Elements on page 380 
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Changing the Color of an Element
As you add elements to the Exposure Sheet window and Timeline window, Toon 
Boom Studio™ assigns a default color to each element based on its type.  You can 
change the color of specific elements to help you group and identify elements.

For example, if you drew a character on several layers, say the body in one layer, the 
head in another and the legs in another, you could give all of these layers a color 
different from the defaults to help you identify them easier in the Exposure Sheet 
window and Timeline.

To customize the color of an element, follow these steps:

1. Select the element.

2. Select Element > Display > Color. The Color dialog box opens.

3. Select the color you want to use for the selected element and click OK. The 
selected column now appears in the new color. 

4. To reset the element colors to their default settings, select Element > Display > 
Default Color.

See Also
Changing the Default Colors of Elements on page 384 
Changing the Track Color in the Timeline on page 370 

The element color appears next to the 
element name in the Exposure Sheet 
window and for the trackbar color in 
the Timeline window.
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Changing the Default Colors of Elements
Toon Boom Studio™ uses color to help you distinguish each element type in the 
Exposure Sheet window and Timeline window.  

You can change these default colors using the Preferences dialog box, which applies 
the changes in your current Toon Boom Studio™ session and any other animation set 
you create from then onwards.   

To change the default color assigned to elements, follow these steps:

1. Select Edit > Preferences. The Preference dialog box opens.

2. Click the Interface tab.

The element colors appear in the 
Exposure Sheet and Timeline 
window.
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3. Double-click the swatch next to the feature you want to change. The Color dialog 
box opens

.

4. Select the color you wish to use and click OK. Your selected color appears next to 
the feature you selected. If the color you want to assign does not appear here, you 
can click the Define Custom Colors button to select from a wider range of colors.

5. When you define all of the default colors, click OK in the Preferences dialog box.

See Also
Changing the Color of an Element on page 383 
Assigning Keyboard Shortcuts on page 48 
Real-Time Playback on page 431 
Selecting the Units of Measure on page 50 

Use the Color dialog box to select 
element type colors.
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Sequencing Element Contents
Your animation set folder contains all of the contents of your animation.        

• Each scene has its own folder in the root of the animation set folder.
• Also at the root of the animation set folder are the sound and template 

folders, which provide storage for the entire animation set.
• In each scene folder are bitmap and drawing folders, which store every static 

and vector image in the scene. The names of drawing and image files are 
based on the name of the element and their order of creation.

In Drawing Mode, cell labels in the Exposure Sheet let you know what will appear at 
each frame. 

These are all of the drawings in 
Scene-001 of this animation.

The cell label displays the 
element name plus the cell 
name, which tells Toon Boom 
Studio™ what drawing to display 
from the animation set folder.
386 



Chapter 11: Organizing Elements
In Sceneplanning Mode, the Timeline window and the Cells tab let you know what 
image or drawing is displayed at each frame

To sequence the contents of your animation:

• In Drawing Mode, create or import new content and use the Exposure Sheet 
to manage and name your elements. 
When you want to change the drawing or image that appears at a frame, you 
change the cell label so that a new one is displayed from the animation set 
folder.

• In Sceneplanning Mode, you can ‘t create new content. But you can select 
different drawings and images to display at each cell.

See Also
Inserting a Range of Numbered Cells on page 388 
Inserting Blank Cells in an Element on page 390 
Naming and Renaming a Cell on page 393 
Cutting, Copying and Pasting Cells on page 394 
Clearing a Drawing from a Cell on page 399 
Protecting Drawings on page 398 
Inserting Blank Frames in a Scene on page 391 
Deleting Cells from Elements on page 399 

In the Timeline window, the vertical bar 
indicates every frame where there is a new 
drawing or image.

The Timeline doesn’t let you know exactly 
which drawing or image is in use, but you can 
use the Cells tab to figure out the exact name 
of the drawing or image and use. 

You can even use the slider to see all of the 
drawings and images in an element, and 
change the one that is displayed at the current 
frame.
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Inserting a Range of Numbered Cells
If you want to preplan the number of frames an animation sequence should take, you 
can label a range of cells before you start drawing. For example, if you want to create a 
walk cycle in 10 frames, you can label those 10 frames first and then add the drawings 
to them later. 

You can add numbered cells to the selected element in the Exposure Sheet window or 
Timeline window. However, you can only insert named cells in the Exposure Sheet 
window.

You can only add a range of named cells to drawing elements, because you’ll be 
using Toon Boom Studio™ to create the drawings for that element.

Because the other elements like Sound and Media rely on files you create outside of 
Toon Boom Studio™, the system automatically assigns the cell name when you 
import them.

Inserting named cells labels the cells in the 
selected element with numbers that 
increase from the last cell.
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To insert a range of numbered cells, follow these steps:

1. Select the cell where you want to start the range of numbered cells 

2. Select Element > Cell > Insert Cell. The Insert Cells dialog box opens.

3. Type the number of cells you want to insert in the Number field. You can also use 
the arrow buttons or the arrow keys to increase or decrease this value.

4. Select Named Cells checkbox to automatically number the cells in this element. 
Toon Boom Studio™ reads the last numbered cell for this element and starts the 
new range with the next number.

5. Select where you insert these new cells by selecting one of the following radio 
buttons:
• Before: inserts the cells before the row you selected.
• After: inserts the cells after the row you selected.

6. Click OK to add the cell(s) to your Exposure Sheet window.

See Also
Naming and Renaming a Cell on page 393 
Creating Cycles on page 395 
Inserting Blank Frames in a Scene on page 391 

There is an even quicker way to add numbered cells to your Exposure Sheet window.

1. Select a range of cells by pressing [Shift] and clicking another cell. 

2. Right-click on the selected cells and select Insert Cell from the pop-up 
menu. Toon Boom Studio™ automatically adds numbered cells in the range 
you select.
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Inserting Blank Cells in an Element
You can insert blank cells between cells with content. For these blank cells, nothing 
from the element will appear in the frame.   

To insert a range of blank cells in an element, follow these steps:

1. Right-click the cell where you want to start the range of blank cells and select 
Insert from the pop-up menu. The Insert Cells dialog box opens.

2. Type the number of cells you want to insert in the Number field. You can also use 
the arrow buttons or the arrow keys to increase or decrease this value.

3. Make sure you deselect the Named Cells checkbox so that the cells appear blank. 
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4. Select where you insert these new cells by selecting one of the following radio 
buttons:
• Before: inserts the cells before the row you selected.
• After: inserts the cells after the row you selected.

5. Click OK to add the cell(s) to your Exposure Sheet window.

See Also
Naming and Renaming a Cell on page 393 
Creating Cycles on page 395 
Inserting Blank Frames in a Scene on page 391 

Inserting Blank Frames in a Scene
When you need to add time to an entire scene (across all of the elements), you can add 
frames to the Exposure Sheet window or Timeline window. This is useful if you need 
to add time to the middle of a scene. For example, if you want to have a complete stop 
to all visual and audio content for 5 frames. 

We added five frames to all elements. 
You can see what happened by 
comparing the before/after shots of the 
Exposure Sheet and Timeline.
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To insert blank frames in a scene, follow these steps:

1. Select the frame where you want to insert the new frames.
• In the Exposure Sheet window, click a cell or a frame.
• In the Timeline window, use the red frame slider to advance to the frame 

number.

2. Select Element > Cell > Insert Cell from the pop-up menu. The Insert cells 
dialog box opens.

3. Type the number of frames you want to insert in the Number field. 

You can also use the arrow buttons or the arrow keys to increase or decrease this 
value.

4. Select In all Elements checkbox to add frames to the entire scene at the frame 
number.

5. Select where you insert these new frames by selecting one of the following radio 
buttons:
• Before: inserts the frames before the row you selected.
• After: inserts the frames after the row you selected.

6. Click OK to add the frame(s).

See Also
Inserting Blank Cells in an Element on page 390 
Naming and Renaming a Cell on page 393 
Creating Cycles on page 395 
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Naming and Renaming a Cell
You can change the name of a cell to either:

• Create a new drawing file in the animation set folder
• Load a different drawing from the animation set folder. 

For example, if there is already a drawing called dude-02 and you type 02 in 
the dude element, the dude-02 drawing appears in the frame you selected.

To name or rename a drawing manually, follow these steps:

1. Double-click the cell that you want to modify. The cell becomes editable.

2. Type the name you want to assign to that cell and press [Enter]. The next cell in 
the element becomes editable.

3. Press [Esc] to quit the edit mode.

See Also
Layering Elements on page 371 
Clearing a Drawing from a Cell on page 399 

Renaming a Drawing or Image
If you want to give an existing drawing or image file a new name, you need to use the 
Rename command.

To rename a drawing or image, follow these steps:

1. Right-click the drawing or image you want to rename and select Rename 
Drawing/Image from the pop-up menu. The Rename Drawing/Image dialog 
box opens.

2. Type the new name in the Drawing/Image Name field and click OK. If the name 
you type already exists, you must select a new name.

See Also
Renaming Elements on page 379 
Naming and Renaming a Cell on page 393 
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Cutting, Copying and Pasting Cells
As you build content, you will want to reuse as much as possible to reduce your work, 
and hopefully reduce the file size of your animation.   

• If you cut or copy and paste a cell in the same element, Toon Boom Studio™ 
will paste the original cell label, accessing the original drawing or image in 
the animation set folder. 
To reduce your work and keep the file size of your final Macromedia® Flash™ 
movie small, you can to reuse the same drawing at different frames.

• If you paste a new object, Toon Boom Studio™ copies the contents of the 
original cell to the new cell and creates a new file in your animation set folder. 
You can use the paste new object feature to use the contents of one cell for the 
basis of another drawing.

To cut, copy and paste cells, follow these steps:

1. Select the cell(s) you want to copy from the element column in the Exposure Sheet 
window.

2. Select Edit > Cut or Edit > Copy.
• Select Copy to leave a copy of the cell at its original frame.
• Select Cut to delete the cell.

3. Select where you want to paste the cells.
• If you want to reuse the same drawing and keep the file size small, you must 

select a cell in the same element.
• If you want to create a new drawing, you can select a cell in the same or a 

different element.
• In the Timeline window, you must change the current frame (with the red 

frame slider) to select the cell in the element where you want to insert the 
pasted object.

4. Select Edit > Paste or Edit > Paste New Object.
• Select Paste. 

If you selected a cell in the same element, Toon Boom Studio™ accesses 
the original file. When you modify a file, all cells that access the file are 
updated.
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If you selected a cell in a different element, Toon Boom Studio™ creates a 
new file in your animation set folder. You can modify either file without 
affecting the other.

• Select Paste New Object if you want to create a new cell in the same element 
with the contents of the original cell.

See Also
Sequencing Element Contents on page 386 
Creating Cycles on page 395 

Creating Cycles
Animation cycles are a key technique in the reuse of work and file size management.     

The Create Cycles command simplifies the process of labelling cells in the exposure 
sheet to create cycles. 

You can create animation cycles in the Exposure Sheet window or in the Timeline 
window.

To create cycles from a section of cells, follow these steps:

1. Select the cells that contain the drawings in the cycle.
• In the Exposure Sheet window, press [Shift] and select the range of cells.
• In the Timeline window, press [Alt] and select the range of cells.

Select the cells that you want to use in the cycle.
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2. Right-click the selected cells and select Create Cycle. The Create Cycle dialog 
box opens.

3. In Number of Cycle field, type the number of cycles you want to create, 
including the cycle you have selected.

See Also
Cutting, Copying and Pasting Cells on page 394 
Timing/Exposing Drawings and Images on page 401 
Exposure Sheet and Timeline Windows on page 354 
Creating Advanced Cycles on page 397 

The cycle is added after the selected cells.
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Creating Advanced Cycles
During animation development, you design more complicated cycles.      

For example, a bouncing ball cycle where the sequence of drawings goes backwards 
and forwards during the cycle (1-2-3-4-3-2-1).

You can use the Advanced Create Cycle dialog box to automate the process of creating 
cycles and labelling cells.

To create advanced cycles, follow these steps:

1. Right-click a cell in the element where you want to create the cycle and select 
Advanced Create Cycle from the pop-up menu. The Advance Create Cycle 
dialog box opens.

2. In the First Drawing and Last Drawing panels, select the drawings that you want 
in the first and last position of the cycle. You can type values in the Name fields or 
use the slider to select the drawings.

3. In the Exposure panel, set the exposure time for the drawings in the cycle. You 
can set a different exposure for the last drawing in the cycle to stay on-screen.

4. In the Loops panel, select the number of times you want the cycle to repeat.
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• Select None if you don’t want the cycle to repeat.
• Select Continuous if you want the cycle to restart with the first drawing on 

each loop. 
For example, if you created 2 continuous loop of drawings 1-2-3, the resulting 
loop would be: 1-2-3-1-2-3.

• Select Forward-Backward, if you want to restart the loop with the previous 
drawing. 
For example, if you created 2 forward-backward loops with drawings 1-2-3, 
the resulting loop would be: 1-2-3-2-1-2-3-2.

• Type the number of times you want the cycle repeat in the Loops field. If you 
want to repeat the cycle for a specific number of frames, type a value in the 
Frames field.

5. Select how you want to insert the cycle.
• Select Insert Frames to add the cycle in the current location.
• Select Overwrite Frames to delete frames that overlap the cycle.

6. Click OK when you are done. Toon Boom Studio™ updates the Exposure Sheet 
window with the new cell labels.

See Also
Cutting, Copying and Pasting Cells on page 394 
Timing/Exposing Drawings and Images on page 401 
Exposure Sheet and Timeline Windows on page 354 
Creating Cycles on page 395 

Protecting Drawings
In Drawing Mode, you can lock drawings so that they can’t be modified accidentally.     

If you lock selected drawings in an element, you can auto paint all the other drawings 
without modifying the locked ones.

You can only lock drawings from the Exposure Sheet window.

To protect drawings, follow these steps:

1. Select the drawing(s) you want to lock.

2. Right-click the selected drawing(s) and select Lock Drawing from the pop-up 
menu. 
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A lock  appears on the selected drawings wherever in use.

3. To unlock the drawing, right-click it and select Unlock Drawing from the pop-up 
menu.

See Also
Exposure Sheet and Timeline Windows on page 354 
Drawing Line Art on page 114 

Clearing a Drawing from a Cell
In Drawing Mode, you can clear drawings that you don’t want to use anymore from a 
cell. This action keeps the drawing file, but deletes all of the contents of the drawing. 

You must use the Exposure Sheet window to clear drawings from a cell.

To clear drawings from selected cells, follow these steps:

1. Select the cell(s) that contain drawings you want to erase.

If you are selecting more than one cell, you should check each cell to make sure it 
contains a drawing you don’t want anymore. If you select a range of cells, only the 
first cell appears in the Drawing View window.

2. Right-click the selected cell(s) and select Clear from the pop-up menu. Toon 
Boom Studio™ deletes the contents of the drawing and leaves the cell with the 
same name.

See Also
Deleting Cells from Elements on page 399 
Protecting Drawings on page 398 

Deleting Cells from Elements
You can delete cells when you want to remove it from the playback. 

• When you delete cells from drawing and image elements, the original files 
remain in your animation set folder.

• When you delete cells from sound or media elements, the deleted frames are 
not played in the rendered animation, though the original file is unchanged. 
For complete control over your sounds, you should edit them with the Sound 
Element Editor.
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Although you can only delete cells from the Exposure Sheet in Drawing Mode, it affects 
the scene in both Drawing and Sceneplanning Modes.

To delete cells from selected element(s), follow these steps:

1. Select the cells from the element(s) you want to affect.

2. Right-click your selection and select Delete Cell from the pop-up menu.

See Also
Editing Sounds on page 222 
Editing Templates on page 412 
The Library Window on page 404 
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Timing/Exposing Drawings and Images
The amount of time a single frame appears on screen depends on the animation’s frame 
rate. If the frame rate is 12 frames-per-second (fps), then each frame appears for 1/12th 
of a second.  

You can change the exposure of a drawing, image or media to increase or decrease the 
amount of time it spends on screen. For example, you can extend the exposure of a 
drawing from 1 to 3, the drawing will appear on screen for 3 times as long.

You can change the exposure of a drawing, image or media from either Drawing Mode 
or Sceneplanning Mode.

To change the exposure of a drawing or image, follow these steps:

1. Select the cell of the drawing, image or media element.
• In the Exposure Sheet window, click the cell. 
• In the Timeline window, use the red frame slider to select the cell. 

2. Select one of the following commands from the Element > Cell menu.
• Set Exposure to 1: appears in one frame (the default setting)
• Set Exposure to 2: appears in two frames. 
• Set Exposure to 3: appears in three frames.
• Set Exposure: to set another exposure time. This command opens the Set 

Exposure dialog box.
• Add Exposure: adds one to the drawing, image or media’s current exposure 

time.
• Remove Exposure: removes one exposure from the drawing or images 

current exposure time.
• Extend Exposure: adds a selected number of frames to the current exposure 

time. This command opens the Extend Exposure dialog box. This option is 
not available when you select multiple cells.
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See Also
Changing an Element’s Start Time in the Timeline on page 402 
Changing the Start Time and Duration of a Peg on page 262 

Changing an Element’s Start Time in the 
Timeline

Because the Timeline window displays the scene’s elements horizontally, you can 
easily see when elements start and stop. 

The Timeline window also makes it easy to change an element’s timing in a scene. You 
can change when an element starts or stops in the Timeline window simply by 
dragging it from one position to another. 

See Also
Timing/Exposing Drawings and Images on page 401 
Changing the Start Time and Duration of a Peg on page 262 
Changing the Start Frame and Duration of a Dynamic Camera on page 332 

Here’s a shortcut for extending the exposure in the Exposure Sheet window.

1. Selecting the cell and then selecting a range of cells, the last one of which is 
where you want to extend the exposure time to.

2. Right-click the range of cells and select Extend Exposure from the pop-up 
menu. 

Drag the element’s trackbar to a 
new position to change its start/end 
time.

You can select and drag multiple 
elements at the same time.
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Re-using Content

This chapter explains how to re-use content and make the most of 
your work.

This chapter contains the following topics:

• The Library Window on page 404 

• Re-using Drawings and Images in the Current Animation on 
page 409 

• Creating Templates on page 410 

• Using Templates on page 417 

• Organizing Templates in Catalogs on page 423 

• Defining the Template Author and Copyright on page 426 



The Library Window
The Library Window
The Library window is your center for managing re-usable content in Toon Boom 
Studio™. From the Library window, you can access:  

• All vector elements and drawings, and image elements and bitmaps in your 
animation. 
From the list of vector elements, you can copy any drawing from one place in 
your animation set to another.

• All global and local templates.  
Templates are files that you can use to store individual pieces of animation 
content, such as drawings, images, or sounds, or collections of animation 
content (many drawings, images or sounds) or elements. 

When you need to re-use any piece of animation content in your current animation, or 
in any project you are working on, you can use templates. 

You can even use templates to share work with other artists on a project. Create 
templates from completed work and then send the template files to the rest of the 
people on your team. Those responsible for compositing can import the templates into 
the Library and then build the finished work.

Templates can reduce the amount of work you need to do, as well as keep the file size 
of your animation small.

The Animation folder lists all of the 
vector elements in your animation, 
organized by scene.

Templates are stored in the Local 
and Global folders.
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 You can create templates from:    

• Drawings, images and sound in Drawing Mode. 
• Entire elements in Sceneplanning Mode. Templates you create from 

Sceneplanning Mode store the layout order and peg effects you design.
You can also import media files (sound files and SWF movies) into the Library so that 
you can manage them as re-usable templates.  

See Also
Local and Global Template Storage on page 406 
Previewing Content in the Library on page 408 
Editing Templates on page 412 
Importing Multimedia Files into the Library on page 413 
Copying a Template into Your Animation on page 419 
Linking Templates to Media Elements on page 420 
Re-using Drawings and Images in the Current Animation on page 409 

You cannot create templates from Media elements or their contents.

You can create templates from single or multiple drawings 
and images by dragging them from the Exposure Sheet.

You can create templates from single 
or multiple elements by dragging them 
from the Timeline. 

You can create a template from the 
entire scene if you want.
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Local and Global Template Storage
You can store your templates globally or locally. 

• Local: templates are available to all scenes in the current animation set. You 
can find these template files in the Template folder of your animation set. 

• Global: these templates are available to all animation sets you create on your 
system. Toon Boom Studio™ stores all global templates in a folder that is 
accessible in all animation sets. 

See Also
Configuring the Global Library Storage Path on page 407 
Organizing Templates in Catalogs on page 423 
Creating Templates on page 410 
Using Templates on page 417 

The templates you have in your 
current animation set appear in 
the Local folder.

The templates that you can 
use in any animation set 
appear in the Global folder.
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Configuring the Global Library Storage Path
Toon Boom Studio™ stores the global templates in a directory that all animation sets 
can access. 

By default, Toon Boom Studio™ stores the global templates in your My Documents 
folder, but you can select another folder for these global templates. 

To change the default path for global templates, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens.

2. Select the General tab.

3. Click the browse button next to the Global Library field and select the path 
where you want to store your template files.

4. Click OK when done.

See Also
Defining the Template Author and Copyright on page 426 
Creating Templates on page 410 
Using Templates on page 417 

The Global Library 
field identifies the 
location of your 
Global template 
folder.
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Previewing Content in the Library
You can check the contents in the Library using the preview area in the window.

To preview content in the library, follow these steps:

1. Make sure the preview radio button is enabled.

2. Double-click the object you want to preview. 
• In the Animation folder, you can preview entire scenes or elements, or 

individual drawings.
• In the Global and Local folders, you can preview any type of template. 

However, if your template consists of a peg or a camera element only, you 
may not see anything in the preview window.

3. Click the Play  button in the preview panel. If there are multiple frames in the 
object you want to playback, you can use the slider to select the frame you want to 
see.

See Also
The Library Window on page 404 
Re-using Drawings and Images in the Current Animation on page 409 
Creating Templates on page 410 
Using Templates on page 417 

Select the radio button 
to enable preview in the 
Library window.
408 



Chapter 12: Re-using Content
Re-using Drawings and Images in the 
Current Animation

You can re-use vector drawings and bitmap images in the current animation by 
copying them to new elements, in the same or different scenes.    

To re-use drawings and images in the current animation, follow these steps:

1. In the Animation folder, select the scene and element that contains the drawings 
you want to copy.

2. Decide what you want to copy.
• To copy all of the drawings in the element to the new location, drag the 

element from the Library window to the Exposure Sheet or Timeline.
• To copy only those drawings you need, drag selected drawings from the right 

column of the Library window to a new or existing element. You can also 
select the frame where you want to copy the selected content, right-click the 
drawing or image, and select Copy to Current Frame from the pop-up 
menu.

Toon Boom Studio™ copies the drawings you select to the new location. The drawing 
you copy will have a new name. You can edit the vector drawings you copy in their 
new location.

See Also
The Library Window on page 404 
Creating Templates on page 410 
Using Templates on page 417 

The AnimationSet folder lists all of the 
vector elements and drawings in your 
animation, organized by scene.

When you select an element, the 
contents appear in the right side of 
the Library window.
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Creating Templates
Creating a template is as easy as selecting what you want from the Exposure Sheet or 
Timeline window and dragging your selection into the Library window!   

You can create templates from any piece of animation content:

• Create templates from single or multiple images and drawings, or sounds, in 
the Exposure Sheet window. 

• Create templates from single or multiple elements from the Timeline window.

When you drag your selection in the Library window, Toon Boom Studio™ analyzes 
the content and assigns an icon to the template based on what it contains. 

To create templates, follow these steps:

1. Select Windows > Library to display the Library window.

2. Select the item(s) you want to use to create a template from either the Exposure 
Sheet (Drawing Mode) or the Timeline window (Sceneplanning Mode).

Select sequences of drawings and 
images from the Exposure Sheet.

Select sequences of 
elements from the 
Timeline window.
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Depending on the mode you are in, you can select the same items one of the 
following ways:
• If you are in Drawing Mode, you can select a range of cells from any part of 

the Exposure Sheet (you cannot select one or more columns).
To select a range of cells, click the first cell and drag-select the adjoining cells 
(either from the same column or the adjacent columns). You can also press 
[Shift]+click to select a range of cells.

• If you are in Sceneplanning Mode, you can select a range of adjacent items 
(cells or elements, pegs, cameras) from the Timeline window, as well.

To select a single element, click the element title in the Timeline window.
To select a range of elements, click the first element title and [Shift] + click 
a range of elements in the Timeline window.
To select a range of cells, press [Alt] and drag the pointer through the cells 
you want to select. To select adjacent cells, they must all be in drawing or 
image elements.

3. Drag the selected items to the Library window. Toon Boom Studio™ assigns an 
icon to represent the contents of the template and assigns a temporary name.

4. Type the name of the new template, replacing the default name, and press [Enter]. 
To better organize your project or global templates, you can create Catalogs (which 
are similar to folders).

See Also
Editing Templates on page 412 
Importing Multimedia Files into the Library on page 413 
Renaming Templates on page 414 
Deleting Templates on page 415 
Viewing a Template’s Properties on page 415 
Organizing Templates in Catalogs on page 423 .
Using Templates on page 417 
Renaming Templates on page 414 
Using Templates on page 417 
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Editing Templates
You can modify the content of global or local templates. Toon Boom Studio™ updates 
all animation sets that link to templates you edit.  

To edit templates, follow these steps:

1. In the Library window, right-click the template you want to edit and select Edit 
Template from the pop-up menu. 

The contents of the template you are editing appear in the View windows, the title 
bar on the Exposure Sheet and Timeline windows changes to indicate that you are 
editing a template, and the identification of the active scene changes in the Scene 
Manager.

2. Now that you are in template editing mode, you can change the contents of the 
template in the View windows, Exposure Sheet window or Timeline window. 

When you edit a template, the 
arrows next to the scene in the 
Scene Manager disappear to 
indicate that you are editing a 
template.
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3. Save your template.
• Select File > Save to save the changes to the local and global template, as well 

as the animation set.
• Select File > Save Global Library to save the contents of the global library 

only and not the animation set.

4. To exit the edit template mode, right-click the template and select Return to 
Scene. You can also double-click the scene name in the Scene Manager.

See Also
Using Templates on page 417 
Creating Templates on page 410 
The Library Window on page 404 
Renaming Templates on page 414 
Deleting Templates on page 415 

Importing Multimedia Files into the Library
If you have a SWF file, a sound file, an image, or even another template that is not 
currently in your animation set, you can import it into the Library window so that you 
can manage and re-use it. 

To create templates from multimedia files, follow these steps:

1. Right-click in the right panel of the Library window and open the Import menu.

2. Select what you want to import from the following choices:
• Image File: import any bitmap image supported by your version of 

QuickTime®.
• Movie File: import an SWF file. 
• Sound File: import any sound file supported by your version of QuickTime®.
• Template File: import a template created by Toon Boom Studio™.
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3. Browse to the folder that contains the file you want to import, select the file, and 
click OK. 

See Also
Using Templates on page 417 
Creating Templates on page 410 
The Library Window on page 404 
Renaming Templates on page 414 
Deleting Templates on page 415 

Renaming Templates
When you create a template, Toon Boom Studio™ assigns a default name to it. You can 
rename the template at any time. Renaming a template does not affect the items it 
contains.  

To rename a template, follow these steps:

1. Right-click the template you want to rename and select Rename Template from 
the pop-up menu. 

2. Type the new template name and press [Enter] or click outside the template icon.

See Also
Using Templates on page 417 
Creating Templates on page 410 
Importing Multimedia Files into the Library on page 413 
The Library Window on page 404 
Deleting Templates on page 415 

We imported an SWF, 
a sound, and template 
file into the Library.
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Deleting Templates
When you don’t need a template anymore, you can simply delete it from your library. 
Deleting a template does not affect the contents of the Timeline or Exposure Sheet 
window, unless you linked the template to a scene. 

To delete a template, follow these steps:

• Right-click the template you want to delete and select Delete Template from 
the pop-up menu.

See Also
Using Templates on page 417 
Creating Templates on page 410 
Importing Multimedia Files into the Library on page 413 
The Library Window on page 404 
Renaming Templates on page 414 

Viewing a Template’s Properties
When you create a template, Toon Boom Studio™ uses an icon to help you remember 
what it contains. If you need more information about the template, you can view the 
template’s properties. You can see the following information:  

• the type and version of the template
• who created the template, when it was created, and any copyright 

information. You can configure the artist’s name and copyright information 
using the General tab in the Preferences dialog box. 

• the size of the template
• the contents of the template
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To view a template’s properties:

• Right-click the template and select Template Properties from the pop-up 
menu. The Properties dialog box opens.

See Also
Defining the Template Author and Copyright on page 426 
Creating Templates on page 410 
Renaming Templates on page 414 

In addition to the properties of 
the template, you can see the 
type of elements that are in the 
template as well as their 
duration.
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Using Templates
After you create templates, you can build the content of your animation with work you 
have already done.  

For example, if you are working on an animated series that uses the same opening and 
ending sequences, you can create templates from these sequences and simply bring 
them into each new episode.

You can either copy or link templates into your animation. 

• When you copy templates into your animation, Toon Boom Studio™ adds 
the contents of the template into your animation set folders, increasing the file 
size of your animation, and expands the template contents so that you can 
edit them.
Copying templates is a great way of building your content from basic material 
that you can modify.

• When you link templates, Toon Boom Studio™ makes a Media element, 
which references the template file. You cannot edit the contents of a media 
element. However, if you edit the template, all sources that link to that 
template are updated too. 

We copied this walk cycle into multiple 
scenes so that we could change essential 
qualities of the original material. In this 
case, we changed the color of the 
character’s clothes.
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Linking templates is particularly useful for frequently used content, like 
credits or logos, which must remain the same for all productions. It also keeps 
the file size of your animation small by referring to re-usable items rather than 
duplicating them.

See Also
Copying a Template into Your Animation on page 419 
Linking Templates to Media Elements on page 420 
The Library Window on page 404 
Creating Templates on page 410 

Each of these animations is going 
to use the same final credits, so 
we linked the final credits (stored 
in an SWF file) to each of these 
animation projects.
418 



Chapter 12: Re-using Content
Copying a Template into Your Animation
You can drag a template from the Library to the Exposure Sheet or Timeline window 
to add its contents to your animation. 

Toon Boom Studio™ displays the contents in the View windows, where you can edit 
them, and adds the contents to your animation folder.     

Copying templates into your animation will increase the file size of your movies. You 
can link templates to your animation to keep the file size of your animation small. 
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To copy a template into your animation, follow these steps:

1. Select the template you want to use from the Library window.

2. Drag the template to the Timeline or Exposure Sheet window. The mouse 
pointer displays a plus (+) sign when it is in a position where you can add it. 
• If your template, contains only one type of content (say bitmaps), you can add 

it to an existing bitmap element.
• If your template contains multiple elements, you will not be able to add it to 

an existing element if that element is not compatible with the template. You 
must drag templates that contain multiple elements just outside an element 
column or row to add it to the animation. 
When you copy templates that have multiple elements to the Exposure 
Sheet, you will not see those elements that can’t be displayed in Drawing 
Mode, like pegs and cameras. However, you will be able to see them when 
you switch to Sceneplanning Mode.

See Also
Linking Templates to Media Elements on page 420 
The Library Window on page 404 
Creating Templates on page 410 

Linking Templates to Media Elements
You must use media elements to link templates to your animations. Media elements 
identify the contents they contain as references to a centrally stored file. If the template 
you link contains multiple elements, all of those elements are composited into one 
element, the media element.   

Linking templates has two advantages:

• It helps you keep the file size of your Macromedia® Flash™ animations small. 
For more information on reducing the file size of your final animation, see 
Optimizing your Animation for the Web.

• It helps you update and manage frequently used material in a central 
location.
If the contents of the template are updated, Toon Boom Studio™ will update 
all animations that use the template.
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To link a template to a media element, follow these steps:

1. Select Element > New > Media Element. A new element appears in the Exposure 
Sheet and Timeline window.

2. In the Library window, select the template you want to link and drag it to the 
media element you created.

You can also create a media element as you link a template, by pressing [Alt] as 
you drag the template to the Exposure Sheet or Timeline window.

Toon Boom Studio™ links to the original file and displays the contents of the file 
in the View windows.

See Also
Cutting, Copying and Pasting Linked Media Content on page 422 
Creating Templates on page 410 
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Cutting, Copying and Pasting Linked Media Content
When you have a media element that contains some linked content, it occupies a range 
of cells in the element. You can modify this content by cutting, copying, and pasting 
the occupied cells. 

This does not affect the original content, but does allow you to change the timing of the 
animation in the media element. You can also change the timing of the contents of a 
media element by changing its exposure or creating cycles.

To move the contents of the cells in the media element, follow these steps:

1. Select the cell or range of cells you want to move or copy.

2. Right-click the select and select either Cut or Copy.
• Cut: the system removes the contents of the selected cells, moving the 

following cells to fill their place.
• Copy: the system makes a copy of the selected cell(s), leaving the original 

cell(s) unchanged.

3. Right-click a cell in a media element and select Paste. The cut/copied cells 
appear in their new cells. 

See Also
Linking Templates to Media Elements on page 420 
Timing/Exposing Drawings and Images on page 401 
Creating Cycles on page 395 
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Organizing Templates in Catalogs
As your projects evolve and grow, you may need to sort and group related templates. 
You can create template Catalogs within the Local or Global library folder. This catalog 
acts like a file folder and allows you to create groups of related templates.   

For example, if you had a collection of templates for the different characters in your 
project, you could create a catalog for each character, with sub catalogs for specific 
aspects of the character’s design.

To organize your templates in catalogs, follow these steps:

1. Select the Local or Global library folder.

2. Right-click in the template section of the Library window and select New 
Catalog from the pop-up menu. An empty catalog appears in the window with a 
default name.

3. Type a new name for the catalog or accept the default name. You can change the 
catalog name at any time.

In this example, the 
Dude catalog contains 
a number of other 
catalogs, one for 
dude’s lip sync 
images and the other 
for his walk cycle.
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4. To move or copy an existing template to a catalog, select the template and drag it 
to the catalog you want.
• If you simply drag the template file, Toon Boom Studio™ moves the selected 

template.
• If you press [Ctrl] while you drag the template file, Toon Boom Studio™ 

places a copy of the template in the selected catalog.

5. To create a template in a catalog, select the catalog from the left pane of the 
Library window and then drag the contents from the Exposure Sheet or Timeline 
window to the catalog.

See Also
Renaming Catalogs on page 424 
Deleting Catalogs on page 425 
The Library Window on page 404 
Creating Templates on page 410 

Renaming Catalogs
When you create a catalog, Toon Boom Studio™ assigns a default name to it. You can 
rename the catalog at any time. Renaming a catalog does not affect the templates it 
contains.

You cannot rename the main Local of Global catalogs in the left panel of the Library 
window. You can only rename the catalogs within the Local or Global catalogs.   

To rename a catalog, follow these steps:

1. Right-click the catalog you want to rename and select Rename Catalog from the 
pop-up menu. 

You can also select the catalog, click it once, and leave your pointer over the 
catalog name until the name become editable.

2. Type the new catalog name and press [Enter] or click outside the template icon.

See Also
Organizing Templates in Catalogs on page 423 
Deleting Catalogs on page 425 
The Library Window on page 404 
Creating Templates on page 410 
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Deleting Catalogs
When you don’t need a catalog anymore, you can simply delete it from your library. 
When you delete a catalog, you are also deleting all the templates in it. 

Deleting a catalog or its templates does not affect the contents of the Timeline or 
Exposure Sheet window.

To delete a catalog, follow these steps:

• Right-click the catalog you want to delete and select Delete from the pop-up 
menu. 

See Also
Organizing Templates in Catalogs on page 423 
Renaming Catalogs on page 424 
The Library Window on page 404 
Creating Templates on page 410 

You cannot delete the main Local or Global catalogs in the left panel of the Library 
window. You can only delete the catalogs within the Local or Global catalogs.
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Defining the Template Author and 
Copyright

When you create a template, Toon Boom Studio™ automatically assigns a default 
name and copyright owner.  

You can view a template’s author name and copyright notice in the template’s 
Properties dialog box.

To define the template author and copyright owner, follow these steps:

1. Select Edit > Preferences. The Preferences dialog box opens

2. Select the General tab.

3. Type the name of the person who will be creating the templates from now on in 
the User Name field.

4. Type any copyright information in the Copyright field.

5. Click OK when done. Any template you create from now on will use the author 
and copyright information you just entered in the General tab.

See Also
Viewing a Template’s Properties on page 415 
Creating Templates on page 410 
The Library Window on page 404 

You can change 
information about 
templates you create 
in the General tab.
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Playback and Rendering 

This chapter explains how to generate a preview of your scene or 
of all the scenes in your animation set. It also explains how to 
export your animation set’s scenes to the final SWF format.

This chapter contains the following topics:

• Previewing a Scene Interactively on page 428 

• Real-Time Playback on page 431 

• Exporting to Flash on page 433 

• Exporting to QuickTime on page 438 

• Exporting to Plazmic SVG on page 442 



Previewing a Scene Interactively
Previewing a Scene Interactively
At any point in the development of your animation, you can see a preview of the 
current scene using Interactive Playback. During Interactive Playback, you can change 
the content that is playing back. For example, you can add drawings and elements to 
the playback selection.

In Interactive Playback, the animation appears in the View windows in Drawing Mode 
and Sceneplanning Mode. Interactive Playback will not play your animation in real-
time and you will not hear the contents of any Sound elements.    

To playback your animation using Interactive Playback, follow these steps:

1. Select the drawings/elements you want to playback.
• Use the Show/Hide buttons in the Exposure Sheet window and Timeline 

window to display the elements you want to preview.
• In the Exposure Sheet window, drag your mouse pointer through the cells 

you want to preview.
• In the Timeline window, change the playback range to select the frames you 

want to preview.

If you select nothing, the entire contents of the scene plays back.

2. Press Play  from the Interactive Playback toolbar.

All of the selected content plays in sequential order in the View windows until the 
frame marker reaches the last frame of the scene or until you click the Stop  
button.

Rewind to first 
frame

Play

Forward by 
one frame

Forward to last 
frame

Loop playback

Stop

Rewind by one 
frame
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3. If you want the playback to repeat, select the Loop  button in the Interactive 
Playback toolbar before you click the Play  button.

See Also
Setting the Playback Range in the Timeline on page 429 
Real-Time Playback on page 431 
Exporting to Flash on page 433 
Exporting to QuickTime on page 438 

Setting the Playback Range in the Timeline
By default, when you want to preview the animation in your scene from Sceneplanning 
Mode, Toon Boom Studio™ starts at the current frame in the scene and plays until the 
last frame, unless you stop the playback manually. 

If you want to preview only a specific segment of your scene, you can customize the 
playback range by setting a start and end frame of the playback. 

To set the playback range in the Timeline, follow these steps:

1. Right-click the frame counter at the top of the Timeline window and select Play-
back Range > Free. When you select this option, two markers appear in the 
frame counter to mark the start and end frames.

The Automatic Fit option (selected by default) sets the playback range to the 
entire length of the scene. It adjusts the playback range automatically as your 
scene expands or shrinks.

2. Select the start frame in the playback range by dragging the start frame marker 
(the marker on the left) to where you want to start the playback range.

When you playback the 
scene, Toon Boom 
Studio™ plays only the 
frames that fall between 
these two markers.
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Previewing a Scene Interactively
You can also right-click the frame counter, select Change Playback Range Start 
Frame, type the start frame number, and click OK. The start frame marker 
appears at the frame you selected.

3. Select the end frame in the playback range by dragging the end frame marker (the 
marker on the right) to where you want to end the playback range.

You can also right-click the frame counter, select Change Playback Range End 
Frame, type the end frame number, and click OK. The end frame marker appears 
at the frame you selected.

4. Click Play  in the Interactive Playback toolbar to preview the animation in the 
current playback range.

See Also
Previewing a Scene Interactively on page 428 
Real-Time Playback on page 431 
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Real-Time Playback
You can render your movie or scene to play it back in real-time and see how your 
animation will look in its final state.

There are three different ways you can playback rendered animation in real-time:

• You can playback all or selected content from Drawing Mode, without any 
effects built in Sceneplanning Mode. 
This is particularly useful if you want to check the timing of a cycle in real-
time.

• You can playback the current scene with the effects you built in 
Sceneplanning Mode.  
This shows you the entire scene as it will appear in the final movie.

• You can playback all visible scenes in the movie, including all Sceneplanning 
Mode effects.
This will show you how the visible scenes in your movie fit together.

To playback Drawing Mode content, follow these steps:

1. Select the cells you want to playback. If you want to playback all of the content, 
you don’t have to select anything.
• Drag your mouse through the cells you want to playback in real-time.

2. Select one of the following commands from the Play > Drawing Mode Current 
Scene menu.
• Select Selection to play only the cells you selected.
• Select All to play the contents of the entire Drawing Mode scene.

The Rendering progress dialog box opens as Toon Boom Studio™ renders your 
animation. 

When the render is complete, the Playback window opens with your animation 
and begins to playback your movie from the first frame.

The display settings of the Drawing Mode window (zoom and pan) determine what 
part of your scene is rendered for playback when you use the commands in the 
Drawing Mode Current Scene menu.
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Real-Time Playback
3. Use the controls in the Playback window to adjust the playback of your movie.

To playback the entire scene with Sceneplanning Mode effects, follow these 
steps:

1. Select the elements you want to display in the rendered animation. 

Use the Show/Hide buttons next to the element names in the Timeline window to 
select the elements you want to render.

2. Select Play > Sceneplanning Current Scene.

To playback selected scenes in the movie in real-time, follow these steps:

1. Show/hide the scenes you want to playback from the Scene Manager window.

2. Select Play > Movie. 

See Also
Previewing a Scene Interactively on page 428 
Exporting to Flash on page 433 
Exporting to QuickTime on page 438 
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Exporting to Flash
When your animation is done and ready to share with your audience, you are ready to 
export a Macromedia® Flash™ movie.       

You can distribute your Macromedia® Flash™ movie as is or you can add interactive 
controls to your movie in Macromedia® Flash™.

To export to Macromedia® Flash™ format, follow these steps:

1. Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.

2. Type the name of the movie in the File name field, select a location, and click 
Save. 

The Export as Macromedia Flash Movie dialog box opens.

3. Select the part of the movie that you want to export from the Export Type panel. 
You have the following choices:
• Full Movie: exports all the scenes in the current animation set. The order the 

scenes appear in is displayed in the Scene Manager window.
• Sceneplanning Current Scene: exports the contents of the scene or 

template currently open in Toon Boom Studio™.
• Drawing Mode Scene: exports the contents of the scene or template from 

Drawing Mode. This option does not include any of the effects you created in 
Sceneplanning Mode.
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Exporting to Flash
4. In the Export Range panel, select the content you want to export.
• All: exports the entire scene or movie. If you selected Full Movie in the Export 

Type panel, All is selected by default and you cannot change it.
• Frames from: enter the selection of frames you want to export.
• Free Playback Range: If you are in Sceneplanning Mode, this option is 

available. It exports the playback range you set up in the Timeline window. If 
there is no playback range, the option is not available.

• Selection: If you are in Drawing Mode, this option is available when you 
select to export the Drawing Mode scene. It exports the frames you have 
selected in the Exposure Sheet window.

5. Select the Protect From Import checkbox to prevent people from accessing the 
content of your final SWF file.

6. Select Media Links as Movie Clips to convert media elements in your animation 
into Macromedia® Flash™ movie clips.

If you select this option, Media elements that you re-use throughout your 
animation will be converted to movie clips to keep the file size of your animation 
small.

However, Macromedia® Flash™ does not import movie clips from the SWF format. 
If you plan on importing your animation into Macromedia® Flash™, all but the 
first frame of the movie clip will appear in Macromedia® Flash™. Of course, if you 
use the Toon Boom Studio™ Importer for Macromedia® Flash™ MX, you won’t 
have to use the SWF file anyway and this will not even be a concern!

7. Use the JPEG Quality slider to select the quality of the graphics in the animation.

The lower you set the quality, more compression you apply, and the smaller your 
final file size becomes. However, the quality of your images may be noticeably 
affected.
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8. To view the Macromedia® Flash™ movie after the compilation is complete, select 
the Launch Player After Export checkbox. 

Your Macromedia® Flash™ movie appears automatically in the Playback window 
when the export has finished.

9. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

See Also
Setting the Frame Rate and Size of Your Movie on page 39 
Setting the Playback Range in the Timeline on page 429 
Adding Interactivity to a Flash Movie on page 435 

Adding Interactivity to a Flash Movie
Toon Boom Studio™ is a powerful animation tool. Its drawing, inking and painting, 
and sceneplanning features provide you with the tools you need to produce quality 
animation for the Web. 

But Toon Boom Studio™ is not a programming tool. You cannot add interactivity to 
your animations with it. When you need to add interactivity to your animations, you 
need to use Macromedia® Flash™. When you use Toon Boom Studio™ and 
Macromedia® Flash™ together to create interactive animations, you can maximize the 
strengths of these two tools.

With the powerful scripting language of Macromedia® Flash™, ActionScript, you can 
make your movies interactive. Here are some ideas:

• You can allow viewers to control the playback of your movies. 
• You can also turn drawings you created in Toon Boom Studio™ into 

Macromedia® Flash™ symbols that you can program with behaviors or use 
repeatedly throughout your animations. 
For example, you can turn a drawing of a character you created in Toon 
Boom Studio™ into a button that users click to move to another scene.

The Toon Boom Studio Importer (TBSi) for Macromedia® Flash™ MX is the bridge 
between these two powerful animation tools.

See Also
Transforming Drawings into Buttons on page 437 .
Adding Playback Controls to your Movie on page 436 
Exporting to Flash on page 433 
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Exporting to Flash
Adding Playback Controls to your Movie
For some of your animations, you may want your viewers to decide when they want 
to advance to the next scene. Or, you may want your viewers to select the scene they 
want to see.

• If you have Macromedia® Flash™MX, you can use the Toon Boom Studio 
Importer (TBSi) for Macromedia® Flash™ MX, you can import all of the Toon 
Boom Studio™ scenes into a new movie and add playback controls.

• If you don’t have Macromedia® Flash™ MX, you must export each scene as a 
separate SWF movie, import each SWF into a new scene, and then add user 
controls between scenes.

To add playback controls between scenes of your movie, follow these steps:

1. Get your Toon Boom Studio™ animation into Macromedia® Flash™.
• If you have Macromedia® Flash™ MX, use TBSi to import your movie as 

separate scenes.
• If you don’t have Macromedia® Flash™ MX, you must export each scene as a 

separate SWF file and then import each into a new scene in Macromedia® 

Flash™.
Macromedia® Flash™ imports the SWF file as one layer in the scene you have 
selected.

2. Add a Stop Frame action to the last frame of each scene.

3. Add a button to a key frame in the last frame of each scene.

4. To the button, add a GoToandPlay action that advances the movie to the selected 
scene. 

5. Repeat steps 2 through 4 for each scene in your animation.
For more information on using Macromedia® Flash™ to add playback controls to your 
SWF animation, refer to the Macromedia® Flash™ documentation.

See Also
Transforming Drawings into Buttons on page 437 
Exporting to QuickTime on page 438 
Exporting to Plazmic SVG on page 442 
Exporting to Flash on page 433 
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Transforming Drawings into Buttons
When you import Toon Boom Studio™ movies into Macromedia® Flash™ MX or 
export your animation as a SWF file, each drawing becomes a symbol. In Macromedia® 

Flash™, you can easily convert these symbols into programmable buttons.   

To transform a Toon Boom Studio™ drawing into a programmable button, follow 
these steps:

1. Create the drawing in Toon Boom Studio™.

2. Get the drawing into Macromedia® Flash™.
• If you have Macromedia® Flash™ MX, use TBSi to import the selected 

drawing. 
The drawing becomes a symbol in the Library, with the same name it has in 
Toon Boom Studio™.

• Export the drawing as an SWF file and import the file into a Macromedia® 

Flash™ movie.
Macromedia® Flash™ recognizes drawings in your SWF file as separate 
symbols that you modify. 

3. Use Macromedia® Flash™ commands to convert the symbol into a button. 
For more information on using Macromedia® Flash™ to add interactivity to your SWF 
animation, refer to the Macromedia® Flash™ documentation.

See Also
Adding Playback Controls to your Movie on page 436 
Exporting to QuickTime on page 438 
Exporting to Plazmic SVG on page 442 
Exporting to Flash on page 433 
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Exporting to QuickTime

QuickTime® is an important format when developing work for distribution on film or 
TV. With various QuickTime® editing tools, you can create effects that add a new 
dimension to your animated movies.  

The QuickTime® export renders your movie into bitmap format based on the camera 
resolution you set in the Animation Properties dialog box. During the QuickTime® 
export, you will have the opportunity to select various settings for the quality and 
compression of images and sound in the final QuickTime® movie.

Toon Boom Studio™ preserves alpha channel information in the QuickTime® file so 
that you can use this channel to build effects in video editing programs like Adobe® 
After Effects®. Toon Boom Studio™ exports the alpha channel as Straight 
(Unmatted). To export the alpha channel to QuickTime®, you must select Millions of 
Colors+ in the Video Compression Settings dialog box.

To export the animation to QuickTime® format, follow these steps:

1. Select File > Export > QuickTime Movie. The Save As dialog box opens.

2. Type the name of the movie in the File Name field, select a location, and click 
Save.

The Export as QuickTime Movie dialog box opens.

3. Select the part of the movie that you want to export from the Export Type panel. 
You have the following choices:  
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• Full Movie: exports all visible scenes in the current animation set. The order 
the scenes appear in is displayed in the Scene Manager window.

• Sceneplanning Current Scene: exports the contents of the scene or 
template currently open in Toon Boom Studio™.

• Drawing Mode Current Scene: exports the contents of the scene or template 
from Drawing Mode. This option does not include any of the effects you 
created in Sceneplanning Mode.

4. In the Export Range panel, select the content you want to export.
• All: exports the entire scene or movie. If you selected Full Movie in the Export 

type panel, All is selected by default and you cannot change it.
• Frames from: enter the selection of frames you want to export.
• Free Playback Range: If you are in Sceneplanning Mode, this option is 

available. It exports the playback range you set up in the Timeline window. If 
there is no playback range, the option is not available.

• Selection: If you are in Drawing Mode, this option is available when you 
select to export the Drawing Mode scene. It exports the frames you have 
selected in the Exposure Sheet window.

5. To view the QuickTime® movie after the compilation is complete, select the 
Launch Player After Export checkbox. 

Your QuickTime® movie appears automatically in the Playback window when the 
export has finished.
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6. To set the compression settings on the movie, click the Video Compression 
Options button. The Compression Settings dialog box opens. Use the controls 
in this dialog to select your settings and click OK when you are done. 
• Selecting a compression codec designed to handle video may generate visible 

artefacts.  For best result, we recommend that you select a codec that uses 
lossless compression, like None, BMP, PNG, TIFF, TGA or Animation.
For information on video compressors supplied with QuickTime®, see http://
developer.apple.com/techpubs/quicktime/qtdevdocs/INMAC/QT/
iqImageCompMgr.7.htm

• To export the alpha channel to QuickTime®, you must select Millions of 
Colors+.

7. To set the qualities of the sound track, click the Sound Settings button. The 
Sound Settings dialog box opens. Use the controls in this dialog to select your 
settings and click OK when you are done.

8. To set the qualities of the bitmap render to QuickTime®, click the Rendering 
Options button. The Rendering Settings dialog  box opens.   
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• High Quality Textures: this option filters bitmaps you import into Toon 
Boom Studio™ to remove unwanted noise.

• Texture Cache Size: because bitmaps are often reused from frame to frame, 
Toon Boom Studio™ uses RAM cache to reuse bitmap images and reduce 
demands on your processor. This option changes the amount of memory used 
from your RAM, but does not affect the quality of the final output. It is best to 
set this value as large as possible; 40% of your total memory is a good 
standard.

• Click OK when you are done.

For information on the different settings, see the QuickTime® documentation.

9. Click OK when you’ve configured your settings. 
A progress bar appears to show you the progress of the export. If you want to cancel 
the export, click Cancel. 

See Also
Reordering Scenes on page 44 
Setting the Frame Rate and Size of Your Movie on page 39 
Exporting to Flash on page 433 
Exporting to Plazmic SVG on page 442 
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Exporting to Plazmic SVG

Toon Boom Studio™ supports content development for wireless devices with export 
to Plazmic™ Mobile SVG. Plazmic™ Mobile SVG can be played on wireless devices with 
the Plazmic Media Engine™, as well as other SVG players.     

Plazmic Media Engine™ supports interactivity. If you want to add interactivity to your 
wireless animation, you must edit the SVG file, which is XML and can be opened in any 
text or XML editor.   

Because the Plazmic™ Mobile SVG file is intended for wireless devices, which have 
memory and resolution constraints, there are a number of features that are not 
supported. It is essential to keep your animations as simple as possible for wireless 
devices.

• All lines are converted to one pixel in width.
• Gradients, textures and bitmaps are not supported. 
• Sound is not supported. 
• Color transform and clipping mask effects are not supported.   
• Elements that you rotate and scale dynamically in Sceneplanning Mode tend 

to create large-sized files.
• Elements that change composition order in Sceneplanning Mode also create 

large-sized files. 
Before you can export, you must create the Plazmic™ Mobile SVG command that 
appears in the File > Export menu.

(Windows® 2000) To create the Plazmic™ Mobile SVG command, follow these 
steps:

1. Click the Windows® Start menu and select Settings > Control Panel.

2. Double-click the System icon.

3. In the Advanced tab, click the Environment Variables. The Environment 
Variables dialog box opens.

4. Create a new user variable:
• Click New. The New User Variable dialog box opens.
• In the Variable field, type: TBS_ENABLE_PLAZMIC_EXPORT
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• In the Variable Value field, type: 1
You can actually type any value except 0 to enable this variable. If you type 0, 
you will disable the variable.

5. Close all of the dialog boxes and re-start Toon Boom Studio™.

6. Check the File > Export > menu to see that the Plazmic Mobile SVG command is 
there.

(Windows® 98 and ME) To create the Plazmic™ Mobile SVG command, follow 
these steps:

1. Open the autoexec.bat in a text editor such as Notepad.

2. Create a new line and type: set TBS_ENABLE_PLAZMIC_EXPORT=1

3. Save the file and restart Windows®.

To export to Plazmic™ Mobile SVG, follow these steps:

1. Set the size of your movie to 120 (width) x 130 (height). To play in the Plazmic 
Media Engine™, your movie must have these dimensions.

2. Select File > Export > Plazmic Mobile SVG. The Save As dialog box opens.

3. Type the name of the movie in the File name field, select a location, and click OK.

Toon Boom Studio™ renders your animation in the Plazmic™ SVG format.
After you export your animation to the Plazmic™ Mobile SVG format, you are not done. 
To package the SVG file so that it can be played on the Plazmic Media Engine™, you 
must use the tools provided by Plazmic™. The Plazmic™ Software Development Kit is 
on the Toon Boom Studio™ CD. For further information on preparing the SVG file, 
please see the Plazmic™ documentation.

See Also
Setting the Frame Rate and Size of Your Movie on page 39 
Exporting to Flash on page 433 
Exporting to Plazmic SVG on page 442 
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numbered  388
paste  394
play sound  221
renaming  393
show notes  363
sound preview  221
thumbnail display  363
timing display  363
update notes  361
view notes  362
waveform  228

cell display
active  363
changing in Exposure Sheet  363

cell display inactive  363
center line

extract from stroke  132
file size  131

change camera effect duration  333
change camera field of view  327
change camera position  324
change camera start/end frame  332
change cell display

in Exposure Sheet  363
Change Current Frame  367
change duration  263
change editor window view  317
change element default colors  384
change feet and frames  368
change loops

looping pegs  264
change rotation pivot point position

using rotate tool  257
using specific values  258

change start frame  263
changing

color offset properties  212
line art color  204

lip assignment  231
changing color evenly over time  342
changing FB position  248
changing NS/EW position  246
changing playback range

timeline  429
changing rotation pivot point position  257
changing scale pivot point  253
clear

cell  399
drawings  399
frame  399

clip
hiding part of  349

clip mask  348
clipping mask support

wireless device  442
clone

add new elements to drawing  381
change properties  381
color transform effects  381
drawings  381
elements  381
images  381
media  381
pegs  381
sounds  381

cloned elements
changing properties  381

close
Close Gap tool  201

Close Gap tool
Tools palette  200

closing gaps  203
collapse pegs  359
color

add gradient swatch  183
adding swatches  180
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additive changes  340
add palettes  206
Add Stroke tool  201
alpha value  185
background  42

changing in scene  42
blend palette styles  215
change element color  383
change element default  384
change element default colors  384
changing background color in Camera View  

51
changing background color in Drawing 

View  51
changing over time  340
channel  341, 342
Close Gap tool  201
Color Picker  183
combining additive and multiplicative 

values  342
copy palettes  206
create gradient swatch  183
create palettes  206
customize track color  370
define custom color  42
delete palettes  208
delete palette styles  211
Dropper tool  197
duplicate palettes  206
final  342
inking line art  204
ink overview  178
linear gradient  184
multiplicative changes  340
offsetting  212
paint overview  178
paint shape  190
Paint tool  189
paint zone  190
palettes  205
palette styles  209

radial gradient  184
rename palettes  208
rename palette styles  210
swatches  179
tint palette styles  212
transparency  185
unpaint  198
unpaint zones  189
using swatches  179
using templates  417
values

additive color transformations  341
multiplicative color transformations  342

workflow  32
zone  189

color channels
add color values  341
multiply color values  342
subtract color values  341

Color palette  205
adding swatches  180
copying  206
creating  206
inking line art  204
naming swatches  186
swatches  179

Color Picker  183
linear gradient  184
radial gradient  184
swatch name  180

color properties
inking line art  204

color swatches
creating palettes  206
palette styles  205

color transform
adding key frames  345
applying to vector elements  344
change properties  343
effect  343
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effect cloning elements  381
elements

create color changes in  340
nesting in multiple elements  344
removing key frames  345

color transformations  340, 342
additive  341
combining  342, 346
multiplicative  341

color transform support
wireless device  442

column width
adjusting in Exposure Sheet  365

combining
color transformations  342, 346

Commands list
keyboard  49
shortcuts  49

composition
layer order  375

concepts
Sceneplanning  238

configure
Bias  283
bitmap filter  171
Continuity  283
Copyright field  426
global library storage path  407
Keyboard tab  49
measurements  50
Onion Skin  159
rendering options  52
Tension  283
Units tab  50
username  426

constraints
memory/resolution in wireless devices  442

contest sensitive help  26
contextual menu

cell display  363
Continuity

definition  282
set default  283

contour
file size  131

Contour Editor tool
conversion  132
curve grips  143, 145
extraction  132
modifying vector line shapes  142
overview  142
reshape line  143
Tools palette  143, 145

contours
adding using Add Stroke tool  201

control point
add  275
add motion points to motion path  273
adjust curve  282
Bias  282
Brush tool  131
Continuity  282
conversion  132
copy/paste motion point values  280
create FB motion path  271
create motion path with pegs  267
create NS or EW motion path  269
deleting  278
extraction  132
lock  279
motion path  276
overview  131
remove  278
reshape line  143
reshape shape  143
rotation value  293, 299
Tension  282
unlock  279

control point shapes
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control point  131
conversion

from stroke  132
to center line  132

converting
bitmap images to vector drawings  171

coordinates
changing FB position  248
changing NS/EW position  246
repositioning elements  245
X-axis  238
Y-axis  238
Z-axis  238

copy
cells  394
Ctrl click  127
drawing objects  127
gradient swatch  183
linked animation  422
motion point values  280
palettes  206
templates  417

copying a template into your animation  419
copy/paste motion point values  280
copyright field  426
create

add motion points to motion path  273
animation set  38
FB motion path  271
gradient color swatch  183
import files as templates  413
Lip Sync images  230
masking effects  348
motion path with pegs  267
NS or EW motion path  269
palettes  206
pen styles  151
templates  410

create cycles command  395, 397

Creating Cross-dissolves with Color 
Transform Elements

Tutorial  96
Creating Mask Effects

Tutorial  107
credits

final
linking templates  418

cropping
sound  224

Ctrl copy  127
curve

adjust between motion points  282
changing shape of  142

curve grips  143
add control point  146
Brush tool  145
Contour Editor  143, 145
delete control point  148
Ellipse tool  143
Paint tool  145
Pencil tool  143
Rectangle tool  143
reshaping  143
reshaping shapes  145
reshaping strokes  145

curve type droplist
spline  302

custom
element colors (Exposure Sheet)  383
track colors  370

customize
color swatches  206

cut
cells  394
Cutter tool  139, 140
drawing objects  127
Eraser tool  139
linked animation  422
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Cutter tool  139

D
default

Bias  283
camera  322
Continuity  283
element colors  384
Tension  283

default swatch name
changing  186

defining
copyright in template  426

definition
Bias  282
Continuity  282
Tension  282

delete
catalogs  425
control point from peg  278
control point in line  148
control point in shape  148
control point in stroke  148
drawing in Static Light Table  160
elements  380
key frame  278
palettes  208
palette styles  211
scenes  46
Static Light Table  160
template  415

dialog box
Preferences  50, 51, 52

digital animator  16
digital pen

Brush tool  114
digital process  15
disable all effects

color transform  345

display
Auto Light Table  163
disable all effects  345
selected elements (Timeline)  357
Static Light Table  160
toolbars  47
track color  370
waveform  228

distort objects  128
divide

Timeline  369
documentation

conventions  24
where to get updates  23

drag and drop
copy template into animation  419

drawing
add color over time  341
Add Stroke tool  201
Auto Light Table  157, 163
cell image display  363
cell lip sync display  363
cell name display  363
cell thumbnail display  363
cell timing display  363
clear cell  399
clear frame  399
Cutter tool  139, 140
deselect  122
display options  363
distort  128
drawing tools  114
Eraser tool  139
exposure time  401
grid display  154
import static images  168
insert blank cells  390
insert numbered cells  388
Lip Sync images  230
lock  398
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mask layer  349
multiply color over time  342
new features  19
next drawing  157
nudge  124
Onion Skin  157
optimizing for the web  131
Paint All  195
painting zones in  189
Perspective tool  128
previous drawing  157
remove color over time  341, 342
remove from Static Light Table  160
renaming  393
reposition all  175
reuse in current animation  409
rotate drawing space  156
select  121
skew  128
Static Light Table  157

display  161
hide  161

transform into programmable buttons  437
Tutorial  56
type (element)  373
unlock  398
workflow  30, 33

drawing element
cloning  381

drawing folder
animation set  386

Drawing layers
reduce using Optimize command  134
reducing using flatten command  135

Drawing Line Art  114
pen styles  150, 151
pen styles, modifying  152

Drawing Mode  124
Auto Light Table  163
Brush tool  30, 116

Contour Editor tool  142
control point  131
create clip mask  348
create pen style  151
create templates  405, 410
delete control point  146, 148
delete elements  380
deselect objects  121
drawing tools  114, 115, 123
element contents sequence  386
Ellipse tool  30, 116
erase  141
Eraser tool  141
Exposure Sheet

overview  354
extract center line  132
file size  131
Flatten command  135
grid display  154
illustrator import  173
import illustrator  173
import SWF files  174
import transparent images  170
inking  178
layered elements  157
layering elements  371
layer order  375
Line tool  30, 116
masking effects  347
modify pen style  152
Move object  124
Onion Skin  157
Optimize command  134
paint  178
panning  165
PDF import  173
Pencil tool  30, 116
pen style properties  129
pen styles  150
Perspective tool  128
Polyline tool  116
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protecting drawings  398
real-time playback  431
Rectangle tool  30, 116
remove elements  380
removing points  137
rename elements  379
reshape line art  143
reshape shape  145
reshape stroke  145
Resize height/width  124
Resize object  124
Resize sides  124
Resize top/bottom  124
rotate drawing space  156
Rotate object  124
select objects  121
show/hide elements  355
Static Light Table  160
toolbars  47
view

cell notes  362
element notes  362

workflow  114
Zoom in  164
Zoom out  164

drawing objects
cutting parts from  140
erasing sections from  141

Drawing space
setup  153

drawing tools
Brush  114
Brush tool  30, 116
deselect  122
Drawing Mode  114
Ellipse  114
Ellipse tool  30, 116
grid display  154
Line tool  30, 114, 116
overview  114

Pencil tool  30, 116
Polyline  114
Polyline tool  116
rectangle  114
Rectangle tool  30, 116
select  121

Drawing View
Auto Light Table  157
changing background color  51
Cutter tool  139, 140
deselect objects  122
Eraser tool  139
grid display  154
Onion Skin  157
panning  165
recenter  165
reposition all drawings  175
rotate drawing space  156
select objects  121
Static Light Table  157, 160

Draw Top Layer command
enable/disable  138
optimize layers automatically  138

Dropper tool  197
duplicate

palettes  206
duration

camera  332
camera effect  333
changing peg  262
looping pegs  264

dynamic camera
timeline properties  332

dynamic zoom  329

E
Edit

Preferences
Sceneplanning tab  50
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edit
bitmap texture fills  193
changing lip assignment of a sound  231
customizing playback range  229
end position (sound)  223
generating a lip chart  230, 231
global template  412
gradient fills  193
lip sync notes  233
local template  412
mapping lip sync drawings  236
Preferences

Interface tab  51
Rendering tab  52

sound fades  227
sound looping  226
sounds  222
sound scrubbing  235
start position (sound)  223
texture fills  193

Editor window
changing view of  317

effects
adding color over time  341
additive color  340
additive color transformation  341
add key frame  345
building a peg hierarchy  265
cameras  320
changing color evenly over time  342
changing color over time  340, 341
color transform  343
color transform elements  340
combining multiple color transforms  346
create masks  348
disable mask effects  350
exporting  345
hide mask layers  350
looping pegs  264
mask layer

hiding part of clip  349

masks  347
move  351
resize  351
rotate  351

multiplicative colors  340
multiplicative color transformations  342
nesting color transformations  344
new features  19
remove key frame  345
removing color over time  341
show mask layers  350

element  388, 390
add motion points to motion path  273
add notes  360
Amount  374
animation set folder sequence of contents  

386
Auto Light Table  157, 163
building a peg hierarchy  265
change clone properties  381
change default colors  384
change over time

adding pegs  261
attaching to pegs  261

change rotation pivot point position  257
changing FB position  248
changing NS/EW position  246
changing over time with pegs  260
changing peg start time  262
changing rotation pivot point over time  303
changing scaling pivot point over time  303
clear cell  399
clear frame  399
cloning  381

color transform effects  381
drawings  381
images  381
media  381
pegs  381
sharing contents  381
sounds  381
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collapse pegs  359
combining multiple color transforms  346
copying templates  419
create FB motion path  271
create NS or EW motion path  269
create templates  410
creating motion path with pegs  267
delete  380
display colors (custom)  383
display colors (default)  384
display selected  357
divide Timeline  369
end time  402
expand pegs  359
exposure  401
fade in/out sound  227
hide selected  357
layering  371
layering in timeline

background  377
bring forward  377
bring to front  377
foreground  377
normal  377
send backward  377
send to back  377

layer order  375
library

overview  404
preview content  408

linking templates  420
Lip Sync images  230
lock drawing  398
looping a peg  264
mask layer

hiding part of clip  349
media

linking template  418
linking to template  420

motion point tab  299
Name  374

naming a cell  393
notes (Sound element)  233
nudge  247
Onion Skin  157
Paint All zones  195
peg duration  262
peg ghosts  270
playback sound  221
recompute lip sync  234
remove  380
rename  379
renaming a cell  393
renaming a drawing  393
renaming images  393
repositioning in 3D space  245
reposition in motion path  268
reposition pivot points in camera view  305
reposition pivot points in motion point tab  

307
reshaping plotline  315
rotate  255
scale in camera view  298
scaling in motion paths  267
selecting in Timeline window  244
select in View windows  243
show/hide  355, 356
show selected  357
Solo mode  357
sound editor  222
sound playback  221
sounds  218
split Timeline  369
start time  402
Static Light Table  157
templates

overview  404
track color  370
tween (overview)  260
tweening  17
unlock drawing  398
update notes  361
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using templates  417
velocity based scale changes  302
view notes  362
View windows  239
waveform  228
workflow  33
zoom Timeline  366

element layering order  249
background  249
foreground  249
normal  249

elements
change color over time  343
nesting color transformations  344
rotating over time  289
scale over time  297
scaling  250

using scale handles  251
using specific values  252

timeline zoom level  366
element types  371
Ellipse tool  30, 116

add control point  146
curve grips  143
delete control point  148
Eraser tool  141
pen styles  150

Enable Color Shading
Onion Skin  159

enable shade
Static Light Table  162

end frame
camera  332

end position (sound)
edit  223

erase
Cutter tool  139, 140
Eraser tool  139

Eraser tool  139

Brush tool  141
event sounds  219
EW

1D Editor (motion)  285
1D Editor (pivot point)  309
3D space  238
graph motion  285
graph pivot point  309
Motion Point tab  276
overview  238
plot motion  285
plot pivot point  309

excess points
removing  137

expand pegs  359
export

add buttons  437
add playback controls  436
animation (SWF)  433
camera size  39
disable all effects  345
Drawing Mode Scene  433
effects  345
frame rate  39
Full Movie  433
hide elements  355
interactivity  435
new features  21
Sceneplanning Current Scene  433
SVG  37
workflow  37

exporting sounds to
Macromedia Flash  219

exporting to
Macromedia Flash  433, 438
SVG  442
wireless devices  442

exposure  401
Exposure Sheet
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 Index
add frames  391
add image  168
adjusting column width  365
changing cell display  363
clear cell  399
clear frame  399
copying templates  419
create advanced animation cycles  397
create animation cycles  395
create templates  410
delete elements  380
delete scenes  46
export to SWF  433
exposure time  401
generating a lip chart  230
import sounds  218
insert blank cells  390
insert numbered cells  388
Interactive Playback  428

show/hide  428
layering elements  371
linking templates  420
new features  20
overview  354
playback  431
playback sound  221
remove elements  380
rename elements  379
rename scenes  44
sorting scenes  44
Static Light Table  160
waveform  228
workflow  33

extending
pegs  263

extract
center line  132

F
fade in/out  227

fading sound  227
FB

1D Editor (motion)  285
3D space  238
graph motion  285
Motion Point tab  276
plot motion  285

FB space
overview  238

feet and frames  368
field of view

camera  327
change over time  329, 334
dynamic camera  329, 334

fields
additive color transform  344
multiplicative color transform  344

field size
camera  39

file size
affect of motion path with pegs  267, 269, 271
Brush tool  131
center line  131
control point  131
copying template into animation  419
creating advanced cycles  397
creating animation cycles  395
linking templates  420
overview  131
reshape contour  143

fills
editing bitmap  193
editing gradient  193
editing texture  193

final color
additive plus multiplicative values  342

final credits
linking templates  418

Flash
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animator  16
export  433
workflow  37

Flatten command  135
reduce drawing layers  135

flipbook  12
FOV

change over time  329, 334
dynamic camera  329, 334

frame
add control point  275
add key frame  275
add notes  360
blank  390
change  367
change duration  263
change start frame  263
clear  399
copy/paste motion point values  280
delete control point  278
delete key frame  278
exposure  401
numbered  388
remove control point  278
remove key frame  278
scale elements over time  297
update notes  361
view notes  362

frame marker  367
frame marks

distribution on motion path  287
frame rate  39

defining properties of  40
exposure time  401
Warning  40

frames
add  391
number of in animation  388

framing

add camera  322
Function Editor

adding key frames to plotline  313
camera zoom  334
dynamic zoom  334
field of view zoom  334
FOV zoom  334
overview  311
plotline  335
preset acceleration changes  287
reshaping plotline  315
rotation path  295
scaling a peg  301
velocity  287
view options  317
X-axis  335
Y-axis  335
zoom over time  334

Function Editor tab
rotation spline path  295
velocity  287

G
gaps

auto close  203
closing  201

General
new features  22

generate
lip chart from Exposure Sheet  230
lip chart from Sound Element Editor  231

ghosts
peg  270

global catalogs
renaming  424

global library
storage path  407
template catalogs  423

global template  406
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catalogs (overview)  423
storage path  407

global templates  404
Grabber  240

1D Editor  317
Function Editor  317

gradient
add  183
Color Picker  183
color swatch  183
create  183
Dropper tool  197
linear  184
painting zones with  191
radial  184
transition  184

gradient fills
editing  193

gradient support
wireless devices  442

graph
EW (motion)  285
EW pivot point  309
FB motion  285
motion path  285, 295
NS (motion)  285
NS pivot point  309
pivot point path  309
rotation path  295
spline path (motion)  285
velocity  287

graphic tablet
Brush tool  114

grid
12 field  155
16 field  155
1D Editor  317
drawings  154
Function Editor  317
Grid Control toolbar  155

Normal size  155
overlay  155
underlay  155

Grid Control
toolbar  47

grips
Move  124
overview  124
Resize height/width  124
Resize sides  124
resize top/bottom  124
Rotate  124

H
help

context sensitive  26
webhelp  26

hide
Auto Light Table  163
elements in view windows  358
selected elements (Timeline)  357
Static Light Table  160

hiding unrelated elements  357
hierarchy

pegs  265
show/hide peg attachments  359

High Quality Options
rendering options  440

history  12
cel process  13
digital process  15
zoetrope  13

How to use the User Guide  23
HScale tab

scaling a peg  301
HSV

blend Palette Style  215
mix colors  181
solid  180
Index - H 461 



 Toon Boom Studio  V2 User Guide
tint Palette Style  212
values  181

I
Illustrator

importing  173
illustrator  16

import  173
image

renaming  393
image element

cloning  381
type  373

images
reuse in current animation  409

import
backgrounds  168
bitmaps  168
files to templates  413
illustrator  173
images  168
images (transparent)  170
PDF files  173
sounds  218
SWF files  174

Importing
new features  20

Importing artwork
BMP files  168
PDF files  173
reposition drawings  175
SWF files  174
vectorizing bitmaps  171

inactive
cell display  363

ink
alpha  186
Color Picker  67, 184
Drawing Mode  178

Dropper tool  197
gradient color swatch  183
gradient swatch  183
mix HSV  181
mix RGB  181
overview  178
Paint tool  189
swatch name  186
transparency  186
workflow  32

inking
line art  204

Inking and Painting
new features  20
Swatches  179

insert
blank cells  390
blank frames  390
numbered cells  388
numbered frames  388
range of cells  388
to cells  360

installation  18
Interactive Playback  428

range  429
toolbar  47

interactive preview  428
interpolation

overview  260
tweening  17

K
keyboard

Assign  49
Category drop-list  49
Commands list  49
shortcuts  48

Keyboard combinations
assigning  48
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keyboard shortcuts
assigning  48
resetting  50

keyboard tab  49
key frame

add  275
adding to a plotline  313
adding to color transform  345
add motion points to motion path  273
add to motion path  273
adjust curve  282
Bias  282
Continuity  282
copy/paste motion point values  280
create FB motion path  271
delete  278
lock  279
modify peg pivot point  307
modify using Function Editor  301
motion path  276
motion point tab  299
remove  278
removing from color transform  345
scale elements over time  297
scaling an element  299
scaling a peg  299
scaling pegs with Function Editor  301
Tension  282
unlock  279

key frames
create motion path with pegs  267
create NS or EW motion path  269
motion point tab  293

L
large gaps

closing  203
layering

element types
camera  371

clipping effects  371
color transform effects  371
drawing  371
image  371
media  371
peg  371
sound  371

layer order
Exposure Sheet  375

layers  375
Auto Light Table  157
element  371
Onion Skin  157
optimize automatically  138
reducing for web use  134, 135
Static Light Table  157
tweening  17

length
camera  332

library
copy template into animation  419
defining copyright  426
defining template author  426
delete template  415
deleting catalogs  425
global storage path  407
import media files  405
linked media content  422
linking templates  418
media elements  418
overview  404
preview content  408
rename template  414
re-useable templates  405
reuse drawings  409
reuse images  409
template

global  406
local  406
using  417
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viewing properties  415
template catalogs  423
templates

linking media element to  420
Library window

creating templates  410
edit global template  412
edit local template  412

Light Table tab
Onion Skin  159

limitation
naming animation set  38
tweening  17

line
conversion  132
curve grips  143
extraction  132
reshape contour  143

linear
gradient  184

Line art
drawing  114

line art
inking  204
unpaint  198
workflow  30

line constraints
wireless devices  442

lines  131
add control point  146
delete control point  148
deselect  122
Eraser tool  141
pen properties  129
pen styles  150
select  121

Line tool  30, 116
centerline points  131

link

adding media  420
copy animation  422
cut animation  422
paste animation  422
templates  418

linked media content
copy  422
cut  422
paste  422

linking templates
advantages  420

lip chart
automatic lip sync mapping  236
generating  230, 231
lip assignments  231
lip sync notes  233
recompute  234

Lip Sync
mapping  236
overview  230
recompute  234
sound scrubbing  235
thumbnails  230
Tutorial  76
view  230
waveform  228

Lip Sync notes
adding  233

local catalog
renaming  424

local library
template catalogs  423

local template  404, 406
catalogs (overview)  423

lock
control point  279
drawing  398
key frame  279

looping
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pegs  264
sound  226

M
Macromedia Flash

add interactivity to movie  435
add playback controls to movie  436
create programmable buttons  437
exporting event sounds to  219
exporting streaming sounds to  219
export to  433

Drawing Mode Current Scene  438
Drawing Mode Scene  433
Full Movie  433
Sceneplanning Current Scene  433

file size
clone elements  381
linking templates  420

TBSi  436
Main toolbar  47
Manager

delete scenes  46
rename scenes  44

managing colors
blending color in a palettes style  215
copying a palette  206
creating multiple palette styles  209
creating palettes  206
deleting a palette  208
deleting a palette style  211
offsetting colors in a palette style  212
renaming a palette  208
renaming a palette style  210
using palettes  205

mapping
lip sync drawings  236

markers
customizing playback range  229

Masking effects

create  348
overview  347

mask layer
hide part of clip  349
multiple elements  349

masks
clip mask  348
create  348
modifying  351
move  351
resize  351
rotate  351

measure
selecting Units of  50

measurements
configure  50
Preferences  50

media element
cloning  381
linking templates  418
linking to templates  420
type  373

media files
import to library  405

medium gaps
closing  203

merging layers
Draw Top Layer command  138

mix colors
alpha  186
RGB  181
transparency  186

Mobile Plasmic SVG  442
Mobile SVG  442
Mode

toolbar  47
modify

pen styles  152
modify shapes
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Contour Editor tool  142
motion

1D Editor  285
add control points  275
add key frame  275
copy/paste motion point values  280
delete control points  278
delete key frame  278
graph  285
Motion Point tab  276
offset from path  276
plot  285
remove control points  278
remove key frame  278
tweening  17
workflow  35

motion guide
overview  260

motion over time
Sceneplanning Mode  260

motion path
1D editor  285
adding pegs  261
add motion points  273
affect on file size  267, 269, 271
attach elements to pegs  261
bias  282
building a peg hierarchy  265
changing rotation pivot point over time  303
changing scaling pivot point over time  303
changing velocity  287
continuity  282
create FB  271
create NS or EW  269
creating with pegs  267
defining

default bias values  283
default continuity values  283
default tension values  283

delete motion points  278, 280

direction of  267
display selected elements  357
frame mark distribution  287
Function Editor (rotation)  295
locking/unlocking control points  279
lock position  273
looping a peg  264
motion point curve  282
moving motion points  276
peg ghosts  270
peg resize  297
pegs  260
position pivot points in motion point tab  307
reposition pegs in  268
rotate peg in camera view  291
rotating elements over time  289
scale elements over time  297
scaling a peg in camera view  298
scaling a peg with the Function Editor  301
tension  282
walk cycle  262

motion point
copy/paste values  280
existing values  283
nudge  274
tab  275

Motion Point tab
motion path  276
positioning pivot points  307
scaling an element  299
spline path  276

motion point tab  293
motion tool

create FB motion path  271
createNS or EW motion path  269
creating motion paths with pegs  267
modify pivot point  307
motion point tab  293, 299

MOV
workflow  37
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move
contents of cells in linked media  422
pivot point over time  303

Move grips  124
movie

add buttons  437
adding scenes  41
add interactivity  435
add playback controls  436
changing scene background color  42

moving over time
adding pegs  261

multimedia
workflow  30

multiplane camera  320
adding camera elements  322
dynamic zooms  329
panning  336
trucking  336

multiple color transforms
combining  346

multiple elements
selecting  243

multiple scenes
sorting  44

multiplicative
color transformations  342

N
Name

element  374
name

swatch  180
naming

swatches  186
nesting

color transformations  344
new feature

3D Sceneplanning  21
new features

drawing  19
effects  19
Exporting  21
Exposure Sheet  20
General  22
Importing  20
Inking and Painting  20
sound  20
Templates  21
Timeline  20

new scene
adding  41

next drawing  157
Normal size grid  155
notes

add to cell  360
add to element  360
add to frame  360
lip sync  233
sound element  233
Sound Element Editor  233
view in cell  362
view in element  362
view in frame  362

NS
1D Editor (motion)  285
1D Editor (pivot point)  309
3D space  238
graph motion  285
graph pivot point  309
Motion Point tab  276
plot motion  285
plot pivot point  309
space (overview)  238

nudge
drawing  124
element  247
motion point  274
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numbered cells  388
numbered frames  388

O
objects

copy  127
cut  127
distort  128
paste  127
skew  128

offset
camera position  324
motion path  276

offsetting colors  212
Onion Skin  157

configure  159
Enable Color Shading  159
next drawing  157
overview  157
previous drawing  157
Rotary Light Table  157
toolbar  47, 158

online help
conventions  24
overview  26

Optimize command  134
reduce drawing layers  134

optimize layers automatically  138
optimizing drawing objects for the web  131
order  375
Organizing elements

add elements to scene  373
add notes  360
animation cycles  395, 397
change cell display  363
change current frame  367
change layering order  375
change layering order in timeline  377
change timeline zoom level  366

changing color  383
changing default color  384
cloning  381
customize track color  370
deleting  380
display selected elements  357
Exposure Sheet  354
insert blank cells  390
insert blank frames in scene  391
insert numbered cells  388
layering elements  371
measurement  368
naming/renaming cell  393
renaming  379
renaming a drawing  393
resize columns in Exposure Sheet  365
sequencing contents  386
show/hide  355
show/hide peg attachments  359
Timeline window  354, 369
viewing notes  362

Organizing templates in catalogs  423
overlay  155

Drawing View  155
grid  155
Static Light Table  162

overview
Auto Light Table  163
camera  320
Camera View  239
Contour Editor tool  142
control point  131
drawing  114
EW space  238
Exposure Sheet  354
FB space  238
file size  131
grips  124
ink  178
interpolation  260
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library  404
Lip Sync  230
masking effects  347
motion guide  260
NS space  238
Onion Skin  157
online help  26
paint  178, 189
playback  431
reshaping objects  142
rotating elements over time  289
scene camera  320
Side View  239
Sound Element Editor  222
Static Light Table  160
templates  404
Timeline  354
Top View  239
tweening  17, 260

P
paint

alpha  186
closing gaps  203
Color Picker  67, 184
Drawing Mode  178
Dropper tool  197
edit bitmap texture fills  193
edit gradient fills  193
gradient color swatch  183
gradient swatch  183
mix HSV  181
mix RGB  181
overview  178, 189
Paint All  195
Paint tool  189
shapes  190
solid zone  190
swatch name  186
transparency  186

unpaint  198
workflow  32
zones (overview)  189

Paint All  195
Painting

Tutorial  65
painting zones

with bitmap textures  191
with gradients  191

Paint tool  189
curve grips  145

palettes  205
add  206
color  205
copy  206
create  206
delete  208
duplicate  206
rename  208
swatches  205
workflow  32

palette style
Tint Blend  213, 215

palette styles  205, 209
blend  215
color  209
creating a color palette  206
delete  211
rename  210
swatches  209
tint  212
workflow  32

pan
camera  320

panning  336
drawing view  165
in view windows  240

paste
cells  394
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drawing objects  127
motion point values  280

pasted
linked animation  422

Paste special
copy/paste motion point values  280

path
adjust curve  282
Bias  282
Camera View rotation motion path  291
Continuity  282
motion path  276
Tension  282
View window rotation motion path  291

peg
add control point  275
adding  261
add key frame  275
add motion points to motion path  273
adjust curve  282
attaching element to  261
Bias  282
building a hierarchy  265
building hierarchies  265
camera zoom  329
change duration  262, 263
change masks dynamically  351
change start frame  263
change start time  262
changing element over time  260
changing pivot point over time  303
collapse  359
Continuity  282
copy/paste motion point values  280
create FB motion path  271
create motion path  267
create NS or EW motion path  269
delete control point  278
delete key frame  278
display quality

rendering options  52
duration  289
expand  359
extending  263
field of view zoom  329
FOV zoom  329
ghosts

create motion paths  270
lock control point  279
lock key frame  279
looping  264
mapping movement in 3D space  312
masks

move  348, 351
resize  348, 351
rotate  348, 351

modifying masks  351
modify pivot point  307
motion path  276
motion point tab  293
panning camera  336
peg ghosts  270
plotting rotation over time  295
plot values  317
preset acceleration changes  287
remove control point  278
remove key frame  278
reposition in motion path  268
reposition pivot points in camera view  305
reposition pivot points in motion point tab  

307
reshaping plotline  315
rotate elements over time  289
rotation motion path in View windows  291
scale elements over time  297
scale in camera view  298
scale tool  297, 298
scale with Function Editor  301
Sceneplanning Mode  260
show pegs in view window  355
smooth pegs  262
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speed  287
Tension  282
toolbar  47
trucking camera  336
tween (overview)  260
tweening  17
type (element)  373
unlock control point  279
unlock key frame  279
walk cycle  262
workflow  35

peg element
cloning  381

Pencil tool  30, 116
add control point  146
conversion  132
curve grips  143
delete control point  148
Eraser tool  141
extraction  132
pen styles  150

pen styles
add  151
create  151
modify  152
properties  129
smoothness  151

persistence of vision  12
perspective

3D space  239
add cameras  322

Perspective tool  128
pivot point

1D Editor  309
changing over time  303
graph  309
plot  309
reposition over time  303

pivot point path
1D Editor  309

graph  309
plot  309

place elements
View windows  239

planes
depth  238
horizontal  238
vertical  238

Play
Movie  431
Scene  431

playback
camera size  39
current scene

real-time  431
frame rate  39
hide elements  355
overview  431
preview a scene interactively  428
range  429
real-time  431
selected content

real-time  431
set range  429
sound  221

playback range
customizing  229

Play Movie  431
Play Scene  431
Plazmic Media engine  442
Plazmic Mobile SVG

export to  442
Plazmic SVG  442
plot

EW (motion)  285
EW pivot point  309
FB (motion)  285
motion path  285
NS (motion)  285
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NS pivot point  309
pivot point path  309
rotation path  295
spline path (motion)  285
velocity  287

plotline
changing effect values  311
changing shape of  302
reshape functions  315
reshaping with Function Editor  315
scaling pegs  301

plotline adding key frames to  313
plot values

peg  317
Polyline tool

pen styles  150
position

camera  324
offset camera  324

Preferences
Copyright  426
global library storage path  407
global template storage path  407
Keyboard tab  49
library  407
Light Table tab  159
measurements  50
Onion Skin  159
Scene tab  283
Templates  407
Template tab  426
Units tab  50
username  426

preset
reshape functions  315

previous drawing  157
primary color transform  346
progammable buttons  437
project

workflow  28
project folder

animation set  29
create  38
save  38

Properties
bitmap swatch  187
color transform  343
Color Transform tab  344
pen styles  129
Static Light Table  161
template  415

Properties dialog box
change rotation pivot point  258
rotate  255
scale pivot point  253
scaling elements  252

proportional scaling  252
protect

drawings  398

Q
QT

export to  438
QuickTime

export to  438
Full Movie  438
Sceneplanning Current Scene  438
Video compression options  440

Rendering Options  440
High Quality Textures  440
Texture Cache Size  440

QuickTime export
workflow  37

R
radial

gradient  184
real-time playback  431
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real-time sound playback
sound scrubbing  235

Recenter view  242
Recenter View tool  242
recompute lip sync  234
Rectangle tool  30, 116

add control point  146
curve grips  143
delete control point  148
Eraser tool  141
pen styles  150

recycle
animation

library  404
templates  404

reducing drawing layers  134, 135
remove

control point  278
elements  380
key frame  278, 345
Static Light Table  160

removing points
smooth command  137

rename
elements  379
palettes  208
palette styles  210
scenes  44
template  414

render
hide elements  355
playback (overview)  431

rendering options
configuring  52
Peg display quality  52
tool display quality  52
video card type  52

repeating effects
looping pegs  264

reposition
all drawings  175
camera  320
elements in motion path  268
masks  351
pegs in motion path  268

reposition elements in 3D space  245
reposition pivot points over time  303
reset

keyboard shortcuts  50
rotation  157

Reset View tool  242
reshape

curve grips  143
overview  142

reshape functions
change plotline shape  315
extreme fast in/out  315

reshaping functions
constant  315
ease in/out  315
extreme ease in/out  315
fast in/out  315
linear  315
slow acceleration  315
slow deceleration  315

resize
columns in Exposure Sheet  365
Function Editor  287

resize elements  250
using scale handles  251
using specific values  252

Resize height/width
grips  124

Resize sides
grips  124

resize top/bottom
grips  124

reuse
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animation
library  404
templates  404

drawings
copy to current frame command  409

drawings in current animation  409
images

copy to current frame command  409
images in current animation  409
library

overview  404
preview content  408

templates  417
overview  404

RGB
blend Palette Style  215
color transformation  340
mix colors  181
solid  180
tint Palette Style  212
values  181

RGB/HSV intensity
adjusting using Blending slider  214

Rotary Light Table  156
rotate

Camera View  291
change pivot point over time  303
change rotation pivot point

properties dialog box  258
changing rotation pivot point position  257
drawing space  156
element  255
elements over time  255
element using rotate tool  255
Function Editor  295
grips  124
plot  295
properties dialog box  255
reposition pivot points in camera view  305
reposition pivot points in motion point tab  

307
View windows  291

rotate element
using specific values  256

Rotate tool
View window  291

rotating
bitmap texture fills  193
gradient fills  193

rotating elements over time  289
rotating over time

adding pegs  261
rotation

modify key frames  301
reposition pivot points in camera view  305
resetting  157
workflow  35

rotation effects  257
rotation path

graph  295
rotation pivot point  257

changing over time  303

S
save as

animation set  39
saving

animation set  38
scale

change pivot point over time  303
reposition pivot points in camera view  305
reposition pivot points in motion point tab  

307
workflow  35

scale changes
velocity based  302

scale elements over time  297
scale pivot point
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properties dialog box  253
rescaling using scale tool  253
rescaling using specific values  253

scale tool  297
scaling

in motion paths  267
reposition pivot points in camera view  305

scaling a peg in camera view window  298
scaling a peg with the Function Editor  301
scaling elements  250

properties dialog box  252
proportional scaling  252
scale elements over time  297
using scale handles  251
using specific values  252

scaling over time
adding pegs  261

scaling pivot point
changing over time  303

scene
add buttons  437
add camera  322
add elements  373
add frames  391
adding  41
add interactivity  435
additive color changes  340
add playback controls  436
camera effects  320
changing background color  42
clear drawings  399
collapse pegs  359
color palette management  205
copying templates  419
create templates  410
delete  46
display selected elements  357
dynamic zoom  329, 334
element colors (custom)  383
element colors (default)  384

expand pegs  359
export (SWF)  433
frame marker  367
hide selected elements  357
importing files to templates  413
import sound  218
import sounds  218
inserting blank frames in  391
library

overview  404
preview content  408

linking templates  420
multiplicative color changes  340
playback  431
playback range  429
position camera  324
preview interactively  428
recompute lip sync  234
rename  44
show/hide  45
show selected elements  357
Solo mode  357
sorting  44
templates

overview  404
track color  370
zoom camera  327
zoom over time  329, 334

scene camera
overview  320

scene folder
animation set  386

Scene Manager
show/hide scenes  45
sorting scenes  44

Scene Operation
toolbar  47

Sceneplanning
concepts  238
Solo mode  357
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tweening  17
workflow  35

Sceneplanning Mode
building a peg hierarchy  265
cameras  321
color transform effects  343
contents sequence  387
create templates  405, 410
delete elements  380
display selected elements  357
layering elements  371
masking effects  347
motion over time  260
pan camera  321
pegs  260
real-time playback  431
remove elements  380
rename elements  379
reposition camera  321
scale elements over time  297
show/hide elements  356
switching active view  241
Timeline

overview  354
toolbars  47
view element notes  362
zoom camera  321

Scene tab  283
Scene View

Camera drop-list  322
toolbar  47

secondary
camera  322

secondary color transform  346
select

color  197
deselect drawings  122
drawings  121
Dropper tool  197
sound section  224

Zoom region  164
selecting

Units of Measure  50
selecting elements

3D space  243
Camera View  243
Side View  243
Top View  243

Select tool  121
deselect  121, 122

sequencing animation set contents
in Drawing Mode  387
in Sceneplanning Mode  387

series
building a peg hierarchy  265

setting pen styles  150
setup

drawing space  153
shape

curve grips  143
shapes

add control point  146
color zone  190
Contour Editor tool  142
curve grips  145
cutting parts from  140
delete control point  148
deselect  122
Eraser tool  141
erasing sections from  141
Optimize command  134
paint  190
pen properties  129
reshape contour  143
select  121

shortcuts
Assign  49
Category drop-list  49
Commands list  49
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keyboard  48
Keyboard tab  49

show
selected elements (Timeline)  357

Show/Hide
scene background color  43
scenes  45

show/hide  42
Display Menu commands  355
in Exposure Sheet  355
in Timeline window  355

show/hide elements  355, 356
show pivot path

reposition pivot points in camera view  305
Side View

changing the view  240
dynamic zoom  329
Grabber tool  240
offset position  324
overview  239
Recenter View tool  242
resetting the view  242
Reset View tool  242
selecting elements  243
zoom  327
zoom over time  329

skew objects  128
small gaps

closing  203
smooth

pen styles  151
Smooth command  137

removing points  137
smoothness

pegs  262
solid

alpha  180
Dropper tool  197
HSV  180

paint shape  190
Paint tool  189
RGB  180

Solo mode  357
sort

layer order  375
scenes  44

sound
adding lip sync notes  233
changing lip assignment  231
creating lip charts  230
cropping  224
customizing playback range  229
edit  222
edit end position (sound)  223
edit start position (sound)  223
event  219
fade in  227
fade out  227
generating lip chart  230, 231
import  218
Lip Sync  230
mapping lip sync drawings  236
new features  20
playback  221
recompute lip sync  234
repeating  226
scrubbing  235
streaming  219
streaming multiple sounds  220
synchronization  219
type (element)  373
view Lip Sync  230
waveform  228
workflow  31

sound cells
lip sync active  228
lip sync inactive  228

sound element
cloning  381
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import  218
Sound Element Editor  222

changing lip assignment  231
customize playback range  229
end position  223
fade in  227
fade out  227
generating a lip chart  231
looping sounds  226
mapping lip sync drawings  236
select section  224
sound scrubbing  235
start position  223

sound folder
animation set  386

sound loops  226
sound support

wireless devices  442
spline

add control point  275
add key frame  275
adjust curve  282
Bias  282
Continuity  282
copy/paste motion point values  280
curve type droplist  302
delete control point  278
delete key frame  278
motion path  276
remove control point  278
remove key frame  278
Tension  282
workflow  35

spline path
1D Editor  285
Function Editor (velocity)  287
graph (motion)  285
Motion Point  276
plot (motion)  285

split

Timeline  369
start frame

camera  332
start position (sound)

edit  223
start time

changing peg  262
Static Light Table  157

add image  160
delete drawings in  160
display  160
display drawings  161
enable/disable shading  162
overlay  162
overview  160
properties  161
remove drawings  160
show/hide drawings  161
underlay  162

streaming sounds  219
stretching

bitmap swatches  187
stroke

add control point  146
conversion  132
delete control point  148
deselect  122
Eraser tool  141
extraction  132
pen styles  150
select  121

structure
animation set  386

styles
copying a palette  206
creating color palettes  206
palette  205

supported features
SVG wireless devices  442
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SVG
export  37
wireless devices

supported features  442
workflow  37

SVG players  442
swatch

add gradient  183
adding to palette  180
add palettes  206
blend palette styles  215
changing HSV values  181
changing RGB values  181
changing transparency of  185
Color Picker  183
copy gradient  183
copy palettes  206
create gradient  183
create palettes  206
creating bitmap swatches  187
delete palettes  208
delete palette styles  211
Dropper tool  197
duplicate palettes  206
edit bitmap texture fills  193
edit gradient fills  193
inking line art  204
linear gradient  184
naming  186
Paint tool  189
palettes  205
palette styles  209
radial gradient  184
rename palettes  208
rename palette styles  210
selecting from a drawing  197
stretching bitmap swatches  187
texture  187
tiling bitmap swatches  187
tint palette styles  212
transition marker  184

transparency  185
workflow  32

swatches  179
SWF

add buttons  437
add playback controls  436
export  433
import  174
interactivity  435
workflow  37

system requirements  18

T
TBSi  436
template

adding to a scene  419
catalogs (overview)  423
contents

updating  420
copying to a scene  419
Copyright  426
creating  410
creating in Drawing Mode  405
creating in Sceneplanning Mode  405
delete  415
deleting catalogs  425
global  406
global library storage path  407
global template storage path  407
importing files  413
linking to a scene  420
local  406
overview  404
properties  415
rename  414
username  426
using  417
view properties  415

template author  426
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Template Browser
add elements  410
copying templates  419
create templates  410
importing files  413
linking templates  420

template catalogs
organizing  423

Template folder
animation set  386
configure  426

Templates
new features  21

templates
deleting catalogs  425
renaming catalogs  424

Tension
definition  282
set default  283

texture
painting zones with  191
stretching swatches  187
swatches  187
tiling swatches  187

Texture Cache Size
rendering options  440

texture constraints
wireless devices  442

texture swatch  179
properties  187

threshold filter
vectorizing bitmaps  172

thumbnails
Lip Sync images  230
Static Light Table  160
waveform  228

tiling
bitmap swatches  187

Time

adding blank frames in a scene  391
Timeline

camera element  332
change duration  263
change layering order  377
change start frame  263
collapse pegs  359
copying templates  419
create templates  410
delete scenes  46
display selected elements  357
divide  369
element end  402
element start  402
expand pegs  359
export to SWF  433
extend peg  263
frame marker  367
insert blank frames in a scene  391
linking templates  420
new features  20
overview  354
playback  431
playback range  429
rename scenes  44
selected hide elements  357
show selected elements  357
Solo mode  357
sorting scenes  44
split  369
track color  370
Zoom In/Out  366

timeline properties
dynamic camera  332

Timeline window
adding a camera to a scene  323
adding pegs  261
change camera effect duration  333
change camera start/end frame  332
create advanced animation cycles  397
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create animation cycles  395
create templates  410
dynamic zoom option  330
Interactive Playback  428
layering elements  371
selecting multiple elements  244
selecting single elements  243

Time measurement  368
timing

exposure  401
workflow  33

tint
alpha  212
HSV  212
palette styles  212
RGB  212

Tint Blend  213, 215
tolerance levels

auto close gaps  203
toolbars

displaying  47
Grid Control  47
Interactive Playback  47
Main  47
Mode  47
Onion Skin  47, 158
Peg  47
Scene Operation  47
Scene View  47

Tool display quality
rendering options  52

tools
Auto Gap  203
edit gradient  193
edit texture  193
Paint All  195
Perspective  128

Tools palette
Add Stroke tool  200, 201

Brush tool  30, 116
Close Gap tool  200, 201
Contour Editor tool  143, 145
Cutter tool  139, 140
Dropper tool  197
Ellipse tool  30, 116
Eraser tool  139
Grabber tool  240
Line tool  30, 116
Paint tool  189
Pencil tool  30, 116
Rectangle tool  30, 116
reshape  143
unpaint tool  198

Toon Boom Studio
installing  18
requirements  18
workflow  28

Top View
changing the view  240
dynamic zoom  329
Grabber tool  240
offset position  324
overview  239
recentering the view  242
Recenter View tool  242
resetting the view  242
Reset View tool  242
selecting elements  243
zoom  327
zoom over time  329

track color  370
traditional animator  16
transform drawings into programmable 

buttons  437
transition

gradient  184
markers  184

transparency
adjusting using Alpha slider  213
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import  170
mix colors  186
swatch  185

trimming
sounds  224

truck
camera  320

trucking  336
Tutorial

Building a Multiplane Scene  86
Creating Cross-dissolves with Color 

Transform Elements  96
Creating Mask Effects  107
drawing  56
Lip Sync  76
Painting  65

tweening
animation  17
interpolation  17
limitations  17
overview  17, 260
peg  17
Sceneplanning  17

type (element)
camera  373
drawing  373
image  373
media  373
peg  373
sound  373

U
underlay  155

Drawing View  155
grid  155
Static Light Table  162

Units of Measure
selecting  50

Units tab

configure  50
Preferences  50

unlock
control point  279
key frame  279

unlock drawing  398
unpaint  198

color zones  189
update

cell note  361
element note  361
notes  361

updating
contents of template  420

User Guide
how to get document updates  23
how to use it  23

Username field  426
using templates  417

V
values

additive color  342
multiplicative color  342

vector artwork
adding points  146

vector drawings
converting bitmap images into  171

vector drawing tools
Brush  114
Ellipse  114
Polyline  114
Rectangle  114

vector element
applying color transform  344

vectorizing
bitmaps  171

vectorizing bitmaps
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bitmap filters  171
threshold filter  172

vector lines
Contour Editor tool  142

velocity
graph  287
plot  287

video card type
configuring  52

Video Compression Options
when exporting to QuickTime  440

view
1D Editor  317
divide Timeline  369
Function Editor  317
lip sync  230
notes  362
split Timeline  369
waveform (sound)  228
zoom Timeline  366

view template properties  415
View windows

changing FB position  248
changing NS/EW position  246
changing the view  240
edit global template  412
edit local template  412
Grabber tool  240
panning  240
recentering the view  242
recenter view  242
Recenter View tool  242
repositioning elements  245
resetting scene view  242
Reset View tool  242
Rotate tool  291
rotation spline  291
scale pivot point  253
scaling elements  250, 251, 252
selecting elements  243

using  239
zoom  240
Zoom tool  239

vision
flipbook  12
persistence of  12

VScale tab
scaling a peg  301

W
walk cycle

looping pegs  264
pegs  262

Warning
deleting catalogs in Library window  425
exporting effects  345
frame rate  40
Interactive Playback sound synchronization  

221, 405
regenerating lip chart  234
Unpainting  199
updating lipsync mapping  236
viewing file names in sound cells  228

wave
display  228

waveform  228
web

digital animator  16
file size  131, 132
Flash animator  16
illustrator  16
optimizing drawing objects  131
reducing layers using flatten command  135
reducing layers using the optimize 

command  134
reducing points in a line  132
reducing points in drawings  132
removing points using smooth command  

137
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traditional animator  16
webhelp  26
wireless animation  442
wireless devices  442

export to  442
workflow  28

3D space  35
animation set  29
color  32
create animation set  38
drawing line art  30
Drawing Mode  114
elements  33
export  37
Exposure Sheet  33
Flash export  37
gather multimedia  30
ink  32
motion  35
MOV  37
paint  32
palettes  32
palette style  32
pegs  35
project  28
QuickTime export  37
rotation  35
scale  35
Sceneplanning  35
sequence of drawings  33
sound  31
spline  35
SVG  37
swatches  32
SWF  37
timing  33

Z
zoetrope  13
zone

closing gaps automatically  203
closing gaps manually  201
Dropper tool  197
paint (overview)  189
Paint All  195
paint solid shape  190
Paint tool  189

zoom
1D Editor  317
camera  320, 327
divide Timeline  369
dynamic camera  329, 334
Function Editor  317
in view windows  240
split Timeline  369
Timeline  366
zoom over time  329, 334

zoom speed
changing in Function Editor  335

Zoom tool
region select  164
select region  164
View windows  239
zoom in  164
zoom out  164
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